Switches : Switches Cisco Catalyst 6500 Series

Exemplo de configuração para migrar a medida - árvore do PVST+ ao MST

17 Outubro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (7 Outubro 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para migrar o modo Spanning Tree do PVST+ ao Spanning Tree Múltipla (MST) na rede do campus.

Pré-requisitos

Requisitos

Refira compreendendo o protocolo multiple spanning-tree (802.1s) antes que você configure o MST.

Esta tabela mostra o apoio do MST nos Catalyst Switches e no software mínimo exigido para esse apoio.

Plataforma Catalyst MST com RSTP
Catalyst 2900XL e 3500XL Não disponível
Catalyst 2950 e 3550 12.1(9)EA1 do Cisco IOS
Catalyst 3560 Cisco IOS 12.1(9)EA1
Catalyst 3750 Cisco IOS 12.1(14)EA1
Catalizador 2955 todas as versões do Cisco IOS
Catalyst 2948G-L3 e 4908G-L3 Não disponível
Catalizador 4000, 2948G, e 2980G (OS do catalizador (CatOS)) 7.1
Catalizador 4000 e 4500 (Cisco IOS) 12.1(12c)EW
Catalizador 5000 e 5500 Não disponível
Catalizador 6000 e 6500 (CatOS) 7.1
Catalizador 6000 e 6500 (Cisco IOS) 12.1(11b)EX, 12.1(13)E, 12.2(14)SX
Catalyst 8500 Não disponível

  • Catalizador 3550/3560/3750: A aplicação de TheMST no Cisco IOS Release 12.2(25)SEC é baseada no padrão do IEEE 802.1S. As aplicações MST em umas liberações mais adiantadas do Cisco IOS são prestandard.

  • Catalyst 6500 (IO): A aplicação MST no Cisco IOS Release 12.2(18)SXF é baseada no padrão do IEEE 802.1S. As aplicações MST em umas liberações mais adiantadas do Cisco IOS são prestandard.

Componentes Utilizados

Este documento é criado com o Cisco IOS Software Release 12.2(25) e o CatOS 8.5(8), mas a configuração é aplicável à Versão do IOS mínima mencionada na tabela.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

A característica MST é o IEEE 802.1S e é uma alteração ao 802.1Q. O MST estende a medida do Rapid 802.1w - algoritmo da árvore (RST) às Spanning Tree múltiplas. Esta extensão prevê a convergência rápida e o Balanceamento de carga em um ambiente VLAN. Instância de Spanning Tree da corrida PVST+ e Rapid-PVST+ para cada VLAN. No MST, você pode agrupar VLAN em uma instância única. Usa a versão 3 da unidade de dados de protocolo de bridge (PDU) que é inversa - compatível com o 802.1D STP que usa a versão 0 BPDU.

Configuração MSTP: A configuração inclui o nome da região, do número de revisão, e do mapa da atribuição do VLAN-à-exemplo MST. Você configura o interruptor para uma região com o comando global configuration da configuração do mst da medir-árvore.

Região MST: Uma região MST consiste nas pontes interconectadas que têm a mesma configuração de MST. Não há nenhum limite no número de regiões MST na rede.

Instâncias de Spanning Tree dentro da região MST: Um exemplo não é nada mas um grupo de VLAN traçados no comando configuration do mst da medir-árvore. À revelia, todos os VLAN são agrupados em IST0, que é chamado uma medida interna - a árvore (IST). Você pode manualmente criar os exemplos numerados 1 a 4094, e são etiquetados MSTn (n =1 a 4094), mas a região pode apoiar somente até 65 exemplos. Algumas das liberações apoiam somente 16 exemplos. Consulte o manual de configuração do software para sua plataforma do switch.

IST/CST/CIST: O IST é o único exemplo que pode enviar e receber BPDU na rede MST. Um exemplo de MSTn é local à região. Os IST em regiões diferentes são interconectados com um Common Spanning Tree (CST). A coleção dos IST em cada região MST e no CST que conecta os IST é chamado a medida comum e interna - árvore (CIST).

Compatibilidade retrógrada: O MST é inverso - compatível com PVST+, Rapid-PVST+, e Prestandard MST (MISTP). O interruptor MST é conectado ao outro Switches STP (PVST+ e Rapid-PVST+) pelo Common Spanning Tree (CST). O outro Switches STP (PVST+ e Rapid-PVST+) considera a região MST inteira como um switch único. Quando você conecta o interruptor do prestandard MST com o interruptor do padrão MST, você precisa de configurar o PRE-padrão do mst da medir-árvore na relação do interruptor do padrão MST.

Configurar

Este exemplo contém duas seções. A primeira seção mostra a configuração atual PVST+. A segunda seção mostra a configuração que migra do PVST+ ao MST.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

Este diagrama inclui este Switches:

  • Distribution1 e Distribution2, que estão na camada de distribuição

  • Dois switch de camada de acesso chamaram Access1 (IO) e Access2 (CatOS)

  • Dois Switches da agregação do server chamaram Services1 e Services2

Os VLAN 10, 30, e 100 levam o tráfego de dados. Os VLAN 20, 40, e 200 levam o tráfego de voz.

/image/gif/paws/72844/MST-1.gif

Configurações

Este documento utiliza as seguintes configurações:

Configuração PVST+

O Switches é configurado no PVST+ para levar os dados e o tráfego de voz conforme o diagrama da rede. Este é um sumário sucinto da configuração:

  • O interruptor Distribution1 é configurado para transformar-se um bridge-raiz preliminar para os VLAN de dados 10, 30, e 100 com a medir-árvore 10,30,100 vlan Distribution1(config)# enraízam o comando primary, e o bridge-raiz secundário para a Voz VLAN 20, 40, e 200 usa o comando secondary vlan de 20,40,200 raizes da medir-árvore Distribution1(config)#.

  • O interruptor Distribution2 é configurado para transformar-se um bridge-raiz preliminar para a Voz VLAN 20, 40, e 200 com a medir-árvore 20,40,200 vlan Distribution2(config)# enraízam o comando primary, e o bridge-raiz secundário para os VLAN de dados 10, 30, e 100 usa o comando secondary vlan de 10,30,100 raizes da medir-árvore Distribution2(config)#.

  • O comando spanning-tree backbonefast é configurado em todo o Switches convirgir mais rapidamente o STP em caso da falha indireta do link na rede.

  • O comando spanning-tree uplinkfast é configurado nos switch de camada de acesso convirgir mais rapidamente o STP em caso da falha do uplink direta.

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Podemos ver que a porta Fa1/0/24 é configurada com o comando spanning-tree vlan 20,40,200 port-priority 64. Distribution2 é a raiz configurada para VLAN 20,40, e 200. Distribution2 tem dois links a Distribution1: Fa1/0/23 e Fa1/0/24. Ambas as portas são designadas portas para VLAN 20, 40, e 200 porque Distribution2 é a raiz para aqueles VLAN. Ambas as portas têm a mesma prioridade 128 (padrão). Também, estes dois links têm o mesmo custo de Distribution1: fa1/0/23 e fa1/0/24. Distribution1 escolhe o mais baixo número de porta das duas portas a fim ajustar a porta no estado de encaminhamento. O mais baixo número de porta é Fa1/0/23 mas, conforme o diagrama da rede, a Voz VLAN 20, 40, e 200 pode correr através de Fa1/0/24. Você pode realizar este com estes métodos:

  1. Diminua os custos de porta em Distribution1: Fa1/0/24.

  2. Diminua a prioridade de porta em Distribution2: Fa1/0/24.

Neste exemplo, a prioridade de porta é diminuída para enviar VLAN 20, 40, 200 fa1/0/24 diretos.

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Você pode ver essa porta Fa0/5 em Services1, e Fa0/6 e Fa0/48 em Services2 têm a configuração do custo e da prioridade de porta da porta de Spanning Tree. O STP é ajustado aqui de modo que o VLAN 100 e 200 de Services1 e de Services2 possam passar através dos enlaces de tronco entre eles. Se esta configuração não é aplicada, Services1 e 2 não podem passar o tráfego através dos enlaces de tronco entre eles. Em lugar de, escolhe o trajeto com Distribution1 e Distribution2.

Services2 vê dois caminhos de custo igual ao VLAN 100 enraizar (Distribution1): um Services1 direto e o segundo um Distribution2 direto. O STP escolhe o melhor caminho (porta de raiz) nesta ordem:

  1. Os custos de caminho

  2. O ID de bridge do interruptor da transmissão

  3. A mais baixa prioridade de porta

  4. O mais baixo número de porta interna

Neste exemplo, ambos os trajetos têm o mesmo custo, mas o Distribution2 (24576) tem uma baixa prioridade do que Services1 (32768) para o VLAN 100, assim que Services2 escolhe Distribution2. Neste exemplo, os custos de porta em Services1: fa0/5 é ajustado mais baixo para deixar Services2 escolher o Services1. Os custos de caminho cancelam o número de prioridade do interruptor da transmissão.

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

O mesmo conceito é aplicado para que Services1 escolha Services2 enviar VLAN 200. Depois que você reduz o custo para VLAN 200 em Services2 - fa0/6, Services1 escolhe fa0/47 enviar VLAN 200. A exigência aqui é enviar VLAN 200 fa0/48 direto. Você pode realizar este com estes dois métodos:

  1. Reduzir o custo da porta em Services1: Fa0/48.

  2. Reduzir a prioridade da porta em Services2: Fa0/48.

Neste exemplo, a prioridade de porta em Services2 é diminuída para enviar VLAN 200 fa0/48 direto.

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

Migração MST

É difícil converter ao mesmo tempo todo o Switches na rede de empreendimento ao MST. Devido à compatibilidade retrógrada, você pode convertê-la fase na fase. Execute as mudanças na janela de manutenção agendada porque a medida - a reconfiguração da árvore pode interromper o fluxo de tráfego. Quando você permite o MST, igualmente permite o RSTP. O spanning-tree uplinkfast e as características do backbonefast são características PVST+, e é desabilitado quando você permite o MST porque aquelas características estão construídas dentro do RSTP, e o MST confia no RSTP. Dentro da migração, você pode remover aqueles comandos nos IO. No backbonefast e no uplinkfast do catOS, os comandos são cancelados automaticamente da configuração, mas a configuração das características tais como o PortFast, o bpduguard, o bpdufilter, o protetor de raiz, e o loopguard são igualmente aplicáveis no modo de MST. O uso destas características reage o mesmo que do modo PVST+. Se você tem permitido já estas características no modo PVST+, permanece ativo após a migração ao modo de MST. Quando você configura o MST, siga estas diretrizes e limitações:

  • A primeira etapa na migração a 802.1s/w é identificar corretamente ponto a ponto e portas de ponta. Assegure-se de que todos os enlaces de switch a switch, em que uma transição rápida é desejada, estejam FULL-frente e verso. As portas de ponta são definidas através dos recursos de portfast.

  • Escolha um nome de configuração e um número de revisão que sejam comuns a todo o Switches na rede. Cisco recomenda que você coloca tanto como Switches como possível em uma única região; não é vantajoso segmentar uma rede em regiões separadas.

  • Decida com cuidado quantos exemplos são precisados na rede comutada, e mantenha-os na mente que um exemplo traduz a uma topologia lógica. Evite traçar todos os VLAN no exemplo 0. Decida que VLAN a traçar naqueles exemplos, e para escolher com cuidado uma raiz e a raiz alternativa para cada exemplo.

  • Assegure-se de que os troncos levem todos os VLAN que são traçados a um exemplo ou não levam nenhuns VLAN de todo para este exemplo.

  • O MST pode interagir com os legacy bridge que executam o PVST+ em uma base por porto, assim que não é um problema para misturar ambos os tipos de pontes se as interações são compreendidas claramente. Tente sempre manter a raiz do CST e do IST dentro da região. Se você interage com uma ponte PVST+ através de um tronco, assegure-se de que a ponte MST seja a raiz para todos os VLAN que são permitidos nesse tronco. Não use pontes PVST como a raiz do CST.

  • Assegure-se de que todas as pontes da raiz de Spanning Tree PVST tenham uma mais baixa (numericamente) prioridade mais alta do que o bridge-raiz CST.

  • Não desabilite a medida - árvore em nenhum VLAN em algumas das pontes PVST.

  • Não conecte o Switches com os enlaces de acesso porque os enlaces de acesso podem dividir um VLAN.

  • Toda a configuração de MST que envolver um grande número portas VLAN lógicas atuais ou novas deve ser terminada dentro de uma janela de manutenção porque o banco de dados completo MST obtém reinitialized para qualquer mudança incremental, tal como a adição de VLAN novos aos exemplos ou o movimento dos VLAN através dos exemplos.

Neste exemplo, a rede do campus tem uma região MST region1 nomeado e dois exemplos de MST1 - os VLAN de dados 10, 30, e 100, e MST2 - exprimem VLAN 20, 40, e 200. Você pode ver que o MST executa somente dois exemplos, mas o PVST+ executa seis exemplos. Distribution1 é escolhido como a raiz regional CIST. Significa que Distribution1 é a raiz para IST0. A fim carregar o equilíbrio o tráfego na rede conforme o diagrama, Distribution1 é configurado como a raiz para MST1 (exemplo para VLAN de dados), e MST2 é configurado enquanto a raiz para MST2 (exemplo para a Voz VLAN).

Você precisa de migrar primeiramente o núcleo e de trabalhar para baixo sua maneira aos switch de acesso. Antes que você mude o modo Spanning Tree, configurar a configuração de MST no Switches. Mude então o tipo STP ao MST. Neste exemplo, a migração ocorre nesta ordem:

  1. Distribution1 e Distribution2

  2. Services1 e Services2

  3. Access1

  4. Access2

  1. Migração Distribution1 e Distribution2:

    
    !--- Distribution1 configuration:
    
    Distribution1(config)#spanning-tree mst configuration
    Distribution1(config-mst)#name region1
    Distribution1(config-mst)#revision 10
    Distribution1(config-mst)#instance 1 vlan 10, 30, 100
    Distribution1(config-mst)#instance 2 vlan 20, 40, 200
    Distribution1(config-mst)#exit
    Distribution1(config)#spanning-tree mst 0-1 root primary
    Distribution1(config)#spanning-tree mst 2 root secondary
    
    
    !--- Distribution2 configuration:
    
    Distribution2(config)#spanning-tree mst configuration
    Distribution2(config-mst)#name region1
    Distribution2(config-mst)#revision 10
    Distribution2(config-mst)#instance 1 vlan 10, 30, 100
    Distribution2(config-mst)#instance 2 vlan 20, 40, 200
    Distribution2(config-mst)#exit
    Distribution2(config)#spanning-tree mst 2 root primary
    Distribution2(config)#spanning-tree mst 0-1 root secondary
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    
    Distribution1(config)#interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)#interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    !--- STP mode conversion.
    
    Distribution1(config)#spanning-tree mode mst
    Distribution2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic.
    
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#spanning-tree mst 2 port-priority 64
    
    
    !--- PVST+ cleanup.
    
    Distribution1(config)#no spanning-tree backbonefast
    Distribution2(config)#no spanning-tree backbonefast
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#no spanning-tree vlan 20,40,200 port-priority 64
    

    Nota: Recomenda-se que você ajusta a raiz MST0 manualmente. Neste exemplo, Distribution1 é escolhido enquanto a raiz MST0, assim que Distribution1 se transformam a raiz CIST.

    Agora a rede está em configuração misturada. Pode ser representada conforme este diagrama:

    MST-2.gif

    Distribution1 e Distribution2 estão em MST region1, e o Switches PVST+ considera o region1 como uma única ponte. O fluxo de tráfego após o reconvergir é mostrado no diagrama 2. Você pode ainda ajustar o Switches PVST+ (medir-árvore VLAN X custado) ao loadbalance os dados e o tráfego de voz conforme o diagrama 1. Depois que você migra todo o Switches restante conforme etapas 2 a 4, você obtém a topologia de Spanning Tree final conforme o diagrama 1.

  2. Migração Services1 e Services2:

    
    !--- Services1 configuration:
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)#name region1
    Services1(config-mst)#revision 10
    Services1(config-mst)#instance 1 vlan 10, 30, 100
    Services1(config-mst)#instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    !--- Services2 configuration:
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)#name region1
    Services2(config-mst)#revision 10
    Services2(config-mst)#instance 1 vlan 10, 30, 100
    Services2(config-mst)#instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the 
    !--- VLANs that are mapped to an instance.
    
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    !--- STP Mode conversion:
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic:
    
    Services1(config)#interface fastEthernet 0/46
    Services1(config-if)#spanning-tree mst 2 cost 200000
    Services1(config-if)#exit
    Services1(config)#interface fastEthernet 0/47
    Services1(config-if)#spanning-tree mst 2 cost 100000
    Services1(config-if)#exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)#exit
    
    
    !--- PVST+ cleanup:
    
    Services1(config)#no spanning-tree uplinkfast
    Services1(config)#no spanning-tree backbonefast
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#no spanning-tree vlan 100 cost 18
    Services1(config-if)#exit
    
    Services2(config)#no spanning-tree uplinkfast
    Services2(config)#no spanning-tree backbonefast
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#no spanning-tree vlan 200 cost 18
    Services2(config-if)#exit
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#no spanning-tree vlan 200 port-priority 64
    Services2(config-if)#exit
    
  3. Migração Access1:

    
    !--- Access1 configuration:
    
    Access1(config)#spanning-tree mst configuration
    Access1(config-mst)#name region1
    Access1(config-mst)#revision 10
    Access1(config-mst)#instance 1 vlan 10, 30, 100
    Access1(config-mst)#instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    !--- STP mode conversion:
    
    Access1(config)#spanning-tree mode mst
    
    
    !--- PVST+ cleanup:
    
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
  4. Migração Access2:

    
    !--- Access2 configuration:
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    !--- Ensure that trunks carry all the VLANs that are mapped to an instance:
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    
    !--- Backbonefast and uplinkfast configurations are cleaned up automatically.
    
    

Verificar

Recomenda-se verificar a topologia de Spanning Tree cada vez que a configuração é mudada.

Verifique que o interruptor Distribution1 é o bridge-raiz para os VLAN de dados 10, 30, e 100, e verifique que o trajeto de encaminhamento da medir-árvore combina conforme o trajeto no diagrama.

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p


!--- CIST root is Distribution1. All the 
!--- switches are in the same region "region1".
!--- Hence in all the switches in the region1 you can see the path cost as 0.


Distribution2#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 72844