Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Asymmetric Digital Subscriber Line (ADSL)

Configuração e guia de Troubleshooting do roteador Cisco DSL - RFC1483 que distribui com um único endereço IP estático

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Seu provedor de Internet (ISP) atribuiu um endereço IP público estático único a seu roteador Cisco Digital Subscriber Line (DSL).

Dica: Refira a configuração passo a passo do RFC1483 que distribui com um único endereço IP estático se você não é familiar com como configurar dispositivos Cisco e gostaria de seguir uma configuração passo a passo.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Tarefas executar

  • Projete um esquema de endereçamento de IP para sua LAN privada.

  • Configurar manualmente um endereço IP de Um ou Mais Servidores Cisco ICM NT e uma máscara de sub-rede na interface Ethernet do roteador Cisco DSL.

  • Configurar a interface ATM (relação da linha de assinante digital de Asymetric (ADSL)) do roteador Cisco DSL com uns Circuitos Virtuais Permanentes (PVC) ATM, o encapsulamento, e um endereço IP de Um ou Mais Servidores Cisco ICM NT.

  • Para o Network Address Translation (NAT): Configurar o NAT no roteador Cisco DSL a fim permitir a partilha do endereço IP público estático da interface ATM.

    • Opcional: Conjunto NAT, se os endereços IP de Um ou Mais Servidores Cisco ICM NT adicionais foram fornecidos por seu ISP.

    • Opcional: NAT estático, se os usuários do Internet exigem o acesso aos servidores internos.

  • Configurar cada host PC com um endereço IP de Um ou Mais Servidores Cisco ICM NT, uma máscara de sub-rede, um gateway padrão, e um server do Domain Name System (DNS).

    Para o protocolo de configuração dinâmica host (DHCP): Alternativamente, se você quer o roteador Cisco DSL atribuir a seus clientes PC endereços IP dinâmicos, configurar cada PC para obter automaticamente um endereço IP de Um ou Mais Servidores Cisco ICM NT e server DNS através do DHCP.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Configuração

Dica: Refira a configuração passo a passo do RFC1483 que distribui com um único endereço IP estático se você não é familiar com como configurar dispositivos Cisco e gostaria de seguir uma configuração passo a passo.

Roteador Cisco DSL com endereço IP estático e NAT

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface atm0.1 point-to-point
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat outside
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!

!--- For NAT:

ip nat inside source list 1 interface atm0.1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface atm0.1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Refira pesquisando defeitos o RFC1483 que distribui se seu serviço ADSL não funciona corretamente.


Informações Relacionadas


Document ID: 71132