Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Asymmetric Digital Subscriber Line (ADSL)

Configuração e guia de Troubleshooting do roteador Cisco DSL - Roteador Cisco DSL que atua como um PPPoE Client com um endereço IP dinâmico

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Seu provedor de Internet (ISP) atribuiu um endereço IP público dinâmico a seu roteador Cisco Digital Subscriber Line (DSL).

Dica: Se você não é familiar com como configurar dispositivos Cisco e gostaria de seguir uma configuração passo a passo, refira a configuração passo a passo do PPPoE com um endereço IP dinâmico.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Tarefas executar

  • Projete um esquema de endereçamento de IP para sua LAN privada.

  • Configurar ajuste um endereço IP de Um ou Mais Servidores Cisco ICM NT, uma máscara de sub-rede, e de um Maximum Segment Size TCP (MSS) na interface Ethernet do roteador Cisco DSL.

  • Configurar a interface ATM (relação da linha de assinante digital de Asymetric (ADSL)) do roteador Cisco DSL com uns Circuitos Virtuais Permanentes (PVC) e o encapsulamento ATM.

  • Configurar um grupo virtual da rede de dados privados do Point-to-Point Protocol sobre Ethernet (PPPoE) (VPDN) para o software do ½ do ¿  de Cisco IOSï mais velho do que 12.2(13)T.

  • Crie e configurar a interface do discador do roteador Cisco DSL para o PPPoE com um endereço IP de Um ou Mais Servidores Cisco ICM NT negociado.

  • (Para o [NAT] da tradução de endereço de rede) — Configurar o NAT no roteador Cisco DSL para permitir a partilha do endereço IP de Um ou Mais Servidores Cisco ICM NT da pública dinâmica da interface do discador.

    • Opcional: Conjunto NAT, se os endereços IP de Um ou Mais Servidores Cisco ICM NT adicionais foram fornecidos por seu ISP.

    • Opcional: NAT estático, se os usuários do Internet exigem o acesso aos servidores internos.

  • Configurar cada cliente de PC com um endereço IP de Um ou Mais Servidores Cisco ICM NT, uma máscara de sub-rede, um gateway padrão, e um server do Domain Name System (DNS).

    (Para o [DHCP] do protocolo de configuração dinâmica host) — Alternativamente, se você quer o roteador Cisco DSL atribuir os endereços IP dinâmicos dos seus clientes PC, configurar cada PC para obter automaticamente um endereço IP de Um ou Mais Servidores Cisco ICM NT e server DNS através do DHCP.

Passos de configuração requerida possíveis no PC

Se seus suportes de software do roteador Cisco DSL o IP tcp ajustam-mss 1452 ou o IP ajusta-mss 1452 comandos configuration, nenhuma ação mais adicional está precisada e você pode continuar com a seção configurar.

Se seu software do roteador Cisco DSL não apoia o IP tcp ajusta-mss 1452 ou o IP ajusta-mss 1452 comandos configuration, você deve mudar o tamanho da unidade de transmissão máxima (MTU) em cada PC em seu LAN que tem o acesso ao Internet através do roteador Cisco DSL.

Termine estas etapas a fim mudar o tamanho do MTU:

  1. Transfira a versão a mais atrasada do Dr. utilitário TCPleavingcisco.com .

  2. Refresque sua página do navegador para assegurar-se de que a página seja atual.

  3. Execute o Dr. utilitário TCP.

  4. Do menu escolha seu adaptador do Ethernet.

  5. Tipo 1492 no campo MTU.

  6. O clique aplica-se a fim salvar a mudança, e clica-se então a saída.

  7. Recarregue o cliente de PC PPPoE.

A mudança de registro salvar quando os revestimentos assim que você do procedimento precisam de executar a utilidade somente uma vez pelo PC.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Configuração

Dica: Se você não é familiar com como configurar dispositivos Cisco e gostaria de seguir uma configuração passo a passo, refira a configuração passo a passo do PPPoE com um endereço IP dinâmico.

Roteador Cisco DSL com um endereço IP dinâmico

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
 vpdn-group pppoe
  request-dialin
   protocol pppoe

!--- These commands are needed only on Cisco IOS Software earlier than 12.2(13)T.

!
!
ip subnet-zero
!


!--- For DHCP:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported,  
 !--- try this configuration statement:
 !--- ip adjust-mss 1452   


 
!--- If this command is not supported in your current Cisco DSL Router software
 !--- release, either upgrade to the latest Cisco DSL Router software or follow the 
 !--- procedure in the "Possible Required Configuration Steps on the PC" 
 !--- section of this document. 

 


!--- For NAT:


ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
 pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address negotiated
 mtu 1492


!--- For NAT:


 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication chap pap callin
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!


!--- For NAT:


ip nat inside source list 1 interface dialer1 overload


!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> 
!---  <last ip address> netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer 1


!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network was 10.10.10.0, configuring 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 would allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Se seu serviço dsl não está trabalhando corretamente, veja a pesquisa de defeitos do PPPoE Client do roteador Cisco DSL.


Informações Relacionadas


Document ID: 71118