Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Asymmetric Digital Subscriber Line (ADSL)

Configuração e guia de Troubleshooting do roteador Cisco DSL - Configuração passo a passo do PPPoA com um endereço IP estático

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Seu provedor de Internet (ISP) atribuiu um endereço IP público estático a seu roteador Cisco Digital Subscriber Line (DSL).

Nota: Este exemplo destaca dois tipos de configurações:

  • Server do protocolo de configuração dinâmica host (DHCP)

  • Network Address Translation (NAT).

Importante: Antes que você comece, feche todos os programas no PC que pôde monitorar sua porta COM. Os dispositivos tais como PDA e câmeras digital colocam frequentemente os programas na bandeja do sistema que tornam sua porta COM inusável para a configuração de seu roteador Cisco DSL.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Procedimentos de configuração

Conecte o roteador Cisco DSL e seu PC

Uma conexão de console é feita com um cabo enrolado e conecta a porta de Console do roteador Cisco DSL a uma porta COM em um PC. O cabo do console que é incluído com o roteador Cisco DSL é uma luz lisa - cabo azul. Para obter mais informações sobre dos pinouts de um cabo enrolado, ou dos pinouts de um RJ-45 ao conversor DB9, refira o guia de cabeamento para Console e Portas AUX.

  1. Conecte o conector RJ-45 em uma extremidade de um cabo do console da Cisco à porta de Console do roteador Cisco DSL.

  2. Conecte o conector RJ-45 no outro extremo do cabo do console a um RJ-45 ao conversor DB9.

  3. Conecte o conector DB9 a uma porta COM aberta em seu PC.

Comece e estabelece o HyperTerminal

Conclua estes passos:

  1. Comece o programa do HyperTerminal no PC.

  2. Estabelecer sua sessão de hiperterminal.

    1. Atribua um nome a sua sessão e clique a APROVAÇÃO.

    2. Na conexão ao indicador, clique o cancelamento.

    3. Escolha o arquivo > propriedades.

    4. Da janela de propriedades, vá à conexão usando a lista e selecione a porta COM onde você conecta a extremidade DB9 do cabo do console.

    5. Do clique da janela de propriedades configurar e preencha estes valores:

      • Bits por segundo: 9600

      • Bits de dados: 8

      • Paridade Nenhum

      • Bits de parada: 1

      • Controle de fluxo: Nenhum

    6. Clique em OK.

    7. Do Call Menu, disconexão do clique.

    8. Do Call Menu, atendimento do clique.

    9. A imprensa entra até que você ver uma alerta de roteador em sua janela do Hyperterminal.

Cancele configurações existentes no roteador Cisco DSL

Conclua estes passos:

  1. O tipo permite na alerta de roteador a fim incorporar o modo privilegiado.

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. Cancele configurações existentes no roteador.

    Router#write erase
    
  3. Recarregue o roteador de modo que carreg com uma configuração de inicialização vazia.

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- The router reload can take a few minutes.
    
    
  4. Depois que o roteador recarregou, incorpore o modo enable outra vez.

    Router>enable
    Router#

Configurar o roteador Cisco DSL

Conclua estes passos:

  1. Configurar o rótulo de tempo de serviço para registrar e indicar corretamente o resultado do debug na seção de Troubleshooting.

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. Desabilite o console de registro em seu roteador Cisco DSL para suprimir os mensagens do console que puderam ser provocados quando você configurar o roteador.

    Router#configure terminal
    Router(config)#no logging console
    Router(config)#end
    
  3. Configurar Roteamento IP, o sub-rede zero IP, e o IP sem classe a fim fornecer a flexibilidade em opções de configuração de roteamento.

    Router#configure terminal
    Router(config)#ip routing
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. Configurar um endereço IP de Um ou Mais Servidores Cisco ICM NT e uma máscara de sub-rede na interface Ethernet do roteador Cisco DSL.

    Para o NAT: (Opcional) permita o NAT para dentro na interface Ethernet.

    Router#configure terminal
    Router(config)#interface ethernet 0
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat inside
    Router(config-if)#no shut
    Router(config-if)#end
    
  5. Configurar a interface ATM de seu roteador Cisco DSL com uns Circuitos Virtuais Permanentes (PVC), o tipo de encapsulamento, e o pool de discadores ATM.

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#pvc <vpi/vci>
    Router(config-if-atm-vc)#encapsulation aal5mux ppp dialer
    Router(config-if-atm-vc)#dialer pool-member 1
    Router(config-if-atm-vc)#no shut
    Router(config-if-atm-vc)#end
    
  6. Configurar a interface do discador de seu roteador Cisco DSL para o protocolo Point-to-Point sobre ATM (PPPoA) com um endereço IP estático.

    Para o NAT: (Opcional) permita o NAT fora na interface do discador.

    Router#configure terminal
    Router(config)#interface dialer 1
    Router(config-if)#ip address <IP address> <subnet mask>
    Router(config-if)#no ip directed-broadcast
     
    !--- For NAT:
    
    Router(config-if)#ip nat outside
    Router(config-if)#encapsulation ppp
    Router(config-if)#dialer pool 1  
    Router(config-if)#ppp chap hostname <username>
    Router(config-if)#ppp chap password <password>
    Router(config-if)#ppp pap sent-username <username> password <password>
    Router(config-if)#end
    
  7. Configurar uma rota padrão usando Discador1 como a interface externa.

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 dialer1
    Router(config)#end
    
  8. Para o NAT: Configurar comandos nat globais no roteador Cisco DSL a fim permitir a partilha do endereço IP público estático da interface do discador.

    Router#configure terminal
    Router(config)#ip nat inside source list 1 interface dialer1 overload
    Router(config)#access-list 1 permit <ip network address of ethernet0> 
     <wildcard mask>
    Router(config)#end
    

    Configurações opcionais

    Conjunto NAT, se os endereços IP de Um ou Mais Servidores Cisco ICM NT adicionais foram fornecidos por seu ISP.

    Router(config)#ip nat inside source list 1 interface dialer1 overload 
    Router(config)#ip nat pool <nat pool name> <first ip address> 
     <last ip address> netmask <subnet mask>
    Router(config)#end
    

    NAT estático, se os usuários do Internet exigem o acesso aos servidores internos.

    Router(config)#ip nat inside source static tcp <inside ip address of server> 
     {80 or 25} <outside well-known ip address of server> {80 or 25} extendable
    Router(config)#end
    
  9. Para o DHCP: (Opcional) configurar o roteador Cisco DSL como um servidor DHCP com um pool dos endereços IP de Um ou Mais Servidores Cisco ICM NT para atribuir aos anfitriões conectados à interface Ethernet do roteador Cisco DSL. O servidor DHCP atribui dinamicamente um endereço IP de Um ou Mais Servidores Cisco ICM NT, o Domain Name Server (DNS), e o endereço IP de Gateway padrão a seus anfitriões.

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    Router(config)#ip dhcp pool <dhcp pool name>
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    Router(dhcp-config)#end
    
  10. Permita o console de registro no roteador Cisco DSL, e escreva todas as mudanças à memória.

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

Configuração

Esta é a configuração que é construída depois que você terminou os procedimentos na seção dos procedimentos de configuração deste documento.

Roteador Cisco DSL com um endereço IP estático

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask> 
 default-router <ip address of ethernet0> 
 dns-server <ip address of dns server> 
! 
interface ethernet0  
 no shut 
 ip address <ip address> <subnet mask>  
 ip nat inside 
 no ip directed-broadcast 
! 
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 pvc <vpi/vci>
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address <ip address> <subnet mask> 
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username> 
 ppp chap password <password> 
 ppp pap sent-username <username> password <password> 
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided
!--- by your ISP, you can use a NAT Pool. Replace
!--- ip nat inside source list 1 interface dialer1 overload




!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25}
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used
!--- for this example. You can open other TCP or UDP ports, if needed.

!
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list
!--- that permits the addresses that NAT translates. For example, if
!--- your private IP network is 10.10.10.0, configure
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verificar

Seu roteador Cisco DSL é agora operacional para o serviço do Asymmetric Digital Subscriber Line (ADSL). Você pode emitir um comando show run a fim ver a configuração.

Router#show run
Building configuration...

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Troubleshooting

Refira a pesquisa de defeitos do PPPoA se seu serviço ADSL não funciona corretamente.


Informações Relacionadas


Document ID: 71112