Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Asymmetric Digital Subscriber Line (ADSL)

Configuração e guia de Troubleshooting do roteador Cisco DSL - Roteador Cisco DSL PPPoA com um endereço IP estático

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Seu provedor de Internet (ISP) atribuiu um endereço IP público dinâmico a seu roteador Cisco Digital Subscriber Line (DSL).

Dica: Se você não é familiar com como configurar dispositivos Cisco e gostaria de seguir uma configuração passo a passo, refira a configuração passo a passo do PPPoA com um endereço IP estático.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Tarefas executar

  • Projete um esquema de endereçamento de IP para sua LAN privada.

  • Configurar um endereço IP de Um ou Mais Servidores Cisco ICM NT e uma máscara de sub-rede na interface Ethernet do roteador Cisco DSL.

  • Configurar a interface ATM (relação do Asynchronous Digital Subscriber Line (ADSL)) do roteador Cisco DSL com uns Circuitos Virtuais Permanentes (PVC) e o encapsulamento ATM.

  • Crie e configurar a interface do discador do roteador Cisco DSL para o protocolo Point-to-Point sobre ATM (PPPoA) com um endereço IP estático.

  • Para o NAT: Configurar o NAT no roteador Cisco DSL para permitir a partilha do endereço IP público estático da interface do discador.

    • Opcional: Conjunto NAT, se os endereços IP de Um ou Mais Servidores Cisco ICM NT adicionais foram fornecidos por seu ISP.

    • Opcional: NAT estático, se os usuários do Internet exigem o acesso aos servidores internos.

  • Configurar cada host PC com um endereço IP de Um ou Mais Servidores Cisco ICM NT, uma máscara de sub-rede, um gateway padrão, e um server do Domain Name System (DNS).

    Alternativamente, se você quer o roteador Cisco DSL atribuir os endereços IP dinâmicos dos seus clientes PC, configurar cada PC para obter automaticamente um endereço IP de Um ou Mais Servidores Cisco ICM NT e server DNS através do DHCP.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Configuração

Dica: Se você não é familiar com como configurar dispositivos Cisco e gostaria de seguir uma configuração passo a passo, refira a configuração passo a passo do PPPoA com um endereço IP estático.

Roteador Cisco DSL com um endereço IP estático

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 pvc <vpi/vci>
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

!
interface dialer1
 ip address <ip address> subnet mask <subnet mask> 
 no ip directed-broadcast

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username> 
 ppp chap password <password> 
 ppp pap sent-username <username> password <password> 
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Refira a pesquisa de defeitos do PPPoA se seu serviço ADSL não funciona corretamente.


Informações Relacionadas


Document ID: 71110