Sem fio/Mobilidade : LAN Wireless (WLAN)

Exemplos de configuração do módulo do controlador do Wireless LAN (WLCM)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (20 Dezembro 2015) | Feedback


Índice


Introdução

O módulo Cisco WLAN Controller (WLC) (WLCM) permite que ISRs Cisco e Cisco 3700 Series Routers gerenciem até seis pontos de acesso (APs) da LAN wireless e simplifiquem a implementação e o gerenciamento das WLANs. É equivalente a um Cisco WLC 2006 colocado em um fator de forma NM. A única diferença é que o NM-WLC (módulo WLCM) tem somente uma única porta Fast Ethernet conectada internamente ao roteador do host e a porta Fast Ethernet externa na placa dianteira do NM está desabilitada e inutilizada. Este documento explica como configurar o WLCM em diferentes cenários.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento básico do protocolo de ponto de acesso leve (LWAPP)

  • Conhecimento básico do WLC e dos AP de pouco peso (regaços)

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configuração básica

Pense do NM-WLC como um WLC externo (2006) com a somente uma relação do Fast Ethernet (FE) (conhecida como a porta 1) conectada internamente à interface rápida de Ethernet de um roteador nomeou a relação do controlador de WLAN. Este diagrama mostra um exemplo.

Nota: A porta fastethernet externo na placa dianteira do módulo de Cisco WLC não é apoiada.

/image/gif/paws/70530/nm-wlc-config-guide-1.gif

A maneira comum conectar ao módulo está internamente dentro do roteador com o comando session do módulo de serviço.

  1. Introduza o módulo NM-WLC no roteador e carreg acima do roteador com uma imagem válida.

    Toda a imagem (do ipbase a adventerprisek9) pode apoiar o módulo NM-WLC. Esta característica foi introduzida com Cisco IOS Software Release 12.4(2)XA1 (software do roteador). A versão mínima do firmware de controlador deve ser 3.2.78.0 (software do controlador).

  2. Configurar um endereço IP de Um ou Mais Servidores Cisco ICM NT no WLAN-controlador 1/0 da relação; supor o módulo é obstruída no slot1 do roteador. Execute um nenhum fechado se está no estado de fechamento.

    c2811#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    c2811(config)#
    c2811(config)#interface wlan-controller 1/0
    c2811(config-if)#ip address 192.168.99.254 255.255.255.0
    c2811(config-if)#no shut
    c2811(config-if)#end
    c2811#
  3. Do prompt de exec privilegiado, abra uma sessão ao controlador que usa o comando session do módulo de serviço.

    c2811#service-module wlan-controller 1/0 session 
    Trying 192.168.99.254, 2066 ... Open

    Nota: Os comandos cisco ios para o módulo do theWLCM variam no roteador que executa o Software Cisco IOS versão 12.4(15)T ou mais tarde. Refira configurar Cisco WLCM no roteador para mais informação.

Se o controlador é trazido acima pela primeira vez sem a configuração anterior, participa automaticamente em um assistente CLI que lhe peça uma série de informação de configuração. Este assistente não pode ser contorneado e você deve incorporar toda a informação que pede. Compreendendo de antemão como você quer suas configurações olhar quando as ajudas terminadas respondem às perguntas. Alguma da informação que pede não é relevante e usada imediatamente mas você ainda precisa de fornecê-lo porque não aceita a entrada inválida e você igualmente não pode contornear. A saída parece similar à saída nesta tabela:

Controlador de Cisco
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_ff:f6:a0]: NMWLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
 
Management Interface IP Address: 192.168.99.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1
Management Interface DHCP Server IP Address: 192.168.99.24
 
AP Manager Interface IP Address: 192.168.99.25
 
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.99.24): 192.168.99.24
 
Virtual Gateway IP Address: 1.1.1.1
 
Mobility/RF Group Name: mg1
 
Network Name (SSID): wl15
Allow Static IP Addresses [YES][no]: no
 
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
 
Enter Country Code (enter 'help' for a list of countries) [US]: US
 
Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: YES
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: no
Configuration saved!
Resetting system with new configuration...

Uma vez que a configuração está completa, recarrega automaticamente com a configuração nova e para no usuário: alerte onde você fornece um nome de usuário e senha. (Controlador de Cisco) > a alerta aparece então.

User:admin
Password:*****
(Cisco Controller) >

Uma vez que você está na alerta do controlador, você pode fazer umas configurações ou umas alterações mais adicionais do que você fez através do assistente CLI. Use? para obter ajuda.

A fim comutar de volta ao roteador, pressione ctrl+shift+6, libere, e pressione então o X. Isto toma-o à alerta de roteador. A sessão permanece intacto, assim que se você pressiona entra, ele toma-o de volta ao controlador. Se você quer completamente claro a sessão, incorpore a disconexão na alerta de roteador.

Mesmo que o controlador tenha somente uma porta física (referida como a porta 1), você pode criar todo o número de interfaces lógica nele, estático ou dinâmico, e aquelas relações podem VLAN-ser etiquetadas ou sem etiqueta. À revelia, o controlador tem duas relações estáticas e do sem etiqueta:

  • Interface de gerenciamento

  • Relação do gerenciador AP

A interface de gerenciamento é usada para propósitos do gerenciamento. Se você escolhe usar uma interface GUI com base na Web a fim controlar o WLCM, você precisa de configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT na interface de gerenciamento e de fazer isso alcançável da estação de trabalho que você planeia a controlar de.

Nota: À revelia, o Server do HTTP no controlador é desabilitado mas o HTTP seguro é permitido. Consequentemente, a URL ao endereço IP de gerenciamento do controlador deve ser https://mgt-ip-address.

A relação do gerenciador AP é usada pelo controlador para falar aos regaços. Desde que o Gerenciamento e as relações do gerenciador AP são sem etiqueta, deve estar na mesma sub-rede IP que a relação WLC no roteador.

(Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254
(Cisco Controller) config>interface address ap-manager 
                           192.168.99.25 255.255.255.0 192.168.99.254

Você pode configurar o CLI em duas maneiras. Um é do lembrete regular precedendo o CLI com a configuração. O outro método é ir à alerta da configuração com o comando config e emitir então CLI sem a configuração da palavra. Por exemplo:

 (Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254

ou

(Cisco Controller)>config interface address management 
                        192.168.99.24 255.255.255.0 192.168.99.254

Este exemplo configura a interface de gerenciamento com o endereço IP de Um ou Mais Servidores Cisco ICM NT 192.168.99.24/24 e define o gateway padrão como 192.168.99.254.

Nota: O gateway padrão no Gerenciamento e no Gerenciamento AP deve apontar ao endereço IP de Um ou Mais Servidores Cisco ICM NT da porta Ethernet WLCM.

Nota: Uma vez que você configura estes endereços IP de Um ou Mais Servidores Cisco ICM NT através do assistente então você não precisa estes comandos. Este é apenas mostrar-lhe que ambos estes endereços IP de Um ou Mais Servidores Cisco ICM NT pertencem à mesma sub-rede e este pode igualmente ser configurado através da linha de comando.

Em ambos os casos, o último endereço IP de Um ou Mais Servidores Cisco ICM NT (192.168.99.254) é o endereço IP de Gateway padrão. Desde que a única maneira fora do controlador é através do roteador host, o gateway padrão deve ser o endereço IP de Um ou Mais Servidores Cisco ICM NT da relação wlan-controller1/0 no roteador. Com esta muita configuração, você pode sibilar do roteador ao endereço IP de Um ou Mais Servidores Cisco ICM NT da interface de gerenciamento do controlador.

c2811#ping 192.168.99.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.24, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
c2811# 

Exemplo 1 - A configuração básica com um AP conectou a um roteador a bordo o Fast Ethernet/Gigabit Ethernet

Quando um REGAÇO conectado à interface Gigabit Ethernet a bordo (g0/0) de um roteador é posto sobre, envia uma requisição DHCP para um endereço IP de Um ou Mais Servidores Cisco ICM NT. Neste exemplo, o roteador é configurado como um servidor DHCP com o pool do endereço IP de Um ou Mais Servidores Cisco ICM NT da rede 192.168.100.0/24. Assim, o REGAÇO obtém um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.100.101. A oferta de DHCP igualmente diz o REGAÇO (através da opção 43) que o endereço IP de Um ou Mais Servidores Cisco ICM NT do controlador é 192.168.99.24 (o endereço IP de gerenciamento do controlador). O REGAÇO envia agora a um controlador o unicast do mensagem de descoberta a 192.168.99.24. O controlador oferece o registro e em consequência, o REGAÇO registra-se com o controlador.

Use o comando show ap summary a fim ver o REGAÇO que se registra com o WLCM.

(Cisco Controller) >show ap summary

AP Name             Slots  AP Type    MAC Addr           Location          Port
------------------  -----  ---------  -----------------  ---------------- 	----
AP11                 2     Cisco      00:0b:85:01:03:30                   	1

Neste exemplo, o controlador é configurado com dois WLAN (wl15 e wl16) como descrito mais tarde no documento.

O cliente C1 envia um pedido da associação com SSID wl15. Associa e obtém um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.15.101 e um gateway padrão de 192.168.15.1 do servidor DHCP configurado no roteador.

O cliente C2 igualmente envia um pedido da associação com SSID wl16. Associa e obtém um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.16.101 e um gateway padrão de 192.168.16.1. Agora há dois clientes em duas sub-redes diferentes. Uma comunicação entre elas é possível por meio de um roteador que execute o roteamento entre suas duas subinterfaces (wlc1/0.15 e wlc1/0.16) como este diagrama mostra:

A configuração exigida nos dispositivos para esta instalação é discutida na seção de configuração de controle deste documento.

/image/gif/paws/70530/nm-wlc-config-guide-2.gif

Configuração de controle

Esta seção discute a configuração exigida no módulo do controlador.

  1. Crie duas interfaces dinâmica nomeadas vl15 no VLAN15 e vl16 em VLAN 16.

    (Cisco Controller) >config interface create vl15 15
    (Cisco Controller) >config interface create vl16 16
    
  2. Atribua o endereço IP de Um ou Mais Servidores Cisco ICM NT, o netmask, e o gateway padrão para estas interfaces de VLAN.

    (Cisco Controller) >config interface address vl15 
                                  192.168.15.254 255.255.255.0 192.168.15.1
    
    (Cisco Controller) >config interface address vl16 
                                  192.168.16.254 255.255.255.0 192.168.16.1
    

    Nota: O gateway padrão para as interfaces dinâmica deve ser o endereço IP de Um ou Mais Servidores Cisco ICM NT da secundário-relação no roteador para o VLAN correspondente.

  3. Crie dois WLAN 15 e 16 com SSID correspondentes wl15 e wl16.

    (Cisco Controller) >wlan create 15 wl15
    (Cisco Controller) >wlan create 16 wl16
    
  4. Ligue estes WLAN com as interfaces VLAN correspondente que você criou (na face da tela).

    (Cisco Controller) >wlan interface 15 vl15
    (Cisco Controller) >wlan interface 16 vl16
    
  5. Configurar as interfaces dinâmica que você criou com um endereço IP de servidor DHCP para enviar as requisições DHCP do cliente a.

    Desde que o servidor DHCP é configurado no roteador, deve apontar aos endereços IP de Um ou Mais Servidores Cisco ICM NT correspondentes da secundário-relação do roteador. Se você tem um servidor de DHCP externo, a seguir deve apontar a esse endereço IP de Um ou Mais Servidores Cisco ICM NT.

    (Cisco Controller) >interface dhcp vl15 192.168.15.1
    (Cisco Controller) >interface dhcp vl16 192.168.16.1
    
  6. À revelia, o método de autenticação é dot1x e é permitido. A fim trabalhar com autenticação aberta, desabilite-a com este comando para ambos os WLAN:

    (Cisco Controller) >wlan security 802.1X disable 15
    (Cisco Controller) >wlan security 802.1X disable 16
    

Esta configuração pode ser expandida baseou em suas necessidades tais como mais VLAN/WLAN, autenticação ([LEAP] do protocolo lightweight extensible authentication, EAP), QoS, e assim por diante.

Nota: Com WLCM, é difícil para um REGAÇO descobrir o WLCM com o broadcast de sub-rede IP. Isto é devido à maneira que o WLCM integra no backplane e o REGAÇO e a interface de gigabit do 2800 Router que é conectado diretamente com o REGAÇO precisam de ser a mesma sub-rede. Se você quer executar a descoberta do broadcast de sub-rede IP com o sucesso, use os comandos UDP 12223 do dianteiro-protocolo IP helper-address/ip. Geralmente, a finalidade destes comandos é enviar/relé potencialmente todo o quadro da transmissão IP. Simplesmente retransmiti-la e dirigir à interface de gerenciamento WLC devem ser adequadas conseguir o WLC responder de volta ao REGAÇO.

Nota: Todas as configurações de controle nesta seção podem facilmente ser feitas com o acesso de GUI através de um navegador da Web uma vez que a interface de gerenciamento é configurada com um endereço IP de Um ou Mais Servidores Cisco ICM NT, um netmask, e uma informação de gateway. Também, todo o roteamento exigido na rede para que suas estações do navegador possam alcançar o controlador é feito. A URL para abrir a página GUI é https://192.168.99.24.

Configuração do roteador

Termine estas etapas a fim configurar o roteador para setup esta seção descreve.

  1. Configurar a relação G0/0 no roteador que está conectada ao REGAÇO.

  2. Configurar o WLAN-controlador 1/0 da relação com um endereço IP de Um ou Mais Servidores Cisco ICM NT das 192.168.99.0/24 redes e as subinterfaces w1/0.15 no VLAN15 e w1/0.16 em VLAN 16 com os endereços IP de Um ou Mais Servidores Cisco ICM NT das redes 192.168.15.0/24 e 192.168.16.0/24.

  3. Configurar um servidor DHCP no roteador com diversas associações definidas.

    • O pool lwapp-ap atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT ao AP da rede 192.168.100.0/24 que igualmente inclui a opção de DHCP 43 que informa o AP do endereço IP de Um ou Mais Servidores Cisco ICM NT do controlador para contactar.

    • O pool client-15 atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT aos clientes (prendidos/Sem fio) no VLAN15 da rede 192.168.15.0/24.

    • O pool client-16 atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT aos clientes (prendidos/Sem fio) em VLAN 16 da rede 192.168.16.0/24.

Esta saída mostra a configuração no roteador:

Router
!		
interface GigabitEthernet0/0								
Description: Connected to AP							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 duplex auto									
 speed auto
									
!										
ip dhcp excluded-address 192.168.100.1 192.168.100.100
!
ip dhcp pool lwapp-ap

!--- Creates a DHCP pool for the LAP.

network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15

!--- Creates a DHCP pool for users that connect to WLAN wl15.

network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16

!--- Creates a DHCP pool for users that connect to WLAN wl16.

network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!										
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15

!--- Creates a sub-interface for VLAN 15.
						
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16

!--- Creates a sub-interface for VLAN 16.
					
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0							
!

Exemplo 2 - Configurações de VLAN com os AP conectados a um switch externo

O WLCM obstruído no roteador pode logicamente ser considerado equivalente a um WLC externo conectado ao roteador através de uma interface Ethernet enquanto este diagrama mostra. Com a suposição que o módulo de rede está obstruído no slot1 do roteador, a Conectividade típica consiste:

  • Um WLCM conectado ao roteador através do WLAN-controlador 1/0 da relação.

  • Um switch de Camada 2 conectado à interface Gigabit Ethernet a bordo G0/0 do Roteadores.

  • Um protocolo de pouco peso AP (LWAPP) AP conectado ao interruptor.

  • Clientes Wireless C1 e C2 associados com o AP, o um em WLAN 15 e o outro em WLAN 16.

Este exemplo mostra como dois VLAN sem fio ou WLAN (wl15 e wl16) são criados no controlador, traçado ao VLAN15 da face da tela e a VLAN correspondentes 16, e como distribuir entre o VLAN15 e o VLAN 16 é feita pelo roteador através das subinterfaces do dot1q.

No roteador, crie uma secundário-relação sob a relação WLC (no modo de configuração da interface) para cada VLAN, atribua-a ao VLAN correspondente, e configurar-lo o endereço IP de Um ou Mais Servidores Cisco ICM NT dos sub-rede respectiva.

Veja a seção de configuração de controle deste documento para as configurações exigidas nos dispositivos para esta instalação.

/image/gif/paws/70530/nm-wlc-config-guide-3.gif

Configuração de controle

Termine estas etapas no módulo do controlador para esta instalação.

  1. No controlador, para cada VLAN, crie uma interface dinâmica no VLAN correspondente e atribua um endereço IP de Um ou Mais Servidores Cisco ICM NT, um netmask, e uns gateways padrão dos sub-rede respectiva.

    (Cisco Controller)#configure interface create vl15 15
    (Cisco Controller)#configure interface create vl16 16
    
    (Cisco Controller)#configure interface address 
                      Vl15 192.168.15.254 255.255.255.0 192.168.15.1
    (Cisco Controller)#configure interface address 
                      Vl16 192.168.16.254 255.255.255.0 192.168.16.1
    
  2. Crie dois WLAN 15 e 16 com SSID correspondentes wl15 e wl16.

    (Cisco Controller)#configure wlan create 15 wl15
    (Cisco Controller)#configure wlan create 16 wl16
    
  3. Ligue estes WLAN com as interfaces VLAN correspondente que você criou (na face da tela).

    (Cisco Controller)#configure wlan interface 15 Vl15
    (Cisco Controller)#configure wlan interface 16 Vl16
    
  4. Configurar a informação do servidor DHCP nas relações dos controladores (para clientes Wireless) esse ponto aos endereços IP de Um ou Mais Servidores Cisco ICM NT respectivos da secundário-relação no roteador.

    (Cisco Controller)#configure interface dhcp vl15 192.168.15.1
    (Cisco Controller)#configure interface dhcp Vl16 192.168.16.1
    

Com estas configurações, os dois clientes Wireless em dois WLAN devem ser em serviço, com a suposição que a configuração de segurança apropriada está feita igualmente. O tráfego do cliente em WLAN 15 destinado ao cliente em WLAN 16 é distribuído entre as subinterfaces w1/0.15 e w1/0.16 no roteador. As mesmas configurações podem ser prolongadas para todo o número de VLAN até o número máximo de VLAN apoiados para o controlador (16).

Configuração do Switch

Com a suposição que todos os clientes prendidos estão conectados ao interruptor (por exemplo, cat3750) que é em tronco ao roteador através da atuação 1/0/1 da relação para o roteamento inter-LAN, conecte o LWAPP AP na relação F1/0/1 no interruptor e configurar-lo para o VLAN 100.

Interface Fastethernet 1/0/1
Description: Connected to LWAPP AP
Switchport access vlan 100
Switchport mode access
!
Interface Gigabitethernet 1/0/1
Description: Connected to Router
Switchport trunk encapsulation dot1Q
Switchport mode trunk

Configuração do roteador

Termine estas etapas no roteador.

  1. Configurar a relação G0/0 que está conectada ao interruptor e igualmente às subinterfaces exigidas para o Roteamento Inter-Vlan para o LAN ligado com fio.

  2. Configurar o WLAN-controlador 1/0 da relação com um endereço IP de Um ou Mais Servidores Cisco ICM NT das 192.168.99.0/24 redes e as subinterfaces w1/0.15 no VLAN15 e w1/0.16 em VLAN 16 com os endereços IP de Um ou Mais Servidores Cisco ICM NT das redes 192.168.15.0/24 e 192.168.16.0/24.

  3. Configurar um servidor DHCP no roteador com diversas associações definidas.

    • O pool lwapp-ap atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT ao AP da rede 192.168.100.0/24 que igualmente inclui a opção de DHCP 43 que informa o AP do endereço IP de Um ou Mais Servidores Cisco ICM NT do controlador para contactar.

    • O pool client-15 atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT aos clientes (prendidos/Sem fio) no VLAN15 da rede 192.168.15.0/24.

    • O pool client-16 atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT aos clientes (prendidos/Sem fio) em VLAN 16 da rede 192.168.16.0/24.

    Nota: Os conjuntos separados são precisados para AP e clientes.

Router
ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
								
ip dhcp pool client-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 

ip dhcp pool client-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet0/0
Description: Connected to AP
No ip address							
 load-interval 30									
 duplex auto									
 speed auto
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0	
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0

Nota: Você pode igualmente dirigir serviços DHCP para os clientes no controlador. Mas recomenda-se ser executado no roteador porque o controlador não é um servidor DHCP desenvolvido e não pode passar sobre opções como o servidor TFTP exigido para aplicativos como o CallManager da Cisco expresso.

Com esta configuração, o AP pode obter o endereço IP de Um ou Mais Servidores Cisco ICM NT, encontrá-lo, e registrar-se com o controlador. Dois clientes Wireless C1 e C2 devem poder associar com o AP e obter o endereço IP de Um ou Mais Servidores Cisco ICM NT dos sub-rede respectiva.

Exemplo 3 - Configurações com os AP conectados a um EtherSwitch no roteador e nos VLAN correspondentes da fusão do prendido e Sem fio LAN

Nesta encenação, há um EtherSwitch HWIC obstruído no slot 0 ISR HWIC e um NM-WLC obstruído no cliente prendido C3 do entalhe 1. NM é conectado para conectar F0/0/1 no VLAN15 com um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.15.102 e o cliente prendido C4 é conectado a F0/0/2 em VLAN 16 com um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.16.102.

O LWAPP AP é conectado para conectar F0/0/0 no VLAN 100 com um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.100.1. O roteador é configurado como um servidor DHCP para servir um endereço IP de Um ou Mais Servidores Cisco ICM NT ao AP. Por exemplo, um AP recebe um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.100.101, um gateway padrão de 192.168.100.1 e um endereço IP de Um ou Mais Servidores Cisco ICM NT do controlador de 192.168.99.24 através da opção 43.

Nota: A configuração exigida no controlador é similar à configuração explicada no exemplo anterior e não é discutida aqui. As seções remanescente fornecem a configuração exigida no roteador.

/image/gif/paws/70530/nm-wlc-config-guide-4.gif

Os clientes Wireless C1 e C2 associam com o REGAÇO em wl15 e em wl16 respectivamente. Os clientes Wireless C1 e C2 igualmente obtêm um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.15.101 e de 192.168.16.101 atribuídos pelo servidor DHCP configurado no roteador ou em um servidor de DHCP externo com as associações IP para aquelas sub-redes. Se o servidor DHCP é externo, o endereço IP auxiliar deve ser configurado no VLAN correspondente e nas subinterfaces. Da perspectiva do roteador, tem dois VLAN prendidos representados pelo VLAN15 da relação e a relação os VLAN sem fio VLAN 16 e dois representados pelas subinterfaces w1/0.15 e w1/0.16 do dot1q sob o WLC conecta no roteador.

A fim desmoronar junto o VLAN15 e o Sem fio prendidos WLAN 15, configurar o VLAN15 da relação e conecte w1/0.15 sob um grupo de bridge comum, por exemplo, o ponte-grupo 15. Similarmente, a fim desmoronar VLAN prendido 16 e Sem fio WLAN 16, configurar a relação VLAN 16 e conecte w1/0.16 sob um grupo de bridge comum, por exemplo, o ponte-grupo 16. Com esta configuração, a correspondência prendida e os VLAN sem fio pertencem ao mesmo sub-redes IP 192.168.15.0/24 e 192.168.16.0/24 e podem falar entre si dentro do grupo de bridge. Mas para que os clientes em dois grupos de bridge diferentes a comunicar-se entre si, permita o Integrated Routing and Bridging (IRB) no roteador de modo que se comuniquem através das interfaces de BVI nos grupos de bridge respectivos.

Nota: Esta configuração é baseada na suposição que você tem o EtherSwitch HWIC ou NM-ESW no roteador para o LAN ligado com fio. Se você tem o módulo de serviço do EtherSwitch (NME-ESW) em vez do NM/HWIC, as interfaces de VLAN estão substituídas por subinterfaces correspondentes do dot1q sob a interface Gigabit Ethernet no roteador e o resto da configuração permanece mesmo.

Configuração do roteador
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 


interface FastEthernet0/0/0								
Description: Connected to AP
Switchport mode access
Switchport access vlan 100
!
interface FastEthernet0/0/1								
Description: Connected to C3
Switchport mode access
Switchport access vlan 15
!
interface FastEthernet0/0/2								
Description: Connected to C4
Switchport mode access
Switchport access vlan 16
!
Interface vlan 15
Bridge-group 15
!
Interface vlan 16
Bridge-group 16

Interface vlan 100							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Exemplo 4 - As configurações com os VLAN prendidos sob NME-ESW fundiram com os VLAN sem fio sob NM-WLC

Considere esta encenação onde você tem um módulo de serviço do EtherSwitch (NME-ESW) obstruído no entalhe 2 e um NM-WLC ISR NM obstruído no slot1 NM. O NME-ESW pode ser considerado equivalente a um switch externo conectado ao roteador através de um enlace de Ethernet Gigabit. O cliente prendido C3 é conectado para conectar F0/0/1 no VLAN15 com o endereço IP 192.168.15.102 e o cliente prendido C4 conectados a F0/0/2 em VLAN 16 com o endereço IP de Um ou Mais Servidores Cisco ICM NT 192.168.16.102

O LWAPP AP é conectado para conectar F0/0/3 no VLAN 100. A interface interna do EtherSwitch (G1/0/2) é conectada internamente ao roteador host com o Gigabit Ethernet 2/0 da relação. Desde que há mais de um VLAN no interruptor, o link interno entre o interruptor e o roteador deve ser configurado como um tronco. O roteador é configurado como um servidor DHCP com diversas associações a fim servir o endereço IP de Um ou Mais Servidores Cisco ICM NT ao AP e aos clientes (prendidos e Sem fio).

O AP obtém um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.100.101, um gateway padrão de 192.168.100.1 e um endereço IP de Um ou Mais Servidores Cisco ICM NT do controlador de 192.168.99.24 através da opção 43, e descobre-os e registra-se com o controlador. Os clientes Wireless C1 e C2 associam com o REGAÇO em WLAN 15 e 16 e obtêm o endereço IP 192.168.15.101 e o 192.168.16.101 respectivamente. Os clientes prendidos C3 e C4 no VLAN15 e 16 igualmente obtêm um endereço IP de Um ou Mais Servidores Cisco ICM NT de 192.168.15.102 e de 192.168.16.102 do servidor DHCP.

A fim fundir prendeu o VLAN15 com Sem fio WLAN 15, configuram as relações G2/0.15 e a relação w1/0.15 sob um grupo de bridge comum 15. Similarmente, relações inferiores G2/0.16 do grupo de bridge 16 e W1/0.16. Os dois grupos de bridge comunicam-se entre si através de suas interfaces de BVI BVI15 e BVI16.

A configuração de controle permanece mesma que nas encenações mais adiantadas.

/image/gif/paws/70530/nm-wlc-config-guide-5.gif

Configuração do roteador

Configuração do roteador
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet2/0								
Description: Internally connected to Etherswitch
IP address 20.0.0.1 255.255.255.0
load-interval 30
!
Interface GigabitEthernet2/0.100
Encapsulation dot1Q 100							
 ip address 192.168.100.1 255.255.255.0						

Interface GigabitEthernet2/0.15
Encapsulation dot1Q 15							
 Bridge-group 15
!
Interface GigabitEthernet2/0.16
Encapsulation dot1Q 16							
Bridge-group 16									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Configuração do Switch

Abra uma sessão do roteador ao módulo de serviço do EtherSwitch com o comando session do módulo de serviço. Uma vez no interruptor, configurar o interruptor como esta saída mostra:

!
Interface GigabitEthernet 1/0/2
Description: Internally connected to router G2/0 interface.
Switchport trunk encapsulation dot1Q
Switchport mode trunk

!
Interface Fastethernet 0/0/1
Description: Connected to Client C3 in vlan 15
Switchport access vlan 15
Switchport mode access
!
Interface Fastethernet 0/0/2
Description: Connected to Client C4 in vlan 16
Switchport access vlan 16
Switchport mode access
!
Interface Fastethernet 0/0/3
Description: Connected to Client LWAPP AP in vlan 100
Switchport access vlan 100
Switchport mode access

Informações Relacionadas


Document ID: 70530