Roteadores : Cisco ONS 15454 SDH Multiservice Provisioning Platform (MSPP)

Configurar o EtherChannel usando um cartão ML no ONS15454 e o Catalyst Switch através do RPR

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documentdescribes o procedimento para configurar o EtherChannel e o 802.1Q que escavam um túnel usando um Cisco Catalyst 3500XL Switch e o cartão do ML-Series através do anel de pacote de informação resistente (RPR) em um ambiente do Cisco ONS 15454.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • Cisco ONS 15454

  • Placas do Ethernet do ML-Series do Cisco ONS 15454

  • Catalyst 3500XL Switch

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Versão 6.x do Cisco ONS 15454

  • Catalyst 3500XL Switch que executa o Software Release 12.0(5)XC de Cisco IOS�

  • ML (empacotado como parte da liberação ONS15454 6.0) esse Software Release 12.2(27)SV e Mais Recente de Cisco IOS� das corridas

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Diagrama de Rede

Este documento usa uma instalação de laboratório com dois Nós ONS15454 e dois Catalyst 3500XL Switch. EachONS 15454 é equipado com o um cartão ML1000-2, e um anel de pacote de informação resistente (RPR) é construído entre eles através do cartão ML1000-2. Duas portas de Ethernet Gigabit no Catalyst 3500XL são conectadas a duas portas de Ethernet Gigabit no cartão ML1000-2 respectivamente. O diagrama da rede é indicado em figura 1.

Figura 1: Diagrama de Rede

/image/gif/paws/69342/f1.gif

Configuração

Configurando o RPR

Termine estas etapas para construir o RPR:

  1. Crie um circuito entre o POS0 do ML1000-2 em ONS15454 A e POS1 do ML1000-2 em ONS15454 B.

  2. Crie um circuito entre o POS1 do ML1000-2 em ONS15454 A e POS0 do ML1000-2 em ONS15454 B.

  3. Configurar o cartão ML1000-2 em ONS15454 A.

    1. Gire a construção de uma ponte sobre e a distribuição sobre integradas (IRB).

      bridge irb
      
    2. Crie a ponte 1

      Bridge 1 protocol rstp  
    3. Configurar a relação SRP.

      interface SPR1
       no ip address
       no keepalive
       spr station-id 3
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
    4. Configurar a relação POS0.

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. Configurar a relação POS1.

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
  4. Configurar o cartão ML1000-2 em ONS15454 B.

    1. Gire a construção de uma ponte sobre e a distribuição sobre integradas (IRB).

      bridge irb
      
    2. Crie a ponte 1

      Bridge 1 protocol rstp
      
    3. Configurar a relação SRP.

      interface SPR1
       no ip address
       no keepalive
       spr station-id 4
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
    4. Configurar a relação POS0.

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. Configurar a relação POS1.

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      

Configurando o EtherChannel

Termine estas etapas para construir o EtherChannel:

  1. Configurar a relação GigabitEthernet0/1 e GigabitEthernet0/2 no CAT3500_A.

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  2. Configurar a relação GigabitEthernet0/1 e GigabitEthernet0/2 no CAT3500_B.

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  3. Configurar o ML1000-2 em ONS15454 A.

    1. Configurar o gigabitethernet 0 da relação e o gigabitethernet 1.

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Configurar o canal de porta.

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
  4. Configurar o ML1000-2 em ONS15454 B.

    1. Configurar a relação GigabitEthernet0 e o gigabitethernet 1.

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Configurar o canal de porta.

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      

Verificação

Termine estas etapas para verificar a configuração:

  1. Emita o comando show interfaces port-channel do ML1000-2 em ONS15454 A. Este showsthat do comando o EtherChannel contém duas portas de Ethernet Gigabit (veja os caracteres em negrito).

    15454A_ML1000-2>show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 000d.28bd.0b34 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 4000 bits/sec, 7 packets/sec
    
      5 minute output rate 2000 bits/sec, 4 packets/sec
    
         495875 packets input, 33757916 bytes
    
         Received 493640 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         55924 packets output, 4080533 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
  2. Emita o comando show interfaces port-channel do ML1000-2 em ONS15454 B. Este comando mostra que o EtherChannel contém duas portas de Ethernet Gigabit (veja os caracteres em negrito).

    15454B_ML1000-2>show int port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 0013.60f8.65f4 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 3000 bits/sec, 5 packets/sec
    
      5 minute output rate 3000 bits/sec, 6 packets/sec
    
         1970114 packets input, 143644364 bytes
    
         Received 1969971 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         2256335 packets output, 164715496 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
    
  3. Emita o comando show cdp neighbor no CAT3500_A (veja figura 2). Este comando indica o CAT3500_B como seu vizinho com o EtherChannel.

    Figura 2: mostre o vizinho cdp no CAT3500_A

    f2.gif

  4. Emita o comando show cdp neighbor no CAT3500_B (veja figura 3). Este comando indica o CAT3500_A como seu vizinho com o EtherChannel.

    Figura 3: mostre o vizinho cdp no CAT3500_B

    f3.gif

  5. Execute um teste de ping.

    1. Configurar o VLAN2 no CAT3500_A com um endereço IP 192.168.0.2.

      !
      interface VLAN2
       ip address 192.168.0.2 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    2. Configurar o VLAN2 no CAT3500_B com um endereço IP 192.168.0.4.

      !
      interface VLAN2
       ip address 192.168.0.4 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    3. Emita o comando ping no CAT3500_A (veja figura 4).

      ping 192.168.0.4
      
      Figura 4: Teste de ping do CAT3500_A ao CAT3500_B

      /image/gif/paws/69342/f4.gif

    4. Emita o comando ping no CAT3500_B (veja a figura 5).

      ping 192.168.0.2
      
      Figura 5: Teste de ping do CAT3500_B ao CAT3500_A

      /image/gif/paws/69342/f5.gif

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 69342