Voz e comunicações unificadas : Cisco Unified Communications Manager (CallManager)

Falha CallManager unificada carregar grandes arquivos de Origem de áudio de MOH

14 Outubro 2016 - Tradução por Computador
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Índice


Introdução

Este documento descreve e fornece uma solução para uma razão pela qual Cisco Unified CallManager não carrega a grande música em arquivos de fonte de áudio da posse (MOH).

Pré-requisitos

Requisitos

Cisco recomenda que você tem o conhecimento de Cisco Unified CallManager.

Componentes Utilizados

A informação neste documento é baseada no CallManager de Cisco Unifed.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Background

O Ative Server Pages ajusta um limite para a quantidade de tempo que uma página dada pode executar. A base racional é que se uma página toma demasiado tempo para executar e retornar resultados, o usuário se torna frustrante e se pressiona o botão Stop Button no navegador.

O timeout padrão em todas as versões do Internet Information Server (IIS) é ajustado a 90 segundos. Contudo, no caso de um upload de arquivo, a página deve executar para a duração da transferência de arquivo pela rede. Se um usuário transfere a informação sobre uma linha lenta ou transfere uma grande quantidade de informação, é fácil exceder este limite.

Sintoma

Um erro do script acontece quando você introduz um grande arquivo de Origem de áudio de MOH novo. O arquivo de Origem de áudio de MOH novo transcoded com sucesso a ULAW.wav, a ALAW.wav, a G729.wav e a WB.wav mas não introduz (veja a seta A em figura 1).

Figura 1 — Introduza o Origem de áudio de MOH novo

http://www.cisco.com/c/dam/en/us/support/docs/unified-communications/unified-communications-manager-callmanager/68980-ccm-large-moh-files-1.gif

Indicadores deste Mensagem de Erro (veja figura 2):

Server returned HTTP response code: 500 for URL:
Figura 2 — Erro remoto do script

http://www.cisco.com/c/dam/en/us/support/docs/unified-communications/unified-communications-manager-callmanager/68980-ccm-large-moh-files-2.gif

O Mensagem de Erro ASP 0113 Script_timed_out está identificado enquanto estas saídas de exemplo mostram quando você revê o arquivo de log de erros correspondente IIS. O arquivo de registro é ficado situado no diretório de c:\WINNT\System32\LogFiles\W3SVC1:

2006-01-30 21:46:40 10.174.129.246 - 10.174.129.246 80 GET
 /CCMAdmin/_RemoteScripts/rs_mediaresource.asp _method=updateMOHAudioSource&
_mtype=execute&pcount=10&p0=%7BB2D8F578-4C1C-4299-BF06-
45B5A102EF80%7D&p1=3&p2=ciscotac&p3=ciscotac.xml&p4=-794816657&p5=29763044&p6=null&
p7=null&p8=%5C%5C142.174.129.246%5CTFTPPATH%5C&p9=ciscotac.ULAW.wav%7Cciscotac.ALAW.
wav%7Cciscotac.G729.wav%7Cciscotac.WB.wav|-|ASP_0113|Script_timed_out 
500 0 Mozilla/4.0+(compatible;+MSIE+6.0;+Win32) -

Causa

O ScriptTimeout property especifica a quantidade máxima de tempo que um script pode executar antes que esteja terminado. O erro é gerado quando o tempo de processamento do script excede o valor máximo que esteve designado para o ScriptTimeout property. Explica porque este problema acontece somente quando você introduz grandes arquivos de Origem de áudio de MOH.

Resolução

Você pode aumentar o tempo que é permitido processar scripts ASP para um Web site particular. Mude o valor do metabase no IIS a fim realizar isto.

Conclua estes passos:

  1. Selecione o Iniciar > Programas > Ferramentas Administrativas > Gerenciador de Serviços de Internet para abrir o gerente de serviços de Internet.

  2. Expanda a árvore e a website padrão.

  3. Clicar com o botão direito o ccmadmin sob a website padrão.

  4. Clique em Propriedades.

  5. Clique a aba do diretório home.

  6. Clique a configuração situada sob configurações de aplicativo.

  7. Clique a aba das opções do App.

    Os indicadores do indicador da configuração do aplicativo (veja figura 3).

    Figura 3 — Configuração do aplicativo

    http://www.cisco.com/c/dam/en/us/support/docs/unified-communications/unified-communications-manager-callmanager/68980-ccm-large-moh-files-3.gif

  8. Aumente o valor de Intervalo de Script de ASP a um número altamente bastante para impedir intervalos do script.

    Neste caso, o valor é aumentado a 180 segundos (veja a seta A em figura 3) a fim carregar com sucesso grandes arquivos de origem MOH.

Se você recebe um erro que indicasse o arquivo é demasiado grande quando você tenta transferir arquivos pela rede todo o arquivo de fonte de áudio que for mais longo de 8 segundos, pôde ser devido ao navegador que você se está usando. Os navegadores suportados oficiais para a administração de Cisco Unified CallManager são:

  • Netscape Communicator 4.x

  • Microsoft Internet explorer 5 ou 6

Refira a consultação à administração do CallManager da Cisco para mais informação.

Erro: CM_Media_PayloadType desconhecido 262

Problema

Quando você tenta transferir arquivos pela rede o arquivo de Origem de áudio de MOH, o processo falha com este erro:

CM_Media_PayloadType desconhecido 262

Solução

Este erro ocorre quando o arquivo do wav não está no formato exigido. Os arquivos de áudio devem estar em um destes formatos:

  • G.711a-law ou Mu-law

  • Anexo A de G.729

  • Wideband

Também, certifique-se de que está em megahertz 8000 e na amostra de 16 bits.

Refira a identificação de bug Cisco CSCtr11072 (clientes registrados somente) para mais informação.


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