Sem fio/Mobilidade : VLAN sem fio

VLAN no exemplo de configuração dos controladores do Wireless LAN

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar VLANs nos Controllers de LAN Wireless (WLC).

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento. Contudo, este documento supõe que há um servidor DHCP de trabalho para fornecer endereços IP de Um ou Mais Servidores Cisco ICM NT aos Access point (AP) que estão registrados ao controlador.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Configuração A:

    • Catalyst Switch que executa o software do½ do¿Â do Cisco IOSï e um controlador de WLAN

    • Controlador de WLAN de Cisco 4404 que executa a versão de software 7.0

  • Configuração B:

    • Catalyst Switch que executa o software do OS do catalizador (Cactos) e um controlador de WLAN

    • Controlador de WLAN de Cisco 4404 que executa a versão de software 7.0

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Interfaces dinâmica em WLC

As interfaces dinâmica, igualmente conhecidas como interfaces de VLAN, são criadas por usuários e projetadas ser análogas aos VLAN para clientes do Wireless LAN. Um controlador pode apoiar até 512 interfaces dinâmica (VLAN). Cada interface dinâmica individualmente é configurada e permite que os córregos separados de uma comunicação existam em algum ou em todas as portas do sistema de distribuição do controlador. Os controles de cada interface dinâmica VLAN e outras comunicações entre controladores e todos dispositivos de rede restantes, e cada um atuam como uma transmissão de DHCP para os clientes Wireless associados aos WLAN traçados à relação. Você pode atribuir interfaces dinâmica às portas do sistema de distribuição, WLAN, a interface de gerenciamento da camada 2, e a relação do gerenciador AP da camada 3. Você pode igualmente traçar a interface dinâmica a um porto de backup.

Você pode configurar zero, um, ou as interfaces dinâmica múltiplas em um sistema de distribuição movem. Contudo, todas as interfaces dinâmica devem estar em uma sub-rede diferente VLAN ou IP de todas relações restantes configuradas na porta. Se a porta é sem etiqueta, todas as interfaces dinâmica devem estar em uma sub-rede diferente IP de toda a outra relação configurada na porta.

Configurar uma interface dinâmica com uma sub-rede secundária não é apoiado.

Cisco recomenda usar VLAN etiquetados para interfaces dinâmica.

Os VLAN com controladores de WLAN usam este modelo:

/image/gif/paws/68100/wlan_controllers_vlans1.gif

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Configurações de Catalyst switch

Esta seção utiliza as seguintes configurações:

Catalyst Switch que executa o Cisco IOS Software
lab1sup720ip1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

Catalyst Switch que executa o Cactos Software
controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- This command should be on one line.

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.

Configuração de VLAN do controlador de WLAN

Configuração de GUI

Termine estas etapas no controlador de WLAN.

  1. Do WLC GUI, escolha o controlador > as relações. As relações paginam lista todas as relações que são configuradas no WLC. A fim criar uma interface dinâmica nova, clique novo.

    wlan_controllers_vlans2.gif

  2. Dê entrada com o nome da relação e o identificador de VLAN e o clique aplicam-se.

    wlan_controllers_vlans3.gif

  3. Incorpore os parâmetros específicos a este VLAN. Alguns dos parâmetros incluem o endereço IP de Um ou Mais Servidores Cisco ICM NT, a Máscara de rede, o gateway, e o endereço IP de servidor DHCP, e o clique aplica-se.

    Exemplo:

    wlan_controllers_vlans4.gif

    Nota: O endereço IP de Um ou Mais Servidores Cisco ICM NT atribuído a esta relação atua como a transmissão de DHCP para que um cliente obtenha um endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor DHCP. Por exemplo, quando um cliente tenta associar a um WLAN/SSID (veja a etapa 5 nesta configuração) traçado a esta interface dinâmica, executa uma transmissão da sub-rede local para identificar o servidor DHCP. O controlador envia um pedido ao servidor DHCP (ou a se se é o servidor DHCP para o segmento) com o endereço IP de Um ou Mais Servidores Cisco ICM NT desta interface dinâmica como o IP do relé ao servidor DHCP configurado para esta relação. O servidor DHCP atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT ao cliente do escopo de DHCP configurado.

  4. Verifique a configuração da interface.

    Clique a aba do controlador no menu na parte superior do indicador, e escolha relações do menu à esquerda.

    wlan_controllers_vlans5.gif

  5. Clique a aba WLAN no menu na parte superior do indicador, e o clique cria novo.

    wlan_controllers_vlans6.gif

  6. Entre no Service Set Identifier (SSID) e o nome de perfil e o clique aplicam-se.

    Este exemplo usa o vlan15 para a facilidade da compreensão.

    wlan_controllers_vlans7.gif

  7. Selecione o vlan15 do menu suspenso do nome da relação na parte inferior do indicador, e o clique aplica-se.

    Neste caso, o vlan15 SSID é amarrado para conectar o vlan15 do nome.

    wlan_controllers_vlans8.gif

Configuração de CLI

Use esta seção a fim configurar seu VLAN através do comando line interface(cli).

  1. Crie a relação e a etiqueta associada VLAN.

    O comando é relação da configuração cria o vlan_id do interface_name.

    (lab5wlc4404ip15) >config interface create "vlan 15" 15
    

    Nota: Se há um espaço no nome VLAN/WLAN como é o caso neste exemplo, certifique-se que o nome está nas citações.

  2. Defina o endereço IP de Um ou Mais Servidores Cisco ICM NT e o gateway padrão.

    O comando é gateway do netmask de IP_address do interface_name da relação da configuração.

    (lab5wlc4404ip15) >config interface address "vlan 15" 192.168.15.10  
    255.255.255.0 192.168.15.1
    
    !--- This command should be on one line.
    
    
  3. Defina o servidor DHCP.

    O comando é <secondary-server> preliminar do [secondary] do <primary-server> do <interface-name> da interface dinâmica DHCP da relação da configuração.

    (lab5wlc4404ip15) >config interface dhcp dynamic-interface "vlan 15" primary 1
    2.168.15.15
    
  4. Emita este comando a fim traçar a relação a uma porta física:

    physical_ds_port_number do operator_defined_interface_name da porta da relação da configuração. Aqui está um exemplo:

    (Cisco Controller) >config interface port "vlan 15" 2
    
  5. Verifique a configuração da interface.

    O comando é sumário da relação da mostra.

    (Cisco Controller) >show interface summary
    
    Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Guest
    -------------------------------- ---- -------- --------------- ------- ------ ----
    ap-manager                       2    untagged 10.77.244.207   Static  Yes    N
    
    management                       2    untagged 10.77.244.206   Static  No     N
    
    service-port                     N/A  N/A      50.0.0.1        Static  No     N
    
    virtual                          N/A  N/A      1.1.1.1         Static  No     N
    
    vlan 15                          2    15       192.168.15.10   Dynamic No     N
  6. Defina o WLAN.

    O comando é configuração wlan cria o nome do wlan_id.

    (lab5wlc4404ip15) >config wlan create 2 "vlan 15"
    
  7. Defina a relação para o WLAN.

    O comando é interface_name wlan do wlan_id da relação da configuração.

    (lab5wlc4404ip15) >config wlan interface 2 "vlan 15"
    
  8. Verifique o WLAN e a relação associada.

    O comando é sumário wlan da mostra.

    (lab5wlc4404ip15) >show wlan summary 
    
    Number of WLANs.................................. 2
    
    WLAN ID�  WLAN Name�������������� Status���� �� Interface Name����������������� 
    -------� �--------------------�   ---------� ���--------------------------------
    1������� �lab5wlc4404ip15������   Enabled����   management��������������������� 
    2������� �vlan 15����������������� Disabled���   vlan 15������������������������� 
    
    (lab5wlc4404ip15) >

Clique este link a fim ver Cisco apoiam o vídeo da comunidade que descreve como configurar VLAN em controladores do Wireless LAN:

VLAN em controladores do Wireless LAN leavingcisco.com

wlan_controllers_vlans9.gif

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Verificação dos Catalyst Switches

  • Catalyst Switch que executa o Cisco IOS Software interface_number do interface_type do show running-config interface

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
     
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • Catalyst Switch que executa o Cactos Software — mostre a modificação da configuração

    controller-catos> (enable) show config 2
    
    !--- This command shows non-default configurations only.
    !--- Issue the show config mod all command in order to  
    !--- show both default and non-default configurations.
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04 
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)

Verificação de VLAN de controlador WLAN

Veja a seção de configuração de VLAN do controlador de WLAN deste documento, que inclui passos de verificação.

Troubleshooting

Use esta seção para resolver problemas de configuração.

Procedimento de Troubleshooting

Termine estas instruções a fim pesquisar defeitos sua configuração.

  1. Sibile do controlador de WLAN ao gateway padrão que é configurado na interface roteada VLAN, e sibile então na direção oposta.

    • Controlador de WLAN:

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • Interface roteada VLAN:

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = �/4 ms
      lab1sup720ip1#
  2. Se os sibilos são mal sucedidos, distribua uma captura de pacote de informação/sniffer no interruptor e verifique-os a fim verificar a colocação de etiquetas apropriada VLAN.

    Nota: Quando você inicia o sibilo de seu controlador a um gateway da camada 3, que esteja na mesma sub-rede como sua interface dinâmica, o controlador parece à fonte o sibilo da interface dinâmica.


Informações Relacionadas


Document ID: 68100