Sem fio/Mobilidade : Segurança de WLAN

Roteador Wireless de 1800 ISR com exemplo de configuração interno DHCP e de autenticação aberta

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento oferece uma configuração de exemplo de uma rede sem fio (WLAN) em um roteador de serviços integrados (ISR) Cisco 1800.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • 1800 ISR no Software Release 12.3 ou Mais Recente do ½ do ¿  de Cisco IOSï com o conjunto de recursos avançado dos Serviços IP

    Nota: Você pode aplicar a mesma configuração a alguns dos ISR. A configuração não é específica ao 1800 Series.

  • PC com estas placas de rede Wireless:

    • 802.11a

    • 802.11b

    • a/b/g 802.11b/g

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

Conexão Wireless ao roteador

1800_isr_wireless1.gif

Configuração

Instruções passo a passo

Conclua estes passos:

  1. Estabelecer o escopo de DHCP e excluiu endereços.

    Nota: Os endereços excluídos são opcionais.

    Refira o servidor de DHCP IOS Cisco para mais explicação detalhada do servidor DHCP no Cisco IOS Software.

  2. Gire sobre o Integrated Routing and Bridging, e estabelece o grupo de bridge.

  3. Atribua um endereço IP de Um ou Mais Servidores Cisco ICM NT para conectar o Bridge-Group Virtual Interface 1 (BVI1).

  4. Estabelecer o Sem fio.

    1. Atribua a relação Dot11Radio0 ou Dot11Radio1 ao grupo de bridge 1.

    2. Atribua um Service Set Identifier (SSID) à interface de rádio, e defina então a autenticação aberta.

Configuração

Este documento utiliza esta configuração:

Sem fio e configuração de DHCP do 1800 Series ISR
1800-ISR#show running-config 
 Building configuration...
 .
 .
!
hostname 1800-ISR
!

!--- Output suppressed.

!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.100

!--- This sets up DHCP and excluded addresses. Excluded addresses are optional.

!
ip dhcp pool 1800-ISR
   network 192.168.2.0 255.255.255.0
!
!
bridge irb

!--- Turn on integrated routing and bridging.

!
!
interface Dot11Radio0

!--- This is the wireless radio interface configuration.

 no ip address
 !
 ssid Cisco

!--- Here, the SSID is given as "Cisco".
  
    authentication open 

!--- This defines the authentication as open.

 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
!
interface BVI1
 ip address 192.168.2.1 255.255.255.0
!
ip classless
!

!--- Note: Configure the bridge 1 protocol IEEE and the bridge 1 route IP 
!--- before you create interface BVI1 or add the radio interface to bridge group 1.

!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Use estes comandos a fim verificar o DHCP apropriado e a operação Wireless:

  • mostre associações do dot11

  • mostre o emperramento DHCP IP

O MAC e os endereços IP de Um ou Mais Servidores Cisco ICM NT devem combinar na saída do comando show dot11 associations e na saída do comando show ip dhcp binding. Aqui está um exemplo:

1800-ISR#show dot11 associations

802.11 Client Stations on Dot11Radio0: 

SSID [Cisco] : 

MAC Address��� �IP address����� Device������� ���Name����������Parent�������� State��� �
0040.96ac.345c  192.168.2.101�� CB21AG/PI21AG��� WLCLIENT� ��� self���������� Associated
!

!--- Output suppressed.

!
1800-ISR#show ip dhcp binding 
Bindings from all pools not associated with VRF:
IP address��������� Client-ID/������������� Lease expiration������ Type
���������������������Hardware address/
���������������������User name
192.168.2.101��     0100.4096.ac34.5c������ Dec 18 2005 05:07 PM�� Automatic
1800-ISR#

Troubleshooting

Use esta seção para resolver problemas de configuração.

Comando de Troubleshooting

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

Emita o comando debug ip dhcp server packet a fim debugar o ip dhcp server. Com uma autenticação em aberto unencrypted WLAN, este comando fornece o mais rápido e a maioria de método efetivo pesquisar defeitos.

O comando debug ip dhcp server packet mostra estas transações dos dados:

/image/gif/paws/68099/1800_isr_wireless2.gif

Esta saída do comando debug ip dhcp server packet é um exemplo de uma requisição DHCP bem sucedida:

1800-ISR#debug ip dhcp server packet

*Dec 17 15:40:50.379: DHCPD: DHCPREQUEST received from client 0100.4096.ac34.5c.
!

!--- This shows the client DHCP discover packet that is sent to the router.

!
*Dec 17 15:40:50.379: DHCPD: No default domain to append - abort update
*Dec 17 15:40:50.379: DHCPD: Sending DHCPACK to client 0100.4096.ac34.5c (192.168.2.101)
!

!--- This shows the router DHCP acknowledgment (ACK) that is sent back to the client.

!
*Dec 17 15:40:50.379: DHCPD: creating ARP entry (192.168.2.101, 0040.96ac.345c).
*Dec 17 15:40:50.379: DHCPD: unicasting BOOTREPLY to client 0040.96ac.345c (192.168.2.101)

Procedimento de Troubleshooting

Se você não vê a oferta de DHCP na saída do comando debug ip dhcp server packet, comece a pesquisar defeitos o protocolo do 802.11. Conclua estes passos:

  1. Não verifique os ajustes do cliente Wireless, o SSID, e a nenhuma Segurança/configuração de criptografia.

    Nota: O SSID deve ser o mesmo no ISR e nos clientes. Neste caso, o SSID é “Cisco”. Figura 1 e figura 2 mostra os ajustes SSID no utilitário de desktop do Cisco Aironet (ADU) e no Aironet Client Utility (ACU). O indicador que você vê depende do cartão do cliente Wireless e das versões de firmware que você usa.

    Figura 1 – Ajustes de Cisco ADU SSID

    1800_isr_wireless3.gif

    Figura 2 – Ajustes do ACU Cisco SSID

    1800_isr_wireless4.gif

    Figura 3 – Ajustes zero wireless de Windows

    /image/gif/paws/68099/1800_isr_wireless5.gif

  2. Verifique a compatibilidade do Wi-fi.

    Refira a página de Allianceleavingcisco.com do Wi-fi a fim verificar a compatibilidade do Wi-fi da placa de interface da rede Wireless (NIC) que é usada.

  3. Contacte o Suporte técnico de Cisco para uma assistência técnica mais adicional.


Informações Relacionadas


Document ID: 68099