Voz e comunicações unificadas : Cisco Unity Express

Exemplo de Configuração da Interoperação da Distribuição Automática de Chamadas Básica do Cisco CME com o Atendimento Automático do Cisco Unity Express

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (8 Junho 2009) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece exemplos de configuração para a utilização dos recursos da Distribuição Automática de Chamadas (ACD) básica do Cisco CallManager Express (CME) e do Atendimento Automático (AA) do Cisco Unity Express.

Pré-requisitos

Requisitos

A familiaridade geral com as configurações do Cisco CME e do Cisco Unity Express é necessária. Este documento é voltado especificamente para as configurações de interoperação da ACD básica do Cisco CME e do AA do Cisco Unity Express.

As seguintes versões são as mínimas necessárias para as funcionalidades descritas neste exemplo de configuração:

  • Cisco CME 3.3

  • Software Release 12.4.3 de Cisco IOS�

  • Cisco Unity Express 2.1.3

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Um Cisco 2821 Router com Cisco CME e Cisco Unity Express

  • Cisco IOS Software Release 12.4.3

  • Cisco CME 3.3

  • Script de ACD básica versão 2.1.0.0

  • Cisco Unity Express 2.1.3

  • Conjunto de recursos IP Voice Cisco IOS

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Produtos Relacionados

Esta configuração também pode ser utilizada com Cisco 2600XM, Cisco 3700, Cisco 2800 ou Cisco 3800 Series Routers com Cisco IOS Software Release 12.4.1 ou posterior.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Estes três cenários são abordados neste documento:

  • Cenário 1 -- Uso do AA do Cisco CME e os grupos de ACD com o Cisco Unity Express somente como destino de correio de voz

  • Cenário 2 -- Uso do Cisco Unity Express como o ponto de entrada principal do AA e do AA do Cisco CME como um "sub-menu" dentro desse AA

  • Cenário 3 -- Uso do AA do Cisco CME como o ponto de entrada principal do AA e do AA do Cisco Unity Express para fornecer "anúncios" flexíveis como parte do AA

O cenário 1 é mais aplicável quando seu AA do Cisco CME se limita a fornecer um menu para direcionar as chamadas nos grupos de ACD. Nesse cenário, o Cisco CME é utilizado como o destino de AA para as chamadas recebidas, e o Cisco Unity Express é utilizado exclusivamente como um servidor de correio de voz quando os agentes de ACD não estão disponíveis ou não atendem às chamadas em um determinado intervalo de tempo. O AA do Cisco Unity Express não é utilizado nesse cenário.

O cenário 2 é a configuração geral mais flexível para a integração da ACD básica do Cisco CME e o AA do Cisco Unity Express. No design usado no cenário 2, o AA do Cisco Unity Express é utilizado para a automação geral de tratamento de chamadas e para a transferência de chamadas para os agentes de ACD. Nesta encenação, o Cisco Unity Express é usado como o destino AA para chamadas recebidas; O Cisco Unity Express igualmente fornece uma variedade de opções do menu ao chamador (tal como o discagem por nome, o discagem por ramal, e os segmentos da informação gravada). Uma dessas opções direciona algumas chamadas aos grupos de ACD do Cisco CME. O correio de voz do Cisco Unity Express é utilizado de maneira semelhante à do cenário 1.

O cenário 3 é uma variação do cenário 1, onde o AA do Cisco CME é utilizado como o destino de AA para as chamadas recebidas e o ACD é a função principal necessária do AA. Entretanto, o AA do Cisco Unity Express é utilizado como um “servidor de anúncios” com o AA do Cisco CME. Isso possibilita adicionar alguns anúncios (tais como horários ou localização de escritórios) que não estariam disponíveis se somente o AA do Cisco CME fosse usado.

Nota: Os procedimentos de configuração com base em GUI fornecidos nesta publicação são usados para ilustrar os processos de implementação associados com este exemplo de configuração e para resumir as etapas necessárias executar as características descritas durante todo o documento. Entretanto, procedimentos passo a passo completos não são fornecidos. Esta publicação supõe que você já tenha familiaridade para trabalhar com as interfaces gráficas do Cisco CME e do Cisco Unity Express, bem como conhecimento operacional da CLI do Cisco IOS. Consulte o guia do administrador, o guia de configuração e a referência de comandos apropriada do Cisco CME e do Cisco Unity Express para obter detalhes explícitos sobre o uso de procedimentos e comandos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

Figura 1 - Diagrama de Rede da ACD Básica do Cisco CME e do AA do Cisco Unity Express

/image/gif/paws/67907/135345.jpg

Configurações

Todos os três cenários de configuração possuem estas características gerais:

  • Sistema Cisco CME de site único.

  • Troncos PSTN integrados no roteador Cisco CME

  • A configuração define um plano de discagem de 4 dígitos com ramais de telefones IP no intervalo de 2000 a 2010, ramais que não são telefones (tais como grupos de busca) no intervalo de 2020 a 2099 e pontos de entrada do Cisco Unity Express no intervalo 21 xx.

  • São definidos nove telefones IP, ramais 2000 a 2009.

  • A configuração de ACD utiliza três grupos de busca com três telefones IP em cada grupo.

  • São definidos dois recepcionistas, os quais também são parte dos nove telefones IP nos grupos de ACD.

A configuração de rede utiliza um roteador Cisco 2821 com estas características:

  • Acesso de rede IP por meio do endereço IP b .168.1.1

  • Configuração do Cisco CME com nove Telefones IP--cada um com uma extensão do 4-dígito (2001 2010)

  • NM-CUE

  • Endereço IP do Cisco Unity Express a .1.11.2

Este documento utiliza as seguintes configurações:

Notas sobre a Configuração da Implementação Geral

A conectividade PSTN usada nessa configuração é feita por meio de um tronco de Foreign Exchange Office (FXO). Se você possuir um tronco de PRI, a configuração é exatamente a mesma daquelas fornecidas nos exemplos de configuração mostrados nesta publicação, com a adição destas entradas de configuração:

controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Serial2/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 2/1:23
!
dial-peer voice 777 pots
 incoming called-number .
 direct-inward-dial
 port 2/1:23

Os scripts de AA do Cisco Unity Express utilizados nos exemplos apresentados nesta publicação são muito simples, e, por clareza, contêm um número mínimo de recursos para que as funcionalidades ilustradas neste documento sejam obtidas. Os scripts de AA do Cisco Unity Express implementados em uma rede real devem possuir uma capacidade de tratamento de chamadas recebidas significativamente maior em comparação com a das redes de teste de laboratório. "Passos" adicionais de tratamento de chamadas podem incluir o seguinte:

  • Manipulação de erros melhorada (como, por exemplo, quando o chamador pressiona dígitos que não estão no menu).

  • Manipulação de timeout (como, por exemplo, menus repetidos um número fixo de vezes).

  • Capacidade de bloquear a transferência externa de chamadas para destinos externos da PSTN (para evitar fraudes de tarifas).

Cenário 1 - Uso da ACD Básica do Cisco CME com o Correio de Voz do Cisco Unity Express

No cenário 1, as chamadas recebidas são direcionadas para o AA do Cisco CME (ramal 2040), o qual apresenta uma mensagem de boas-vindas e um menu com três opções ao chamador. Com base na escolha do chamador, a chamada é direcionada para um dos três grupos de busca da ACD. Se as chamadas não forem respondidas no grupo de ACD, as chamadas serão encaminhadas para uma Caixa Postal de Entrega Geral (GDM) para que uma mensagem seja deixada.

Nota: Você não pode estabelecer um GDM a ser copiado à caixa postal de cada usuário (similar a uma lista de distribuição).

No cenário descrito nesta seção, uma única GDM é utilizada para que todos os nove agentes de ACD nos grupos de ACD possam se conectar e recuperar suas mensagens. Em outras variações descritas como parte do cenário 2, a capacidade de haver uma GDM individual por grupo de ACD será explorada.

Fluxo de chamada

O fluxo de chamadas da configuração desta seção está ilustrado na Figura 2.

Figura 2 - Fluxo de Chamadas do Cenário 1 - AA do Cisco Unity Express com ACD Básica do Cisco CME

/image/gif/paws/67907/135346.jpg

Notas sobre a Configuração do Cenário 1

As chamadas da PSTN a partir da porta FXO (0/3/0) são terminadas automaticamente (por meio do comando connection plar-opx 2040) no número piloto do AA do Cisco CME (2040). Cisco CME AA apresenta um cumprimento bem-vindo e um menu bem-vindo com três opções--os índices falados das alertas são dados na imagem do fluxo de chamadas em figura 2. A frase de boas-vindas gravada fica residente no arquivo flash file en_bacd_welcome.au, enquanto as frases do menu gravadas ficam residentes no arquivo en_bacd_options_menu.au.

A saudação da GDM para o ramal 2070 é a seguinte: “Obrigado chamando o serviço de cliente; ninguém está disponível agora. Please leave a message and we will return your call as soon as we can.”

Uma Indicação de Mensagem em Espera (MWI) para mensagens na GDM é obtida pelo encaminhamento do AA do Cisco CME (o comando param voice-mail 2070) para um ramal intermediário (2070) que é CFA (Call Forward All) do piloto de correio de voz (2105). Esta transmissão é feita em vez de apontar Cisco CME AA diretamente ao correio de voz piloto--qual seria feito com o comando param voice-mail 2105. O ramal 2070 é o botão 2 nos telefones dos agentes, e esse botão indica MWI para a GDM, a qual é associada ao ramal 2070 -- em vez dos números do grupo de busca de ACD (2020, 2021 ou 2022). Os números “Finais” não são configurados nos grupos de busca porque a lógica da ACD ignora os números finais em favor do número de encaminhamento do AA (comando param voice-mail).

Nota: Quando isso você faz toda a mudança ao script, você precisa de carregar o aplicativo.

O script de Cisco CME AA é associado com um endereço IP de loopback (um .1.1.1) para assegurar o script do Tool Command Language (TCL) é sempre acima--apesar do estado das interfaces de LAN (comando dial-peer voice 2040 voip). Um peer de discagem back-to-back é utilizado para direcionar chamadas ao ponto de entrada do AA do Cisco CME (2040) para garantir que os chamadores da PSTN (bem como os telefones IP locais) possam chamar o AA (comando dial-peer voice 2041 voip).

Configuração do Cisco CME para o Cenário 1

Estes passos resumem a configuração do Cisco CME para o cenário 1:

  1. Selecione Configure > System Parameters para configurar três grupos de busca de ACD 2020, 2021 e 2022 que são associados a três opções de menu do AA do Cisco CME. Veja figura 3.

    Figura 3 - Especificação dos Grupo de Busca de ACD do Cisco Unity Express

    /image/gif/paws/67907/135352.jpg

  2. Escolha configuram > os parâmetros de sistema para configurar os detalhes para o grupo de buscas 2020 com agentes 2001, 2002, e 2003. Veja figura 4.

    Figura 4 - Configuração dos Detalhes do Grupo de Busca 2020

    /image/gif/paws/67907/135353.jpg

  3. Selecione Configure > Phones e clique no endereço MAC do telefone que você deseja alterar. A janela Change Phone é exibida (consulte a Figura 5).

  4. Insira o ramal 2070 no telefone do agente de ACD para obter a MWI para as mensagens na GDM.

    Figura 5 - Associação de Ramal a Botão Específico

    /image/gif/paws/67907/135354.jpg

A configuração a seguir é a configuração completa (e comentada) da CLI do roteador Cisco CME para o cenário 1 que resulta das alterações específicas feitas na configuração base.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Define the parameters for the Cisco CME ACD TCL script. 
!--- The hunt groups for the
!--- ACD are 2020, 2021, and 2022.

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !

!--- Define the parameters for the Cisco CME AA TCL script. 
!--- The pilot number is 2040.
!--- The voice-mail destination is extension 2070, which is call forward all
!--- (CFA) routed to voice mail (2105).

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the loopback address to which the TCL script is attached.

!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CME AA pilot number 2040.

!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!

!--- Calls to Cisco CME AA pilot number 2040 are associated with a loopback address
!--- a.1.11.1 to ensure that the TCL script is always up.

!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- The back-to-back dial-peer for Cisco CME AA 
!--- pilot number 2040 points to the
!--- AA TCL script and ensures that all PSTN and 
!--- internal callers can reach the AA.

!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- All calls in the 21xx range are directed to Cisco Unity Express.

!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!

!--- The following section shows nine ACD agents' extensions.

!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2070 is associated with the GDM. 
!--- This extension is used to get MWI
!--- on the ACD agents' phone.

!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- The following section shows phone definitions for the nine ACD agents.
!--- Ephone-dn 11 (2070) is defined as button 2 on each phone, so that all
!--- agents can get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!

!--- Three hunt-groups are used by the ACD scripts. 
!--- There are three agents in each group.

!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configuração do Cisco Unity Express para o Cenário 1

Estas etapas resumem a configuração para o Cisco Unity Express para a encenação 1:

  1. Selecione Configure > Groups. Em seguida, clique no grupo (custservice) que você deseja editar. A janela Group Profile é exibida (consulte a Figura 6).

  2. A guia Profile é a exibição padrão. Configure o grupo custservice associado ao ramal 2070.

    Figura 6 - Configuração do Perfil do Grupo

    142424.jpg

  3. Clique na guia Owners/Members (consulte a Figura 7).

  4. Configure os membros (todos os nove usuários agentes de ACD) do grupo custservice.

    Figura 7 - Configuração dos Membros do Grupo

    135356.jpg

A configuração a seguir é a configuração completa (e comentada) da CLI do Cisco Unity Express para o cenário 1 que resulta das alterações específicas feitas na configuração base:

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
!

!--- The custservice group is defined as all the 
!---users that have access to the GDM.

!
groupname custservice create
!

!--- Nine ACD agents are defined as users.

!
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The custservice group (and therefore GDM) 
!--- is associated with extension 2070.

!
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
groupname Administrators member admin
!

!--- Nine ACD agents users are members of the 
!--- custservice group, so they can have
!--- access to the GDM to retrieve messages.

!
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
!

!--- The Cisco Unity Express system AA is defined 
!--- in the system by default, but
!--- is not used in this scenario.

!
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Define the GDM associated with 2070, 
!--- associated with the custservice group.

!
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
!

!--- Define personal mailboxes for nine ACD agents.

!
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Cenário 2 - Uso do AA do Cisco Unity Express como o Menu de Primeiro Nível e da ACD Básica como o Menu de Segundo Nível

No cenário 2, as chamadas recebidas são direcionadas para o AA personalizado do Cisco Unity Express (número piloto 2100), o qual apresenta uma mensagem de boas-vindas e um menu com quatro opções ao chamador. Com base na escolha do chamador, a chamada é direcionada para a ACD do Cisco CME (opção 1), a um de dois anúncios (opções 2 e 3) ou a uma caixa postal geral da empresa (GDM para o ramal 2080) associada aos recepcionistas (opção 4).

Se o chamador escolher a opção 1, a chamada será transferida para o ACD do Cisco CME onde o AA do Cisco CME fornece um menu de segundo nível similar ao cenário 1.

Fluxo de Chamadas do Cenário 2

O fluxo de chamadas da configuração nesta seção é ilustrado em figura 8.

Figura 8 - Fluxo de Chamadas do Cenário 2

135360.jpg

Notas de configuração da encenação 2

As chamadas da PSTN da porta FXO (0/3/0) são terminadas automaticamente no AA do Cisco Unity Express (2100).

O menu da primeiro-série (“obrigado chamando sistemas do Widget; pressione 1 para o serviço de cliente; imprensa 2 para o local do escritório; imprensa 3 por horários comerciais; a imprensa 4 para deixar uma Voz message.") é fornecida pelo costume AA do Cisco Unity Express (arquivo S10_Main_Menu.wav).

O menu de segundo nível (“To help redirect your call: Pressione 1 para perguntas relacionados a hardware; imprensa 2 para perguntas relacionados ao software; a imprensa 3 para o general questions.") é fornecida pelos arquivos da alerta de Cisco CME AA. A primeira frase (“To help redirect your call”) está contida no arquivo flash en_bacd_welcome.au, enquanto o resto das instruções é igual às da configuração do cenário 1, contidas no arquivo flash en_bacd_options_menu.au.

Você pode ignorar a mensagem de boas-vindas do Cisco CME ao gravar um pequeno arquivo vazio ou excluir o arquivo da flash do seu roteador (o que faz o software do Cisco CME ignorar a mensagem). No exemplo do cenário 2 mostrado nesta seção, as frases de menu associadas aos arquivos de prompt do Cisco Unity Express e do Cisco CME foram estruturadas para fluir como um único AA para o chamador. Você também pode ignorar todo o AA do Cisco CME (a mensagem de boas-vindas e as opções de escolha) ao usar o comando param drop-through-option number para transferir uma chamada diretamente à ACD do Cisco CME e ignorar o AA do Cisco CME.

O ramal 2080 e a GDM associada são adicionados à configuração para fornecer uma caixa postal geral para os recepcionistas. Essa caixa postal é acessada selecionando-se a opção 4 no menu de primeiro nível e é totalmente manipulada dentro do Cisco Unity Express. O ramal 2080 foi adicionado aos telefones IP 2001 e 2004 -- os telefones associados a dois funcionários que são recepcionistas (bem como agentes de ACD).

Se um chamador escolher 1 no menu de primeiro nível e for direcionado para os grupos de ACD, mas a chamada permanecer sem resposta, a chamada será encaminhada para o ramal 2070 -- que é a GDM dos agentes de ACD.

Configurar Cisco CME para a encenação 2

Estas etapas resumem a configuração para Cisco CME para a encenação 2:

  1. Selecione Configure > Phones. Em seguida, clique no endereço MAC do telefone que você deseja alterar. O indicador do telefone da mudança aparece (veja a figura 9).

  2. Incorpore a extensão 2080 para abotoar 3 do telefone do recepcionista, quando o ACD GDM permanecer no botão 2. Com esta instalação, o empregado obtém o MWI para o recepcionista e as caixas de correio ACD GDM.

    Figura 9 - Adição de Botão de Ramal ao Telefone do Recepcionista

    /image/gif/paws/67907/135361.jpg

A configuração a seguir é a configuração completa (e comentada) da CLI do roteador Cisco CME para o cenário 2 que resulta das alterações específicas feitas na configuração base.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CUE AA pilot number 2100.

!
voice-port 0/3/0
 connection plar opx 2100
!
voice-port 0/3/1
 connection plar opx 2100
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2080 is associated with the receptionists' GDM. 
!--- This extension is used to get MWI on the receptionists' phones.

!
ephone-dn  10
 number 2080
 description Reception GDM
 name Reception GDM
 call-forward all 2105
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- Ephone-dn 10 (2080) is defined as button 3 on 
!--- phones 2001 and 2004 so that all
!--- receptionists (ephones 1 and 4) get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configurar o Cisco Unity Express para a encenação 2

Estas etapas resumem a configuração para o Cisco Unity Express para a encenação 2:

  1. Abra o utilitário Cisco Unity Express Script Editor e crie o script personalizado do Cisco Unity Express. Veja a figura 10.

    Figura 10 - Configuração do Script de AA do Cisco Unity Express para o Menu de Nível Superior

    /image/gif/paws/67907/135362.jpg

  2. Escolha o correio de voz > o atendimento automático e associe o script (S10_CUE-AA-BACD-script.aef) com o número piloto 2100. Veja figura 11.

    Figura 11 - Associação do Script a um Número Piloto

    /image/gif/paws/67907/135363.jpg

  3. Grave todos os prompts do script de AA. Você pode gravá-los offline e transferir os arquivos .wav para o Cisco Unity Express com o nome correto do arquivo ou gravá-los por meio do Administration via Telephony (AVT).

  4. (Opcional) Se você utilizar o AVT, o Cisco Unity Express atribuirá um nome genérico de arquivo que você poderá, em seguida, alterar para o nome desejado. Selecione Voice Mail > Prompts e clique no nome do arquivo do sistema.

  5. (Opcional) Edite o(s) nome(s) do(s) arquivo(s) conforme o necessário na caixa de diálogo e clique em OK. A janela Voice Mail > Prompts exibirá o(s) nome(s) correto(s) do(s) arquivo(s) na lista (consulte a Figura 12).

    Figura 12 - Lista de Prompts do Script de AA

    /image/gif/paws/67907/135364.jpg

  6. Selecione Voice Mail > Auto Attendant e abra o AA preparado no passo 1. Selecione Script Parameters e associe os nomes dos arquivos de prompt com o parâmetro correto no script.

  7. Selecione Configure > Groups e clique no grupo ( reception ) que você deseja editar. A janela Group Profile será exibida (consulte a janela parcial na parte superior da Figura 13). A guia Profile é a exibição padrão.

  8. Clique na guia Owners/Members para configurar os membros.

    Figura 13 - Definição do Grupo Reception

    142217.jpg

A configuração a seguir é a configuração completa (e comentada) da CLI do Cisco Unity Express para o cenário 2 que resulta das alterações específicas feitas na configuração base.

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1

!--- Add the reception group.

!
groupname Administrators create
groupname Broadcasters create
groupname custservice create
groupname reception create
username admin create

username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The reception group (and therefore GDM) is associated with extension 2080.

!
groupname custservice phonenumber "2070"
groupname reception phonenumber "2080"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
!

!--- Add membership to group "reception".

!
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname reception member user21
groupname reception member user24
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast

!--- Define a 09:00-17:00 Monday-Friday business schedule for the AA.

!
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Add the custom AA script for the first-tier menu.

!
ccn application s10-cue-aa-bacd
 description "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10-cue-aa-bacd-script.aef"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_CustomerService" "2040"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the custom AA script with the pilot number 2100.

!
ccn trigger sip phonenumber 2100
 application "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Add the GDM for "reception"

!
voicemail mailbox owner "reception" size 3000
 description "Receptionists mailbox"
 end mailbox
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Variação de Configuração 1 do Cenário 2 - GDMs Individuais por Grupo de Busca

A configuração do cenário principal descrito nas seções anteriores define uma única GDM para todas as mensagens deixadas por chamadores nos três grupos de ACD (hardware support, software support e general questions) Essa granularidade pode não ser suficiente para algumas situações, pois os agentes de um grupo (como o software support) podem não querer navegar pelas mensagens deixadas para os outros grupos antes de localizar mensagens endereçadas a seu próprio grupo. Se o volume de mensagens for alto, você pode utilizar uma caixa postal separada para cada grupo de ACD.

Com grupos de buscas normais de Cisco CME (ao não usar o ACD), você pode definir uma caixa postal separada para cada grupo de buscas associando GDM individuais com os números de grupo de buscas (2020, 2021, 2022) e apontando o destino “final” do grupo de buscas ao correio de voz--como ilustrado nos seguintes exemplos de configuração.

Configuração do Cisco CME para a Variação 1 do Cenário 2

A seguir são mostradas variações de configuração do Cisco CME para GDMs individuais:

ephone-hunt 1 sequential
 pilot 2020
 list 2001, 2002, 2003
 final 2105
 timeout 10
!
!
ephone-hunt 2 sequential
 pilot 2021
 list 2004, 2005, 2006
 final 2105
 timeout 10
!
!
ephone-hunt 3 sequential
 pilot 2022
 list 2007, 2008, 2009
 final 2105
 timeout 10

Configuração do Cisco Unity Express para a Variação 1 do Cenário 2

Estes passos resumem a configuração dos grupos e das GDMs no Cisco Unity Express para a Variação 1 do Cenário 2:

  1. Os grupos individuais são definidos no Cisco Unity Express para cada um dos três grupos de busca. Selecione Configure > Groups para definir os grupos. Veja figura 14.

    Figura 14 - Definição dos Grupos Individuais

    135357.jpg

  2. Em Configure > Groups, clique no grupo (hardware) que você deseja editar. A janela padrão da guia Profile será exibida (consulte a parte superior da Figura 15).

    Figura 15 - Configuração de Grupos Específicos

    /image/gif/paws/67907/135358.jpg

  3. Selecione a guia Owners/Members (consulte a parte inferior da Figura 15) e clique na caixa de seleção à esquerda para selecionar os proprietários e membros.

    A seguir são mostradas variações de configuração do Cisco Unity Express para GDMs individuais:

    groupname hardware create
    groupname software create
    groupname general create
    groupname hardware phonenumber "2020"
    groupname software phonenumber "2021"
    groupname general phonenumber "2022"
    groupname hardware member user21
    groupname hardware member user22
    groupname hardware member user23
    groupname software member user24
    groupname software member user25
    groupname software member user26
    groupname general member user27
    groupname general member user28
    groupname general member user29
    voicemail mailbox owner "general" size 5520
     description "general mailbox"
     end mailbox
    voicemail mailbox owner "hardware" size 5520
     description "Hardware mailbox"
     end mailbox
    voicemail mailbox owner "software" size 5520
     description "software mailbox"
     end mailbox

Variação de Configuração 2 do Cenário 2 - GDMs Individuais por Grupo de ACD

Existem duas desvantagens na configuração resumida na seção “Variação de Configuração 1 do Cenário 2 -- GDMs Individuais por Grupo de Busca”.

  • Ela funciona somente se os grupos de busca são chamados diretamente (ramais 2020, 2021 e 2022), mas não quando os grupos de busca são utilizados como uma ACD quando o número piloto de ACD (2040) é chamado.

  • Ela não fornece nenhum meio de oferecer MWI para os agentes, pois os números dos grupos de busca não podem ser colocados nos telefones como botões.

Para fornecer uma configuração que resolva essas duas desvantagens, você pode utilizar o script do sistema xfermailbox no Cisco Unity Express. Defina três grupos no Cisco Unity Express (hardware, software e general), e associe cada grupo a um ramal interino (tais como 2030, 2031 e 2032) que podem ser incluídos como botões no telefone do agente (e, consequentemente, fornecem MWI). Essa configuração de grupos, ramais e telefones é resumida na Tabela 2.

Agente Extensão Número do Grupo de Busca Grupo de ACD Caixa Postal do Grupo
user21 2001 2020 Hardware 2030
user22 2002 2020 Hardware 2030
user23 2003 2020 Hardware 2030
user24 2004 2021 Software 2031
user25 2005 2021 Software 2031
user26 2006 2021 Software 2031
user27 2007 2022 Geral 2032
user28 2008 2022 Geral 2032
user29 2009 2022 Geral 2032

O fluxo de chamadas ajustado dessa configuração modificada está ilustrado na Figura 16.

Figura 16 - Fluxo de Chamadas Ajustado da Variação de Script xfermailbox

/image/gif/paws/67907/135359.jpg

O direcionamento de chamadas para GDMs individuais no Cisco Unity Express requer um script personalizado que chame o script do sistema xfermailbox. As chamadas para a ACD do Cisco CME podem somente ser encaminhadas para o Cisco Unity Express utilizando-se o comando simples param voice-mail number (os destinos finais individuais nos grupos de busca não podem ser utilizados para fluxos de chamada de ACD). Esse comando fornece um único ramal ao Cisco Unity Express para a entrada de uma caixa postal (ramal 2070 nas configurações anteriores). O Cisco Unity Express não tem como distinguir qual grupo de busca é o destinatário desejado e não pode determinar qual das três GDMs deve acessar.

Em vez disso, direcione o correio de voz da ACD do Cisco CME para um número piloto do Cisco Unity Express (2110) que acessa um script personalizado ( s12-xfer-to-mbox.aef ). Esse número piloto fornece ao usuário um menu que oferece uma escolha dos grupos aos quais uma mensagem pode ser deixada (hardware, software ou general). O conteúdo desse menu é exibido na parte inferior do fluxo de chamadas na Figura 16. Com base na resposta do chamador, a variável mbox é definida para o ramal apropriado (2030, 2031 ou 2032), e a chamada é transferida (por meio do script do sistema xfermailbox) para uma das três GDMs.

Os passos associados à modificação da configuração do cenário 2 para a manipulação das alterações de configuração descritas na Tabela 2 e na Figura 16 são descritos a seguir:

  1. Abra a utilidade do editor de script do Cisco Unity Express e escreva um script feito sob encomenda do Cisco Unity Express chamado s12-xfer-to-mbox.aef. Veja figura 17.

    Figura 17 - Janela de Criação de Script Personalizado do Cisco Unity Express

    /image/gif/paws/67907/135347.jpg

  2. Selecione Voice Mail > Auto Attendant. Veja figura 18. Adicionar um atendimento automático novo e associe-o com o script construído em etapa 1.

  3. Associe o script personalizado s12-xfer-to-mbox.aef do Cisco Unity Express ao número piloto 2110. Veja figura 18.

    Figura 18 - Associação do Script Personalizado do Cisco Unity Express a um Número Piloto

    /image/gif/paws/67907/135348.jpg

  4. Grave o prompt (nesse caso, S12_Main_Menu.wav) para o novo script de AA. Você pode gravá-lo offline e transferir o arquivo .wav para o Cisco Unity Express com o nome correto do arquivo ou gravá-lo por meio do Administration via Telephony (AVT).

  5. (Opcional) Se você utilizar o AVT, o Cisco Unity Express atribuirá um nome genérico de arquivo que você poderá, em seguida, alterar para o nome desejado. Selecione Voice Mail > Prompts e clique no nome do arquivo do sistema.

  6. (Opcional) Edite o nome do arquivo na caixa de diálogo conforme o necessário e clique em OK. A janela Voice Mail > Prompts exibirá o nome correto do arquivo na lista (consulte a Figura 19).

  7. Selecione Voice Mail > Auto Attendant e abra o AA preparado no passo 2. Selecione Script Parameters e associe os nomes dos arquivos de prompts ao parâmetro correto no script.

    Figura 19 - Lista de Prompts Gravados

    135349.jpg

  8. Selecione Configure > Extension para definir os ramais 2030, 2031 e 2032 para associar as GDMs a cada um desses ramais. Veja figura 20.

    Figura 20 - Definição de Ramais para a Associação das GDMs aos Grupos de Busca de ACD

    /image/gif/paws/67907/135350.jpg

  9. Selecione Configure > Phones e clique no endereço MAC do telefone que você deseja alterar. O indicador do telefone da mudança aparece (veja figura 21).

  10. Adicione botões para 2030, 2031 ou 2032 nos telefones dos agentes de ACD para oferecer MWI.

    Figura 21 - Janela Ilustrativa da Adição de Botões

    /image/gif/paws/67907/135351.jpg

A seguir é mostrada a configuração comentada da CLI do roteador Cisco CME para alterações e adições feitas na configuração do Cisco CME do cenário base associado à seção “Configuração do Cisco CME para o Cenário 2”.


!--- Set the Cisco CME AA voice mail destination 
!--- to 2110, the Cisco Unity Express
!--- script entrypoint for the transfer-to-mailbox functionality.

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2110
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the group extensions (2030, 2031 and 2032) to 
!--- be used as button appearances
!--- on the agent phones so they can get MWI for the GDMs. 
!--- Put these extension in CFA
!--- so they never ring and do not disturb the agents.

!
ephone-dn  12
 number 2030
 description HW Cust Svc Mbox
 name HW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  13
 number 2031
 description SW Cust Svc Mbox
 name SW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  14
 number 2032
 description Gen Cust Svc Mbox
 name Gen Cust Svc Mbox
 call-forward all 2110
!

!--- Add a button appearance of the appropriate 
!--- group extension to each of the
!--- ACD Agent phones.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:12 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:12
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:12
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:13 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:13
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:13
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:14
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:14
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:14

A seguir é mostrada a configuração comentada da CLI do Cisco Unity Express para alterações e adições feitas na configuração do cenário base associado à seção “Configuração do Cisco Unity Express para o Cenário 2” e as alterações anteriores à GUI.


!--- Define the three new groups, Hardware, Software and General.

!
groupname hardware create
groupname software create
groupname general create
!

!--- Define the new groups (and therefore GDMs) are associated with 
!--- extensions 2030, 2031 and 2032.

!
groupname hardware phonenumber "2030"
groupname software phonenumber "2031"
groupname general phonenumber "2032"
!

!--- Define the membership of  the Hardware, Software and General groups.

!
groupname hardware member user21
groupname hardware member user22
groupname hardware member user23
groupname software member user24
groupname software member user25
groupname software member user26
groupname general member user27
groupname general member user28
groupname general member user29
!

!--- Define the custom AA script that will branch 
!--- to the xfermailbox.aef system script
!--- when the caller selects the correct GDM from the menu.

!
ccn application s12-xfer-to-mbox
 description "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 script "s12_cue-aa-bacd-script.aef"
 end application
!

!--- Define the pilot number 2110 to the custom script.

!
ccn trigger sip phonenumber 2110
 application "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 end trigger
!

!--- Define the GDMs for each of the groups.

!
voicemail mailbox owner "hardware" size 3000
 description "hardware mailbox"
 end mailbox
voicemail mailbox owner "software" size 3000
 description "software mailbox"
 end mailbox
voicemail mailbox owner "general" size 3000
 description "general mailbox"
 end mailbox

Variação de Configuração 3 do Cenário 2 - Uso da Funcionalidade Drop Through da ACD

O recurso drop through da ACD do Cisco CME pode ser utilizado para ignorar o menu do AA do Cisco CME e transferir uma chamada diretamente à ACD. Com esse recurso, todo o menu de AA pode ser consolidado no script de AA do Cisco Unity Express. Apesar da utilização desse recurso necessitar de configurações adicionais no roteador Cisco CME, ele simplifica a manutenção dos scripts de AA (menus) em comparação à divisão de menus e anúncios gravados entre o AA do Cisco Unity Express (menu de nível 1) e o AA do Cisco CME (menu de nível 2).

Na configuração da variação 3 do cenário 2, ambos os níveis do menu de AA estão contidos no script de AA do Cisco Unity Express da seguinte forma:

  • Thank you for calling Widget Systems

    • Press 1 for Customer Service

      • Press 1 for Hardware related questions

      • Press 2 for Software related questions

      • Press 3 for General questions

    • Press 2 for Office location

    • Press 3 for Office hours

    • Press 4 to Leave a Voice Message

As opções de menu do nível 2 resultam em chamadas transferidas do Cisco Unity Express para um número piloto individual de ACD do Cisco CME para cada um destes grupos:

  • Hardware — Número piloto de ACD do Cisco CME 2040

  • Software — Número piloto de ACD do Cisco CME 2041

  • General — Número piloto de ACD do Cisco CME 2042

As configurações apresentadas anteriormente neste documento definem um único número piloto de ACD (2040). Nesta variação de configuração, três número pilotos de ACD do Cisco CME serão definidos (2040, 2041 e 2042). Essa variação ilustra a forma como você pode habilitar a funcionalidade drop through. O uso do recurso drop through ignora o menu do AA do Cisco CME e especifica uma opção em particular a ser seguida (especificada no comando correspondente da CLI). O sistema age como se o chamador tivesse pressionado a opção especificada estaticamente na CLI. Nesse cenário, a configuração do AA do Cisco CME inclui as seguintes adaptações:

  • A configuração do número piloto 2040 da ACD inclui o comando param drop-through-option 1

  • A configuração para o número piloto 2041 ACD inclui o comando param drop-through-option 2

  • A configuração para o número piloto 2042 ACD inclui o comando param drop-through-option 3

Configurar Cisco CME para a variação 3 da encenação 2

Estes passos resumem a configuração do Cisco CME para a variação 3 do cenário 2:

  1. Inclua a configuração adicional do AA do Cisco CME e do TCL da ACD para os números pilotos 2040, 2041 e 2042, utilizando a CLI "drop-through".

  2. Adicione os peers de discagem para habilitar a discagem dos novos números pilotos 2040, 2041 e 2042.

    A seguir é mostrada a configuração comentada da CLI do roteador Cisco CME para alterações e adições feitas na configuração do Cisco CME do cenário base associado à seção “Configuração do Cisco CME para o Cenário 2”.

    application
     service acd flash:app-b-acd-2.1.0.0.tcl
      param queue-cme-debugs 1
      param aa-hunt1 2020
      param aa-hunt2 2021
      param number-of-hunt-grps 3
      param aa-hunt3 2022
      param queue-len 30
    !
    
    !--- Define the TCL configuration for the Hardware group, using pilot number 2040 
    !--- and "drop-through-option 1". Extension 2030 is associated with the GDM for
    !--- the Hardware group, so this is the voice mail destination.
    
    !
     service hardware-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param max-time-vm-retry 1
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2030
      param aa-pilot 2040
      param number-of-hunt-grps 1
      paramspace english language en
      param handoff-string hardware-aa
      param call-retry-timer 20
      paramspace english location flash:
      param service-name acd
      param drop-through-option 1
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the TCL configuration for the Software group, 
    !--- using pilot number 2041 
    !--- and "drop-through-option 2". Extension 2031 is associated with the GDM for
    !--- the Software group, so this is the voice mail destination.
    
    !
     service software-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param number-of-hunt-grps 1
      paramspace english index 0
      param handoff-string software-aa
      paramspace english language en
      param call-retry-timer 20
      param service-name acd
      paramspace english location flash:
      param drop-through-option 2
      param second-greeting-time 30
      param max-time-vm-retry 1
      param voice-mail 2031
      paramspace english prefix en
      param max-time-call-retry 60
      param aa-pilot 2041
    !
    
    !--- Define the TCL configuration for the General group, using pilot number 2042 
    !--- and "drop-through-option 3". Extension 2032 is associated with the GDM for
    !--- the General group, so this is the voice mail destination.
    
    !
     service general-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param call-retry-timer 20
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2032
      param service-name acd
      param number-of-hunt-grps 1
      param drop-through-option 3
      paramspace english language en
      param handoff-string general-aa
      param max-time-vm-retry 1
      paramspace english location flash:
      param aa-pilot 2042
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the dial-peers for pilot number 2040 and attach the Hardware
    !--- TCL script to this number.
    
    !
    dial-peer voice 2040 voip
     destination-pattern 2040
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20400 voip
     service hardware-aa
     incoming called-number 2040
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    
    !--- Define the dial-peers for pilot number 2041 and attach the Software
    !--- TCL script to this number.
    
    !
    dial-peer voice 2041 voip
     destination-pattern 2041
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20410 voip
     service software-aa
     incoming called-number 2041
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    �
    
    !--- Define the dial-peers for pilot number 2042 and attach the General
    !--- TCL script to this number.
    
    !
    dial-peer voice 2042 voip
     destination-pattern 2042
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20420 voip
     service general-aa
     incoming called-number 2042
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad

Configurar o Cisco Unity Express para a variação 3 da encenação 2

Estes passos resumem a configuração do Cisco Unity Express para a variação 3 do cenário 2:

  1. Abra o utilitário Cisco Unity Express Script Editor e ajuste o script s10-cue-aa-bacd.aef para conter ambos os níveis do menu de AA. Veja figura 22.

    Figura 22 - Configuração do Script de AA do Cisco Unity Express para Ambos os Níveis de Menu

    /image/gif/paws/67907/142220.jpg

  2. Escolha o correio de voz > o atendimento automático e associe o script novo (S10A_CUE-AA-BACD-script.aef) com o número piloto 2100. Veja figura 23.

    Figura 23 associado o script com um número piloto

    /image/gif/paws/67907/142221.jpg

  3. Grave todos os prompts necessários para o script de AA. Você pode gravá-los offline e transferir os arquivos .wav para o Cisco Unity Express com o nome correto do arquivo ou gravá-los por meio do Administration via Telephony (AVT).

  4. (Opcional) Se você utilizar o AVT, o Cisco Unity Express atribuirá um nome genérico de arquivo que você poderá, em seguida, alterar para o nome desejado. Selecione Voice Mail > Prompts e clique no nome do arquivo do sistema.

  5. (Opcional) Edite o(s) nome(s) do(s) arquivo(s) na caixa de diálogo conforme o necessário e clique em OK. A janela Voice Mail > Prompts exibirá o nome correto do arquivo na lista.

A seguir é mostrada a configuração comentada da CLI do Cisco Unity Express para alterações e adições feitas na configuração do Cisco Unity Express do cenário base associado à seção “Configuração do Cisco Unity Express para o Cenário 2”.


!--- Define a new AA with script s10a-cue-aa-bacd.aef.

!
ccn application s10a-cue-aa-bacd
 description "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10a_cue-aa-bacd-script.aef"
 parameter "S10_Hardware" "2040"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_Software" "2041"
 parameter "S10_General" "2042"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
!

!--- Associate AA pilot number 2100 with the new script.

!
ccn trigger sip phonenumber 2100
 application "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger

Cenário 3 - Uso da ACD Básica como o Menu de Primeiro Nível e do AA do Cisco Unity Express como o Menu de Segundo Nível

Na terceira encenação apresentada neste documento, as chamadas recebidas são dirigidas a Cisco CME AA (número piloto 2040) exatamente como na encenação 1. A única diferença é que há somente dois grupos ACD (hardware e software), quando a terceira opção do menu principal for alcançar um anúncio que descreva o lugar e os horários de operação de loja.

Nota: Não é possível incluir anúncios de forma livre com Cisco CME AA. Em vez disso, é necessário um script personalizado do Cisco Unity Express.

Você pode conseguir este mesmo resultado (do ponto de vista de um chamador) com uma variação de cenário 2. O exemplo da encenação 3 é dado para ilustrar uma outra maneira de estruturar o aplicativo entregando fora de um atendimento de Cisco CME ACD que processa ao Cisco Unity Express AA. A utilização de uma variação do cenário 2 é, provavelmente, a forma mais típica de se criar essa aplicação.

Fluxo de chamadas da encenação 3

O fluxo de chamadas da configuração nesta seção é ilustrado em figura 24.

Figura 24 - Fluxo de Chamadas do Cenário 3

135510.jpg

Notas de configuração da encenação 3

As chamadas da PSTN da porta FXO (0/3/0) são terminadas automaticamente no AA do Cisco CME (2040).

A ACD do Cisco CME possui apenas dois grupos de agentes (2020 e 2021). A opção 3 do menu é utilizada para transferir a chamada para o AA do Cisco Unity Express para o anúncio. Em vez de listar um número de grupo de busca, quando os chamadores escolhem a opção 3, o sistema os direciona para o número piloto de AA do Cisco Unity Express (2100) como resultado do uso do comando param aa-hunt3 2100.

Configurar Cisco CME para a encenação 3

A configuração da CLI para o roteador Cisco CME é mostrada no exemplo seguinte:

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Point option 3 of the menu (aa-hunt3) to the 
!--- Cisco Unity Express AA (2100).

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2100
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configurar o Cisco Unity Express para a encenação 3

Estes passos resumem a configuração do Cisco CME para o cenário 3:

  1. Abra o utilitário Cisco Unity Express Script Editor e crie o script personalizado do Cisco Unity Express. Veja figura 25.

    Figura 25 - Script de Armazenamento de Horário e Localização

    /image/gif/paws/67907/135367.jpg

  2. Grave o prompt (neste caso, S11_Announcement.wav) do script de AA (S11_CUE-AA-BACD-script.aef). Você pode gravá-lo offline e transferir o arquivo .wav para o Cisco Unity Express com o nome correto do arquivo ou gravá-lo por meio do Administration via Telephony (AVT).

  3. (Opcional) Se você utilizar o AVT, o Cisco Unity Express atribuirá um nome genérico de arquivo que você poderá, em seguida, alterar para o nome desejado. Selecione Voice Mail > Prompts e clique no nome do arquivo do sistema.

  4. (Opcional) Edite o nome do arquivo na caixa de diálogo e clique em OK. O indicador do correio > das alertas de The Voice mostra agora o nome de arquivo corrigido na lista (veja figura 26).

  5. Selecione Voice Mail > Auto Attendant e abra o AA preparado no passo 2. Selecione Script Parameters e associe os nomes dos arquivos de prompts ao parâmetro correto no script.

    Figura 26 - Janela com as Opções de Prompt

    135368.jpg

  6. Escolha o correio de voz > o atendimento automático e associe o script com o número piloto 2100 AA. Consulte a figura 27.

    Figura 27 - Janela com a Associação do Script ao Número Piloto de AA

    /image/gif/paws/67907/135369.jpg

A configuração da CLI do sistema Cisco Unity Express é mostrada no exemplo a seguir:

cue# 
show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
groupname custservice create
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Define the AA script that will provide the announcement.

!
ccn application s11-cue-aa-bacd
 description "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s11_cue-aa-bacd-script.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the script with the 2100 AA pilot number.

!
ccn trigger sip phonenumber 2100
 application "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000

description "user26 mailbox"
end mailbox
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Alerta BACD para os únicos atendimentos automáticos que não jogam

Se o arquivo BACD está no flash: o dobrador /bacdprompt/, emite o flash inglês do lugar do paramspace: comando /bacdprompt/ no serviço AA.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 67907