Colaboração : Cisco ICM Logger

O registador afirma constantemente porque a tabela do Config_Message_Log está vazia

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve uma razão para a asserção repetitiva do processo de logger no registador, e fornece uma solução em um Intelligent Contact Management (ICM) ou no ambiente de empreendimento do Centro de Contato de IP (IPCC).

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • ICM Cisco

  • Microsoft SQL server

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Versão do ICM 4.5.x de Cisco e mais tarde

  • Microsoft SQL server 6.5 e 7.0

  • Server de Microsoft SQL2000

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Somente a base de dados central contém a tabela do Config_Message_Log. A tabela do Config_Message_Log armazena mensagens de configuração. A tabela contém estes cinco campos:

  1. RecoveryKey: O software ICM usa o valor de campo do RecoveryKey internamente para seguir o tempo virtual.

  2. LogOperation: O campo da LogOperation indica o tipo de alteração de configuração. Por exemplo, “adicionar” ou “atualização”.

  3. TableName: O campo do TableName indica o nome da tabela que a alteração de configuração afeta.

  4. DateTime: O campo do DateTime indica a data e hora em que o registador registra um grupo de mensagens.

  5. ConfigMessage: O campo do ConfigMessage contém todos os mensagens de configuração em uma transação.

Problema

O lgr ou o processo de logger no registador afirmam constantemente. Ou seja o processo de logger começa, falha, e reinicia repetidamente.

O log correspondente contém este Mensagem de Erro:

la-lgr Fail: Assertion failed: syncMsg.UpdateKey == g.checksumInfo.updateKey.
  File: y:\icm\logger\logger\rtinput.cpp.  Line 691

A fim ver o lgr ou o processo de logger no registador, você pode ver a janela de processo relevante. Alternativamente, use o utilitário dumplog para ver o log respectivo do processo.

Causa

Uma tabela vazia do Config_Message_Log é a causa de raiz da edição. A fim verificar se a tabela do Config_Message_Log está vazia, emita este comando sql:

select * from Config_Message_Log

A tabela do Config_Message_Log não contém provavelmente nenhuma fileira porque você seleciona a caixa de verificação truncada do log de mensagens da configuração quando você dirige a administração da base de dados do Intelligent Contact Management (ICMDBA) para exportar dados de configuração.

Solução

A fim resolver este problema, você pode emitir este comando sql:

insert into Config_Message_Log values (0, 'LogBegin', 'Config_Message_Log',
 getdate(),0x0000)

Este comando sql adiciona uma fileira à tabela do Config_Message_Log.


Informações Relacionadas


Document ID: 65201