Voz : Protocolos de gateway

Configurar troncos Q.SIG PRI entre o Call Manager e o Avaya S8700/G650 com integração de correio de voz do Unity

29 Julho 2013 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (20 Agosto 2006) | Feedback


Índice


Introdução

O objetivo deste documento é fornecer aos clientes Cisco e parceiros de negócios as etapas para configurar troncos de PRI Q.SIG entre o Cisco Call Manager e o Avaya S8700/G650. Além disso, este documento detalha as etapas de como adicionar o Cisco Unity na plataforma do Cisco Call Manager para fornecer suporte ao correio de voz para telefones IP Cisco e Avaya. Isto é particularmente importante em situações onde a interoperabilidade IP-PBX e a integração do correio de voz são necessárias. As capturas da tela de configuração da Avaya foram criadas com a ferramenta padrão de Emulação. Como uma alternativa, você também pode usar a ferramenta Avaya Site Administration (ASA) para tarefas de configuração no Avaya S8700/G650. A exibição da saída é o mesmo em ambos os casos. Este documento sobre a interoperabilidade IP-PBX e a integração de correio de voz foi projetada para uso externo.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • O sistema de Avaya IP-PBX usado é o gerenciador de comunicação Avaya running 2,0 de Avaya S8700/G650. O conjunto de recursos Q.SIG vem como padrão com esta versão de software.

  • Os Telefones IP de Avaya usados neste documento são a versão de firmware running 2,01 4610SW e de telefone 4620.

  • O Cisco Call Manager 4.1.(2) foi usado a fim controlar o Gateway do Media Gateway Control Protocol (MGCP) 3745 com o módulo NM-HDV, versão 12.2.15ZJ3 running de Cisco IOS®. Os testes foram repetidos igualmente com versão 12.3.8.T5 de Cisco IOS®.

  • A versão 4.0(4) running SR1 do Cisco Unity foi usada para o teste da integração de correio de voz.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Definição de teste

O sistema de Avaya IP-PBX usado era o gerenciador de comunicação Avaya running 2,0 de Avaya S8700/G650. O conjunto de recursos Q.SIG vem como padrão com esta versão de software. Os telefones de AvayaIP usados eram a versão de firmware running 2,01 4610SW e de telefone 4620. No lado de Cisco, o Cisco Call Manager 4.1.2 foi usado para controlar o gateway MGCP 3745 com o módulo NM-HDV, versão 12.2.15ZJ3 running de Cisco IOS®. Os testes foram repetidos igualmente com versão 12.3.8.T5 de Cisco IOS®. A versão 4.0(4) running SR1 do Cisco Unity foi usada para o teste da integração de correio de voz.

Topologia de teste

/image/gif/paws/63790/top.gif

Interoperabilidade entre Cisco e sistemas de Avaya IP-PBX

As próximas seções fornecem procedimentos e capturas de tela para ajudá-lo a configurar o tronco Q.SIG entre um gerenciador de comunicação Avaya running 2,0 de Avaya S8700/G650 e uma versão 4.1(2) running do gerenciador de chamada da plataforma do Cisco Call Manager com o dispositivo do Cisco 3745 MGCP que fornece a conexão de ISDN PRI física a Avaya S8700/G650.

Procedimento no sistema de Avaya S8700/G650 IP-PBX

Conclua estes passos:

  1. Entre ao server S8700. Execute o comando display system-parameters customer a fim assegurar-se de que todas as características necessárias Q.SIG estejam permitidas no server S8700.

    /image/gif/paws/63790/proced1.gif

  2. Configurar o cartão DS1 para Q.SIG PRI.

    2.gif

  3. Configurar um grupo de troncos. O tipo adiciona o grupo de troncos # onde # está o tronco desejado.

    As três capturas de tela seguintes relacionam-se à configuração de tronco. Uma vez que o grupo de troncos é criado, adicionar os 23 canais DS0 ao grupo. Este é um exemplo da atribuição de porta: 01A0901 significa: Gateway# 1, armário A, slot- 9, grupo1 do channel# DS0.

    /image/gif/paws/63790/3.gif

    4.gif

    5.gif

  4. Adicionar o grupo e o ponto de sinalização ao grupo de troncos criado mais cedo.

    /image/gif/paws/63790/6.gif

  5. Adicionar a rota padrão e aponte-a ao grupo de sinalização. Neste exemplo, a rota padrão 4 aponta a sinalizar o grupo número 1 que foi criada em etapa 4.

    /image/gif/paws/63790/7.gif

  6. Adicionar uma entrada na tabela de AAR a fim usar a rota padrão que você criou para distribuir atendimentos. Neste exemplo, os atendimentos à extensão 4XXX do Cisco IP Phone usam a entrada de tabela de AAR que começa com 4, que aponta por sua vez à rota padrão # 4.

    /image/gif/paws/63790/8.gif

  7. Assegure-se de que o ID de chamada esteja permitido em cada telefone IP de enviar o nome da chamada originada.

    /image/gif/paws/63790/9.gif

Procedimento no Cisco Call Manager

Conclua estes passos:

  1. Sob parâmetros de serviço, certifique-se de que os valores do mínimo e de tempo máximo da substituição do trajeto do começo estão ajustados apropriadamente a fim impedir todas as edições (tais como o hair pinning).

    As duas capturas de tela seguintes relacionam-se aos ajustes dos parâmetros de serviço Q.SIG:

    /image/gif/paws/63790/10.gif

    11.gif

  2. Adicionar o Cisco 3745 como um gateway MGCP e configurar o módulo T-1 NM-HDV para o Q.SIG PRI.

    As cinco capturas de tela seguintes relacionam-se a esta configuração:

    /image/gif/paws/63790/2.gif

    13.gif

    15.gif

    16.gif

    17.gif

  3. Como uma etapa final, crie um grupo do recolhimento do Cisco Call Manager a fim fornecer uma extensão da proposta do trajeto ao PBX. Certifique-se de que o número do atendimento de chamada está incorporado igualmente no parâmetro de serviço do ID de substituição PINX de Caminho (veja ao step# 1). Também, o sistema Avaya precisa uma rota padrão a fim distribuir ao grupo do recolhimento.

    /image/gif/paws/63790/8.gif

    Nota: Certifique-se de que estes dois parâmetros Clusterwide (dispositivo - PRI e gateway MGCP) sob parâmetros do serviço do CallManager da Cisco (avançados) combinam a configuração Q.SIG no PBX. Todos os troncos PBX devem ser configurados exatamente como estes parâmetros do CallManager da Cisco.

    • Codificação ASN.1 ROSA OID: Este parâmetro especifica como codificar a identificação de objeto da invocação (OID) para o elemento de serviço das operações remotas (ROSA). Mantenha este conjunto de parâmetro ao valor padrão a menos que um engenheiro de suporte da Cisco instruir de outra maneira. Estes são um campo requerido e a opção é valor do Local do uso.

      Estes são os valores válidos para este parâmetro:

      • Use o valor local, que está apoiado pela maioria de sistemas de telefonia e deve ser usado quando o parâmetro de serviço variante Q.SIG é ajustado a ISO (perfil 0x9F do protocolo).

      • Use o valor global (ISO), que é usado somente se o PBX conectado não apoia o valor do Local do uso.

      • Use o valor global (ECMA), que deve ser usado se o parâmetro de serviço variante Q.SIG é ajustado a ECMA (perfil 0x91 do protocolo).

    • Variação Q.SIG: Este parâmetro especifica o perfil do protocolo enviado nos elementos de informação de partida da facilidade Q.SIG quando o tronco é configurado para o Q.SIG. Mantenha este conjunto de parâmetro ao valor padrão a menos que um engenheiro de suporte da Cisco instruir de outra maneira. Este é um campo requerido, e a opção é ISO (perfil 0x9F do protocolo).

      Estes são os valores disponíveis para este parâmetro:

      • ECMA (perfil 0x91 do protocolo), que é usado tipicamente com ECMA PBX e pode somente usar o perfil 0x91 do protocolo. Se este parâmetro de serviço está ajustado a ECMA (perfil 0x91 do protocolo), o parâmetro de serviço da codificação ASN.1 Rosa OID deve ser ajustado para usar o valor global (ECMA).

      • ISO (perfil 0x9F do protocolo), que é a recomendação ISO atual. Se este parâmetro está ajustado a ISO (perfil 0x9F do protocolo), a seguir o parâmetro de serviço da codificação ASN.1 Rosa OID deve ser ajustado para usar o valor local.

        Aviso: O CallManager da Cisco não apoia o ECMA ao usar troncos intercluster com o conjunto de campo em túnel do protocolo ao Q.SIG no indicador da configuração de tronco na administração do CallManager. Se você ajustou este parâmetro de serviço a ECMA (perfil 0x91 do protocolo), todos os troncos intercluster devem ter o conjunto de campo em túnel do protocolo a nenhuns.

        qsig.gif

Configuração do Cisco 3745

Este é o comando show version e show running-configuration output no dispositivo do Cisco 3745 MGCP. O T1 1/0 do controlador no Cisco 3745 é conectado ao cartão DS1 PRI de Avaya S8700/G650. A sinalização Q.SIG é configurada no link PRI entre o Cisco 3745 e o Avaya S8700/G650.

CCME_CUE_3745# sh vers
Cisco Internetwork Operating System Software 
IOS (tm) 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 25-Sep-03 22:25 by eaarmas
Image text-base: 0x60008954, data-base: 0x61C2C000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
ROM: 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

CCME_CUE_3745 uptime is 39 minutes
System returned to ROM by reload
System image file is "flash:c3745-is-mz.122-15.ZJ3.bin"

cisco 3745 (R7000) processor (revision 2.0) with 246784K/15360K bytes of memory.
Processor board ID JMX0814L3E2
R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
25 Serial network interface(s)
1 terminal line(s)
2 Channelized T1/PRI port(s)
1 ATM AIM(s)
2 Voice FXS interface(s)
2 Voice E & M interface(s)
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
151K bytes of non-volatile configuration memory.
125184K bytes of ATA System CompactFlash (Read/Write)
Configuration register is 0x2102

CCME_CUE_3745# sh run
Building configuration...

Current configuration : 3291 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CCME_CUE_3745
!
logging queue-limit 100
!
voice-card 1
 dspfarm
!
voice-card 5
 dspfarm
!
ip subnet-zero
!
!
no ip domain lookup
!
isdn switch-type primary-qsig
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.28.221.18  
ccm-manager config
mta receive maximum-recipients 0
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/1
 framing sf
 linecode ami
!
!
!
interface FastEthernet0/0
 description CCME-CUE-3745_to_cat3550
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 99
!
interface FastEthernet0/0.2
 description NEW_S8700_G650
 encapsulation dot1Q 300
 ip address 172.28.221.49 255.255.255.240
 ip helper-address 172.28.221.19
 h323-gateway voip bind srcaddr 172.28.221.49
!
interface FastEthernet0/0.3
 description MODULAR_MESSAGING_SOLUTION
 encapsulation dot1Q 900
 ip address 172.28.221.129 255.255.255.240
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.4
 encapsulation dot1Q 301
 ip address 10.1.3.1 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.5
 encapsulation dot1Q 302
 ip address 10.1.3.129 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.6
 encapsulation dot1Q 90
 ip address 90.1.1.254 255.255.255.0
 ip helper-address 172.28.221.19
!
interface Serial0/0
 description CCME-CUE-3745_to_3600
 ip address 25.0.0.1 255.0.0.0
 clockrate 256000
 no fair-queue
!
interface Serial1/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn bchan-number-order ascending
 no cdp enable
!
interface Service-Engine2/0
 no ip address
 shutdown
!
router eigrp 100
 network 10.0.0.0
 network 25.0.0.0
 network 90.0.0.0
 network 172.28.0.0
 auto-summary
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 1/0:23
!
voice-port 4/0/0
!
voice-port 4/0/1
!
voice-port 4/1/0
!
voice-port 4/1/1
!
mgcp
mgcp call-agent 172.28.221.18 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer cor custom
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0:23
!
dial-peer voice 999410 pots
 application mgcpapp
 port 4/1/0
!
!
line con 0
 password cisco
 login
line 65
 flush-at-activation
 no activation-character
 no exec
 transport preferred none
 transport input all
line aux 0
line vty 0 4
 password cisco
 login
!
end

Características testadas para a Interoperabilidade entre Cisco e sistemas de Avaya IP-PBX

Esta seção fornece uma lista de características testadas entre a plataforma do Cisco Call Manager 4.1(2) e o gerente running 2,0 de uma comunicação de Avaya S8700/G650 pelo tronco de PRI Q.SIG:

  • Indicador do nome e do número (bidirecional)

  • Transferência de Chamadas

  • Teleconferência entre os dois sistemas

Integração do correio de voz do Cisco Unity para apoiar Cisco e Telefones IP de Avaya

Neste momento, um pode usar o tronco Q.SIG a fim fazer atendimentos entre um gerenciador de comunicação Avaya running 2,0 de Avaya S8700/G650 e uma versão 4.1(2) running do gerenciador de chamada da plataforma do Cisco Call Manager com o dispositivo do Cisco 3745 MGCP que fornece a conexão de ISDN PRI física a Avaya S8700/G650. Um server do Cisco Unity pode ser adicionado na plataforma do Cisco Call Manager a fim fornecer o apoio do correio de voz a Cisco e aos Telefones IP de Avaya. A fim permitir isto, o administrador precisa de configurar o Cisco Unity na plataforma do Cisco Call Manager. Esta seção inclui os procedimentos com capturas de tela para que como configure o Cisco Unity na página do Gerenciamento da administração do Cisco Call Manager.

Nota:  A maioria da configuração é executada no assistente da porta de correio de voz de Cisco.

Adicionar o Cisco Unity ao Cisco Call Manager

Conclua estes passos:

  1. Sob a característica, selecione o correio de voz > o assistente da porta de correio de voz. Seleto crie um servidor de correio de voz novo e adicionar-lhe portas e clique-as em seguida.

    19.gif

  2. Dê entrada com um nome do servidor de correio de voz de Cisco, tal como AvayaUM3, e clique-o em seguida.

    /image/gif/paws/63790/20.gif

  3. Selecione o número de portas de correio de voz desejadas e clique-o em seguida.

    /image/gif/paws/63790/21.gif

  4. Inscreva uma descrição e um pool de dispositivos para as portas de correio de voz. Na configuração de exemplo, Avaya VMailPorts foi entrado como a descrição e a opção como o pool de dispositivos.

    /image/gif/paws/63790/4.gif

  5. Incorpore o número de diretório do começo, tal como 4406, e o indicador, tal como o correio de voz, e clique-os em seguida.

    /image/gif/paws/63790/2.gif

  6. A tela seguinte pede, “você quer adicionar estes números de diretório a uma linha grupo?” Selecione sim. Adicionar números de diretório a um grupo de nova linha e clique-os em seguida.

    /image/gif/paws/63790/3.gif

  7. Incorpore uma linha nome do grupo que combine o servidor de correio de voz que você entrou previamente, como AvayaUM3.

    /image/gif/paws/63790/4.gif

  8. A tela seguinte mostra a configuração incorporada até agora. Clique o revestimento se não há nenhuma mudança à configuração.

    /image/gif/paws/63790/5.gif

  9. O clique adiciona uma lista nova da caça na página da web de administração da lista da caça.

    /image/gif/paws/63790/6.gif

  10. Incorpore um nome de lista e uma descrição da caça, tal como Avaya VMailHL. Também, selecione a opção para o grupo do Cisco Call Manager.

    /image/gif/paws/63790/7.gif

  11. Esta captura de tela é o resultado da adição bem-sucedida da lista da caça. O clique adiciona a linha grupo.

    28.gif

  12. Selecione a linha grupo configurado previamente. Neste caso, é AvayaUM3.

    /image/gif/paws/63790/9.gif

  13. A captação de tela seguinte mostra o resultado da inserção bem-sucedida da linha grupo.

    /image/gif/paws/63790/30.gif

  14. Vá ao plano de rota > à rota/caça > ao piloto da caça. O clique adiciona um piloto novo da caça da tela do piloto da caça que resulta.

    /image/gif/paws/63790/31.gif

  15. Entre no piloto da caça, tal como 4408, e selecione uma lista da caça, tal como HL de Avaya VMail e a inserção do clique.

    /image/gif/paws/63790/2.gif

  16. Vá à característica > ao correio de voz > ao correio de voz piloto e o clique adiciona um correio de voz piloto novo na tela que resulta.

    /image/gif/paws/63790/3.gif

  17. Incorpore o número do correio de voz piloto que combina o número piloto da caça configurado previamente. Neste caso, os números do piloto e do correio de voz piloto da caça são 4408.

    /image/gif/paws/63790/4.gif

  18. Vá à característica > ao correio de voz > ao perfil de correio de voz e o clique adiciona um perfil de correio de voz novo.

    /image/gif/paws/63790/5.gif

  19. Incorpore o nome e a descrição do perfil de correio de voz, tal como AvayaVMailProfile, e selecione o número do correio de voz piloto em etapa 17. Neste caso, o número do correio de voz piloto é 4408.

    36.gif

  20. Clique o > Add das características > do correio de voz > do indicador de espera de mensagem um número de espera da mensagem nova para adicionar os números de ligar/desligar do indicador de espera de mensagem (MWI). São incluídas aqui duas capturas de tela para números de ligar/desligar do indicador de espera de mensagem.

    37.gif

    38.gif

Características do correio de voz do Cisco Unity testadas

Esta é uma lista de características do correio de voz do Cisco Unity testadas com os Telefones IP de Avaya usados para alcançar o correio de voz do Cisco Unity pelo tronco de PRI Q.SIG entre a plataforma do Cisco Call Manager 4.1(2) e o gerente running 2,0 de uma comunicação de Avaya S8700/G650:

  • Cumprimento interno

  • Cumprimento ocupado

  • MWI

  • Acesso fácil da mensagem

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 63790