IP : Open Shortest Path First (OSPF)

Configurações iniciais para o OSPF em um enlace ponto a ponto

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Em links ponto-a-ponto, como HDLC (High-Level Data Link Control) e PPP (Point-to-Point Protocol), o protocolo OSPF (Open Shortest Path First) é executado como um tipo de rede ponto-a-ponto. Esse tipo de rede está habilitado por padrão. Este documento mostra exemplos de configurações para OSPF via link ponto a ponto. Os outros tipos de rede que o OSPF suporta são Ponto a Multiponto, Broadcast e Non-Broadcast. Para verificar o tipo de rede de uma interface que executa o OSPF, emita o comando show ip ospf interface.

Os exemplos explicados neste documento trabalham com o HDLC e os encapsulamentos PPP.

Pré-requisitos

Requisitos

Os leitores deste documento devem ter algum conhecimento básico do protocolo de roteamento OSPF. Para obter mais informações sobre do protocolo de roteamento OSPF, refira a primeira documentação do caminho mais curto aberto.

Componentes Utilizados

A informação neste documento aplica aos estes a versão de software e hardware.

  • Cisco 2500 Router

  • Software Release 12.2(27) do½ do¿Â do Cisco IOSï que é executado no Roteadores

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

OSPF sobre um link de ponto a ponto com os endereços IP de Um ou Mais Servidores Cisco ICM NT em interfaces serial

Esta seção apresenta-o com a informação que você pode se usar para configurar o Roteadores que executa o OSPF e é conectado com um link serial Point-to-Point com o uso do encapsulamento de HDLC com os endereços IP de Um ou Mais Servidores Cisco ICM NT configurados em interfaces serial.

Nota: A fim encontrar a informação adicional nos comandos que este documento usa, usa a ferramenta de consulta de comandos (clientes registrados somente).

Diagrama de Rede

/image/gif/paws/13687/15a.gif

Configurações

Essa seção usa estas configurações:

Roteador1
Router1
!
interface Loopback0
� ip address 3.3.3.3 255.255.255.255
!
interface Serial0
�ip address 1.1.1.2 255.255.255.0
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

!--- Configures the Serial Interface S0 under OSPF area 0.

!

Roteador2
Router2
!
interface Loopback0
�ip address 2.2.2.2 255.255.255.255
!
interface Serial0
�ip address 1.1.1.1 255.255.255.0
�clockrate 2000000
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

!--- Configures the Serial Interface S0 under OSPF area 0..

OSPF sobre um link de ponto a ponto com as interfaces não numeradas

Esta seção apresenta-o com a informação que você pode se usar para configurar o Roteadores que executa o OSPF como o protocolo de roteamento e é conectado com um link serial Point-to-Point com o encapsulamento PPP e com as interfaces serial Unnumbered. As interfaces serial Unnumbered são as relações que não têm seu próprio endereço IP de Um ou Mais Servidores Cisco ICM NT. Estas relações pedem o endereço IP de Um ou Mais Servidores Cisco ICM NT de uma outra relação no roteador que tem um endereço IP de Um ou Mais Servidores Cisco ICM NT configurado. Para obter mais informações sobre das interfaces serial Unnumbered, refira a compreensão e configurar do comando ip unnumbered.

Nota: A fim encontrar a informação adicional nos comandos que este documento usa, usa a ferramenta de consulta de comandos (clientes registrados somente).

Diagrama de Rede

/image/gif/paws/13687/15b.gif

Configurações

Essa seção usa estas configurações:

Roteador1
!

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0
 ip unnumbered loopback 0

!--- Configures Serial 0 as an unnumbered interface.

 encapsulation ppp

!--- Configures the Encapsulation on the interface as PPP.

!
router ospf 1
  network 3.3.3.0 0.0.0.255 area 0

!--- Configures the Loopback Interface L0 under OSPF area 0.

!

Roteador2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip unnumbered loopback 0

!--- Configures Serial 0 as an unnumbered interface.

 encapsulation ppp

!--- Configures the Encapsulation on the interface as PPP.

!
router ospf 1
  network 2.2.2.0 0.0.0.255 area 0

!--- Configures the Loopback Interface L0 under OSPF area 0..

!

Verificar

Esta seção fornece a informação que você pode se usar para confirmar sua configuração trabalha corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Verifique a configuração do OSPF com endereços IP de Um ou Mais Servidores Cisco ICM NT em interfaces serial

Esta é a saída do comando show ip ospf neighbor emitida no roteador1.

Router1#show ip ospf neighbor
   Neighbor ID   Pri   State       Dead Time       Address        Interface
     2.2.2.2      1   FULL/ -       00:00:32       1.1.1.1         Serial 0

Esta saída mostra que o roteador1 tem um vizinho com um Router ID de 2.2.2.2, e formou a adjacência total com este vizinho. O endereço 1.1.1.1 é o endereço IP de Um ou Mais Servidores Cisco ICM NT da relação do serial0 no roteador2.

Para obter informações adicionais sobre do comando show ip ospf neighbor, refira o que faz o comando show ip ospf neighbor revela?

Esta é a saída do comando show ip ospf interface serial 0 no roteador1. Esta saída mostra o tipo de rede OSPF para o serial0 da relação como ponto a ponto.

Router1# show ip ospf interface serial 0 
   Serial0 is up, line protocol is up 
   Internet Address 1.1.1.2/24, Area 0 
   Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
   Hello due in 00:00:05
   Index 1/1, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1 
   Adjacent with neighbor 2.2.2.2
   Suppress hello for 0 neighbor(s)

Similarmente, este exemplo indica a saída para o OSPF da mostra IP vizinho e os comandos show ip ospf interface no roteador2.

Router2# show ip ospf neighbor
   Neighbor ID     Pri    State     Dead Time     Address      Interface
    3.3.3.3         1     FULL/ -    00:00:32      1.1.1.2      Serial0

Router2# show ip ospf interface serial 0
   Serial0 is up, line protocol is up 
   Internet Address 1.1.1.1/24, Area 0 
   Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
   Index 1/1, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 3.3.3.3
   Suppress hello for 0 neighbor(s)

Verifique a configuração do OSPF com interfaces não numeradas

O comando show ip ospf neighbor em Router1 e Router2 confirma a adjacência completa. Esta saída mostra o tipo de rede OSPF para o serial0 da relação como ponto a ponto. Você pode igualmente ver que o internet address é 0.0.0.0 para a interface serial em ambo o Roteadores. Isto é porque um endereço IP de Um ou Mais Servidores Cisco ICM NT é pedido da interface de loopback (neste caso) em virtude do comando ip unnumbered.

Router1#show ip ospf neighbor
      Neighbor ID  Pri   State    Dead Time    Address      Interface
      2.2.2.2      1   FULL/ -    00:00:37    2.2.2.2       Serial0

Router1# show ip ospf interface serial 0
Serial0 is up, line protocol is up
  Internet Address 0.0.0.0/24, Area 0
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)

Este exemplo indica a saída dos comandos show ip ospf neighbor e show ip ospf interface serial 0 no roteador2.

Router2#show ip ospf neighbor
      Neighbor ID   Pri   State   Dead Time   Address   Interface
      3.3.3.3        1   FULL/ -  00:00:30    3.3.3.3    Serial0

Router2# show ip ospf interface serial 0
Serial0 is up, line protocol is up
  Internet Address 0.0.0.0/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)

Este exemplo mostra a saída do comando show ip route no roteador1 com encapsulamento PPP e o uso das interfaces não numeradas.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0

Este exemplo indica a saída do comando show ip route no roteador2 com encapsulamento PPP e o uso das interfaces não numeradas.

Router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Serial0

Este exemplo indica a saída do comando show ip route no roteador1 com encapsulation hdlc e do uso das interfaces não numeradas.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 2.2.2.2, 00:00:08, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0

Este exemplo indica a saída do comando show ip route no roteador2 com encapsulation hdlc e do uso das interfaces não numeradas.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

        2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 3.3.3.3, 00:01:28, Serial0

Nota: A saída do comando show ip route pôde diferir entre o PPP e os encapsulamentos de HDLC quando a configuração de IP não numerado é usada em interfaces serial. O PPP instala uma rota do host ao endereço IP de Um ou Mais Servidores Cisco ICM NT que é usado na interface serial no extremo oposto como diretamente uma rede conectada. Se o mesmo prefixo é aprendido igualmente com o OSPF como nesta configuração, indica somente como uma rota conectada (enquanto esta saída da rota da mostra IP mostra). Isto é porque as rotas conectadas têm uma distância administrativa mais baixa do que o OSPF e é mais preferido. Você pode mudar este comportamento quando você emite o comando no peer neighbor-route sob as interfaces serial que impede que uma rota do host esteja instalada e o trata como uma rota de OSPF.

Este não é o caso com HDLC porque não instala uma rota do host. O HDLC instala uma rota de OSPF para o endereço na outra extremidade quando o IP unnumbered é usado.

Troubleshooting

Para obter informações sobre de como pesquisar defeitos edições OSPF, refira a pesquisa de defeitos do OSPF.


Informações Relacionadas


Document ID: 13687