IP : Open Shortest Path First (OSPF)

Problema de Roteamento comum com Endereço de Encaminhamento do OSPF

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve os conceitos e o problema associados ao endereço de encaminhamento de Open Shortest Path First (OSPF). Consulte Por que algumas rotas OSPF estão no banco de dados mas não na tabela de roteamento? para obter mais informações sobre o Troubleshooting do OSPF.

O problema explicado neste documento é somente perceptível com software release de Cisco IOS� mais cedo de 12.1(3). O comportamento de redistribuição mudou no Cisco IOS Software Release 12.1(3) e Mais Recente. Para mais detalhes, refira o CSCdp72526 da identificação de bug Cisco (clientes registrados somente). Este erro tem a lista de Cisco IOS Software Release afetados e dos verões fixa. Igualmente refira a redistribuição de redes conectadas no OSPF onde a mudança no comportamento do Cisco IOS é explicada.

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • Distribuição do IP geral.

  • Conceitos e termos do protocolo de roteamento OSPF.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2503 Routers

  • Software Release 12.2(24a) de Cisco IOS� que é executado em todo o Roteadores

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Descrição do endereço de encaminhamento OSPF

O conceito do endereço de encaminhamento do OSPF foi introduzido para evitar saltos extras quando o tráfego é distribuído a um sistema autônomo externo, segundo as indicações desta figura.

/image/gif/paws/13682/10a.gif

Na figura, há dois Roteadores no domínio de OSPF que conecta ao domínio externo. Contudo, somente o roteador1 troca a informação de roteamento com o roteador 100. O roteador1 redistribui a informação aprendida do roteador 100 no OSPF e anuncia a informação ao resto do domínio de OSPF. Ao fazer isso, o Router 1 torna-se o Next Hop (ou endereço de encaminhamento) para as informações que ele redistribui para o domínio OSPF. Quando o roteador2 receber um pacote do domínio de OSPF destinado para um endereço no domínio externo, ele para a frente o pacote ao roteador1 do roteador 1. então para a frente ele ao roteador 100. O conceito do endereço de encaminhamento permite este salto extra seja evitado porque permite que o roteador1 especifique o endereço IP de Um ou Mais Servidores Cisco ICM NT de um outro roteador como o endereço de encaminhamento. Na figura, o roteador1 pode especificar o roteador 100 como o endereço de encaminhamento para a informação externa que o roteador1 redistribui no domínio de OSPF. Quando o roteador2 receber um pacote do domínio de OSPF destinado para um endereço no domínio externo, ele para a frente o pacote ao roteador 100. O resultado é que o salto extra está evitado com o roteador1.

O valor do endereço de encaminhamento especificado pelo roteador de limite de sistema autônomo (ASBR) (roteador1 na figura precedente) pode ser 0.0.0.0 ou diferente de zero. O endereço 0.0.0.0 indica que o roteador de origem (o ASBR) é o Next Hop. O endereço de encaminhamento é determinado por estas circunstâncias:

  • O endereço de encaminhamento está ajustado a 0.0.0.0 se o ASBR redistribui rotas e o OSPF não está permitido na interface de próximo salto para aquelas rotas. Isto é verdadeiro na figura se o roteador1 não tem o OSPF permitido na interface Ethernet.

  • Estas circunstâncias ajustaram o campo de endereço de encaminhamento a um endereço diferente de zero:

    • O OSPF é permitido na interface de próximo salto do ASBR E

    • A interface de próximo salto do ASBR é NON-passiva sob o OSPF E

    • A interface de próximo salto do ASBR não é ponto a ponto E

    • A interface de próximo salto do ASBR não é point-to-multipoint E

    • O endereço da interface de próximo salto do ASBR cai sob o intervalo de rede especificado no comando router ospf.

  • Quaisquer condições diferentes dessas definem o endereço de encaminhamento para 0.0.0.0.

Para obter informações sobre de como o endereço de encaminhamento é ajustado e das influências a seleção de trajeto refere os efeitos do endereço de encaminhamento no tipo seleção de trajeto 5 LSA.

Problema de Roteamento Comum do OSPF com Endereço de Encaminhamento

/image/gif/paws/13682/10b_01.gif

O roteador R2513, que executa somente o RASGO (e pode ser conectado a uma rede do rasgo-somente), é adicionado à rede token ring na figura. Quando as rotas aprendidas a partir de R2513 são redistribuídas em OSPF pelo ASBR (R2515), algumas delas não são instaladas na tabela de roteamento de alguns dos roteadores. A informação de configuração relevante de cada um do Roteadores é dada nestas tabelas.

hostname R2504
interface Serial0
ip address 1.1.1.2 255.255.255.0
         
interface TokenRing0
ip address 3.3.4.2 255.255.255.0
         
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
network 3.0.0.0 0.255.255.255 area 1
area 1 range 3.0.0.0 255.0.0.0

hostname R2507
interface Serial0
ip address 1.1.1.1 255.255.255.0
         
interface Serial1
ip address 7.7.7.1 255.255.255.0
         
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
default- information originate metric 20
         
ip route 0.0.0.0 0.0.0.0 Serial1 

hostname R2513
interface TokenRing0
ip address 3.3.4.4 255.255.255.0
       
interface ethernet 0
ip address 200.1.1.4 255.255.255.0
       
router rip
network 3.0.0.0
network 200.1.1.0

hostname R2515
interface TokenRing0
ip address 3.3.4.3 255.255.255.0
       
interface ethernet 0
ip address 3.44.66.3 255.255.255.0
       
interface ethernet 1
ip address 3.22.88.3 255.255.255.0
       
router ospf 1
redistribute rip metric 20 subnets
network 0.0.0.0 255.255.255.255 area 1
       
router rip
network 3.0.0.0

passive-interface ethernet 0
passive-interface ethernet 1

As configurações nas tabelas mostram que o R2515 redistribui o RASGO no OSPF e que o R2504 (o [ABR] do roteador de borda de área) cria uma rede resumida 3.0.0.0/8.

Estas são as tabelas de roteamento para cada um dos roteadores ativado OSPF:

R2507# 
show ip route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0
         1.0.0.0/ 24 is subnetted, 1 subnets
C          1.1.1.0 is directly connected, Serial0
         3.0.0.0/ 8 is variably subnetted, 4 subnets, 2 masks
O IA        3.0.0.0/ 8 [110/ 70] via 1.1.1.2, 00: 15: 37, Serial0
O E2        3.3.4.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
O E2        3.22.88.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
O E2        3.44.66.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
          7.0.0.0/ 24 is subnetted, 1 subnets
C           7.7.7.0 is directly connected, Serial1
S*     0.0.0.0/ 0 is directly connected, Serial1


R2504# show ip route
Gateway of last resort is 1.1.1.1 to network 0.0.0.0
            1.0.0.0/ 24 is subnetted, 1 subnets
C             1.1.1.0 is directly connected, Serial0
            3.0.0.0/ 8 is variably subnetted, 4 subnets, 2 masks
S             3.0.0.0/ 8 is directly connected, Null0
C             3.3.4.0/ 24 is directly connected, TokenRing0
O             3.22.88.0/ 24 [110/ 11117] via 3.3.4.3, 00: 15: 16, TokenRing0
O             3.44.66.0/ 24 [110/ 11117] via 3.3.4.3, 00: 15: 16, TokenRing0
O  E2 200.1.1.0/ 24 [110/ 20] via 3.3.4.4, 00: 06: 16, TokenRing0
O* E2 0.0.0.0/ 0 [110/ 20] via 1.1.1.1, 00: 15: 16, Serial0

R2515# show ip route
 Gateway of last resort is 3.3.4.2 to network 0.0.0.0
            1.0.0.0/ 24 is subnetted, 1 subnets
 O IA         1.1.1.0 [110/ 70] via 3.3.4.2, 00: 10: 28, TokenRing0
            3.0.0.0/ 24 is subnetted, 3 subnets
 C            3.3.4.0 is directly connected, TokenRing0
 R          200.1.1.0/ 24 [120/ 1] via 3.3.4.4, 00: 00: 10, TokenRing0
 O* E2 0.0.0.0/ 0 [110/ 20] via 3.3.4.2, 00: 10: 28, TokenRing0

Rede Ausente na Tabela de Roteamento

O R2515 tem um RASGO (R) rota derivada para a rede 200.1.1.0/24. O R2515 é o ASBR e redistribui o protocolo do RASGO no OSPF. O R2504 aprende sobre a rede 200.1.1.0/24 do R2515 e instala-o em sua tabela de roteamento como um tipo-2 externo OSPF (E2) rota. O problema é que o R2507 não possui a rede 200.1.1.0/24 em sua tabela de roteamento.

O R2507 tem rotas externas para as redes 3.3.4.0/24, 3.22.88.0/24 e 3.44.66.0/24, mesmo que todas estas redes devam ser incluídas no sumário de 3.0.0.0/8.

A razão que estas rotas externas aparecem é que o ASBR, que redistribui o RASGO no OSPF, tem o RASGO que é executado nestas três sub-redes. Redistribui consequentemente as sub-redes como rotas externas no OSPF. Desde que estas sub-redes são rotas externas, não são resumidas pelo ABR (R2504). As rotas de OSPF externos podem somente ser resumidas pelo ASBR. Neste caso, R2515. O ABR resume somente rotas OSPF internas da área 1 na área 0.

Nota: Com o reparo do CSCdp72526 da identificação de bug Cisco (clientes registrados somente), o OSPF não gera um anúncio link state type-5 (LSA) de uma rede externa sobreposta. O R2507 tem somente uma rota inter-área sumária de 3.0.0.0/8. Então, o R2507 instala 200.1.1.0/24 porque o endereço de encaminhamento e são alcançáveis através da rota inter-área 3.0.0.0/8. Isto é em conformidade com o RFC 2328leavingcisco.com .

Esta saída mostra o LSA externo para a rede 200.1.1.0/24 na base de dados do OSPF do R2507:

R2507# 
show ip ospf data external 200.1.1.0

       OSPF Router with ID (7.7.7.1) (Process ID 1)
       Type- 5 AS External Link States
       LS age: 72
       Options: (No TOS- capability, DC)
       LS Type: AS External Link
       Link State ID: 200.1.1.0 (External Network Number )
       Advertising Router: 3.44.66.3
       LS Seq Number: 80000001
       Checksum: 0xF161
       Length: 36
       Network Mask: /24
                   Metric Type: 2 (Larger than any link state path)
                   TOS: 0
                   Metric: 20
                   Forward Address: 3.3.4.4
                   External Route Tag: 0

O OSPF permite que o ASBR especifique um outro roteador como o endereço de encaminhamento às rotas externas. Neste caso, o ASBR (R2515) especificou 3.3.4.4 como o endereço de encaminhamento para a rede externa 200.1.1.0.

RFC 2328leavingcisco.com , seção 16.4 (que calcula COMO rotas externas), estados:

“Se o endereço de encaminhamento é diferente de zero, olhe acima o endereço de encaminhamento na tabela de roteamento. A entrada de tabela de roteamento de harmonização deve especificar um intra-area ou um trajeto do inter-area; se nenhum tal trajeto existe, não faça nada com o LSA e considere o seguinte na lista.”

Neste exemplo, a rota ao endereço de encaminhamento 3.3.4.4 é mostrada aqui:

R2507# 
show ip route 3.3.4.4

       Routing entry for 3.3.4.0/ 24
           Known via "ospf 1", distance 110, metric 20,type extern 2, forward metric 70
           Redistributing via ospf 1
           Last update from 1.1.1.2 on Serial0, 00: 00: 40 ago
           Routing Descriptor Blocks:
           * 1.1.1.2, from 3.44.66.3, 00: 00: 40 ago, via Serial0
              Route metric is 20, traffic share count is 1

O endereço de encaminhamento de 3.3.4.4 é combinado pela rota externa 3.3.4.0/24 em vez da rota sumária 3.0.0.0/8 do inter-area devido à regra a mais longa do fósforo. Porque o roteador não tem uma rota OSPF interna ao endereço de encaminhamento, não instala a rota externa 200.1.1.0/24 na tabela de roteamento. O uso de uma rota externa alcançar uma outra rota externa pode conduzir aos laços. Consequentemente o OSPF não o permite.

Não resuma no ABR

Como pode você se assegurar de que o endereço de encaminhamento diferente de zero exista na tabela de roteamento como um intra-area ou uma rota inter-área?

A primeira solução não é resumir no ABR.

A segunda solução não é configurar nenhum tipo 3 LSA que filtra. Se o tipo 3 rotas é filtrado, o endereço de encaminhamento que aparece na saída do comando show ip ospf database external não é alcançável. Isto faz a rede externa inacessível. Neste caso, R2504. Isto faz com que o Roteadores na área 0 tenha rotas inter-área (em vez das rotas externas) para todas as sub-redes específicas em outras áreas.

Use estes comandos remover a sumarização no ABR:

R2504(config)# 
router ospf 1

R2504(config- router)# no area 1 range 3.0.0.0 255.0.0.0

Os resultados deste comando na tabela de roteamento no R2507 são mostrados aqui:

R2507# show ip route
       Gateway of last resort is 0.0.0.0 to network 0.0.0.0
                 1.0.0.0/ 24 is subnetted,        1 subnets
       C            1.1.1.0        is directly connected, Serial0
                 3.0.0.0/ 24 is subnetted,        3 subnets
       O IA      3.3.4.0 [110/ 70] via 1.1.1.2, 00: 00:        48, Serial0
       O IA      3.22.88.0 [110/ 80] via 1.1.1.2, 00:        00: 48, Serial0
       O IA      3.44.66.0 [110/ 80] via 1.1.1.2, 00:        00: 48, Serial0
                 7.0.0.0/ 24 is subnetted,        1 subnets
       C           7.7.7.0 is        directly connected, Serial1
       O E2 200.1.1.0/ 24 [110/ 20] via 1.1.1.2, 00: 00: 48, Serial0
       S*     0.0.0.0/ 0 is directly connected, Serial1
	   
	  R2507# show ip route 3.3.4.4
     Routing entry for 3.3.4.0/24
      Known via "ospf 1", distance 110, metric 70, type inter area
      Last update from 1.1.1.2 on Serial1, 00:03:52 ago
      Routing Descriptor Blocks:
      * 1.1.1.2, from 3.3.4.2, 00:03:52 ago, via Serial1
          Route metric is 74, traffic share count is 1

Da saída, você pode ver que o endereço 3.3.4.4 é alcançável através de uma rota inter-área à rede 3.3.4.0/24. O roteador R2507 aprende a rota a esta rede com um Tipo 5 LSA e Type-3 LSA, depois que a sumarização no ABR R2504 é removida. Desde que o OSPF prefere uma rota inter-área sobre uma rota externa à mesma rede, instala-a como uma rota inter-área. O seno R2507 tem agora uma rota inter-área ao endereço de encaminhamento 3.3.4,4, a rede externa 200.1.1.0/24 é instalado igualmente em sua tabela de roteamento.

Nota: Se o NSSA (Not So Stubby Area) está usado e se o tipo 3 filtração LSA está feito em NSSA ABR, a seguir o mesmo endereço de encaminhamento da edição inacessível existirá.

Evitar que a sub-rede seja redistribuída como uma rota externa no OSPF

Uma outra solução é impedir que a sub-rede 3.3.4.0 esteja redistribuída no OSPF como uma rota externa, desde que o OSPF é executado nele. Estes comandos configuration no ASBR (R2515) criam um mapa de rotas. Isto é usado pelo comando redistribute permitir que somente a rede 200.1.1.0/24 seja redistribuída no OSPF. O ABR (R2504) ainda resume rotas OSPF internas da área 1 na área 0.

R2515# configure terminal
R2515(config)# router ospf 1
R2515(config-router)# redistribute rip metric 20 subnets route-map rip_to_ospf_filter
R2515(config-router)# exit
   
R2515(config)# 
access-list 28 permit 200.1.1.0 0.0.0.255
   
R2515(config)# 
route-map rip_to_ospf_filter permit 10
R2515(config-route-map)# 
match ip address 28

Os resultados deste comando na tabela de roteamento no R2507 são mostrados aqui:

R2507# show ip route
       Gateway of last resort is 0.0.0.0 to network 0.0.0.0
                 1.0.0.0/ 24 is subnetted,        1 subnets
       C            1.1.1.0        is directly connected, Serial0
       O IA  3.0.0.0/ 8 [110/ 70] via 1.1.1.2, 00: 07: 05, Serial0
                 7.0.0.0/ 24 is subnetted,        1 subnets
       C            7.7.7.0        is directly connected, Ethernet0
       O E2  200.1.1.0/ 24 [110/ 20] via 1.1.1.2, 00: 00: 21, Serial0
       S*      0.0.0.0/ 0 is directly connected, Ethernet0

A única rota externa na tabela de roteamento é 200.1.1.0/24. Esta rede está na tabela de roteamento porque o endereço de encaminhamento desta rede externa (3.3.4.1) é coberto pela rota sumária 3.0.0.0/8, que é uma rota inter-área.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13682