IP : Enhanced Interior Gateway Routing Protocol (EIGRP)

What Do EIGRP "Not On Common Subnet" Messages Mean?

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento explica porque um roteador do ½ do ¿  de Cisco IOSï pode experimentar a não na mensagem de erro comum de sub-rede quando o roteador é configurado com Enhanced Interior Gateway Routing Protocol (EIGRP).

O EIGRP usa pacotes de hello de transmissão múltipla a fim comunicar-se a outros vizinhos EIGRP. Se o EIGRP recebe um pacote Hello que seja originado de um endereço IP de Um ou Mais Servidores Cisco ICM NT em uma sub-rede que não seja configurada no EIGRP que recebe a relação, o EIGRP gerencie este Mensagem de Erro:

timestamp: IP-EIGRP: Neighbor neighbor_IP_address not on common subnet for interface

Pré-requisitos

Requisitos

Este documento exige uma compreensão básica dos protocolos de IP Routing e do protocolo de roteamento EIGRP geralmente. A fim aprender mais sobre protocolos de IP Routing e EIGRP, refira estes documentos:

Componentes Utilizados

A informação neste documento é baseada no Cisco IOS Software Release 12.2(10b) em Cisco 2500 Series Router.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Cisco recomenda que você configura todo o Roteadores em um segmento de rede com endereços IP primários na mesma sub-rede. Este exemplo mostra uma configuração de EIGRP comum:

/image/gif/paws/13674/15a1.gif

Configurações

Este documento utiliza as seguintes configurações:

R1
hostname R1
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

R2
hostname R2
!
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Emita o comando show ip eigrp neighbor a fim verificar que ambo o Roteadores se vê.

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.2                Et0           12 00:00:16    0  3000  0  23
R2#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.1                Et0           14 00:01:19   12   200  0  11

Troubleshooting

Use esta seção para resolver problemas de configuração.

Não há mais vizinhos

Se tudo é configurado corretamente, você vê um formulário do relacionamento do vizinho EIGRP. Mude a configuração do R2. Coloque a relação do ethernet0 R2 em uma sub-rede diferente.

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.2.2 255.255.255.0

R2(config-if)#end

Olhe a configuração R2 agora:

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

Agora você começa a receber Mensagens de Erro na recepção de um pacote de hello de EIGRP. Neste caso, as mensagens ocorrem aproximadamente cada 15 segundos, no r1 e no R2:

R1

3w0d: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 

01:05:01: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:15: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:30: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:44: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
R2

3w0d: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 

00:48:40: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:48:54: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:08: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:22: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)

Apesar dos Mensagens de Erro, o EIGRP trabalha corretamente com todos r1 ou vizinhos R2 restantes. A saída do comando updated show ip eigrp neighbor mostra que o Mensagem de Erro indica um problema grave entre o r1 e o R2. O Roteadores é já não vizinhos e já não troca a informação de roteamento.

R1

R1#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
R2

R2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1

Endereço IP secundário

Você pode igualmente ver este problema nas redes que usam endereços IP secundários, se as redes não são configuradas corretamente. Adicione um endereço secundário para R2:

R2

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.1.2 255.255.255.0 secondary

R2(config-if)#end

A configuração R2 olha agora como esta:

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0


ip address 10.1.1.2 255.255.255.0 secondary
!
router eigrp 1
network 10.0.0.0
!
end

Porque o R2 reconhece agora 10.1.1.0/24 como uma sub-rede válida para o interface ethernet0, você já não vê não sobre a mensagem de erro comum de sub-rede no R2. O R2 mostra o r1 como um vizinho EIGRP, e o R2 recebe e aceita pacotes Hello do r1.

Router2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type
                                        (sec)         (ms)       Cnt Num
0   10.1.1.1                Et0           12 00:00:35    1  5000  1  0

Contudo, o r1 não mostra o R2 como um vizinho, e o r1 não aceita atualizações de roteamento do R2. Isto significa que o R2 restaura continuamente sua adjacência vizinha com r1. Em R1, você continua a ver a mensagem de erro “não na sub-rede comum” e não vê R2 listado na tabela de vizinhos EIGRP.

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process

01:20:54: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:08: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:22: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:36: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)

Isso acontece porque as atualizações do EIGRP sempre usam o endereço IP principal da interface de saída como o endereço de origem. Mude o endereço primário no r1 para combinar a sub-rede principal R2, que é 10.1.2.1/24 neste exemplo.

Você pode configurar algumas redes com duas sub-redes separadas no mesmo segmento físico. Neste caso, os EIGRP Router em uma sub-rede não podem poder comunicar-se com os EIGRP Router na outra sub-rede. Se você executa o Cisco IOS Software Release 11.3, 12.0, ou mais tarde, você pode desabilitar não sobre as mensagens de erro comum de sub-rede com uso do comando no eigrp log-neighbor-warnings.

Nota: Cisco não recomenda geralmente o uso do comando no eigrp log-neighbor-warnings. O comando desabilita não sobre as mensagens de erro comum de sub-rede em todas as relações que o processo de EIGRP usa. Use o comando com discreção.

Configurar o comando no eigrp log-neighbor-warnings no modo de configuração do EIGRP Router.

Router#configure terminal

Router(config)#router eigrp 1

Router(config-router)#no eigrp	log-neighbor-warnings

Causa geral para o Mensagem de Erro

O EIGRP usa pacotes de hello de transmissão múltipla a fim comunicar-se a outros vizinhos EIGRP. O EIGRP gerencie não sobre a mensagem de erro comum de sub-rede quando recebe um pacote de hello de EIGRP originado de um endereço IP de Um ou Mais Servidores Cisco ICM NT em uma sub-rede que não esteja configurada em sua relação de recepção.

Estas são a causa geral para este Mensagem de Erro:

  • Misconfiguration das relações ou as portas de switch ou o problema de cabeamento.

  • Má combinação de preliminar/endereços IP secundários na relação vizinha.

  • Um interruptor/hub está escapando pacotes de transmissão múltipla a outras portas.

  • Se usando um switch LAN, os vlans podem ter-se juntado ao Roteadores junto.

  • Um outro roteador usa a propaganda EIGRP na mesma sub-rede/vlan como este roteador e é desconfigurado com um incorreto COMO o número.

A fim pesquisar defeitos esta edição, verifique estes artigos:

  • Verifique que o cabo está conectado corretamente.

  • Verifique novamente a configuração da interface para endereços IP de Um ou Mais Servidores Cisco ICM NT desconfigurados no local e nos roteadores vizinho.

  • Verifique que o endereço primário da relação está na mesma sub-rede como o endereço primário do roteador vizinho.

  • Se a conexão do vizinho EIGRP é juntada através de um hub LAN, use concentradores separados a fim quebrar acima o domínio de transmissão para cada segmento de LAN lógico, ou não configurar nenhum log-vizinho-aviso do eigrp para eliminar os erros.

  • Se há um interruptor envolvido, verifique a configuração de switch para certificar-se que os segmentos de LAN diferentes não estão configurados para estar no mesmo VLAN que compartilham do mesmo domínio de transmissão.


Informações Relacionadas


Document ID: 13674