Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Asymmetric Digital Subscriber Line (ADSL)

Configurando um ADSL WIC do Cisco 1700/2600/3600 como um cliente PPPoE com NAT

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (12 Novembro 2015) | Feedback


Índice


Introdução

Os Cisco 1700, 2600 e 3600 Series Routers suportam WAN Interface Card (WIC) de Asymmetric Digital Subscriber Line (ADSL). Todas as três plataformas são configuradas basicamente da mesma forma. Contudo, há umas diferenças no hardware e no software release do ½ do ¿  de Cisco IOSï que é exigido para cada um. Ao longo deste documento, Cisco 1700, 2600 e 3600 são chamados de “Cisco ADSL WIC.”

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.1(3)DC1 do Cisco 6400 UAC-NRP IOS

  • Software Release 12.1(3)DB do Cisco 6400 UAC-NSP IOS

  • IOS Software release 12.1(5)DA do Cisco 6130 DSLAM-NI2

Para suportar o ADSL WIC no Cisco 2600/3600, este hardware é exigido:

2600 3600
Slots WIC do chassi NM-1FE1R2W
NM-2W NM-1FE2W
  NM-2FE2W
  NM-2W

Importante: Para o Cisco 3600, este hardware não apoia o ADSL WIC:

  • NM-1E1R2W

  • NM-1E2W

  • NM-2E2W

Para suportar o WIC do ASDL, são necessárias pelo menos estas versões do software Cisco IOS:

  • Cisco IOS Software Release 12.1(5)YB (mais versões somente) no Cisco 2600/3600

  • Cisco IOS Software Release IO 12.1(3)XP ou mais tarde (mais versões ou conjunto de recursos ADSL somente) no Cisco 1700. O recurso ADSL é identificado por "y7" no nome da imagem. Por exemplo, c1700-sy7-mz.121-3.XP.bin.

  • Quando você transfere a imagem para o Cisco 1700, certifique-se de que você seleciona o nome da imagem de 1700. Não transfira uns 1720 ou uma imagem 1750. Estas características não apoiam o ADSL WIC.

Para apoiar o Point-to-Point Protocol sobre Ethernet (PPPoE), você deve ter o conjunto de recursos ADSL+PLUS. O conjunto de recursos apenas para ADSL não suporta PPPoE no Cisco 1700.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

No Cisco IOS Software Release 12.1(3)XG, uns recursos de cliente de PPPoE são introduzidos para o Cisco ADSL WIC. Esse recurso permite que a funcionalidade PPPoE seja movida para o roteador. Os PC múltiplos podem ser instalados atrás do Cisco ADSL WIC. Antes que seu tráfego esteja enviado à sessão de PPPoE, pode ser cifrado, filtrado, e assim por diante. Também, o Network Address Translation (NAT) pode ser executado.

Esse documento mostra um cliente PPPoE configurado na interface Asynchronous Transfer Mode (ATM) (a interface DSL) do Cisco ADSL WIC.

A configuração do NRP (node route processor) do Cisco 6400 também pode ser usada para outro roteador usado como um agregador e com uma interface ATM.

Configurar

Esta seção fornece a informação para configurar as características descritas neste documento.

Nota: Para encontrar a informação adicional sobre os comandos neste documento, use a ferramenta de consulta de comandos (clientes registrados somente).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12964/wicadsl_pppoe_client.gif

Configurações

O PPPoE é configurado no Cisco ADSL WIC com os comandos do Virtual Private Dial-up Network (VPDN). Assegure-se de que você configure estes comandos primeiramente.

Nota: Para obter informações sobre de como mudar o tamanho da unidade de transmissão máxima (MTU), refira pesquisando defeitos o tamanho do MTU na conectividade de discagem PPPoE.

Este documento utiliza as seguintes configurações:

Cisco ADSL WIC
!
vpdn enable
no vpdn logging
!
vpdn-group pppoe
  request-dialin

!--- You are the PPPoE client that asks to establish a session
!--- with the aggregation unit (6400 NRP). These VPDN commands
!--- are not needed with Cisco IOS Software Release 12.2(13)T
!--- or later.

   protocol pppoe
!

!--- Internal Ethernet network.

!
interface FastEthernet0
 ip address 10.92.1.182 255.255.255.0
 ip nat inside

!--- DSL interface.

!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in

!--- All defaults.
!--- PPPoE runs on top of AAL5SNAP. However, the
!--- encap aal5snap command is not used.

!
interface ATM0.1 point-to-point
 pvc 1/1
  pppoe-client dial-pool-number 1

!--- pvc 1/1 is an example value that must be changed to match
!--- the value used by the ISP.

 !

!--- The PPPoE client code ties into a dialer interface upon
!--- which a virtual-access interface is cloned.

!
interface Dialer1
 ip address negotiated
 ip mtu 1492

!--- Ethernet MTU default = 1500 (1492 + PPPoE headers = 1500)

 ip nat outside
 encapsulation ppp
 dialer pool 1

!--- Ties to the ATM interface.

 ppp authentication chap callin
 ppp chap hostname <username>
 ppp chap password <password>
!

!--- The ISP instructs you about the type of authentication
!--- to use.
!--- To change from PPP Challenge Handshake Authentication
!--- Protocol (CHAP) to PPP Password Authentication Protocol
!--- (PAP), replace these three lines:
!---    ppp authentication chap callin
!---    ppp chap hostname <username>
!---    ppp chap password <password>
!--- with these two lines:
!---    ppp authentication pap callin
!---    ppp pap sent-username <username> password <password>
!--- For NAT, overload on the Dialer1 interface and add a
!--- default route out, because the dialer IP address can
!--- change.

ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255 

!--- For NAT. 

! 

Cisco 6400
Cisco 6400 ***
local ppp user

!--- You can also use aaa.

username <username> password <password>

!--- Begin with the VPDN commands. Notice that you bind the
!--- PPPoE here to a virtual-template, instead of on the ATM
!--- interface. You can not (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE beginning with
!--- the VPDN commands.

vpdn enable
no vpdn logging
!
vpdn-group pppoe
 accept-dialin

!--- PPPoE server mode.

  protocol pppoe
  virtual-template 1
!
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 hold-queue 500 in

!--- The binding to the virtual-template interface is
!--- configured in the VPDN group.

!
interface ATM0/0/0.182 point-to-point
 pvc 1/82
  encapsulation aal5snap

!--- This needs the command on the server side.

  protocol pppoe
 !
!

!--- Virtual-template is used instead of dialer interface.

!
interface Virtual-Template1
 ip unnumbered Loopback10
 ip mtu 1492
 peer default ip address pool ippool
 ppp authentication chap
!
!
interface Loopback10
 ip address 8.8.8.1 255.255.255.0
!
ip local pool ippool 9.9.9.1 9.9.9.5

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Use esta seção para resolver problemas de configuração.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

Debugar o PPPoE Client

Para depurar o cliente PPPoE no Cisco ADSL WIC ou Cisco 6400, a pilha de protocolos deve ser considerada. Você pode começar na parte inferior pesquisar defeitos.

  1. Camada física DSL:

    Certifique-se que a linha é ascendente e treinada.

    show interface atm0
    ATM0 is up, line protocol is up
      Hardware is PQUICC_SAR (with Alcatel ADSL Module)
    
    show dsl interface atm0
    
    !--- Look for “Showtime” in the first few lines.
    
    ATU-R (DS)
    ATU-C (US)
    Modem Status:    Showtime (DMTDSL_SHOWTIME)
    
  2. Camada ATM:

    Se a interface ATM está acima, emita o comando debug atm packet ver se qualquer coisa vem dentro do ISP.

    Nota: Você não vê pacotes de saída com esse comando devido à maneira como os pacotes são processados.

    Você precisa de ver a saída similar a esta, com os mesmos campos do tipo, do SAP, CTL, e OUI que mostram que o pacote de ATM recebido é AAL5SNAP:

    debug atm packet
    03:21:32: ATM0(I):
    VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
    03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 000E C021 09AB 000C 0235
    03:21:32: 279F 0000 0000
    03:21:32:
  3. Camada de Ethernet:

    Os frames da Ethernet completos estão nos pacotes AAL5SNAP. Não há comando de depuração de pacotes Ethernet. Contudo, você precisa de executar algum VPDN debuga (o PPPoE debuga para o Cisco IOS Software Release 12.2(13)T ou Mais Recente) para ver os quadros PPPoE.

    Para a referência, um frame da Ethernet que seja um quadro PPPoE contém um deste dois Ethertypes:

    • Ethertipo 0x8863 = pacote de controle de PPPoE (maneja a sessão de PPPoE)

    • Ethertipo 0x8864 = pacote de dados de PPPoE (contém pacotes PPP)

    Uma nota importante é que há duas sessões em PPPoE. A sessão de PPPoE, que é um tipo sessão VPDN L2TP, e a sessão de PPP. A fim estabelecer o PPPoE, você tem uma fase de estabelecimento de sessão PPPoE e uma fase de estabelecimento da sessão de PPP.

    A terminação geralmente envolve uma fase de terminação de PPP e fase de terminação de PPPoE.

    A fase de estabelecimento de PPPoE identifica o PPPoE Client e o server (os endereços MAC) e atribui um ID de sessão. Em seguida isso está completo, o estabelecimento de PPP normal ocorre apenas como toda a outra conexão PPP.

    Para debugar, o uso VPDN PPPoE debuga (o PPPoE debuga para o Cisco IOS Software Release 12.2(13)T ou Mais Recente) para determinar se a fase de conexão PPPoE é bem sucedida.

    #debug vpdn pppoe-events (debug pppoe events)
    06:17:58: Sending PADI: vc=1/1
    
    !--- A broadcast Ethernet frame (in this case encapsulated in ATM)
    !--- requests a PPPoE server, “Are there any PPPoE servers out there?”
    
    06:18:00:  PPPOE: we've got our pado and the pado timer went off
    
    !--- This is a unicast reply from a PPPoE server
    !--- (very similar to a DHCP offer).
    
    06:18:00: OUT PADR from PPPoE tunnel
    
    !--- This is a unicast reply that accepts the offer.
    
    06:18:00: IN PADS from PPPoE tunnel
    
    !--- This is a confirmation and completes the establishment.
    
    

    O estabelecimento de PPP começa como todo o outro início de PPP. Depois que a sessão de PPPoE é estabelecida, emita os comandos show vpdn (sessão do pppe da mostra para o Cisco IOS Software Release 12.2(13)T ou Mais Recente) obter o estado.

    # show vpdn (show pppoe session)
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
    
    PPPoE Tunnel Information
    
    Session count: 1
    
    PPPoE Session Information
    SID      RemMAC          LocMAC      Intf    VASt   OIntf   VC
    1    0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0     11
    

    Obtenha a informação de contagem de pacote de informação através do comando show vpdn session all (show pppoe session all).

    show vpdn session all (show pppoe session all)
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Session Information Total tunnels 1 sessions 1
    
    session id: 1
    local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7
    virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1
        1656 packets sent, 1655 received, 24516 bytes sent, 24486 received
    

    Outros comandos de debug:

    • debug vpdn pppoe-data (debug pppoe data)

    • debugar erros pppoe do vpdn (debugar erros PPPoE)

    • debugar pacotes de PPPoE do vpdn (debugar pacotes de PPPoE)

  4. Camada PPP:

    Depois que a sessão de PPPoE é estabelecida, o PPP debuga é o mesmo para todo o outro estabelecimento de PPP.

    Os mesmos comandos debug ppp negotiation e debug ppp authentication são utilizados. Esse é o exemplo de saída.

    Nota: Nesta amostra, o hostname é “cliente1.” O nome do Cisco 6400 remoto é “Nrp-b.”

    06:36:03: Vi1 PPP: Treating connection as a callout
    06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
    06:36:03: Vi1 PPP: No remote authentication for call-out
    06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
    06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43)
    06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
    06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43)
    06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
    06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
    06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5)
    06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
    06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
    06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5)
    06:36:05: Vi1 LCP: State is Open
    06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
    06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b"
    06:36:05: Vi1 CHAP: Using alternate hostname client1
    06:36:05: Vi1 CHAP: Username nrp-b not found
    06:36:05: Vi1 CHAP: Using default password
    06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
    06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
    06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
    06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
    06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
    06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
    06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
    06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
    06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
    06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
    06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
    06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
    06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
    06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
    06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004)
    06:36:05: Vi1 CDPCP: State is Closed
    06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
    06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
    06:36:05: Vi1 IPCP: State is Open
    06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
    06:36:05: Di1 IPCP: Install route to 8.8.8.1
    06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface Virtual-Access1, changed state to up

Debugar o servidor PPPoE

Para debugar o Cisco 6400 (o servidor PPPoE), use o mesmo procedimento bottom-up que é usado para o Cisco ADSL WIC (cliente). A diferença está na camada física DSL, em que é necessário verificar o DSLAM.

  1. Camada física DSL:

    Para verificar a camada física de DSL, você precisa ver as estatísticas do DSL no DSLAM. Para Cisco DSLAM, emita o comando show dsl interface.

  2. Camada ATM:

    No lado do Cisco 6400, você pode igualmente emitir um comando debug atm packet. Permita o Cisco 6400 para um PVC específico.

    debug atm packet interface atm 0/0/0.182 vc 1/82
    

    Você precisa de ver a saída similar a esta, com os mesmos campos do tipo, do SAP, CTL, e OUI que mostram que o pacote de ATM recebido é AAL5SNAP:

    4d04h: ATM0/0/0.182(I):
    VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
    4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
    4d04h: 15E5 0000 0000

    Nota: Você não vê pacotes de saída com esse comando devido à maneira como os pacotes são processados.

  3. Camada de Ethernet:

    Os mesmos comandos e depurações show do VPDN usados no Cisco ADSL WIC podem ser utilizados no Cisco 6400 para examinar o estabelecimento de PPPoE.

    # debug vpdn pppoe-events (debug pppoe events)
    4d04h: IN PADI from PPPoE tunnel
    
    4d04h: OUT PADO from PPPoE tunnel
    
    4d04h: IN PADR from PPPoE tunnel
    
    4d04h: PPPoE: Create session
    4d04h: PPPoE: VPN session created.
    
    4d04h: OUT PADS from PPPoE tunnel
    
    # show vpdn
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
    
    PPPoE Tunnel Information
    
    Session count: 1
    
    PPPoE Session Information
    SID        RemMAC          LocMAC       Intf    VASt   OIntf        VC
    1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82
    
    # show vpdn session all
    
    nrp-b# show vpdn session all
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Session Information Total tunnels 1 sessions 1
    
    session id: 1
    local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
    virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
        30 packets sent, 28 received, 422 bytes sent, 395 received
    

    Outros comandos de debug:

    • debug vpdn pppoe-data (debug pppoe data)

    • debugar erros pppoe do vpdn (debugar erros PPPoE)

    • debugar pacotes de PPPoE do vpdn (debugar pacotes de PPPoE)

  4. Camada PPP:

    Este é o resultado do debug PPP do Cisco 6400 que corresponde ao mais adiantado debuga do Cisco ADSL WIC:

    debug ppp negotiation and debug ppp authentication
    4d04h: Vi2 PPP: Treating connection as a dedicated line
    4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
    4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15
    4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
    4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814)
    4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10
    4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9)
    4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10
    4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9)
    4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000
    4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6
    4d04h: Vi2 LCP: TIMEout: State ACKsent
    4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15
    4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
    4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814)
    4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15
    4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
    4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814)
    4d04h: Vi2 LCP: State is Open
    4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load]
    4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b"
    4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1"
    4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load]
    4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
    4d04h: Vi2 CHAP: O SUCCESS id 10 len 4
    4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load]
    4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10
    4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801)
    4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10
    4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000)
    4d04h: Vi2 IPCP: Pool returned 9.9.9.2
    4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10
    4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902)
    4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4
    4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004)
    4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10
    4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801)
    4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10
    4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902)
    4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10
    4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902)
    4d04h: Vi2 IPCP: State is Open
    4d04h: Vi2 IPCP: Install route to 9.9.9.2
    4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    Virtual-Access2, changed state to up

Informações Relacionadas


Document ID: 12964