Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Asymmetric Digital Subscriber Line (ADSL)

Configurando e pesquisando defeitos um Cisco 1700 Router que usa um WIC de Ethernet como um cliente PPPoE com NAT

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (12 Novembro 2015) | Feedback


Índice


Introdução

Este documento mostra como configurar um Cisco 1700 usando Ethernet WAN Interface Card (WIC-1ENET) para funcionar como um Point-to-Point Protocol over Ethernet (PPPoE) cliente com tradução de endereço de rede (NAT).

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.1(3) para apoiar XT1 do ½ do ¿  de Cisco IOSï ou mais tarde o Cisco 1700 WIC-1ENET.

  • Para esta configuração de exemplo, o Universal Access Concentrator-Node Route Processor do Cisco 6400 (UAC-NRP) executava o Cisco IOS Software Release 12.1(3)DC1.

Para apoiar o PPPoE, você deve ter o conjunto de recursos ADSL+PLUS. O conjunto de recursos apenas para ADSL não suporta PPPoE no Cisco 1700.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Material de Suporte

O WIC-1ENET é um cartão 10BaseT desenvolvido para os Cisco 1700 Series Router. O WIC-1ENET fornece uma segunda interface Ethernet para o Cisco 1700, que ajude a usar a funcionalidade rica do Cisco IOS Software com todo o digital subscriber line (DSL) ou modem a cabo.

Os recursos de cliente de PPPoE permitem que a funcionalidade de PPPoE seja movida para o roteador. Os PC múltiplos podem ser instalados atrás da interface rápida de Ethernet do Cisco 1700 e, antes que seu tráfego esteja enviado à sessão de PPPoE, pode ser cifrado, filtrado, e assim por diante, e o NAT pode ser executado. O PPPoE sendo executado no roteador remove a necessidade de usar o software do PPPoE Client nos PC.

Requisitos do processador

O Revision B5 do microprocessador MPC860 é exigido. Este processador é usado em todos os Cisco 1700 Series Router enviou depois de novembro 21, 1999. Os números de série do Cisco 1700 que começam com foram fabricados com o microprocessador do Revision B5 do modelo MPC860.

O código de data é construído no número de série. O formato é o LLLYYWWSSSS, onde:

  • O LLL é o lugar em que a unidade foi construída.

  • O YY é o ano que a unidade esteve construída (1997=01, 1998=02, 1999=03, 2000=04).

  • O WW é a semana do trabalho do ano que a unidade esteve construída.

  • O SSSS é o número de série.

A informação de versão do processador é indicada na inicialização. Você pode igualmente verificar a revisão do processador emitindo o comando show version na alerta do router-.

Requisitos de memória

Para executar as imagens IOS do Cisco 1700 que apoiam Cisco WIC-1ENET, o roteador deve ter uma quantidade mínima de memória Flash e de DRAM. Para detalhes nos requisitos de memória para cada imagem, refira os Release Note para os Cisco 1700 Series Router para o Cisco IOS Release 12.1(3)XT1.

Restrições e recursos não suportados do WIC-1ENET

  • O WIC-1ENET não é apoiado nas Plataformas diferentes do Cisco 1700.

  • Somente uma conexão do twisted pair RJ-45 é apoiada; não há nenhuma interface de unidade anexa (AUI) ou apoio da interface BNC.

  • Não há nenhuma auto negociação (auto detecção) entre metade-frente e verso e modos bidirecional.

  • O WIC-1ENET não pode ser usado para o download de arquivos TFTP quando o host estiver no ROMMON.

  • O WIC-1ENET não está reconhecido pelo Cisco 1700 quando reage do modo ROMMON.

  • O Cisco IOS Software atual apoia o WIC-1ENET somente no slot 0 de um Cisco 1700.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

O PPPoE Client é configurado no Cisco 1700 com os comandos do Virtual Private Dial-up Network (VPDN). (Os comandos vpdn não são precisados para o Cisco IOS Software Release 12.2(13)T ou Mais Recente.) Certifique-se de que você configura estes comandos primeiramente.

Nota: Para obter informações sobre de mudar o tamanho da unidade de transmissão máxima (MTU), refira pesquisando defeitos o tamanho do MTU na conectividade de discagem PPPoE.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12956/wic_1enet.gif

Configurações

Este documento utiliza as seguintes configurações:

Cisco 1700
! 
vpdn enable 
no vpdn logging
! 
vpdn-group pppoe 
�request-dialin�� 

!--- The PPPoE client requests to establish�� 
!--- a session with the aggregation unit (6400 NRP).
!--- These VPDN commands are not needed with 
!--- Cisco IOS Software Release 12.2(13)T or later.

��protocol pppoe 
! 
int Dialer1
 ip address negotiated
 encapsulation ppp
 ip mtu 1492

!--- The Ethernet MTU is 1500 by default 
!--- (1492 + PPPoE headers = 1500).

 ip nat outside
 dialer pool 1

!--- This ties to interface Ethernet0.

 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname <username>
ppp chap password <password>
!

!--- The ISP instructs you regarding 
!--- the type of authentication to use.
!--- To change from PPP Challenge Handshake Authentication 
!--- Protocol(CHAP) to PPP Password Authentication Protocol (PAP),
!--- replace these three lines:
!--- ppp authentication chap callin
!--- ppp chap hostname 
!--- ppp chap password 
!--- with these two lines:
!--- ppp authentication pap callin.

ppp pap sent-username <username> password <password>�

!
dialer-list 1 protocol ip permit
!

!--- This is the internal Ethernet network.

interface FastEthernet0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface Ethernet0
 pppoe enable
 pppoe-client dial-pool-number 1

!--- The PPPoE client code ties into a dialer 
!--- interface upon which a virtual-access 
!--- interface is cloned.

!

!--- For NAT, you overload on the 
!--- Dialer1 interface and add a default route
!--- out of the Dialer1 interface because
!--- the IP address can change.


ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
dialer-list 1 protocol ip permit
access-list 1 permit 10.0.0.0 0.0.0.255

!--- This is for NAT.

!

Cisco 6400
*** local ppp user 

!--- Or, you can use AAA.

username <username> password <password>

!--- Begin with the VPDN commands. 
!--- Notice that you are binding the PPPoE here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE� 
!--- beginning with the VPDN commands.

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
�accept-dialin 

!--- This is PPPoE server mode.

�protocol pppoe 
�virtual-template 1 
! 
! 
interface ATM0/0/0 
�no ip address 
�no atm ilmi-keepalive 
�hold-queue 500 in 

!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.

! 
interface ATM0/0/0.182 point-to-point 
�pvc 1/82 
��encapsulation aal5snap

!--- You need the command on the server side. 

� protocol pppoe 
�! 
! 

!--- Virtual-template is used instead of dialer interface. 

! 
interface Virtual-Template1 
�ip unnumbered Loopback10 
�ip mtu 1492 
�peer default ip address pool ippool 
�ppp authentication chap 
! 
! 
interface Loopback10 
�ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Depurando o Cliente PPPoE

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Para debugar o Cisco 1700 (PPPoE Client), você deve considerar a pilha de protocolos.

  • Camada 4 - Camada PPP

  • Camada 3 - Camada de Ethernet

  • Camada 2 - Camada ATM

  • Layer 1 - Camada física DSL

Você poderia pesquisar defeitos o começo na parte inferior. Desde que o DSL e as camadas ATM estão ocorrendo no DSL Customer Premises Equipment (CPE), você precisa de pesquisar defeitos somente os Ethernet e camadas PPP para o Cisco 1700, como mostrado abaixo.

Camada de Ethernet

Os frames da Ethernet completos estão nos pacotes (INSTANTÂNEOS) do protocolo de acesso de sub-rede de comunicação da camada de adaptação ATM 5 (AAL5). Não há nenhum comando debug ethernet packet, mas você deve executar algum VPDN debuga (o PPPoE debuga para o Cisco IOS Software Release 12.2(13)T ou Mais Recente) para ver os quadros PPPoE.

Para a referência, um frame da Ethernet que seja um quadro PPPoE contém um de dois Ethertypes:

  • Ethertipo 0x8863 = pacote de controle de PPPoE (maneja a sessão de PPPoE)

  • Ethertipo 0x8864 = pacote de dados de PPPoE (contém pacotes PPP)

Uma observação importante é que há duas sessões no PPPoE: a sessão de PPPoE que é um protocolo layer two tunneling VPDN (sessão L2TP)-type, e a sessão de PPP. Assim, para estabelecer o PPPoE, há uma fase de estabelecimento de sessão PPPoE e uma fase de estabelecimento da sessão de PPP.

A terminação geralmente envolve uma fase de terminação de PPP e fase de terminação de PPPoE.

A fase de estabelecimento de PPPoE consiste identificar os endereços MAC do PPPoE Client e do server e atribuir um ID de sessão. Em seguida isso está completo, o estabelecimento de PPP normal ocorre apenas como toda a outra conexão PPP.

Para debugar, você pode usar VPDN PPPoE debuga (o PPPoE debuga para o Cisco IOS Software Release 12.2(13)T ou Mais Recente) para determinar se a fase de conexão PPPoE é bem sucedida.

# debug vpdn pppoe-events (debug pppoe events)

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in this case, encapsulated in ATM) 
!--- requests a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server (very similar to 
!--- a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply accepting the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation that completes the establishment.

O estabelecimento de PPP começa agora, como em todo o outro início de PPP. Depois que a sessão de PPPoE é estabelecida, você pode emitir comandos show vpdn obter o estado.

# show vpdn (show pppoe session)
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0    1    1

Você pode obter a informação de contagem de pacote de informação usando o comando show vpdn session all (show pppoe session all).

show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

Outros comandos de debug:

  • debug vpdn pppoe-data (debug pppoe data)

  • debug pppoe-errors (debugar erros PPPoE)

  • debug pppoe-packets (debugar pacotes de PPPoE)

Camada PPP

Depois que a sessão de PPPoE foi estabelecida, o PPP debuga é o mesmo que para todo o outro estabelecimento de PPP.

Os mesmos comandos debug ppp negotiation e debug ppp authentication são utilizados. Aqui está o exemplo de saída:

Nota: Nesta amostra, o nome de host é "client1", e o nome do Cisco 6400 remoto é “Nrp-b”.

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:��� MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:��� MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:� ��AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:��� MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:��� AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:��� MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:��� Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:��� Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:��� Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:��� Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:� ��Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:��� Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed 
 state to up

Depurando o Servidor PPPoE

Para debugar o Cisco 6400 (o servidor PPPoE), você pode usar o mesmo procedimento bottom-up usado para o Cisco 1700 (PPPoE Client).

  • Camada 4 - Camada PPP

  • Camada 3 - Camada de Ethernet

  • Camada 2 - Camada ATM

  • Layer 1 - Camada física DSL

A diferença é que agora você pesquisa defeitos a camada DSL no multiplicador da linha de acesso de assinante digital (DSLAM) e a camada ATM no Cisco 6400, como mostrado abaixo.

Camada física DSL

Para verificar a camada física de DSL, você precisa ver as estatísticas do DSL no DSLAM. Para Cisco DSLAM, o comando show dsl interface pode ser usado.

Camada ATM

No lado do Cisco 6400, você pode igualmente usar o comando debug atm packet e permitir o Cisco 6400 para um PVC específico.

debug atm packet interface atm 0/0/0.182 vc 1/82 

Você deve ver a saída similar ao seguinte, com os mesmos campos do tipo, do SAP, CTL, e OUI que mostram que o pacote de ATM recebido é AAL5SNAP.

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Nota: Você não vê pacotes de saída com este comando devido à maneira que os pacotes são processados.

Camada de Ethernet

Os mesmos comandos show and debug VPDN usados no Cisco 1700 podem ser usados no Cisco 6400 para olhar o estabelecimento de PPPoE.

# debug vpdn pppoe-events (debug pppoe events)

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel


# show vpdn (show pppoe session)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1   82


nrp-b# 
show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

Estes são outros comandos de debug:

  • debug vpdn pppoe-data (debug pppoe data)

  • debug pppoe-errors (debugar dados do pppoe)

  • debug pppoe-packets (debugar pacotes de PPPoE)

Camada PPP

Este é um resultado do debug PPP do Cisco 6400 que corresponda ao mais adiantado debugue do Cisco 1700:

debug ppp negotiation and debug ppp authentication

4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:��� MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:� ��MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP: ���Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:��� Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:��� Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed 
 state to up

Informações Relacionadas


Document ID: 12956