Roteadores : Roteadores Cisco SOHO 70 Series

Configuring a Cisco SOHO77 Router as a PPPoE Client with NAT

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

No Software Release 12.1(3)XG de Cisco IOS�, uns recursos de cliente do Point-to-Point Protocol sobre Ethernet (PPPoE) foram introduzidos para o small office/home office (SOHO) 77 de Cisco. Esse recurso permite que a funcionalidade PPPoE seja movida para o roteador. Os PC múltiplos podem ser instalados atrás de Cisco SOHO77, e antes que seu tráfego esteja enviado à sessão de PPPoE, dos dados podem ser cifrados e filtrado, e o Network Address Translation (NAT) pode ser executado.

Este documento mostra um cliente PPPoE configurado na interface ATM (a interface DSL) do Cisco SOHO77. Essa configuração também pode ser usada em um Cisco 1700 com Placa de Interface WAN (WIC) Asymmetric Digital Subscriber Line (ADSL).

A configuração do NRP (node route processor) do Cisco 6400 também pode ser usada para outro roteador usado como um agregador e com uma interface ATM.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • IOS Software release 12.1(3)XP2 do Customer Premises Equipment de Cisco SOHO77 (CPE)

  • Software Release 12.1(3)DC1 do Cisco 6400 UAC-NRP IOS

  • Software Release 12.1(3)DB do Cisco 6400 UAC-NSP IOS

  • IOS Software release 12.1(5)DA do Cisco 6130 DSLAM-NI2

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12925/soho77pppoe_client.gif

Configurações

Este documento utiliza as seguintes configurações:

  • Cisco SOHO77

  • Cisco 6400

O PPPoE é configurado no Cisco SOHO77 com comandos Virtual Private Dial-up Network (VPND). Certifique-se de você configurar primeiramente estes comandos.

Cisco SOHO77
! 
vpdn enable 
no vpdn logging

!--- Default.

! 
vpdn-group pppoe 
 request-dialin     
 
!--- The PPPoE client requests a session with the aggregation unit (6400 NRP).

  protocol pppoe 
! 


!--- Internal Ethernet network. 

! 
interface Ethernet0 
 ip address 10.92.1.182 255.255.255.0 
 ip nat inside 
  


!--- DSL interface. 

! 
interface ATM0 
 no ip address 
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
 !--- all defaults
  


!--- PPPoE runs on top of AAL5SNAP, but the encap aal5snap command is not used.  

! 
interface ATM0.1 point-to-point 
 pvc 1/1 
  pppoe-client dial-pool-number 1 
  
!--- pvc 1/1 is an example value that you must change to match the value 
  !--- used by the Internet Service Provider (ISP). 

 ! 


!--- The PPPoE client code ties into a dialer interface, upon  
!--- which a virtual-access interface is cloned.  

! 
interface Dialer1 
 ip address negotiated 
 ip mtu 1492
 
!--- Ethernet MTU is 1500 by default. In other words, 1492 + PPPoE headers = 1500.

 ip nat outside 
 encapsulation ppp 
 dialer pool 1
 
!--- Ties to ATM interface.  

 ppp authentication chap callin 
 ppp chap hostname <hostname>
 ppp chap password <password>
! 

!--- The ISP instructs you about the type of authentication to use. 
!--- To change from PPP CHAP to PPP PAP, replace the following three lines:             
!--- ppp authentication chap callin 
!--- ppp chap hostname <hostname>
!--- ppp chap password <password>
!--- with the following two lines:
!--- ppp authentication pap callin
!--- ppp pap sent-username <username> password <password>
!--- For NAT we are going to overload on the Dialer1 interface 
!--- Then add a default route out since dialer IP address can change.  
 
ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255

!--- For NAT.

! 

Cisco 6400
*** local ppp user 

!--- You can also use AAA.


username <username> password <password>



!--- Begin with the VPDN commands.
!--- Note the PPPoE binding to a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one virtual-template (or VPDN group) 
!--- for PPPoE beginning with the VPDN commands. 

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
 accept-dialin
 
!--- PPPoE server mode. 

  protocol pppoe 
  virtual-template 1 
! 
! 
interface ATM0/0/0 
 no ip address 
 no atm ilmi-keepalive 
 hold-queue 500 in 



!--- The binding to the virtual-template interface is configured in the VPDN group.     

! 
interface ATM0/0/0.182 point-to-point 
 pvc 1/82 
  encapsulation aal5snap
  
!--- The command is needed on the server side. 

  protocol pppoe 
 ! 
! 



!--- Virtual-template is used instead of dialer interface. 

! 
interface Virtual-Template1 
 ip unnumbered Loopback10 
 ip mtu 1492 
 peer default ip address pool ippool 
 ppp authentication chap 
! 
! 
interface Loopback10 
 ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5 

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para fazer Troubleshooting e depurar a configuração.

Para debugar o PPPoE Client em Cisco SOHO77 ou Cisco 6400, você deve considerar a pilha de protocolos. Solução de problemas com início na camada do protocolo inferior.

  1. Camada física DSL

  2. Camada ATM

  3. Camada de Ethernet

  4. Camada PPP

Camada física DSL

Assegure-se de que a linha seja ascendente e treinada.

Inscreva os comandos show como indicado neste exemplo. A saída resultante indica o estado da linha.

show int atm0 

ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Alcatel ADSL Module) 
 
show dsl interface atm0 

!--- Look for "Showtime" in the first few lines.


                ATU-R (DS)                      ATU-C (US) 
Modem Status:   Showtime (DMTDSL_SHOWTIME) 

Camada ATM

Se a interface ATM está acima, você pode usar o comando debug atm packets ver se qualquer coisa vem dentro do ISP.

Nota: Você não verá pacotes de saída com esse comando devido à maneira como os pacotes são processados.

Inscreva o comando debug atm packets segundo as indicações deste exemplo.

debug atm packet 
03:21:32: ATM0(I): 
VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 
Length:0x30 
03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 000E C021 09AB 
000C 0235 
03:21:32: 279F 0000 0000 
03:21:32:

A saída como mostrado acima, deve conter os mesmos campos do tipo, do SAP, CTL, e OUI para indicar que o pacote de ATM recebido é AAL5SNAP.

Camada de Ethernet

Os frames da Ethernet completos estão nos pacotes AAL5SNAP. Não há nenhum comando debug ethernet packet, mas você deve executar algum VPDN debuga operações para ver os quadros PPPoE.

Para a referência, um frame da Ethernet que seja um quadro PPPoE contém um de dois ethertypes:

  • 0x8863 Ethertype = Pacote de controle PPPoE (maneja a sessão PPPoE).

  • 0x8864 Ethertype = pacote de dados PPPoE (contém pacotes PPP).

Uma nota importante é que há duas sessões em PPPoE. A sessão de PPPoE que é uma sessão do tipo VPDN L2TP e a sessão PPP. Assim, para estabelecer PPPoE, temos uma fase de estabelecimento de sessões PPPoE e uma fase de estabelecimento de sessões PPP.

A terminação geralmente envolve uma fase de terminação de PPP e fase de terminação de PPPoE.

A fase de estabelecimento de PPPoE consiste em dois passos:

  • Passo 1: Identifique o PPPoE Client e o server (os endereços MAC).

  • Passo 2: Atribua um ID de sessão.

Depois que isto está completo, o estabelecimento de PPP normal ocorre apenas como toda a outra conexão PPP.

Para depurar, use as depurações VPDN PPPoE para determinar se a fase de conexão do PPPoE foi bem sucedida.

  1. Inscreva um comando debug segundo as indicações deste exemplo:

    #debug vpdn pppoe-events
    
    06:17:58: Sending PADI: vc=1/1
    
    !--- A broadcast Ethernet frame (here, encapsulated in ATM) requests 
    !--- a PPPoE server with the message, "Is there a PPPoE server out there?" 
    
    
    06:18:00:  PPPOE: we have got our pado, and the pado timer went off 
    
    !--- This is a unicast reply from a PPPoE server (similar to a DHCP offer).
    
    
    06:18:00: OUT PADR from PPPoE tunnel
    
    !--- This is a unicast reply to accept the offer.
    
    
    06:18:00: IN PADS from PPPoE tunnel
    
    !--- This is a confirmation that completes the establishment.
    
    
  2. Inicie a conexão PPP. O estabelecimento de PPP será iniciado agora como em qualquer outra iniciação de PPP. Depois que a sessão de PPPoE é estabelecida, você pode usar comandos show vpdn obter o estado, como mostrado aqui:

    #show vpdn
    %No active L2TP tunnels 
    %No active L2F tunnels 
    
    PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
    
    PPPoE Tunnel Information
    
    Session count: 1
    
    PPPoE Session Information
    SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
    1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0     1       1
  3. Obtenha a informação de contagem de pacote de informação com o comando show vpdn session all, como mostrado aqui:

    show vpdn session all
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Session Information Total tunnels 1 sessions 1
    
    session id: 1
    local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
    virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
        1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

    Outros comandos de depuração potencialmente úteis incluem debug vpdn pppoe-data, debug pppoe-errors e debug pppoe-packets.

Camada PPP

Depois que a sessão de PPPoE foi estabelecida, o PPP debuga é o mesmo que para todo o outro estabelecimento de PPP. Os mesmos comandos debug ppp negotiation e debug ppp authentication são utilizados.

Nota: Na seguinte amostra, o hostname é "client1" e o nome do Cisco 6400 remoto é “Nrp-b”.

Ative a negociação de PPP ou a autenticação de PPP da linha de comando. A saída resultante assemelhar-se-á a esta:

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol 
CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up

Debug

Para depurar o Cisco 6400 (o servidor PPPoE), você pode usar o mesmo procedimento que parte dos constituintes básicos utilizado pelo Cisco SOHO77 (o cliente). A diferença está na camada física DSL, em que é necessário verificar o DSLAM.

  1. Camada física DSL

  2. Camada ATM

  3. Camada de Ethernet

  4. Camada PPP

Camada física DSL

Para verificar a camada física de DSL, você precisa ver as estatísticas do DSL no DSLAM. Para Cisco DSLAM, use o comando show dsl interface.

Camada ATM

No lado do Cisco 6400, você pode igualmente usar um comando debug atm packet, e permite o Cisco 6400 para um PVC específico.

Enter debuga o pacote atm com parâmetros apropriados da linha de comando, como segue:

debug atm packet interface atm 0/0/0.182 vc 1/82

A saída resultante assemelha-se a esta:

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Nota: Você não verá pacotes de saída com esse comando devido à maneira como os pacotes são processados.

Camada de Ethernet

Os mesmos comandos vpdn show e debugam usado em Cisco SOHO77 podem ser usados no Cisco 6400 para olhar o estabelecimento de PPPoE.

Os exemplos a seguir mostram os comandos show e debug no contexto, junto com sua saída. Utilize esses comandos conforme necessário.

#debug vpdn pppoe-events

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel

#show vpdn
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82



#show vpdn session all


nrp-b#show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

Outros comandos debug incluem debug vpdn pppoe-data, debug pppoe-errors e debug pppoe-packets.

Camada PPP

Seguir é o resultado do debug PPP do Cisco 6400 que corresponde ao mais adiantado debuga de Cisco SOHO77.

Incorpore este comando da interface da linha de comando:

debug ppp negotiation and debug ppp authentication

A saída resultante parece com:

4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2,
changed state to up 

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12925