Roteadores : Roteadores Cisco 800 Series

Configurando um Cisco 827 Router usando PPPoA com CHAP e PAP

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (11 Novembro 2015) | Feedback


Índice


Introdução

As configurações de amostra neste documento mostram um roteador do digital subscriber line (DSL) do Cisco 827 que conecta ao Cisco 6130 um multiplexador de acesso de linha de assinante digital (DSLAM) e que termina em um concentrador de acesso universal (UAC) do Cisco 6400. Cada configuração usa o protocolo ponto-a-ponto sobre o Asynchronous Transfer Mode (PPPoA). A interface do Asynchronous Transfer Mode (ATM) é configurada para o encapsulamento de ALMUX PPP.

Mostras PPPoA de uma configuração usando o protocolo de autenticação de cumprimento do desafio (RACHADURA). A segunda configuração mostra o PPP over ATM usando o protocolo password authentication (PAP).

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Software Release 12.1(1)XB do Customer Premises Equipment do Cisco 827-4V (CPE) IOS�

  • Software Release 12.0(7)DC do Cisco 6400 UAC-NRP IOS

  • Software Release 12.0(4)DB do Cisco 6400 UAC-NSP IOS

  • IOS Software release 12.1(1)DA do Cisco 6130 DSLAM-NI2

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/12886/827pppoachap.gif

PPPoA usando as configurações CHAP

Ao usar o virtual-molde da relação, configurar somente o username do hostname do PPP chap e a senha senha do PPP chap. O comando ppp authentication chap callin não é apoiado. Nesta relação do exemplo o discador é usado, que não é afetado.

Cisco 827
Current configuration: 
! 
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap callin 
 ppp chap hostname username
 
 ppp chap password password

! 
ip classless 
!
ip route 0.0.0.0 0.0.0.0 Dialer0 
! 
dialer-list 1 protocol ip permit 
!
end

Cisco alcança 6400 NRP1
username 
username
 password 
password
 

!--- The username and password values must match 
!--- the username and password values of the remote device. 

!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication chap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

PPPoA usando a configuração PAP

Ao usar o virtual-molde da relação, configurar somente a senha de senha de nome de usuário enviar-username ppp pap. O comando ppp authentication pap callin não é apoiado. Nesta relação do exemplo o discador é usado, que não é afetado.

Cisco 827
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication pap callin
ppp pap sent-username username password password

! 
ip classless 
! 
ip route 0.0.0.0 0.0.0.0 Dialer0 
!
no ip http server 
! 
dialer-list 1 protocol ip permit 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 

Cisco alcança 6400 NRP1
username 
username
 password 
password
 

!--- The username and password values must match 
!--- the username and password values of the remote device. 

!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication pap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12886