Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Asymmetric Digital Subscriber Line (ADSL)

Exemplos de configuração para agregação de banda larga do Cisco 7200

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (9 Novembro 2015) | Feedback


Índice


Introdução

Este documento fornece uma descrição geral de componentes da linha digital do assinante (DSL) e de como os componentes se integram em uma implantação básica de DSL. As configurações de exemplo deste documento mostram as redes DSL mais comuns, que estão atualmente em uso. Você pode usar estas configurações como uma referência geral para projetar uma implantação de agregação de banda larga. Contudo, não considere estas configurações uma solução padrão. Cada cliente e cada requisito são diferentes, e há muitas maneiras de atingir os mesmos objetivos de design.

Quando as configurações neste documento estiverem tão completas como possível, o documento dá somente as linhas essenciais. O documento supõe que o usuário tem uma compreensão básica da configuração de dispositivo Cisco e omite muitas das linhas de comando básico. Use estas configurações somente como um ponto do começo para projetar sua própria aplicação.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Terminação de sessão PPPoA: xDSL para 7200

Diagrama de Rede

Essa seção utiliza esta configuração de rede:

7200_bdaggreg1.gif

Configurações

Este exemplo descreve como conectar um Cisco 677, ou o outro DSL Customer Premises Equipment (CPE), a um Cisco 7200 através do PPP over ATM (PPPoA). A configuração inclui um switch ATM do Cisco lightstream 1010 (LS1010), que seja um componente opcional. Os resultados são os mesmos se você conecta diretamente o multiplicador de acesso de DSL (DSLAM) ao Cisco 7200.

Neste exemplo, você estabelece a sessão de PPP no Cisco 677 e termina-a no Cisco 7200. Após a terminação da sessão, o IP tradicional passa o tráfego ao Network Service Provider (NSP) ou ao Internet.

O CPE tem uma configuração para executar a tradução de endereços da /porta do Network Address Translation (NAT) (PANCADINHA). O CPE igualmente executa um servidor DHCP para atribuir endereços IP de Um ou Mais Servidores Cisco ICM NT às estações de Ethernet.

Esta seção utiliza as seguintes configurações:

Configuração do PC para o PPPoA
  1. Ajuste o endereçamento de IP para obter automaticamente um endereço IP de Um ou Mais Servidores Cisco ICM NT.
  2. Ajuste VITÓRIAS para usar o DHCP para a definição das VITÓRIAS.
  3. Assegure-se de que nenhum gateway padrão esteja ajustado.

Nota: Se o DHCP não pode passar esta informação, você precisa de ajustar um Domain Name.

Configuração CPE de Cisco para o PPPoA
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Configuração do Cisco dslam para o PPPoA
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 atm pvc 1 32 interface atm0/1 1 35

Configuração de Cisco LS1010 para o PPPoA
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuração do Cisco 7200 para o PPPoA
aaa new-model
AAA authentication ppp default local
!
!
username password 
!
!
interface ATM 2/0.1 multipoint
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template 2
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
!
ip local pool <pool name> 172.22.40.10 172.22.40.25

RFC1483 Bridging: xDSL para 7200

Diagrama de Rede

Essa seção utiliza esta configuração de rede:

7200_bdaggreg2.gif

Configurações

Este exemplo descreve como conectar um Cisco 677, ou o outro DSL CPE, a um Cisco 7200 através do Bridged Encapsulation do RFC 1483. Esta configuração inclui um switch ATM de Cisco LS1010, que seja um componente opcional. Os resultados são os mesmos se você conecta diretamente o DSLAM ao Cisco 7200.

Neste exemplo, você estabelece a sessão construída uma ponte sobre no Cisco 677 e termina-a no Cisco 7200. Após as pontes da sessão ao Cisco 7200, o IP tradicional passa o tráfego ao NSP ou ao Internet. Um servidor DHCP com configuração nos 7200 atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT à estação de trabalho cliente.

Esta configuração usa o Integrated Routing and Bridging (IRB). Para aliviar a escalabilidade e os interesses de segurança com IRB, considere o Routed Bridged Encapsulation (RBE).

Esta seção utiliza as seguintes configurações:

Configuração do PC para o RFC 1483
  1. Ajuste o endereçamento de IP para obter automaticamente um endereço IP de Um ou Mais Servidores Cisco ICM NT.
  2. Ajuste VITÓRIAS para usar o DHCP para a definição das VITÓRIAS.
  3. Assegure-se de que nenhum gateway padrão esteja ajustado.

Nota: Se o DHCP não pode passar esta informação, você precisa de ajustar um Domain Name.

Configuração CPE do Cisco 677 para o RFC 1483
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuração do Cisco dslam para o RFC 1483
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuração de Cisco LS1010 para o RFC 1483
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuração do Cisco 7200 para o RFC 1483
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!         
!
bridge irb
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
 bridge-group 1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
 bridge-group 1!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface BVI 1
 ip address 172.22.40.9 255.255.255.0
 no ip directed-broadcast
!
!
bridge 1 protocol ieee
 bridge 1 route ip

RBE: xDSL para 7200

Diagrama de Rede

Essa seção utiliza esta configuração de rede:

7200_bdaggreg2.gif

Configurações

O RBE é atualmente a configuração de escolha para a maioria de instalações DSL novas. O RBE endereça a Segurança e as questões de escalabilidade da construção de uma ponte sobre no ambiente do assinante de banda larga.

Um servidor DHCP com configuração nos 7200 atribui um endereço IP de Um ou Mais Servidores Cisco ICM NT à estação de trabalho cliente.

Importante: O DHCP não pode ser executado no roteador com ATM unnumbered a não ser que quando você usa o Software Release 12.1(2)T ou Mais Recente do ½ do ¿  de Cisco IOSïÂ.

Esta seção utiliza as seguintes configurações:

Configuração do PC para o RBE
  1. Ajuste o endereçamento de IP para obter automaticamente um endereço IP de Um ou Mais Servidores Cisco ICM NT.
  2. Ajuste VITÓRIAS para usar o DHCP para a definição das VITÓRIAS.
  3. Assegure-se de que nenhum gateway padrão esteja ajustado.

Nota: Se o DHCP não pode passar esta informação, você precisa de ajustar um Domain Name.

Configuração CPE de Cisco para o RBE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuração do Cisco dslam para o RBE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuração de Cisco LS1010 para o RBE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuração do Cisco 7200 para o RBE
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!
!
interface Loopback0
 ip address 172.22.40.9 255.255.255.0
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/35 
  encapsulation aal5snap
!
!
interface ATM 2/0.2 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/36 
  encapsulation aal5snap
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!

PPPoE: xDSL para 7200

Diagrama de Rede

Essa seção utiliza esta configuração de rede:

7200_bdaggreg3.gif

Configurações

O PPP over Ethernet (PPPoE) estende a sessão de PPP do roteador ao cliente da extremidade. O PPP e o software de autenticação são executado geralmente no cliente dentro do sistema operacional ou em um aplicativo isolado. O CPE atua no modo de Bridging para construir uma ponte sobre a sessão de PPP sobre a conexão DSL. Mas o CPE não pode atuar como o servidor DHCP nesta encenação.

As configurações para o CPE, o DSLAM, e o switch ATM são as mesmas que as configurações para a construção de uma ponte sobre do RFC 1483. Você pode configurar o roteador de agregação do Cisco 7200 para a autenticação local, porque este exemplo mostra. Ou você pode configurar os 7200 com autenticação RADIUS do Authentication, Authorization, and Accounting (AAA).

Esta seção utiliza as seguintes configurações:

Configuração do PC para o PPPoE
  1. Ajuste o endereçamento de IP para obter automaticamente um endereço IP de Um ou Mais Servidores Cisco ICM NT.
  2. Ajuste VITÓRIAS para usar o DHCP para a definição das VITÓRIAS.
  3. Assegure-se de que nenhum gateway padrão esteja ajustado.

Nota: Se o DHCP não pode passar esta informação, você precisa de ajustar um Domain Name.

Nota: A estação final deve poder estabelecer uma conexão PPP ao roteador. O software de cliente especial para a autenticação e o acesso pode ser necessário.

Configuração CPE do Cisco 677 para o PPPoE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuração do Cisco dslam para o PPPoE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuração de Cisco LS1010 para o PPPoE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuração do Cisco 7200 para o PPPoE
!
username <username> password <password>
!
vpdn enable
!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1
  pppoe limit per-mac 100
  pppoe limit per-vc 100
!
ip cef
!
interface atm2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
  protocol pppoe
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
  protocol pppoe
!
interface Virtual-Template1
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
ip local pool <pool name> 172.22.32.20 172.22.32.100

L2TP: XDSL a 7200 via L2TP

Diagrama de Rede

Essa seção utiliza esta configuração de rede:

7200_bdaggreg4.gif

Configurações

O protocolo layer two tunneling (L2TP) fornece meios terminar a conexão PPP do utilizador final em um lugar e transportar os pacotes de dados L2 a um outro lugar. O L2TP offloads muita da funcionalidade IP do dispositivo de agregação e reserva mais projetos de rede centralizada. Um servidor Radius fornece o AAA.

As configurações para todos os dispositivos exceto o Cisco 7200 são as mesmas que as configurações para o exemplo do RFC 1483.

Esta seção utiliza as seguintes configurações:

Configuração do PC para o L2TP
  1. Ajuste o endereçamento de IP para obter automaticamente um endereço IP de Um ou Mais Servidores Cisco ICM NT.
  2. Ajuste VITÓRIAS para usar o DHCP para a definição das VITÓRIAS.
  3. Assegure-se de que nenhum gateway padrão esteja ajustado.

Nota: Se o DHCP não pode passar esta informação, você precisa de ajustar um Domain Name.

Configuração CPE do Cisco 677 para o L2TP
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Configuração do Cisco dslam para o L2TP
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuração de Cisco LS1010 para o L2TP
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuração de LAC do Cisco 7200 para o L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!  
vpdn-group 4
 request-dialin
  protocol l2tp
  domain cisco.com
 initiate-to ip 172.22.32.27 priority 1
 local name cisco-tunnel      
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template1
 ip unnumbered FastEthernet4/0
 no ip directed-broadcast
 ppp authentication pap
!
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Configuração de LNS do Cisco 7200 para o L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!
vpdn-group 1
 accept-dialin
  protocol any
  virtual-template 1
 terminate-from hostname cisco-tunnel
 local name tunnel-gate
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 12868