Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Asymmetric Digital Subscriber Line (ADSL)

Terminação de sessão PPPoA usando rotas estáticas: xDSL a um Cisco 6400 UAC usando o aal5ciscoppp

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (11 Novembro 2015) | Feedback


Índice


Introdução

Esta configuração de exemplo permite um PC conectado a um roteador do Asymmetric Digital Subscriber Line (ADSL) do Cisco 677 para conectar através de um Advanced Digital Subscriber Line Access Multiplexer do Cisco 6130 (ADSLAM) a uns únicos ou concentradores de acesso universal (UAC) múltiplos de Cisco. O equipamento específico que esta configuração usa não é exigido. Por exemplo, você pode substituir o Cisco 677 com um Cisco 678.

Esta configuração de exemplo tem algumas características permitidas no Cisco 677 que são comuns a um lançamento de ADSL. Estas características são Network Address Translation (NAT), tradução de endereço de porta (PAT), e protocolo de configuração dinâmica host (DHCP). Estas características permitem um lançamento de cortador de cookie. Desde que todas as caixas têm a mesma configuração, hão uma redução de lançamento e uma documentação dos custos significativos.

Você pode copiar e colar o código para o processador IOS�-baseado Cisco da rota de nó (NRP) e o processador de switch de nó (NSP) a suas configurações. Contudo, o Cisco 677 usa Cisco Broadband Operating System (CBOS) e você não pode copiar e colar este código. Os comandos que você se usa para configurar o Cisco 677 são incluídos igualmente nesta configuração de exemplo.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

Hardware

  • PC ou estação de trabalho

  • Customer Premises Equipment do Cisco 677 ADSL (CPE)

  • Serviço ADSL de sua companhia telefônica local

  • Cisco 6130 ADSLAM com NI-2, ATU-C DMT-II

  • Cisco 6400 UAC com 1 x NRP e 1 x NSP

Software

  • Cisco IOS Software Release 12.0.7-DC para o Cisco 6400 UAC NRP

  • Cisco IOS Software Release 12.0.7-DB para o Cisco 6400 UAC NSP

  • O CBOS libera 2.3.0.012 para o Roteador Cisco 677 ADSL

  • Cisco IOS Software Release 12.0.8-DA1 para o Cisco 6130 ADSLAM

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você é presentado com a informação que você pode se usar para configurar as características descritas neste documento.

Nota: A fim encontrar a informação adicional nos comandos usados neste documento, refira a ferramenta de consulta de comandos (clientes registrados somente).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12851/6400dsl_pppoa_stat.gif

Configurações

Notas de configuração

Você deve configurar uma conexão virtual permanente (PVC) no Cisco 6130 que permita que o assinante de teste conecte. Quando você configura o PVP no NSP e termina a sessão de PPP no NRP, a configuração do identificador de caminho virtual/identificador de canal virtual (VPI/VCI) deve ser gravada no Cisco 6400.

Esta configuração de exemplo mostra um caminho virtual no NSP. Este trajeto permite que o Cisco 6400 passe através das pilhas do ADSLAM ao roteador de terminação, ou a um outro switch ATM. Aqui você pode ajustar um PVP para comutar as células ATM a uma rede corporativa ou um ISP sem a terminação da sessão de PPP no Cisco 6400 situado no escritório central.

Esta configuração de exemplo permite que a usuários remotos o acesso transparente a suas redes corporativas (se são conectados) para o email, compartilhe do arquivo/cópia, do intranet corporativa, e ao Internet para a navegação na web, e assim por diante. sem o uso da conexão de Internet corporativa.

Quando os PVC múltiplos são configurados no Cisco 677, é possível distribuir o tráfego através de cada PVC. A configuração do ADSLAM e das rotas UAC-NSP/comuta estes PVC ao destino correto, ao ISP/ASP ou ao corporativo, onde o PPP pode terminar. Esta configuração reduz o tráfego, e desse modo aumenta a largura de banda disponível na rede corporativa e usa uma conta atual ISP a fim levar o tráfego de web.

Este documento utiliza as seguintes configurações:

Configuração do PC
Ajuste o endereçamento de IP de modo que obtenha um endereço IP de Um ou Mais Servidores Cisco ICM NT automaticamente. Ajuste VITÓRIAS de modo que use o DHCP para a definição das VITÓRIAS. Assegure-se de que nenhum gateway padrão esteja ajustado. Pode ser necessário ajustar um Domain Name porque o DHCP não pode passar esta informação.

Cisco 67x CPE (mostra executada)
[[ IP Routing = Section Start ]]
IP NAT = enabled
IP Port Address = 00, 172.22.10.254
IP Default Route for Unnumbered Links = 002, 01, 0
IP Static Route Table Entries for Unnumbered Links = 172.22.32.0, 001, 255.255.2
55.0, 1, 0;
[[ CBOS = Section Start ]]
NSOS Maximum Number of VCs = 2
NSOS Root Password = <
root password
>
NSOS Enable Password = <
enable password
>
[[ PPP Device Driver = Section Start ]]
PPP Port User Name = 00, <
username for wan0-0
>
PPP Port User Password = 00, <
password for wan0-0
>
PPP Port User Name = 01, <
username for wan0-1
>
PPP Port User Password = 01, <
password for wan0-1
>
PPP Port Option = 01, IPCP,IP Address,3,Auto,Negotiation Not Required,Negotiable
,IP,0.0.0.0
[[ DHCP = Section Start ]]
DHCP Server = enabled
DHCP Server Pool IP = 00, 172.22.10.0
DHCP Server Pool Gateway = 00, 172.22.10.254
[[ ATM WAN Device Driver = Section Start ]]
ATM WAN Virtual Connection Parms = 00, 1, 32, 0
ATM WAN Virtual Connection Parms = 01, 2, 63, 0

Comandos emitir a Cisco 67x CPE
cbos#set nat enabled
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos#set int wan0 maxvcs 2
You must use "write" and reboot for changes to take effect.

cbos#write
NVRAM written.

cbos#reboot
 Hello! Expanding CBOS image...
CBOS v2.3.5.012 - Release Software
User Access Verification
Password:<
root password
>

cbos>en
Password:<
enable password
>

cbos#set ppp wan0-0 login <username for wan0-0>
User name for wan0-0 has been set to router.

cbos#set ppp wan0-0 password <password for wan0-0>
Password for wan0-0 has been set to <password for wan0-0>

cbos#set ppp wan0-1 login <username for wan0-1>
Password for wan0-1 has been set to <username for wan0-1>

cbos#set ppp wan0-1 password <password for wan0-1>
Password for wan0-1 has been set to <password for wan0-1>

cbos#set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos#set ppp wan0-1 ipcp 0.0.0.0
PPP wan0-1 IPCP Address set to 0.0.0.0

cbos#set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos#set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0
You must use "write" then reboot for changes to take effect

cbos#set dhcp server enable
DHCP Server enabled

cbos#set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos#set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0
Size of pool 0 is automatically changed to max size 252

cbos#set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos#set password exec <root password>
Exec Password Change Successful! 

cbos#set password enable <enable password>
Enable Password Change Successful! 

cbos#set route default wan0-1
Default Route set

cbos#set route add ip 172.22.32.0 mask 255.255.255.0 gw wan0-0
Route added
cbos#set int wan0-0 close
Closing connection wan0-0

cbos#set int wan0-1 close
Closing connection wan0-1

cbos#set int wan0-0 vpi 1
Change completed.

cbos#set int wan0-0 vc1 32
Change completed.

cbos#set int wan0-1 vpi 2
Change completed.

cbos#set int wan0-1 vci 63
Change completed.

cbos#set int wan0-0 open
Opening connection wan0-0

cbos#set int wan0-1 open
Opening connection wan0-1

cbos#write
NVRAM written

cbos#reboot

61xx ADSLAM
interface ATM 1/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1 32 int atm 0/1 40 40
 pvc 2 63 int atm 0/1 50 51

6400 NSP (entalhe 8)
interface ATM 8/0/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvp 40 interface ATM 1/0/0 40
 atm pvp 50 interface ATM 2/0/0 50

6400 NRP (slot1)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-0> password <password for wan0-0>
!
!
interface ATM 0/0/0.200 multipoint
 no ip directed-broadcast
 pvc 40/40 
  encapsulation aal5ciscoppp Virtual-Template 2
!
!
interface FastEthernet 0/0/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name A>
 ppp authentication pap
!
!
ip local pool <pool name A> 172.22.40.25 172.22.40.50

6400 NRP (entalhe 2)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-1> password <password for wan0-1>
!
!
interface ATM 0/0/0.300 multipoint
 no ip directed-broadcast
 pvc 50/51 
  encapsulation aal5ciscoppp Virtual-Template 21
!
!
interface FastEthernet 0/0/0
 ip address 172.16.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 21
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name B>
 ppp authentication pap
!
!
ip local pool <pool name B> 172.16.100.10 172.16.100.25

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração funciona adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Use estes comandos no Cisco 675 CPE:

  • show interface wan0 — As mostras treinaram acima da velocidade para o link ADSL.

  • show interface wan0-0 — Informação de sessão de PPP das mostras em wan0-0.

  • mostre a relação wan0-1 — Informação de sessão de PPP das mostras em wan0-1.

  • show dhcp server pool 0 — Informação DHCP das mostras na site de cliente.

Use este comando no Cisco 6400 UAC:

  • mostre o pvc atm — Mostra se o PVC correto está estabelecido.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Use estes comandos no Cisco 6400 UAC:

  • debugar a negociação ppp — A negociação de PPP das mostras debuga mensagens.

  • debugar a autenticação de PPP — Mostra se um cliente passa a autenticação.

  • debug ppp error — mostra erros de protocolo e estatísticas de erros associados à negociação e à operação da conexão PPP.

Antes que você tente alguns dos comandos debug, refira a informação importante em comandos Debug.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12851