Serviços de rede de aplicativos : Mecanismos de cache Cisco 500 Series

Exemplo de configuração da reorientação da política WCCP do Cahe Engine 500 Series

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo que demonstra como estabelecer um redirecionamento de política da versão 2 do protocolo web cache communication (WCCPv2) em um motor do esconderijo do Cisco 500 Series. Nesta configuração de exemplo, você usa o comando table-map na configuração de BGP e em traçar a etiqueta do atributo de entrada externo WCCP na tabela de roteamento a fim classificar pacotes com os atributos do Border Gateway Protocol (BGP) associados com a fonte ou o endereço IP de destino de um pacote.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 7513 Router que executa o Software Release 12.0(14)S do ½ do ¿  de Cisco IOSïÂ

  • Cisco Cache Engine 550 que executa o Software Cisco Cache versão 2.3

  • Cisco 2600 Router que executa o Cisco IOS Software Release 12.0

  • Servidores de Web do Windows NT

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Refira as convenções dos dicas técnicas da Cisco para obter informações sobre das convenções de documento.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12658/wwcp_2_policy.gif

Trafique somente que os cursos ao destino PC2 (que pertence ao AS30) estão reorientados ao motor do esconderijo, quando o outro tráfego do sistema autônomo (RouterD, server HTTP 3.3.3.3 no AS33) não for.

Configurações

Este documento utiliza as seguintes configurações:

RoteadorA
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/1
ip address 172.17.241.27 255.255.255.0
!
router bgp 10
bgp log-neighbor-changes
network 2.2.2.0
network 172.17.241.0
redistribute connected
neighbor 2.2.2.1 remote-as 20

RoteadorB
!
ip wccp web-cache password ww policy destination 60
ip cef distributed
!
interface Serial0/0
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet5/0
ip address 2.2.2.1 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect in
ip route-cache same-interface
!
router bgp 20
table-map dst
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip classless
!
access-list 1 permit 3.0.0.0 0.255.255.255
route-map DST permit 10
match ip address 1
set ip wccp 60
!
route-map DST permit 20

RoteadorC
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Ethernet5/0
ip address 3.3.3.1 255.255.255.0
no ip directed-broadcast
!
router bgp 30
network 3.3.3.0
redistribute connected
neighbor 1.1.1.2 remote-as 20
neighbor 1.1.1.2 send-community
neighbor 1.1.1.2 route-map setcomm out
neighbor 3.3.3.3 remote-as 33
!
ip classless
ip bgp-community new-format
!
access-list 1 permit 77.0.0.0 0.255.255.255
route-map setcomm permit 10
match ip address 1
set community 4433:1050
!
route-map setcomm permit 20
!

RouterD
!
interface Ethernet0
ip address 3.3.3.3 255.255.255.0
!
router bgp 33
bgp log-neighbor-changes
network 33.33.33.0
redistribute connected
neighbor 3.3.3.1 remote-as 30
!
ip classless
ip http server

Comandos relacionados

Você pode configurar os exemplos de roteador a estas encenações:

table-map

Use o comando table-map a fim mudar a política WCCP do destino à fonte. O tráfego que é reorientado é representado agora por cada pedido do HTTP com o endereço IP de origem especificado no src do mapa de rotas.

!
router bgp 20
table-map src
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip wccp web-cache password WW policy source 60
!
access-list 1 permit 172.0.0.0 0.255.255.255
route-map src permit 10
match ip address 1
set ip wccp 60
!
route-map src permit 20
!

match as-path

Mude a circunstância que aplica a etiqueta WCCP às rotas de BGP anunciadas. Na configuração do RoteadorC, a etiqueta WCCP é aplicada às rotas de BGP que pertencem à comunidade particular 4433:1050. Você pode usar o comando match as-path a fim selecionar outros critérios no roteadorB tal como o como-PATH.

ip as-path access-list 121 permit ^30$
!
route-map setlist permit 10
match as-path 121
set ip wccp 60
!

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 12658