Cisco Interfaces and Modules : Módulo de switching de conteúdo da Cisco

Configurando o balanceamento de carga do servidor FTP utilizando IOS SLB

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para o Balanceamento de carga do servidor FTP com a ajuda do Cisco IOS Server Load Balancing (SLB).

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.1(8)E de Cisco IOS� do supervisor do Catalyst 6000 Family para o Supervisor Engine 1 com MSFC1 (c6sup11-jsv-mz.121-8a.E)

  • Servidores FTP de Microsoft Windows 2000/IIS

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

A característica do Cisco IOS SLB é uma solução com base em IOS de Cisco que forneça o Server Load Balancing. Esta característica permite que você defina um servidor virtual que represente um conjunto de servidores reais, conhecido como uma fazenda do server. Quando um cliente inicia uma conexão ao servidor virtual, a carga IO SLB equilibra a conexão a um servidor real escolhido, segundo o algoritmo ou o predictor configurado do equilíbrio da carga.

Quando você usa IO SLB, você deve configurar o Balanceamento de carga do servidor FTP para operar-se no modo da expedição. Neste modo, o endereço virtual é sabido aos servidores FTP. Você deve configurar cada um dos servidores FTP com endereços de loopback para sua interface de loopback exclusiva. Esta etapa é necessária para dar a cada máquina no servidor FTP na exploração agrícola o mesmo endereço IP de Um ou Mais Servidores Cisco ICM NT que o endereço virtual. O servidor FTP pode então responder diretamente aos clientes com o endereço de loopback, apenas porque o server responderia para seu próprio endereço IP de Um ou Mais Servidores Cisco ICM NT. OS IO SLB reorientam pacotes ao servidor real na camada 2 na camada de controle de acesso de mídia (MAC). O endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor virtual não é alterado no modo despachado. Consequentemente, os servidores reais devem ser a camada 2-adjacent a IO SLB. Se não, os roteadores intermediários não podem distribuir ao servidor real escolhido.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12577/config_ftpserver_lb.gif

Configurações

Este documento utiliza esta configuração:

  • Configuração IOS SLB FTP usando o Catalyst 5509

Configuração IOS SLB FTP usando o Catalyst 5509
Current configuration: 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin 
! 
redundancy 
 main-cpu 
  auto-sync standard 
ip subnet-zero 
! 

!--- FTP Serverfarm configuration.
 
ip slb serverfarm FTPFARM 
 real 10.1.1.3 
  inservice 
 !  
 real 10.1.1.4 
  inservice 
! 

!--- FTP Virtual configuration. 
!--- Important: Config Loopback address on FTP Server's with Virtual address.
 
ip slb vserver FTPSERVER 
 virtual 172.17.63.241 tcp ftp service ftp 
 serverfarm FTPFARM 
 inservice 
! 
interface GigabitEthernet1/1 
 no ip address 
 shutdown 
! 
interface GigabitEthernet1/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/1 
 description "Uplink to the Default Gateway" 
 no ip address 
 switchport 
 switchport access vlan 100 
! 
interface FastEthernet2/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/3 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/4 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/5 
 no ip address 
 shutdown 
! 
interface FastEthernet2/48 
 no ip address 
 shutdown 
! 
interface Vlan1 
 no ip address 
 shutdown 
! 

!--- Client Side Vlan. 

interface Vlan100 
 ip address 172.17.63.240 255.255.255.192 
! 

!--- FTP Server Vlan. 
!--- Important: Configure the default gateway of the FTP Server to this address.

interface Vlan200 
 ip address 10.1.1.250 255.255.255.0 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
 login 
! 
end

Nota: Além do que IO SLB, o módulo content switching está igualmente disponível para o Cisco Catalyst 6500 Series Switch e o Cisco 7600 Series Router. Este módulo fornece conexões de alto desempenho entre fazendas do server dos dispositivos de rede com base em pacotes de informação da camada 4 com o 7. Para uns detalhes mais adicionais, refira o Módulo de comutação de conteúdo da Cisco.

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • mostre o vserver do slb IP — Indica a informação do servidor virtual. Está aqui um exemplo que indique o estado do servidor virtual e o número de conexões:

    cat#show ip slb vserver 
    
    slb vserver    protocal   virtual                 state         conns 
    ----------------------------------------------------------------------
    FTPSERVER      TCP        172.17.63.241/32:21     OPERATIONAL    4
  • mostre reais do slb IP — Indica a informação do server farm. Esse comando mostra o preditor utilizado para o balanceamento de carga. Este exemplo usa o arredondamento robin (padrão). “Nenhum” aparece sob o NAT porque o dispositivo reage do modo despachado.

    cat#show ip slb serverfarm 
    
    server farm     predictor       nat        reals        bind id 
    ----------------------------------------------------------------- 
    FTPFARM         ROUNDROBIN      none          2           0

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

cuidado Cuidado: O resultado do debug é atribuído a alta prioridade no processo de CPU. Consequentemente, debugar pode tornar o sistema inusável. Por esta razão, use comandos de depuração somente para troubleshoot problemas específicos ou durante sessões de Troubleshooting com a equipe de suporte técnico Cisco. Cisco recomenda que você usa comandos debug durante períodos de fluxos de rede mais baixa e de menos usuários. A eliminação de erros durante estes períodos reduz o efeito destes comandos em outros usuários no sistema.

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debugar o slb IP {conns | reais | vserveres | tudo} — os indicadores debugam mensagens. Não use nenhum formulário deste comando a fim desabilitar a eliminação de erros. Está aqui a descrição da sintaxe:

    Sintaxe Descrição
    conexão Os indicadores debugam mensagens para todas as conexões que os IO SLB seguram atualmente.
    vserveres Os indicadores debugam as mensagens para todos os servidores virtuais definidas a IO SLB.
    reais Os indicadores debugam as mensagens para todos os servidores reais definidas a IO SLB.
    tudo Indica tudo debugam mensagens para IO SLB.

    As sessões de FTP consistem em duas conexões entre o cliente de FTP e o servidor FTP, a saber, o controle e os dados.

  • debugar conexões do slb IP

    Está aqui um exemplo que use o FTP passivo. Nos termos os mais simples, isto é como o FTP passivo trabalha:

    • Uma conexão para a conexão inicial do controle de FTP, que o cliente inicia ao server:

      2d22h: SLB_CONN_DEBUG: TCP event= SYN_CLIENT,
       state= INIT -> SYNCLIENT 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
      2d22h: SLB_CONN_DEBUG: TCP event= SYNACK_SERVER,
       state= SYNCLIENT -> ESTAB 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
    • A outra conexão para a conexão de dados FTP, que é iniciada do cliente ao server:

      2d21h: SLB_CONN_DEBUG: TCP event= DATA_CLIENT,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999 
      2d21h: SLB_CONN_DEBUG: TCP event= DATA_SERVER,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999

Observe que no FTP passivo, o cliente inicia a conexão de controle e a conexão de dados. O modo passivo refere o estado dos server, que o server aceita passivamente ambas as conexões. No modo passivo, o destino e as portas de origem são portas “efémeras” (maior de 1023). O cliente conduz os modos, como em cada caso o cliente deve emitir o comando passive, ou o comando port, iniciar a instalação da conexão de dados. Em cada caso o receptor da conexão de dados (server para o modo passivo, do cliente para o modo ativo) deve fornecer o número de porta em que escutam esta conexão específica. Não é SEMPRE a porta 20 para a conexão de dados, mesmo no modo ativo FTP. Nada nos RFC especifica que as portas a ser usadas são 20 e 21, ele é apenas convenção. Muitos server usam portas efêmeras para a conexão de dados.

% não podem permitir o server nat porque o [chars] do vserver tem o FTP permitido

Este Mensagem de Erro é indicado porque os IO SLB não apoiam o FTP no modo NAT. A ação alternativa é usar o modo e os laços de retorno da expedição nos server. Para mais informação, veja a seção de loopback do modo despachado.

Circuito fechado em modo despachado

Depois que você configurou o FTP Serverfarm e a característica do vserver no Catalyst 6500, você deve configurar cada servidor real com um dispositivo ou uma relação do laço de retorno. Configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor virtual como o endereço IP de loopback, com um netmask de 255.0.0.0.

Route Table 
     =========================================================================== 
     Interface List 
     0x1 ........................... MS TCP Loopback interface 
     0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
     0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
     =========================================================================== 
     Active Routes: 
        Network         Destination     Netmask       Gateway   Interface Metric 
        0.0.0.0         0.0.0.0         10.1.1.250    10.1.1.3      1 
        10.1.1.0        255.255.255.0   10.1.1.3      10.1.1.3      1 
        10.1.1.3        255.255.255.255 127.0.0.1     127.0.0.1     1 
        10.255.255.255  255.255.255.255 10.1.1.3      10.1.1.3      1 
        127.0.0.0       255.0.0.0       127.0.0.1     127.0.0.1     1 
        172.17.63.241   255.255.255.255 127.0.0.1     127.0.0.1     1 
        224.0.0.0       224.0.0.0       10.1.1.3      10.1.1.3      1 
        224.0.0.0       224.0.0.0       172.17.63.241 172.17.63.241 1 
        255.255.255.255 255.255.255.255 10.1.1.3      10.1.1.3      1 
     ===========================================================================

Examine o endereço de rede em cada fileira da tabela, onde você vê que o endereço de loopback aparece. Para que os server comuniquem-se corretamente, você precisa uma referência a um endereço de rede de transmissão múltipla bem conhecido. Isto está na oitava fileira no exemplo, assim que você precisa de suprimir do Default-route extra. Este é esse cujo o endereço de rede começa com o mesmo primeiro dígito que o endereço de cluster, e é seguido por três zero. Neste exemplo, a rota extra está na segunda fileira.

Estes são endereços de rede de transmissão múltipla bem conhecido:

224.0.0.0      224.0.0.0    172.17.63.241      172.17.63.241       1

Estão aqui as rotas padrão automático-instaladas removidas da tabela no exemplo:

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.241          1

Você deve suprimir da rota extra para permitir uma comunicação apropriada com o servidor virtual SLB.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12577