Gerenciamento e automatização de redes : Cisco Network Registrar

Instalação básica do cable modem com o Cisco Network Registrar

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A finalidade desta Nota Técnica é fornecer um guia completo da instalação para uma rede do Cable Modem (CM) em um ambiente de laboratório. Esta configuração pode ser usada como um primeiro passo antes da distribuição para uma rede de cliente. É importante notar que uma instalação sem problemas no laboratório não significa necessariamente uma instalação sem problemas na rede de um cliente. Em um ambiente de laboratório controlado, o ruído não pode ser uma edição; quando na vida real, puder ser bastante o oposto. Contudo, este procedimento pode ser usado para ordenar para fora as edições que elevaram do software release de Cisco IOS�, da configuração, do hardware, e do Radio Frequency (RF).

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Topologia de laboratório

Figura 1 – Instalação da rede de laboratório

basic_bridged_setup_01.gif

Neste diagrama, há um cable modem termination system (CMTS) que consista nestes componentes:

  • uBR7246 que executa o Cisco IOS Software Release 12.1(2)T com placas de modem MC16C

  • UBR904 CM que executa a versão 12.0(7)T do Cisco IOS Software Release

  • Conversor ascendente

  • Filtro de Diplex para separar a alta frequência das baixas frequências

  • Versão 3.5(3) do Cisco Network Registrar (CNR)

  • Divisor tripartido

  • Customer Premises Equipment (CPE) que, neste caso, é um portátil

Nota: A instalação RF nesse diagrama pode ser usada como um ponto de referência começando; contudo, isto pôde mudar uma vez que você o distribui em uma site de cliente. As medidas RF são além do alcance deste documento; refira a conexão do Cisco uBR7200 Series Router ao fim do cabeçalho do cabo para a instalação apropriada e as medidas RF.

Hipóteses

  • O conversor ascendente já está instalado e configurado corretamente. Refira a documentação do vendedor para a instalação. Recorde que, se você está usando um conversor de GI, isto deve ser ajustado 1.75 megahertz em mais baixa do que a frequência central do canal NTSC na pergunta.

  • Há um CPE corretamente configurado que se sente atrás do CM, para obter especificamente um endereço IP de Um ou Mais Servidores Cisco ICM NT através do servidor DHCP.

  • O CNR é usado como o DHCP e os servidores TFTP, com o mesmo endereço IP de Um ou Mais Servidores Cisco ICM NT: 172.17.110.136.

  • O software do server do Time Of Day (ToD) está sendo executado no mesmo servidor NT que o CNR.

As seções neste documento explicam as etapas que são precisadas de configurar estes componentes:

  • Cisco Network Registrar (CNR)

  • Arquivo de configuração do Data-Over-Cable Service Interface Specification (DOCSIS)

  • Cable modem termination system (CMTS)

  • Modem a cabo (CM)

Diagrama de Rede

Figura 2 – Diagrama da rede com os endereços IP de Um ou Mais Servidores Cisco ICM NT e os nomes usados nesta Nota Técnica

/image/gif/paws/12547/basic_bridged_setup_02.gif

Configuração do Cisco Network Registrar

Siga este procedimento para configurar o CNR:

  1. Lance o menu CNR desde o início.

  2. Na barra de menus, clique a aba adicionar para adicionar um conjunto novo.

    1. Digite o nome do cluster.

      Neste caso, um endereço IP de Um ou Mais Servidores Cisco ICM NT é usado como o nome.

    2. Verifique a conexão a esta caixa de seleção uma vez adicionada do conjunto.

    3. Clique em OK.

    Figura 3 – Indicador do nome de grânulos ou do endereço IP de Um ou Mais Servidores Cisco ICM NT no CNR

    /image/gif/paws/12547/basic_bridged_setup_03.gif

  3. Quando você é alertado para o nome de usuário e senha, use o admin e o changeme.

    Figura 4 – Indicador do nome de usuário e senha no CNR

    /image/gif/paws/12547/basic_bridged_setup_04.gif

  4. Clique em OK.

    Um indicador aparece que seja similar figurar 5, que contém os nomes ou os endereços IP de Um ou Mais Servidores Cisco ICM NT dos conjuntos configurados.

    Figura 5 – Janela do gerenciador do servidor no CNR

    basic_bridged_setup_05.gif

  5. Clique duas vezes DHCP@172.17.110.136, para trazer acima a janela de propriedades de DHCP@172.17.110.136.

  6. Clique a aba das políticas e clique-a então novo, para criar uma política nova.

    Figura 6 – Adicionando uma política chamada “Modems a cabo” e copi dos atributos da política do “padrão”

    basic_bridged_setup_06.gif

  7. Digite o nome da política.

    Neste exemplo, o nome é Modems a cabo.

  8. Se esta é uma política nova, ajuste a cópia do campo para optar.

  9. Clique em OK.

  10. O clique edita opções, para especificar opções de DHCP.

    Para a política chamada Modems a cabo, adicionar as seguintes opções (veja a figura 7):

    • o Dhcp-lease-time é ativo à revelia e ajustado a 604800 segundos, que é o número de segundos em uma semana.

    • os roteadores são o endereço IP da interface de cabo CMTS, nesse caso, 10.1.1.10. Veja configurar o final do cabeçalho (CMTS).

    • deslocamento de tempo do CM do Universal Coordinated Time (UTC; Opção offset tempo 2). Isto é usado pelo CM para calcular o horário local, log de erros do selo de tempo.

    • endereço IP de Um ou Mais Servidores Cisco ICM NT dos servidores de tempo para o servidor ToD, que é 172.17.110.136.

    • o pacote-siaddr é o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor TFTP, que é 172.17.110.136.

    • o nome de pacote de arquivo é o arquivo de configuração DOCSIS configurado com o DOCSIS CPE Configurator (clientes registrados somente). Este arquivo deve residir no diretório de inicialização de TFTP do servidor TFTP.

    Figura 7 – Edite a janela de opções com os atributos dados à política de cable modem

    basic_bridged_setup_07.gif

    Nota: Assegure-se de que você verifique a emissão à caixa de verificação de clientes BOOTP, se você tem clientes bootp. É igualmente altamente recomendado que você verifica sempre a emissão à caixa de seleção dos clientes DHCP.

  11. Crie uma outra política associada com os CPE atrás do CM, como portáteis, e assim por diante.

    Neste exemplo, o nome da política é clientes de Cable Modem.

    Siga o mesmo procedimento que foi usado para a política do Modems a cabo exceto, esta vez, ajustou a cópia do campo à política do Modems a cabo em vez à política padrão.

    Figura 8 – Adicionando uma política chamada “clientes de Cable Modem” e copiando os atributos da política existente nomeada “Modems a cabo”

    /image/gif/paws/12547/basic_bridged_setup_08.gif

  12. Clique em OK.

  13. Clique o botão Option Button da edição, para selecionar as opções ativa.

  14. Para a política de CPE, remova todas as opções da lista ativa exceto o Dhcp-lease-time e as opções de roteadores.

    Para fazer assim, selecione a propriedade para suprimir na lista ativa e para clicar o botão Remove Button.

  15. Mude o endereço IP de Um ou Mais Servidores Cisco ICM NT para a opção de roteadores a 192.168.1.1, que é o endereço IP secundário configurado no roteador de CMTS.

    Veja configurar o final do cabeçalho (CMTS).

    Figura 9 – Adicionando o endereço IP de Um ou Mais Servidores Cisco ICM NT para o atributo do Roteadores, que é o endereço IP secundário configurou na interface de cabo a que esta política se aplica no CMTS

    basic_bridged_setup_09.gif

    Nota: Este exemplo usa um endereço IP privado como o endereço secundário no CMTS e na política de cliente do Modems a cabo. Em um ambiente de produção, os dispositivos CPE devem usar um endereço IP público, para poder alcançar o Internet (a menos que o [NAT] da tradução de endereço de rede é usado).

  16. Crie espaços para associar com as políticas do Modems a cabo e dos clientes de Cable Modem.

    1. Para fazer um espaço novo, clique sobre DHCP@172.17.110.136 no menu principal, e clique então a aba adicionar.

      Isso permitirá a adição de um novo escopo.

    2. Dê entrada com o nome do espaço novo e selecione então a política apropriada.

      Neste exemplo, o espaço para o Modems a cabo é ajustado para usar a escala de endereços IP de Um ou Mais Servidores Cisco ICM NT de 10.1.1.20 a 10.1.1.30.

      Figura 10 – Espaço para o Modems a cabo chamado “Modems a cabo”

      /image/gif/paws/12547/basic_bridged_setup_10.gif

    3. Repita as etapas 16a e 16b para o espaço dos clientes de Cable Modem.

      Neste caso, a escala de endereço IP privado de 192.168.1.20 a 192.168.1.30 é usada.

      Figura 11 – O espaço para o equipamento CPE atrás do Modems a cabo chamou “clientes de Cable Modem”

      /image/gif/paws/12547/basic_bridged_setup_11.gif

    4. O espaço usado para os dispositivos CPE exige a configuração adicional.

      1. Uma vez que você criou os clientes de Cable Modem espaço, você precisa de fazer duplo clique o espaço para abrir a caixa de diálogo que é mostrada em figura 12.

        Figura 12 – Janela de escopo dos clientes de Cable Modem

        /image/gif/paws/12547/basic_bridged_setup_11.gif

      2. Clique o guia avançada, a fim relacionar o escopo secundário ao escopo principal.

      3. Verifique fazem a este espaço uma caixa de verificação secundária.

      4. Uma vez que a lista de drop-down mostra um valor vazio, selecione o escopo principal apropriado.

        Neste exemplo, o espaço do Modems a cabo é selecionado.

        Figura 13 – Fazendo o espaço dos “clientes de Cable Modem” secundário e relacionando o ao escopo principal

        basic_bridged_setup_12.gif

  17. Finalmente, você precisa de reiniciar seu servidor DHCP de modo que suas mudanças possam ocorrer.

    No menu principal, DHCP@172.17.110.136 seleto e clica a aba do controle na parte superior, para obter a caixa de diálogo mostrada em figura 14. Esta caixa de diálogo permite que você recarregue o servidor DHCP.

    Figura 14 – Indicador do Reload para comprometer mudanças no CNR

    /image/gif/paws/12547/basic_bridged_setup_13.gif

Arquivo de configuração de DOCSIS

A próxima etapa que é exigida setup uma rede de cabo é compor o arquivo de configuração. Para que um modem a cabo venha em linha, precisa de transferir seu arquivo de configuração através do TFTP de um servidor DHCP. No exemplo deste documento, o CNR é usado para fornecer o TFTP e os servidores DHCP. Refira o DHCP e o arquivo de configuração DOCSIS para o Modems a cabo (DOCSIS 1.0) para obter mais informações sobre dos requisitos mínimos para setup o arquivo de configuração. O arquivo setup com a ferramenta baseada na Web, DOCSIS CPE Configurator (clientes registrados somente), ou com uma transferência da versão independente. Sobre na seção CM (uBR904) deste documento, o arquivo de configuração DOCSIS que é usado é chamado platinum.cm.

Nota: Uma vez que o arquivo de configuração é criado, assegure-se de que esteja copiado ao servidor TFTP. No caso do servidor TFTP do CNR, você igualmente deve assegurar-se de que o servidor TFTP esteja ligado:

  1. Selecione TFTP@172.17.110.136 e clique então a aba do controle.

    Isto traz acima a caixa de diálogo do controle de TFTP@172.17.110.136, onde o server pode ser ligado.

  2. A funcionalidade de servidor de TFTP está à revelia. Para fazer o servidor TFTP começar automaticamente na inicialização, no começo NRCMD (a interface da linha de comando para o CNR) e emitir estes comandos:

    server tftp set start-on-reboot=enabled
    
    save
    

Configurando o fim do cabeçalho (CMTS)

Esta é uma configuração básica para o CMTS (o uBR7246):

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Sydney
!
boot system flash ubr7200-ik1s-mz_121-2_T.bin
no logging buffered
enable password <deleted>
!
no cable qos permission create

!--- Default.

no cable qos permission update

!--- Default.

cable qos permission modems

!--- Default.

!
!
!
ip subnet-zero
no ip domain-lookup
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.139 255.255.255.224

!--- The IP address of the interface in the same LAN segment as CNR.

!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Ethernet1/4
 no ip address
 shutdown
!
interface Ethernet1/5
 no ip address
 shutdown
!
interface Ethernet1/6
 no ip address
 shutdown
!
interface Ethernet1/7
 no ip address
 shutdown
!
 interface Cable2/0
 ip address 192.168.1.1 255.255.255.0 secondary

!--- The secondary IP address is used for the CPE’s scope in CNR.

 ip address 10.1.1.10 255.255.255.0

!--- The primary IP address is used for the CM’s scope in CNR.

 no keepalive
 cable downstream annex B

!--- Default for DOCSIS-compliant cable plants. For EuroDOCSIS, use annex A.

 cable downstream modulation 64qam

!--- Default.

 cable downstream interleave-depth 32

!--- Default.

 cable downstream frequency 451250000

!--- Cosmetic except for the uBR7100. This line has no effect
!--- on Upconverter Frequency. Used as a reminder of the frequency
!--- that is used in the Unconverter.

 cable upstream 0 frequency 28000000

!--- Upstream Frequency configuration. This is chosen after a careful
!--- analysis on the noise levels of the return path.

 cable upstream 0 power-level 0
 no cable upstream 0 shutdown

!--- Enables the upstream 0 port.

 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy

!--- Modifies the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets.

 cable helper-address 172.17.110.136

!--- Specifies a destination IP address for UDP-broadcast DHCP packets.

!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
  transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 login
line vty 1 4
 password cisco
 login
!
end

Configurando o CM

Tipicamente, um modem a cabo não exige nenhuma configuração do usuário para que venha em linha (com exceção dos padrões de fábrica). Isto aplica-se somente se o CM deve ser usada como uma ponte. Este é um exemplo de uma configuração do Cable Modem do uBR que esteja sendo obtida automaticamente, depois que o CM vem em linha:

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
clock timezone - 0
ip subnet-zero
no ip routing
!
!
interface Ethernet0
 ip address 10.1.1.25 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address negotiated
 no ip directed-broadcast
 no ip route-cache
 cable-modem downstream saved channel 453000000 20 1
 cable-modem mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.10
ip classless
no ip http server
!
!
line con 0
 transport input none
line vty 0 4
!
end

Verificação e Troubleshooting

Esta seção descreve os comandos que podem ser usados para verificar o funcionamento correto da rede de cabo.

No CMTS (uBR7246)

Assegure-se de que o Modems a cabo esteja em linha:

Sydney# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 2    online     2290   -0.25  6   1   10.1.1.25       0050.7366.2223

Se o Modems a cabo é colado no init (d) estado, a seguir não há nenhuma Conectividade entre a relação do cabo CMTS e o servidor DHCP.

Assegure-se de que você possa emitir um ping estendido da interface de cabo do CMTS:

Sydney# ping ip

Target IP address: 172.17.110.136
Repeat count [5]: 
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 10.1.1.10
Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

Se o ping não for bem-sucedido, verifique o roteamento IP. Também, assegure-se de que o servidor NT que está executando o CNR tenha o gateway padrão correto ou a rota de volta ao CMTS. Você pode igualmente emitir um sibilo do CNR.

Um outro comando que possa ser usado no CMTS para verificar o modem a cabo e a conectividade CPE é show interface cable 2/0 modem 0:

Sydney# show interfaces cable 2/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
2     00         host      unknown   192.168.1.20  dhcp      0010.a4e6.d04d

!--- A laptop that is obtaining an IP address.

2     00         modem     up        10.1.1.25     dhcp      0050.7366.2223

!--- The cable modem.

No CM (uBR904)

Você pode igualmente verificar a Conectividade no lado do Cable Modem. Emita o comando show ip interface brief e certifique-se das relações sejam Up/Up:

Router# show ip interface brief

Interface                  IP-Address      OK? Method Status         Protocol
Ethernet0                  10.1.1.25       YES unset  up             up
cable-modem0               10.1.1.25       YES unset  up             up

Router# show controllers cable-modem 0

BCM Cable interface 0:
CM unit 0, idb 0x2010AC, ds 0x86213E0, regaddr = 0x800000, reset_mask 0x80
station address 0050.7366.2223  default station address 0050.7366.2223
PLD VERSION: 32
MAC State is maintenance_state, Prev States = 15
MAC mcfilter 01E02F00  data mcfilter 01000000
MAC extended header ON
DS: BCM 3116 Receiver: Chip id = 2
US: BCM 3037 Transmitter: Chip id = 30AC
Tuner: status=0x00
Rx: tuner_freq 453000000, symbol_rate 5055880, local_freq 11520000
    snr_estimate 35210, ber_estimate 0, lock_threshold 26000
    QAM in lock, FEC in lock, qam_mode QAM_64
Tx: TX_freq 27984000, power_level 0x30 (24.0 dBmV), symbol_rate 8
    (1280000 sym/sec)
DHCP: TFTP server = 172.17.110.136, TOD server = 172.17.110.136
      Security server = 0.0.0.0, Timezone Offest = 0
      Config filename = platinum.cm
buffer size 1600

RX data PDU ring with 32 entries at 0x202130
   rx_head = 0x202168 (7), rx_p = 0x8621418 (7)

RX MAC message ring with 8 entries at 0x202270
  rx_head_mac = 0x2022A0 (6), rx_p_Mac = 0x86214BC (6)

TX BD ring with 8 entries at 0x2023A8, TX_count = 0
  TX_head = 0x2023C8 (4), head_txp = 0x8621548 (4)
  TX_tail = 0x2023C8 (4), tail_txp = 0x8621548 (4)

TX PD ring with 8 entries at 0x202428, TX_count = 0
  TX_head_pd = 0x202C28 (4)
  TX_tail_pd = 0x202C28 (4)

Global control and status:
  global_ctrl_status=0x00
interrupts:
  irq_pend=0x0008, irq_mask=0x00F7

Você pode igualmente testar a conectividade IP. Sibile o servidor DHCP do CM:

Router# ping 172.17.110.136

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

uBR7246

Sydney# show version

Cisco Internetwork Operating System Software
IOS (tm) 7200 Software (UBR7200-IK1S-M),
     Version 12.1(2)T, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Tue 16-May-00 13:36 by ccai
Image text-base: 0x60008900, data-base: 0x613E8000
ROM: System Bootstrap,
     Version 11.1(10) [dschwart 10], RELEASE SOFTWARE (fc1)
BOOTFLASH: 7200 Software (UBR7200-BOOT-M),
     Version 12.0(10)SC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Sydney uptime is 4 days, 40 minutes
System returned to ROM by reload
System image file is "slot0:ubr7200-ik1s-mz_121-2_T.bin"
cisco uBR7223 (NPE150) processor (revision B) with 57344K/8192K bytes of memory.
Processor board ID SAB0249006T
R4700 CPU at 150Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache
3 slot midplane, Version 1.0
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
8 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
2 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.
1024K bytes of packet SRAM memory.
20480K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

uBR904

Router# show version

Cisco Internetwork Operating System Software
IOS (TM) 900 Software (UBR900-K1OY556I-M),
     Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:01 by phanguye
Image text-base: 0x08004000, database: 0x0852E888


ROM: System Bootstrap,
     Version 11.2(19980518:195057), RELEASED SOFTWARE
ROM: 900 Software (UBR900-RBOOT-M),
     Version 11.3(7)NA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 


Router uptime is 1 hour, 6 minutes
System returned to ROM by reload at 11:20:43 - Thu Oct 12 2001
System restarted at 11:21:53 - Thu Oct 12 2001
System image file is "flash:ubr900-k1oy556i-mz.120-7.T.bin"

cisco uBR900 CM (68360) processor (revision D) with 8192K bytes of memory.
Processor board ID FAA0315Q07M
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
4096K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Boot flash (Read/Write)
        

Configuration register is 0x2102

Para uma explicação detalhada sobre o uso do CNR debuga — caso que você precisa de pesquisar defeitos edições CNR — referem pesquisando defeitos problemas de DHCP nas redes de cabo usando o Cisco Network Registrar Debugs. Para a configuração da classe de cliente, refira configurar classes de cliente.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12547