Tecnologias IBM : Data-Link Switching (DLSw) e Data-Link Switching Plus (DLSw+)

DLSw básico + configurações

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Data Link Switching (DLSw) é um protocolo switch a switch, que é utilizado para transportar o tráfego IBM Systems Network Architecture (SNA) e IBM NetBIOS em uma rede IP. Este protocolo não fornece o roteamento completo, mas fornece switching na camada de enlace de dados de SNA e encapsulamento em TCP/IP para transporte na Internet.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Informações de Apoio

O DLSw+ é a implementação de DLSw de Cisco. Além do padrão DLSw, o DLSw+ inclui os seguintes recursos:

  • Opção de transporte, incluindo TCP, FST (transporte em rápida seqüência) e encapsulamento direto.

  • Melhorias de escalabilidade por meio de: peer-group, pares por encomenda, firewall do explorador, e aprendizagem de local.

  • Conversão de mídia entre LANs remotos e locais e SDLC ou Ethernet.

Qual é o padrão de DLSw?

Para obter mais detalhes sobre o padrão DLSw, consulte o RFC 1795 (RFC 1434 se tornou obsoleto pelo RFC 1795). Em resumo, o RFC 1795 descreve o switch-to-switch protocol (ssp) usado entre o Roteadores para estabelecer conexões DLSw, encontra recursos, dados dianteiros, controle de fluxo do punho, e recuperação de erro. Também descreve como encerrar conexões DLC localmente e mapeá-las para um circuito DLSw.

Encerrando as conexões de DLC localmente, o DLSw tenta solucionar os seguintes problemas:

  • Intervalos de DLC

  • Reconhecimentos de DLC sobre a WAN

  • Controle de fluxo e de congestionamento

  • Controle de transmissão de pacotes da busca

  • Limites de contagem de nós do Source-Route Bridging

Nota: Os realces ao RFC 1795 podem ser encontrados no RFC 2166. Aqueles realces endereçam questões de escalabilidade em DLSw e esclarecimentos ao RFC 1795. O RFC 2166, contudo, faz não 1795 Obsoletos e deve ser usado conjuntamente com 1795.

Configurações de exemplo

As configurações descritas aqui são configurações parciais; não retratam somente parte da configuração exigida para o apoio do DLSw+, e nenhumas do IP ou do outro suporte de protocolo. Como o DLSw+ confia no TCP/IP (exceto quando você usa o FST ou direto), presume-se que a rede IP já esteja ativa e funcionando.

1. Token Ring ao Token Ring sobre WAN

/image/gif/paws/12411/ringwan.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

Router B

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

neste exemplo, coletamos um anel virtual, número de anel 2000, para estabelecer facilmente um relacionamento entre dois grupos. O campo de informação de roteamento (RIF), contudo, é terminado no roteador do DLSw+. Você pode escolher um número de anel virtual diferente para cada roteador. Seja cuidadoso ao escolher o número de anel; você deve seguir as mesmas regras que se aplicam à construção de uma ponte sobre da rota de origem. Atualmente, Cisco apoia somente um anel virtual pelo roteador.

O comando disw local-peer é utilizado para definir seu próprio DLSw + endereço IP do roteador local. No exemplo acima, o endereço IP da interface de loopback é utilizado para que o DLSW+ não precise contar com a interface física real ativada para funcionar.

O comando dlsw remote-peer define o endereço IP no roteador remoto. O número 0 que segue a palavra-chave do peer remoto é o número da lista de toques. Geralmente, se você quer inteiramente uma rede combinada, use o número 0. O número da lista de anéis é usado para controlar a inundação de quadros exploradores, permitindo que a rede seja segmentada (consulte o exemplo dois para obter uma demonstração de lista de anéis).

2. Token Ring ao Token Ring com Anel-lista

/image/gif/paws/12411/ringlist.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

Router B
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 1 tcp 150.150.1.1
dlsw ring-list 1 rings 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

!
interface TokenRing1
ip address 150.150.30.1 255.255.255.0
ring-speed 16
source-bridge 2 1 2000
source bridge spanning 


!--- Allows the router to forward single route explorer frames.

Neste exemplo, todas as estações de trabalho no anel 3 podem somente estabelecer sessões com estações no anel 1, mas não anel 2, e vice-versa. As estações no Anel 1 ainda podem se comunicar com as estações no Anel 2 porque estão conectadas localmente ao Roteador B.

Isto significa que não haverá nenhuma transmissão do anel 2 que será entregado ao roteador A. O uso das instruções dlsw ring-list, port-list e bgroup-list é muito útil quando se deseja o tráfego de difusão sobre a WAN.

3. Token Ring aos Ethernet sobre WAN

/image/gif/paws/12411/ringether.gif

Nesse exemplo, os dispositivos estão localizados em mídia combinada, para que seja necessário trocar bits de endereço MAC do host antes que ele seja codificado no dispositivo secundário que inicia o pacote de teste do explorer. Veja igualmente a compreensão e pesquisando defeitos o Source-Route Translational Bridging.

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.


No exemplo a seguir, a estação do segmento Ethernet pode conversar com as estações do segmento Token Ring. O roteador DLSw+ cuidará da conversão do formato Ethernet no formato Token Ring. O comando dlsw bridge-group é usado para ligar o segmento Ethernet ao processo DLSw+, assim como a instrução de ligação de origem liga o segmento Token Ring ao DLSw+ por meio do ring-group virtual. Você só precisa configurar o SRT/LB se tiver uma interface Token Ring no roteador B e se a comunicação entre estações nesse Token Ring e na Ethernet for necessária. Veja o exemplo 6.

Nota:  não é necessário um grupo de anéis de ponte de origem no roteador B.

Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!

4. Ethernet aos Ethernet sobre WAN

/image/gif/paws/12411/etherwan.gif

Router A
!
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!
Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec

Nota:  O source-bridge ring-group não é necessário em nenhum dos roteadores.

5. Token Ring aos Ethernet no mesmo roteador

/image/gif/paws/12411/tokenether.gif

Se você precisar conectar estações entre Ethernet e Token Ring que são locais ao roteador, use SR/TLB (Translational Bridging). DLSw local entre Ethernet e Token Ring não é apoiado.

Router A

source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1

interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol ieee

Para o comando source-bridge transparent 2000 1000 1 1 nós temos:

  • 2000 é o número de anel virtual configurado pelo comando source-bridge ring-group 2000.

  • 1000 são o pseudo número de anel dado ao domínio ethernet.

  • 1 é o número do Bridge que conduz para o domínio de Transparent Bridging.

  • 1 é o número do grupo da ponte transparente que você deseja vincular ao domínio transposto do roteador de origem.

Nota: Os endereços IP das interfaces não são necessários para SRT/LB.

6. SR/TLB e DLSw+

srtlb.gif

Router A
source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol dec
Router B
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.11.1  255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.

No exemplo acima, o DLSw e o SRT/LB estão configurados. O SRT/LB é exigido somente quando as estações no Token Ring precisam de falar às estações nos Ethernet no mesmo roteador, o roteador A. Se o único requisito for que as estações Ethernet em um roteador A conversem com estações remotas de Token Ring em um roteador B, então o grupo de pontes dlsw 1 cuidará disso.

7. Token Ring ao SDLC over WAN

/image/gif/paws/12411/tokensdlc.gif

Router A
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.


Router B

dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Serial 1
 no ip address
 encapsulation sdlc
 no keepalive
 clockrate 9600
 sdlc role primary

 !--- Assumes SDLC station role secondary for the controller.

 sdlc vmac 4000.9999.0100 

 
!--- Virtual MAC address given to the controller which will 
 !--- have sdlc address (01) appended to it.

 sdlc address 01          

 
!--- SDLC address, obtained from controller configuration.

 sdlc xid 01 05D20001     

 
 !--- 01 is the SDLC address and IDBLK/IDNUM should match that 
 !--- in SMN on the host.

 sdlc partner 4000.1020.1000 01 

 
 !--- 4000.1020.1000 is the MAC address of the host
 !--- and 01 is the SDLC address.
 
 sdlc dlsw 1
!

Nota: A conexão de circuito de DLSw estará entre 4000.9999.0101 e 4000.1020.1000. Também, o exemplo acima supõe um controlador PU2.0. Para outros tipos de PU, consulte o Guia de Troubleshooting de DLSw SDLC.

Os exemplos de configuração acima são algumas encenações da rede comum. Você pode fazer bem mais com o DLSw+, mas essas configurações trazem a você alguns dos conceitos básicos. Mantenha na mente que o DLSw+ é RSRB aumentado com a capacidade de interoperabilidade adicional com o outro Roteadores que é em conformidade com o RFC 1795 e os 2166.


Informações Relacionadas


Document ID: 12411