IP : Serial Tunnel (STUN)

Configurando BSTUN ponto-a-ponto com reconhecimento local em frame relay

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A característica do Bisync Serial Tunnel (BSTUN) permite o apoio para os dispositivos que usam o protocolo de circuito de dados bissíncrono. Este protocolo permite empresas de transportar o tráfego Bisync sobre a mesma rede que apoia seus Systems Network Architecture (SNA) e tráfego de multiprotocolo, que elimina a necessidade para recursos de Bisync separados. Com Frame Relay, você pode usar a característica do reconhecimento local para fornecer a terminação local da sessão no bstun peer.

Neste exemplo, o bstun Point-to-Point é configurado com o Ackowledgement local sobre o Frame Relay. Os estados relevantes na saída do comando show bstun são destacados neste documento.

Nota: Embora os comandos debug bstun packet/event e debug bsc packet/event não devam causar a utilização excessiva CPU, o comando logging buffered é usado copiar a saída ao arquivo de registro.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada no Software Release 12.1(5) de Cisco IOS�.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

bstun_p2p_localack_over_fr-01.gif

Configurações

Este documento utiliza as seguintes configurações:

Kilcot
Building configuration 
!
version 12.1
service timestamps debug datetime msec
!
hostname kilcot
!
! 
bstun peer-name 100.1.1.1
bstun protocol-group 72 bsc-local-ack
!
! 
interface Loopback0
ip address 100.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 10.1.1.1 255.0.0.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Serial1/0
no ip address
ip directed-broadcast
encapsulation bstun
no ip mroute-cache
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc secondary
bstun route all tcp 200.2.2.2
!
!
router rip
network 10.0.0.0
network 100.0.0.0
!
end

Partido
Building configuration...

version 12.1
! 
service timestamps debug datetime msec
!
hostname party
!
bstun peer-name 200.2.2.2
bstun protocol-group 72 bsc-local-ack
!
!
interface Loopback0
ip address 200.2.2.2 255.255.255.0
! 
interface Serial0
no ip address
encapsulation bstun
load-interval 30
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc primary
bstun route all tcp 100.1.1.1
!
interface Serial1
ip address 10.1.1.2 255.0.0.0
encapsulation frame-relay IETF
no ip mroute-cache
frame-relay interface-dlci 17
frame-relay lmi-type ansi
!
!
router rip
network 10.0.0.0
network 200.2.2.0
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração funciona adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show bstun

  • show bsc

kilcot#show bsc
BSC local-ack on Serial1/0:
secondary state is CU_Idle.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Initializing.
   Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
   Rx Counts: 3 frames(total). 0 frames(data). 15 bytes.
 
Total Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
Total Rx Counts: 19 frames(total). 0 frames(data). 59 bytes.

kilcot#show bstun
This peer: 100.1.1.1
 
*Serial1/0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       200.2.2.2                 open         1       3        0

party#show bsc
BSC local-ack on Serial0:
primary state is TCU_Polled.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Inactive.
   Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
   Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Total Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
Total Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
party#show bstun
This peer: 200.2.2.2
 
*Serial0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       100.1.1.1                 open          3       2        0

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

O debug bstun packet/event e debuga a saída do pacote/evento bsc foi copiado ao arquivo de registro. Quando você interpretar este resultado do debug:

  • Dados em série entrantes (SDI) — Pacotes recebidos da relação do Synchronous Data Link Control (SDLC).

  • Dados de rede entrantes (NDI) — Pacotes desencapsulados de WAN.

Nota: Antes de emitir comandos de depuração, consulte Informações Importantes sobre Comandos de Depuração.

kilcot#show log
Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 5088 messages logged
    Trap logging: level informational, 70 message lines logged
          
Log Buffer (100000 bytes):

Dec 28 09:43:21.748: BSC: Serial1/0: POLLEE-FSM event:  E_LineUp old_state: CU_Down.  new_state: CU_Idle.
Dec 28 09:43:21.756: BSC: Serial1/0: SDI-rx: Data (5 bytes):   40407F7F2D
Dec 28 09:43:36.756: BSTUN bsc-local-ack: Serial1/0 SDI:   Data:   401100
Dec 28 09:43:36.756: BSTUN: Change state for peer  (all[72])200.2.2.2/1976 (closed->opening)
Dec 28 09:43:36.756: BSC: Serial1/0: POLLEE-FSM  event: E_RxEnq 
Dec 28 09:43:36.760: BSTUN: Change state for peer   (all[72])200.2.2.2/1976 (opening->open wait)
Dec 28 09:43:36.764: %BSTUN-6-OPENING: CONN:  opening peer (all[72])200.2.2.2/1976, 3
Dec 28 09:43:36.792: bsttcpd_connect:  Refreshing tcp_encaps for group 72
Dec 28 09:43:36.792: %BSTUN-6-OPENED: CONN:  peer (all[72])200.2.2.2/1976 opened, [previous state open wait]
Dec 28 09:43:36.792: BSTUN: Change state for  peer (all[72])200.2.2.2/1976 (open wait->open)
Dec 28 09:43:36.844: BSTUN bsc-local-ack:  Serial1/0 NDI: Data:   401400
Dec 28 09:43:36.848: BSC: Serial1/0: NDI-rx:  Data (3 bytes):  401400
Dec 28 09:43:37.640: %SYS-5-CONFIG_I:  Configured from console by vty0

party#show log
Syslog logging: enabled (0 messages 
   dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 114 messages logged
        Logging to: vty2(114)
    Buffer logging: level debugging, 5199 messages logged
    Trap logging: level informational, 79 message lines logged
          
Log Buffer (100000 bytes):

ec 28 09:48:09.816: %BSTUN-6-PASSIVEOPEN:   passive open 100.1.1.1(11017) -> 1976
Dec 28 09:48:09.836: %BSTUN-6-OPENED: PHDR:  peer (all[72])100.1.1.1/1976 opened, [previous state closed]
Dec 28 09:48:09.836: BSTUN: Change state for  peer (all[72])100.1.1.1/1976 (closed->open)
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 NDI: Data:   401100
Dec 28 09:48:09.836: BSC: Serial0: NDI-rx:  Data (3 bytes):  401100
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 SDI: Data:   401400
Dec 28 09:48:09.836: BSC: Serial0: SDI-tx:  Data (10 bytes):  37FF32323240407F7F2D

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12347