IP : Serial Tunnel (STUN)

Configurando o bstun Point-to-Point

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A característica do Bisync Serial Tunnel (BSTUN) permite o apoio para os dispositivos que usam o protocolo de circuito de dados bissíncrono. Este protocolo permite empresas de transportar o tráfego Bisync sobre a mesma rede que apoia seus Systems Network Architecture (SNA) e tráfego de multiprotocolo, que elimina a necessidade para recursos de Bisync separados. Com Frame Relay, você pode usar a característica do reconhecimento local para fornecer a terminação local da sessão no bstun peer.

Neste exemplo, um bstun Point-to-Point é configurado com reconhecimento local sobre o Frame Relay. Os estados relevantes na saída do comando show bstun foram destacados neste documento.

Nota: Embora os comandos debug bstun packet/event e debug bsc packet/event não devam causar a utilização de CPU em excesso, o comando logging buffered é usado copiar a saída ao arquivo de registro.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada no Software Release 12.1(5) de Cisco IOS�.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12346/bstun_p2p.gif

Configurações

Este documento utiliza as seguintes configurações:

Blutch
Building configuration 
!
version 12.1
service timestamps debug datetime msec
!
hostname Blutch 
!
! 
bstun peer-name 100.1.1.1
bstun protocol-group 72 bsc-local-ack
!
! 
interface Loopback0
ip address 100.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 10.1.1.1 255.0.0.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Serial1/0
no ip address
ip directed-broadcast
encapsulation bstun
no ip mroute-cache
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc secondary
bstun route all tcp 200.2.2.2
!
!
router rip
network 10.0.0.0
network 100.0.0.0
!
end

Newbury
Building configuration...

version 12.1
! 
service timestamps debug datetime msec
!
hostname Newbury 
!
bstun peer-name 200.2.2.2
bstun protocol-group 72 bsc-local-ack
!
!
interface Loopback0
ip address 200.2.2.2 255.255.255.0
! 
interface Serial0
no ip address
encapsulation bstun
load-interval 30
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc primary
bstun route all tcp 100.1.1.1
!
interface Serial1
ip address 10.1.1.2 255.0.0.0
encapsulation frame-relay IETF
no ip mroute-cache
frame-relay interface-dlci 17
frame-relay lmi-type ansi
!
!
router rip
network 10.0.0.0
network 200.2.2.0
!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • show bstun

  • show bsc

Blutch #show bsc
BSC local-ack on Serial1/0:
secondary state is CU_Idle.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Initializing.
   Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
   Rx Counts: 3 frames(total). 0 frames(data). 15 bytes.
 
Total Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
Total Rx Counts: 19 frames(total). 0 frames(data). 59 bytes.

Blutch #show bstun
This peer: 100.1.1.1
 
*Serial1/0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       200.2.2.2                 open         1       3        0

Newbury #show bsc
BSC local-ack on Serial0:
primary state is TCU_Polled.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Inactive.
   Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
   Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Total Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
Total Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Newbury #show bstun
This peer: 200.2.2.2
 
*Serial0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       100.1.1.1                 open          3       2        0

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debug bstun packet/event

  • debugar o pacote/evento bsc

Nota: Quando você interpretar este comando debug:

  • SDI (Dados em série entrantes) — Pacotes recebidos da relação do Synchronous Data Link Control (SDLC)

  • NDI: (Dados de rede entrantes) — Pacotes desencapsulados de WAN.

blutch#debug bstun event
BSTUN event debugging is on

blutch#debug bstun packet
BSTUN packet debugging is on

blutch#
Aug 26 11:29:04.534: BSTUN bsc: Serial0 SDI: Data: 40520040407F7F2D
Aug 26 11:29:04.570: BSTUN bsc: Serial0 NDI: Data: 40D20037
Aug 26 11:29:04.734: BSTUN bsc: Serial0 SDI: Data: 40530040407F7F2D
Aug 26 11:29:04.770: BSTUN bsc: Serial0 NDI: Data: 40D30037
Aug 26 11:29:04.934: BSTUN bsc: Serial0 SDI: Data: 40540040407F7F2D
Aug 26 11:29:04.970: BSTUN bsc: Serial0 NDI: Data: 40D40037
Aug 26 11:29:05.134: BSTUN bsc: Serial0 SDI: Data: 40550040407F7F2D
Aug 26 11:29:05.170: BSTUN bsc: Serial0 NDI: Data: 40D50037
Aug 26 11:29:05.334: BSTUN bsc: Serial0 SDI: Data: 40560040407F7F2D
Aug 26 11:29:05.370: BSTUN bsc: Serial0 NDI: Data: 40D60037
Aug 26 11:29:05.534: BSTUN bsc: Serial0 SDI: Data: 40570040407F7F2D
Aug 26 11:29:05.570: BSTUN bsc: Serial0 NDI: Data: 40D70037
Aug 26 11:29:05.734: BSTUN bsc: Serial0 SDI: Data: 40580040407F7F2D
Aug 26 11:29:05.770: BSTUN bsc: Serial0 NDI: Data: 40D80037
Aug 26 11:29:05.934: BSTUN bsc: Serial0 SDI: Data: 40590040407F7F2D
Aug 26 11:29:05.970: BSTUN bsc: Serial0 NDI: Data: 40D90037
Aug 26 11:29:06.134: BSTUN bsc: Serial0 SDI: Data: 405A0040407F7F2D
Aug 26 11:29:06.170: BSTUN bsc: Serial0 NDI: Data: 40DA0037
Aug 26 11:29:06.334: BSTUN bsc: Serial0 SDI: Data: 405B0040407F7F2D
Aug 26 11:29:06.370: BSTUN bsc: Serial0 NDI: Data: 40DB0037


newbury#debug bstun event
BSTUN event debugging is on

newbury#debug bstun packet
BSTUN packet debugging is on

newbury#
Aug 26 11:26:24.968: BSTUN bsc: Serial0 NDI: Data: 40780040407F7F2D
Aug 26 11:26:24.992: BSTUN bsc: Serial0 SDI: Data: 40F80037
Aug 26 11:26:25.148: BSTUN bsc: Serial0 NDI: Data: 40790040407F7F2D
Aug 26 11:26:25.172: BSTUN bsc: Serial0 SDI: Data: 40F90037
Aug 26 11:26:25.348: BSTUN bsc: Serial0 NDI: Data: 407A0040407F7F2D
Aug 26 11:26:25.372: BSTUN bsc: Serial0 SDI: Data: 40FA0037
Aug 26 11:26:25.548: BSTUN bsc: Serial0 NDI: Data: 407B0040407F7F2D
Aug 26 11:26:25.572: BSTUN bsc: Serial0 SDI: Data: 40FB0037
Aug 26 11:26:25.748: BSTUN bsc: Serial0 NDI: Data: 407C0040407F7F2D
Aug 26 11:26:25.772: BSTUN bsc: Serial0 SDI: Data: 40FC0037
Aug 26 11:26:25.948: BSTUN bsc: Serial0 NDI: Data: 407D0040407F7F2D
Aug 26 11:26:25.972: BSTUN bsc: Serial0 SDI: Data: 40FD0037
Aug 26 11:26:26.148: BSTUN bsc: Serial0 NDI: Data: 407E0040407F7F2D
Aug 26 11:26:26.172: BSTUN bsc: Serial0 SDI: Data: 40FE0037
Aug 26 11:26:26.348: BSTUN bsc: Serial0 NDI: Data: 407F0040407F7F2D
Aug 26 11:26:26.372: BSTUN bsc: Serial0 SDI: Data: 40FF0037
Aug 26 11:26:26.548: BSTUN bsc: Serial0 NDI: Data: 40400040407F7F2D
Aug 26 11:26:26.572: BSTUN bsc: Serial0 SDI: Data: 40C00037
Aug 26 11:26:26.748: BSTUN bsc: Serial0 NDI: Data: 40410040407F7F2D
Aug 26 11:26:26.772: BSTUN bsc: Serial0 SDI: Data: 40C10037

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12346