IP : Serial Tunnel (STUN)

Exemplo da configuração de encapsulamento direto STUN

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para o encapsulamento direto do Serial Tunnel (STUN). Os estados relevantes na saída do comando show stun e as mudanças de estado no comando debug são mostrados na verificação e pesquisam defeitos seções deste documento.

Embora os comandos debug stun packet e debug stun event não devam causar a utilização de CPU em excesso, o comando logging buffered é usado copiar a saída ao arquivo de registro.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada no Software Release 12.0(8) do ½ do ¿  de Cisco IOSï com características IBM para a configuração STUN.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12277/19_a.gif

Configurações

Este documento utiliza as seguintes configurações:

Cloclo
cloclo# show run

Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cloclo
!
boot system flash rsp-jsv-mz.120-8
logging buffered 64000 debugging
no logging console
enable password cisco
!
microcode CIP flash slot0:cip27-3
microcode reload
ip subnet-zero
no ip domain-lookup
ip cef
!
!
stun peer-name 10.10.10.10
stun protocol-group 2 sdlc
!
!
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation stun
 no ip mroute-cache
 clockrate 9600
 stun group 2
 stun route address 1 interface Serial0/1
!
interface Serial0/1
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!

!--- Output suppressed.

!
interface Ethernet1/0
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!

!--- Output suppressed.

!
router eigrp 100
 network 10.0.0.0
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end
cloclo#

Fairbanks
fairbanks# show run

Building configuration...
Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname fairbanks
!
boot system flash
 logging buffered 64000 debugging
no logging console
enable password cisco
!
ip subnet-zero
!
!
stun peer-name 10.20.20.20
stun protocol-group 2 sdlc
!
!
!
!
interface Loopback0
 ip address 10.20.20.20 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Ethernet1
 ip address 172.17.240.12 255.255.255.0
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation stun
 no ip mroute-cache
 clockrate 9600
 stun group 2
 stun route address 1 interface Serial2
!

!--- Output suppressed.

!
interface Serial2
 ip address 10.2.1.2 255.255.255.0
 no ip directed-broadcast
 clockrate 19200
!

!--- Output suppressed.

!
router eigrp 100
 network 10.0.0.0
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end
fairbanks#

Verificar

Esta seção fornece a informação que você pode usar para confirmar que sua configuração está trabalhando corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

O comando show stun output para ambo o Roteadores é mostrado nesta seção. Mostra que o estado ATURDIR de cada roteador está aberto. Também, os contadores para pacotes recebidos (rx_pkts) e para pacotes transmitido (tx_pkts) incrementam cada vez que você emite o comando show stun.

cloclo# show stun

This peer: 10.10.10.10
  *Serial0/0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial0/1        open             4510      4513         0
fairbanks# show stun

This peer: 10.20.20.20
  *Serial0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial2          open             2260      2257         0

fairbanks# show stun

This peer: 10.20.20.20
  *Serial0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial2          open             2270      2267         0

Troubleshooting

Esta seção fornece informações que você pode utilizar para fazer troubleshooting de configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

  • debug stun packet — Indica a informação sobre os pacotes que viajam através dos links ATURDIR.

  • debug stun event — Conexões de STUN e atividade dos indicadores.

Debugar captações durante a ativação de STUN

cloclo# show log

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 232 messages logged
    Trap logging: level informational, 43 message lines logged

Log Buffer (64000 bytes):

!--- These timestamped lines each appear on one line in normal output:

*Nov  3 11:35:06.191: %LINK-3-UPDOWN:
  Interface Serial0/1, changed state to up
*Nov  3 11:35:07.191: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial0/1, changed state to up
*Nov  3 11:35:31.819: %LINK-3-UPDOWN:
  Interface Serial0/0, changed state to up
*Nov  3 11:35:32.819: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial0/0, changed state to up
*Nov  3 11:35:36.631: STUN sdlc:
  00:04:12 Serial0/0       SDI: (001/008) U: SNRM    PF:1  
*Nov  3 11:35:37.831: STUN sdlc:
  00:00:01 Serial0/0       SDI: (001/008) U: SNRM    PF:1  
*Nov  3 11:35:37.859: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) U: UA      PF:1  
*Nov  3 11:35:37.879: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:37.907: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.031: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.059: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.091: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) I:         PF:0  NR:000  NS:000
*Nov  3 11:35:38.231: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.295: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) I:         PF:1  NR:001  NS:000
*Nov  3 11:35:38.431: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.459: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.555: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) I:         PF:0  NR:001  NS:001
*Nov  3 11:35:38.631: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.691: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) I:         PF:1  NR:002  NS:001
*Nov  3 11:35:38.831: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:38.859: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.031: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.059: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.231: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.259: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.431: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.563: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  

cloclo#
fairbanks# show log

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 203 messages logged
    Trap logging: level informational, 40 message lines logged

Log Buffer (64000 bytes):

!--- These timestamped lines each appear on one line in normal output:

*Nov  3 09:38:12.759: %SYS-5-CONFIG_I:
  Configured from console by console
*Nov  3 09:38:14.231: %LINK-3-UPDOWN:
  Interface Serial2, changed state to up
*Nov  3 09:38:15.231: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial2, changed state to up
*Nov  3 09:38:44.687: STUN sdlc:
  00:04:41 Serial0         NDI: (001/008) U: SNRM    PF:1  
*Nov  3 09:38:45.887: STUN sdlc:
  00:00:01 Serial0         NDI: (001/008) U: SNRM    PF:1  @
*Nov  3 09:38:45.899: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) U: UA      PF:1  
*Nov  3 09:38:45.935: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:45.947: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.087: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.099: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.155: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) I:         PF:0  NR:000  NS:000
*Nov  3 09:38:46.287: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.323: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) I:         PF:1  NR:001  NS:000
*Nov  3 09:38:46.487: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.499: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.615: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) I:         PF:0  NR:001  NS:001
*Nov  3 09:38:46.687: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.719: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) I:         PF:1  NR:002  NS:001
*Nov  3 09:38:46.887: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:46.899: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.087: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.099: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.287: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.299: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
 
fairbanks#

Informações Relacionadas


Document ID: 12277