Cisco Interfaces and Modules : Processadores de interface de canal da Cisco

Executando OROUTED para Trocar as Atualizações do RIP Routing

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento dá um exemplo da configuração exigida no roteador e na unidade central às atualizações de RIP Routing de intercâmbio com o uso do procedimento orouted. O OROUTED é um procedimento que sejam executado na unidade central e que execute essencialmente a mesma função que quando você executa o demónio ROTEADO em um host Unix. O OROUTED é executado do espaço de endereços de OpenEdition/armazenamento virtual múltiplo (OMVS) ou como uma tarefa começada.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Esta configuração foi desenvolvida e testada com estes a versão de software e hardware:

  • Software Release 12.1(2) do � do Cisco IOS com microcódigo xcpa27-7 do adaptador de porta do canal de mainframe (XCPA).

    Esta era a versão de código a mais atrasada liberada naquele tempo, mas estas características devem ser apoiadas em todas as versões principal atualmente mantidas do código.

  • O roteador é um Cisco 7206 com um PCPA (adaptador de porta do canal paralelo).

O OROUTED exige estes dois arquivos de configuração na unidade central no espaço de endereço omvs, com variáveis de ambiente que apontam a seu lugar:

  • exportação ROUTED_PROFILE=/etc/orouted.profile

  • exportação RESOLVER_CONF=/etc/resolv.conf

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

A fim começar o OROUTED, emita estes comandos de dentro do OMVS:

cd /usr/lpp/tcpip/sbin

orouted

No console MVS, você pode emitir este comando a fim encontrar o número do processo do processo orouted:

d omvs,u=p390

Nota:  p390 é a identificação do fazer logon sob que o OROUTED foi começado.

Você pode igualmente começar o processo orouted com a linguagem de controle de tarefas (JCL), como uma tarefa começada. Se você a começa do OMVS, mude a porta 520 no conjunto de dados do perfil TCP/IP ao OMVS.

Estes são exemplos dos conjunto de dados:

/etc/orouted.profile
RIP_SUPPLY_CONTROL: RIP1
RIP_RECEIVE_CONTROL: ANY
RIP2_AUTHENTICATION_KEY:
/etc/resolv.conf
TCPIPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

TCP/IP profile dataset configuration changes
--------------------------------------------

; ----------------------------------------------------------------------- ;

;
orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask      Dest Addr
BSDROUTINGPARMS false
LDIPTG         1500       0     255.255.255.240  10.64.3.33
VIPALINK       1500       0     255.255.255.240  0
ENDBSDROUTINGPARMS
; -----------------------------------------------------------------------
RIP

Configuração

Roteador do processador de interface de canal (CIP)
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname diplodocus
!
boot system flash slot1:c7200-a3js-mz.121-2.bin
!
!
!
!
!
microcode pcpa slot1:xcpa27-9
microcode reload
!
interface Channel2/0
ip address 10.64.3.33 255.255.255.240
no keepalive
csna 0100 41
csna 0100 42
cmpc 0100 24 DIPTG READ
cmpc 0100 25 DIPTG WRITE
lan TokenRing 0
source-bridge 4 1 1
adapter 0 4000.0000.0001
adapter 1 4000.0000.0002
adapter 2 4000.0000.0003
adapter 3 4000.0000.0004
adapter 4 4000.0000.0005
lan TokenRing 1
source-bridge 5 1 1
adapter 7 4000.0000.0001
tn3270-server
pu PU1	    01712444 10.64.3.35      token-adapter 1  04 rmac
4000.0000.0001   lu-seed DIPL###
pu PU2	    01712555 10.64.3.36      token-adapter 1  08 rmac
4000.0000.0001   lu-seed DIPL2##
tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
!
!
router eigrp 1
redistribute rip
passive-interface Channel2/0
network 10.0.0.0
passive-interface Ethernet6/1
passive-interface Ethernet6/3
network 10.0.0.0
!
no auto-summary
!
router rip
redistribute eigrp 1
passive-interface Serial1/3
  
 passive-interface TokenRing5/0

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12258