Cisco Interfaces and Modules : Processadores de interface de canal da Cisco

Configurando OMPROUTE para execução no computador central

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento esboça o exemplo de host e as configurações de roteador para executar o procedimento de OMPROUTE na unidade central para trocar atualizações de roteamento com o resto da rede TCP/IP. O OMPROUTE é usado frequentemente, como neste exemplo, conjuntamente com um endereço IP de Um ou Mais Servidores Cisco ICM NT virtual (VIPA), que permita o endereço IP de Um ou Mais Servidores Cisco ICM NT da unidade central configurada nos clientes para ser independente de toda a uma interface do canal. Isto fornece a Redundância para o canal. Originalmente, a aplicação da unidade central TCP/IP do IBM apoiou somente o Routing Information Protocol (RIP) como um protocolo de roteamento, com o uso do procedimento orouted. O OMPROUTE mais novo apoia o RASGO V1 ou o V2 e o Open Shortest Path First (OSPF). O IBM recomenda que o OMPROUTE esteja usado um pouco do que o OROUTED, e o IBM removerá eventualmente o apoio para o OROUTED.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

O software release de Cisco IOS� que foi usado para esta configuração era 12.1(3a)T2 com micro-código xcpa 27-9, que estava o mais atrasado naquele tempo isto foi testado. Se você está usando a GARRA, contudo, esta deve trabalhar com toda a versão de Cisco IOS Software. O uso do CMPC+ exige um mínimo de Cisco IOS Software Release 12.1T.

O roteador era um Cisco 7206 com um adaptador de porta xcpa. Alternativamente, um Cisco 7500 Router com uma placa CIP poderia ser usado com alterações secundárias na configuração, como notável mais tarde neste documento.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurações

Configuração de computador central - Arquivos OMPROUTE

A configuração do OMPROUTE na unidade central é muito similar à configuração do OROUTED. O OMPROUTE igualmente usa um mínimo de dois arquivos de configuração. Você deve apontar ao lugar destes arquivos de configuração, no espaço de endereço omvs, com estes dois variáveis de ambiente:

  • exportação resolver_conf=/etc/resolv.conf

  • exportação omproute_file=/etc/omproute.conf

Este é um exemplo dos índices do resolver_conf:

TCPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

O omproute_file dependerá sobre se o RASGO ou o OSPF estão sendo usados. Este é um exemplo de configuração para o RASGO:

;
Originate_RIP_Default Condition=Always Cost=1
;
RIP_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Receive_Dynamic_Nets=YES
Receive_Dynamic_Subnets=YES
MTU=1470
Destination_Addr=10.64.3.33
;
RIP_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240
MTU=1470
;

Para o OSPF, há mais opções de configuração disponíveis, que incluem a capacidade para fazer a unidade central atuar como uma área de stub. Isto pode significativamente reduzir as atualizações de roteamento da carga que são colocadas no canal quando muitas separações lógicas (LPARs) estão conectando sobre o mesmo canal. Este é um exemplo:

Area Area_Number=0.0.0.0 Authentication_Type=None Stub_Area=NO
;
Comparison=Type2
;
AS_Boundary_Routing Import_Subnet_Routes=YES
Import_Direct_Routes=YES
;
OSPF_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Attaches_To_Area=0.0.0.0
MTU=1470
Destination_Addr=10.64.3.33
Hello_Interval=30
Dead_Router_Interval=120
;
OSPF_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240

Configuração de mainframe - Pilha TCP/IP

O conjunto de dados do perfil TCP/IP não exige nenhuma configuração especial para o OMPROUTE, a não ser o fato de que você deve comentar para fora toda a configuração da estática e da rota padrão e a seção BSDROUTINGPARMS (que é usada somente pelo OROUTED). Este extrato mostra somente o que deve ser comentado para fora e os parâmetros que os arquivos de configuração OMPROUTE referem:

TCPIP Profile dataset
---------------------
 -----------------------------------------------------------------------
; Hardware definitions:
 -----------------------------------------------------------------------
; NOTE: To use these device and link statements, update the statements
; to reflect your installation configuration and remove the semicolon
;
DEVICE DIPTG MPCPTP
LINK LDIPTG MPCPTP DIPTG
DEVICE VIPADEV VIRTUAL 0
LINK VIPALINK VIRTUAL 0 VIPADEV
;
;
; -----------------------------------------------------------------------
;
; HOME Internet (IP) addresses of each link in the host.
;
; NOTE: To use this home statement, update the ipaddress and linknames 
; to reflect your installation configuration and remove the semicolon
;
HOME
10.64.3.17    VIPALINK
10.64.3.34    LDIPTG
; -----------------------------------------------------------------------
;
; IP routing information for the host.	All static IP routes should
; be added here.
;
; NOTE: To use this GATEWAY statement, update the addresses and links
; to reflect your installation configuration and remove the semicolon
;
; GATEWAY
;
; Direct Routes - Routes that are directly connected to my interfaces.
;
; Network  First Hop  Link Name Packet Size  Subnet Mask  Subnet Value
; 10           =       CIS1      1500       0.255.255.0    0.101.1
; 10           =       LDIPTG    1500       0.255.255.240  0.64.3.32
; 9            =       LIS1      1500       0.255.255.0    0.117.56.0
; 130.50       =       TR1       2000       0.0.255.0      0.0.10.0
; 193.5.2      =       ETH1      1500       0
; 9            =       FDDI1     4000       0.255.255.0    0.67.43.0
; 193.7.2.2    =       SNA1      2000       HOST
;
; Indirect Routes - Routes that are reachable through routers on my
;		    network.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  10.64.3.33  LDIPTG    DEFAULTSIZE  0
; 193.12.2    130.50.10.1 TR1       2000         0
; 10.5.6.4    193.5.2.10  ETH1      1500         HOST
;
; Default Route - All packets to an unknown destination are routed
;		  through this route.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  9.67.43.1   FDDI1     DEFAULTSIZE  0
;
; -----------------------------------------------------------------------
;
; orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask     Dest Addr
; BSDROUTINGPARMS false
; LDIPTG       1500       0     255.255.255.240 10.64.3.33
; VIPALINK     1500       0     255.255.255.240 0
;    TR1       2000       0     255.255.255.0   0
;    ETH1      1500       0     255.255.255.0   0
;    FDDI1  DEFAULTSIZE   0     255.255.255.0   0
; ENDBSDROUTINGPARMS

!--- Note that all of the last two sections have been commented out.

Configuração de mainframe - TCP/IP das definições de vtam e começar

As atualizações de roteamento podem ser trocadas sobre conexões da GARRA ou CMPC+. Se você está usando a GARRA, nenhuma configuração adicional é exigida na unidade central. Este exemplo usa CMPC, que exige uma entrada do Transport Resource List VTAM (TRL). Este é o membro VTAM:

DIPTGTRL VBUILD TYPE=TRL
*
*
DIPTG	 TRLE  LNCTL=MPC,MAXBFRU=16,READ=(E24),WRITE=(E25)
*

O TRL deve ser ativado antes da tarefa começada TCPIP é começado. Por exemplo:

V NET,ACT,ID=DIPTRL1,UPDATE=ALL
IST097I VARY ACCEPTED
ISTTRL ACTIVE

Então, ative a tarefa começada TCP/IP com o comando console dos TCPIP MV S. Uma vez que a tarefa começada TCP/IP está sendo executado, o procedimento de OMPROUTE pode ser começado, com o uso da linguagem de controle de tarefas (JCL) como uma tarefa começada ou de dentro do espaço de endereço omvs. Para começar dentro do OMVS, emita estes comandos:

cd /usr/lpp/tcpip/sbin

omproute &

Para certificar-se do OMPROUTE esteja sendo executado, emita este comando console, onde p390 é o usuário - a identificação sob que o daemon de OMPROUTE foi começado:

d omvs,u=p390

Configuração do roteador

a GARRA e CMPC devem especificamente ser configurados para enviar transmissões sobre o canal, com a palavra-chave da transmissão. Por exemplo, para a GARRA:

claw 0100 20 10.101.1.10 P390D C7000D TCPIP TCPIP broadcast

Neste exemplo, o CMPC+ está no uso, assim que estas são as partes relevantes da configuração de roteador:

!
interface Channel2/0
 ip address 10.64.3.33 255.255.255.240
 ip ospf network point-to-multipoint
 no keepalive
 cmpc 0100 24 DIPTG READ
 cmpc 0100 25 DIPTG WRITE
 tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
 router ospf 1
  network 10.0.0.0 0.255.255.255 area 0
!

Se este tinha sido um Cisco 7500 Router com uma placa CIP em vez de uns 7200 com um adaptador de porta xcpa, a indicação tg seria configurada sob a relação virtual de /2. Note o comando ip ospf network point-to-multipoint, que é exigido para que o OSPF funcione corretamente. A interface do canal é considerada uma interface multiponto bem como o Frame Relay. Se você não deseja executar o OSPF durante todo sua rede, você pode executá-la somente na interface do canal própria e usar a redistribução entre outros protocolos de roteamento. Por exemplo:

!
router eigrp 1
 redistribute ospf 1
 passive-interface Channel2/0
 network 10.0.0.0
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1
 network 10.64.3.33 0.0.0.0 area 0
!

Indicadores no roteador

diplodocus# show extended channel 2/0 status

Path: 0100  -- ESTABLISHED
       Command    Selective   System     Device    CU
Dev    Connects    Retries    Cancels    Reset    Reset    Errors    Busy
24        30         21          1         0        0        0        0
25        29         0           1         0        0        0        0
Blocks         Bytes         Dropped Blk         Memd
Dev-Lnk    Read    Write    Read    Write    Read    Write    wait    Con
24-00       29       6      3484     789      0        0       0       Y
25-00        9      29       801    3920      0        0       0       Y
Path 0100
Total:      38      35      4285    4709      0        0       0
Last statistics 0 seconds old, next in 10 seconds

diplodocus# show extended channel 2/0 cmpc

Path    Dv    TGName    Dir    Bfrs     Status
CMPC   0100     24     DIPTG  READ  16  Active+
CMPC   0100     25     DIPTG  WRITE 16  Active+

diplodocus# show ip ospf i

Channel2/0 is up, line protocol is up
Internet Address 10.64.3.33/28, Area 0
Process ID 1, Router ID 200.100.100.9, Network Type POINT_TO_MULTIPOINT,
Cost: 4
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:10
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.64.3.17
Suppress hello for 0 neighbor(s)

diplodocus# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address       Interface
10.64.3.17       1    FULL/  -        00:01:35
Neighbor is up for 00:04:01           10.64.3.34  Channel2/0

diplodocus# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 10.64.3.1 to network 0.0.0.0
1.0.0.0/27 is subnetted, 1 subnets
C	1.1.1.0 is directly connected, Loopback1
200.100.100.0/29 is subnetted, 1 subnets
C	200.100.100.8 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D	10.0.0.0/8 is a summary, 00:06:40, Null0
C	10.64.3.0/28 is directly connected, Ethernet6/0
O E2	10.64.3.17/32 [110/1] via 10.64.3.34, 00:03:57, Channel2/0
O	10.64.3.16/28 [110/5] via 10.64.3.34, 00:03:57, Channel2/0
C	10.64.3.32/28 is directly connected, Channel2/0
S	10.64.3.34/32 [1/0] via 10.64.3.34, Channel2/0
S	10.64.3.37/32 [1/0] via 10.64.3.37, Channel2/0
C	10.64.3.48/28 is directly connected, Serial1/3.1
C	10.64.3.128/28 is directly connected, Serial1/3.2
S*   0.0.0.0/0 [1/0] via 10.64.3.1

Aparece em mainframe

Exibições de VTAM no console do sistema

D NET,TRL

IST097I DISPLAY ACCEPTED
ST350I DISPLAY TYPE = TRL 042
IST1314I TRLE = DIPTG	  STATUS = ACTIV       CONTROL = MPC
IST1454I 1 TRLE(S) DISPLAYED
IST314I END

D NET,TRL,TRLE=DIPTG

IST097I DISPLAY ACCEPTED
IST075I NAME = DIPTG, TYPE = TRLE 045
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST087I TYPE = LEASED		  , CONTROL = MPC , HPDT = YES
IST1715I MPCLEVEL = HPDT       MPCUSAGE = SHARE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = ***NA***
IST1221I WRITE DEV = 0E25 STATUS = ACTIVE     STATE = ONLINE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = DATASPACE
IST1221I READ  DEV = 0E24 STATUS = ACTIVE     STATE = ONLINE
IST314I END

Indicadores de informação do roteamento sob o TSO do comando netstat

a rota do netstat indica a tabela de roteamento. Por exemplo:

===> netstat route

EZZ2350I MVS TCP/IP NETSTAT CS V2R7       TCPIP NAME: TCPIP       15:56:33
EZZ2755I Destination       Gateway       Flags  Refcnt  Interface
EZZ2756I -----------       -------       -----  ------  ---------
EZZ2757I 10.0.0.0          10.64.3.33    UG     000000  LDIPTG
EZZ2757I 10.64.3.32        0.0.0.0       U      000000  LDIPTG
EZZ2757I 10.64.3.33        0.0.0.0       UH     000000  LDIPTG

exibições de dispositivo do netstat o estado e assim por diante de todos os dispositivos conectados ou links. Por exemplo:

===> netstat device

EZZ2350I MVS TCP/IP NETSTAT CS V2R7	  TCPIP NAME: TCPIP	   15:58:04
EZZ2760I DevName: LOOPBACK	    DevType: LOOPBACK  DevNum: 0000
EZZ2761I   LnkName: LOOPBACK	      LnkType: LOOPBACK    Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000004278   ByteOut: 0000004278
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 00000		 Metric: 00
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 0.0.0.0
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No
EZZ2760I DevName: DIPTG 	    DevType: MPC       DevNum: 0000
EZZ2761I   LnkName: LDIPTG	      LnkType: MPC	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000001848   ByteOut: 0000001936
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: Yes
EZZ2812I     Group            RefCnt
EZZ2813I     -----            ------
EZZ2814I     224.0.0.5        0000000001
EZZ2814I     224.0.0.1        0000000001
EZZ2760I DevName: VIPADEV	    DevType: VIPA      DevNum: 0000
EZZ2761I   LnkName: VIPALINK	      LnkType: VIPA	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000000000   ByteOut: 0000000000
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No

Há muito mais opções disponíveis com netstat. Você pode emitir o netstat? comando indicá-los todos.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12257