Tecnologias IBM : Data-Link Switching (DLSw) e Data-Link Switching Plus (DLSw+)

Data Link Switching Plus

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O switching de link de dados (DLSw) é um padrão executado pelo IBM que apoia o transporte do Logical Link Control (LLC) sobre WAN. DLSw é um formulário mais elaborado do Remote Source-Route Bridging (RSRB) e é mais específico a respeito do que pode ou não pode construir uma ponte sobre. DLSw exige que o roteador transporta uma sessão LLC2 válida ou uma sessão netbios.

RFC 1795 do implementar dos roteadores Cisco (padrão DSLw) e 2166 (versão 2 de DLSw). Também, DLSw executa mais características para o controle de transmissão e transporta menos informação através de WAN do que outros métodos.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Comandos gerais

Esta seção cobre comandos dlsw importantes, comandos para configurar DLSw, e comandos para pesquisar defeitos DLSw.

anel-grupo da fonte-ponte

A primeira etapa em configurar DLSw é adicionar o comando source-bridge ring-group. Isto conecta as interfaces de token ring que executam a conexão de ligação de rota de origem (SRB).

Tarefa Comando
Defina um grupo de toque. source-bridge ring-group ring-group [endereço-mac-virtual]

Nota: Ao executar DLSw em um roteador que tenha somente interfaces Ethernet, não há nenhuma necessidade de estabelecer um anel-grupo.

Defina a identificação do peer local

A opção seguinte é definir a identificação do peer local. Este é um endereço IP de Um ou Mais Servidores Cisco ICM NT na mesma caixa. Isto começa basicamente DLSw no roteador.

Tarefa Comando
Defina o peer DLSw+ local. [biu-segment] do [promiscuous] do [passive] do [keepalive seconds] do [lf size] do [cost cost] do [border] do [group group] do [peer-id ip-address] do local-par do dlsw

A maioria de opção básica em configurar DLSw é estabelecer o local peer-id ip-address. Estas são descrições dos parâmetros de comando:

  • grupo e beira — Estes comandos são emitidos junto criar border peer na rede.

  • custo — Este comando é emitido quando há caminhos múltiplos ao mesmo lugar. Este comando diz ao roteador como alcançar estes locais remotos usando o caminho de custo mais baixo primeiramente.

  • lf — Este comando determina o tamanho do frame o maior que este par pode segurar. Os tamanhos do frame podem ser:

    • máximo de bytes do tamanho do frame do 516-516

    • 1470-1470 máximo de bytes do tamanho do frame

    • Tamanho máximo de estrutura: 1500-1500 bytes

    • Tamanho máximo de quadro 2052-2052 bytes

    • 4472-4472 máximo de bytes do tamanho do frame

    • 8144-8144 máximo de bytes do tamanho do frame

    • Tamanho máximo do quadro de 11407-11407 bytes

    • Tamanho máximo de estrutura 11454 a 11454 bytes

    • 17800-17800 máximo de bytes do tamanho do frame

  • keepalive — Este comando define os pacotes keepalive no meio do intervalo. O intervalo pode variar de 0 a 1200 segundos. É ajustado geralmente a 0 ao configurar DLSw para o Dial-on-Demand Routing (DDR).

  • passivo — Este comando configura o roteador para não iniciar uma partida do par do roteador.

  • promíscuo — Este comando significa que o roteador aceita conexões de todo o peer remoto que pede uma partida do par. Este comando é útil nos grandes locais que têm muitos pares, porque você não tem que definir todos os peer remotos no roteador central.

  • biu-segmento — Este comando é uma opção para DLSw que permite DLSw controlar mais altamente o tamanho do segmento nas camadas do System Network Architecture (SNA). Este comando permite as estações final acredita que podem enviar quantidades maiores de dados.

Defina o peer remoto

Após ter definido o peer local, você define o peer remoto. Você pode definir três tipos de pares: O TCP, o Fast-Sequenced Transport (FST), e dirige o controle de link de nível elevado (HDLC) e o Frame Relay. Estas são explicações dos comandos emitidos para definir o peer remoto:

Tarefa Comando
Encapsulamento direto sobre Frame Relay [pass-thru] do [lsap-output-list list] do [linger minutes] do [lf size] do [keepalive seconds] do [host-netbios-out host-list-name] do [dmac-output-list access-list-number] do [dest-mac mac address] do [cost cost] do [bytes-netbios-out bytes-list-name] do [backup-peer ip-address] do DLCI-número do número de série da interface do Frame Relay do número de lista do remoto-par do dlsw
Encapsulamento direto sobre HDLC [pass-thru] do [lsap-output-list list] do [linger minutes] do [lf size] do [keepalive seconds] do [host-netbios-out host-list-name] do [dmac-output-list access-list-number] do [dest-mac mac address] do [cost cost] do [bytes-netbios-out bytes-list-name] do [backup-peer ip-address] do número de série da relação do número de lista do remoto-par do dlsw
FST [pass-thru] do [lsap-output-list list] do [linger minutes] do [lf size] do [keepalive seconds] do [host-netbios-out host-list-name] do [dmac-output-list access-list-number] do [dest-mac mac address] do [cost cost] do [bytes-netbios-out bytes-list-name] do [backup-peer ip-address] do IP address do fst do número de lista do remoto-par do dlsw
TCP [tcp-queue-max size] do [priority] do [no-llc minutes] do [lsap-output-list list] do [linger minutes] do [lf size] do [keepalive seconds] do [inactivity minutes] do [host-netbios-out host-list-name] do [dynamic] do [dmac-output-list access-list-number] do [dest-mac mac address] do [cost cost] do [bytes-netbios-out bytes-list-name] do [backup-peer ip-address] do dlsw remote-peer list-number tcp ip-address [intervalo seconds][v2-single-tcp]

Estas são as descrições do comando options:

  • peer de backup — Este comando option define o par que suporta este par caso o primeiro par falhar.

  • custo — Este comando option define o custo deste par. Este comando está usado quando há caminhos múltiplos a um destino e quando você precisa uma encenação preferir-capaz.

  • dest-MAC, dinâmico, nenhum-LLC e inatividade — estes o comando options é discutido na seção do peer de custo/backup deste documento.

  • Dmac-output-list — Este comando option é emitido definir uma lista de acessos que diga o roteador que destino remoto MAC o endereça a licença, ou o negue, tráfego de explorador.

  • Host-netbios-out — Este comando option é emitido aplicar nomes do filtro do host de NetBIOS.

  • keepalive — Este comando option é emitido determinar o intervalo nos segundos entre o Keepalives. É usado na maior parte para instalações DDR.

  • lf — Este comando option especifica o tamanho o maior permitido para o par.

  • atrase-se — Este comando option especifica a quantidade de tempo que o roteador deixa o peer de backup aberto que se torna ativo (devido à falha principal) depois que o link principal se torna ativo outra vez.

  • prioridade — Este comando option cria peer múltiplos para a prioridade do tráfego de DLSw.

  • tcp-queue-max — Este comando option muda o valor padrão de 200 para as filas TCP.

  • intervalo — Este comando option é o número de segundos que o TCP espera um reconhecimento antes de rasgar para baixo a conexão.

  • V2-single-tcpM — Este comando option é projetado para o uso em ambientes do Network Address Translation (NAT). Cada par pensa tem o endereço IP de Um ou Mais Servidores Cisco ICM NT mais alto para impedir que cada par rasgue para baixo uma das conexões de TCP.

Temporizadores usados em DLSw

Estas são explicações dos temporizadores usados em DLSw:

Parâmetro Descrição
icannotreach-block-time A vida cache dos recursos inalcançável, durante que procura por esse recurso é obstruída. O intervalo válido é 1 a 86400 segundos. O padrão é 0 (desabilitado)
netbios-cache-timeout Vida cache da localização do nome de netbios para ambos esconderijo da alcançabilidade local e remota. O intervalo válido é 1 a 86400 segundos. O padrão é 16 minutos.
netbios-explorer-timeout Intervalo de tempo que o software IOS� espera uma resposta de explorador antes de marcar um recurso inacessível (LAN e WAN). O intervalo válido é 1 a 86400 segundos. O padrão é os segundos 6.
Netbios-retry-interval Intervalo de nova tentativa do NetBIOS explorer (LAN somente). O intervalo válido é 1 a 86400 segundos. O padrão é 1 segundo.
netbios-verify-interval Intervalo entre a criação de uma entrada de cache e quando a entrada for marcada como velho. Se uma solicitação de pesquisa entra para uma entrada de cache antiga, dirigido verifica que a pergunta está enviada para se assegurar de que ainda exista. O intervalo válido é 1 a 86400 segundos. O padrão é 4 minutos.
sna-cache-timeout Intervalo de tempo que uma entrada de cache do lugar do Access point SNA MAC/Service (SAP) existe antes que estiver rejeitado (local e remoto). O intervalo válido é 1 a 86400 segundos. O padrão é 16 minutos.
sna-explorer-timeout Intervalo de tempo que o IOS Software espera uma resposta de explorador antes de marcar um recurso inacessível (LAN e WAN). O intervalo válido é 1 a 86400 segundos. O padrão é 3 minutos.
sna-retry-interval Intervalo entre as novas tentativas do explorador SNA (LAN). O intervalo válido é 1 a 86400 segundos. O padrão é 30 segundos.
Sna-verify-interval Intervalo entre a criação de uma entrada de cache e quando a entrada for marcada como velho. Se uma solicitação de pesquisa entra para uma entrada de cache antiga, dirigido verifica que a pergunta está enviada para assegurar que ainda existe. O intervalo válido é 1 a 86400 segundos. O padrão é 4 minutos.
explorer-wait-time Cronometre, nos segundos, que o roteador espera todos os exploradores para retornar antes de determinar que par a se usar.

Estes parâmetros são muito úteis. Por exemplo, você pode mudar o intervalo nos segundos que o roteador envia um explorador. Isto ajuda a reduzir a quantidade de explorers na rede aumentando o tempo entre eles. Também, você pode mudar os valores em que o roteador cronometra para fora as entradas de cache.

Comandos dlsw adicionais

Estes são comandos dlsw importantes adicionais:

  • dlsw allroute-SNA/NetBIOS — Este comando é emitido mudar o comportamento de DLSw de modo que todos os exploradores de rota sejam usados em vez dos exploradores de rota única.

  • ponte-grupo do dlsw — Este comando é emitido amarrar transparentemente domínios interligado com DLSw. É usado extensivamente ao configurar NetBIOS com Ethernet.

  • explorerq-profundidade do dlsw — Este conjuntos de comandos o valor da fila do explorador de DLSw. Este comando é emitido após o comando explorer-queue regular da fonte-ponte, mas refere todos os quadros CANUREACH (CUR) que precisam de ser processados. Este comando é importante porque cobre os pacotes dos Ethernet, mesmo que não seja coberto no comando source-bridge explorerq-depth. Refira a compreensão e pesquisando defeitos a rota de origem que constrói uma ponte sobre para obter mais informações sobre deste comando.

comandos show

Os comandos show e as saídas descritos nesta seção são úteis ao pesquisar defeitos DLSw.

show dlsw peer

Este comando fornece a informação sobre pares. Cada peer remoto configurado é indicado aqui, incluindo a quantidade de transmitido e pacotes recebidos.

Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 5.5.5.1         CONNECT          2         2  conf      0    0   0 00:00:06

Estes são os estados possíveis:

  • CONECTE — Este estado significa que o par de DLSw é em serviço.

  • DESLIGUE este estado significa que o par para baixo ou não está conectado.

  • CAP_EXG — Este estado significa que DLSw está na troca das capacidades com o peer remoto.

  • WAIT_RD — Este estado é a etapa final em começar acima do par. Este par está esperando o peer remoto para abrir a porta lida. Refira a seção de debugging deste documento para obter mais informações sobre de quando o par começa acima e emitindo o comando debug dlsw peer.

  • WAN_BUSY — Este estado significa que a fila externa TCP está completa, e o pacote não pode ser transmitido.

O comando show dlsw peer igualmente mostra o número de gotas, a quantidade de circuitos através do par específico, a fila TCP, e o uptime. O contador de queda aumenta por estas razões:

  • A interface WAN não está ativa para um peer direto.

  • DLSw tenta enviar um pacote antes que o par esteja conectado inteiramente (evento de espera TCP ou evento das capacidades). Fila TCP externa completamente.

  • Contagem de números de seqüência FST incompatível.

  • Não pode conseguir o buffer retardar o pacote de FST do interruptor.

  • Falha do controlador de ciscobus na extremidade alta; não pode mover o pacote do recebem o buffer para transmitir o buffer, ou vice versa.

  • O endereço IP de destino do pacote de FST não combina o peer local ID.

  • Interface WAN não conectada para um correspondente FST.

  • Nenhum comando do cache de rota SRB configurado.

  • O buffer do anel de Madge está completo em sistemas baixo da gama: LAN de alimentação MACILENTO demasiado rápido.

capacidades do show dlsw

DLSw: Capabilities for peer 5.5.5.1(2065)
  vendor id (OUI)         : '00C' (cisco)
  version number          : 1
  release number          : 0
  init pacing window      : 20
  unsupported saps        : none
  num of tcp sessions     : 1
  loop prevent support    : no
  icanreach mac-exclusive : no
  icanreach netbios-excl. : no
  reachable mac addresses : none
  reachable netbios names : none
  cisco version number    : 1
  peer group number       : 0
  border peer capable     : no
  peer cost               : 3
  biu-segment configured  : no
  local-ack configured    : yes
  priority configured     : no
  version string          :
Cisco Internetwork Operating System Software
IOS (tm) 4500 Software (C4500-J-M), Version 10.3(13), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1996 by cisco Systems, Inc.

exibir capacidade de alcance de dlsw

DLSw MAC address reachability cache list
Mac Addr        status     Loc.    peer/port            rif
0800.5a0a.c51d  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a49.1e38  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a95.3a13  FOUND      REMOTE  5.5.5.1(2065)
 
DLSw NetBIOS Name reachability cache list
NetBIOS Name    status     Loc.    peer/port            rif
PIN-PIN         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
QUENEPA         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
WIN95           FOUND      REMOTE  5.5.5.1(2065)

O campo de estado é a maioria de parte importante do comando show dlsw reach. Estes são os possíveis status:

  • ENCONTRADO — O roteador encontrou o dispositivo.

  • PROCURAR — O roteador está procurando pelo recurso.

  • NOT_FOUND — Pôr em esconderijo negativo está ligada, e a estação não respondeu às perguntas.

  • NÃO-CONFIRMADO — A estação é configurada, mas DLSw não a verificou.

  • VERIFIQUE — A verificação da informação de cache porque o esconderijo está indo velho, ou a configuração do usuário estão sendo verificadas.

show dlsw circuit

Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:32; Rx CW:20, Granted:32
        RIF = 06B0.0021.00F0

Ao emitir o comando show dlsw circuit, pague a atenção ao controle de fluxo. O controle de fluxo existe em uma base do por-circuito. Esta é uma comunicação que ocorra quando os dois pares de DLSw atribuírem ao circuito um indicador de transferência possível. Este valor aumenta e diminui segundo a quantidade de tráfego que o circuito está tentando se mover com. O valor pode mudar segundo a congestão da nuvem.

O comando show dlsw circuit é mais extensivo até à data de IO 11.1. O comando permite-o agora olhar o circuito de DLSw em um valor do ponto de acesso ao serviço (SAP) ou no valor MAC, que simplifiquem encontrar circuitos ao pesquisar defeitos. Esta é uma saída de exemplo:

ibu-7206#sh dlsw cir
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
ibu-7206#sh dls cir det ?
  <0-4294967295>  Circuit ID for a specific remote circuit
  mac-address     Display all remote circuits using a specific MAC
  sap-value       Display all remote circuits using a specific SAP
  <cr>
 
ibu-7206#show dlsw circuit detail mac 4000.0000.0001
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:29; Rx CW:20, Granted:29
        RIF = 06B0.0021.00F0
241-00  4000.0000.0001(04)  4001.68ff.0000(04) CONNECTED
        Port:To0          peer 5.5.7.1(2065)
        Flow-Control-Tx CW:20, Permitted:27; Rx CW:20, Granted:27
        RIF = 0630.00F1.0010
s5e#sh cls
DLU user: DLSWDLU
      SSap:0x63       type:  llc0   class:0
        DTE:0800.5a95.3a13 0800.5a0a.c51d F0 F0
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
 
        DTE:4000.0000.0001 4001.68ff.0000 04 04
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
TokenRing0 DTE: 4000.0000.0001 4001.68ff.0000 04 04 state NORMAL
   V(S)=23, V(R)=23, Last N(R)=22, Local window=7, Remote Window=127
   akmax=3, n2=8, Next timer in 1240
   xid-retry timer      0/0       ack timer    1240/1000
   p timer              0/1000    idle timer  10224/10000
   rej timer            0/3200    busy timer      0/9600
   akdelay timer        0/100     txQ count       0/200

Troubleshooting

À revelia, DLSw termina sessões de LLC no Roteadores (Local-ack). Além, porque termina o campo de informação de roteamento (RIF), há outros problemas de desenho a considerar. A maioria de problemas comuns de DLSw são descritos nesta seção.

Circuitos

Um da maioria de importantes a recordar sobre DLSw é terminação de RIF. Esta é uma edição porque os laços principais na rede podem facilmente ser criados. Este diagrama demonstra um laço:

/image/gif/paws/12249/dlsw_1.gif

Neste caso, desde que DLSw termina o RIF, o pacote circunda indefinidamente. Isto é porque cada vez que um cur frame é enviado do par para espreitar, o par de recepção cria um explorador novo (NENHUM RIF) e o envia. As etapas do explorador são descritas:

  1. Os 3174 no anel 11 enviam um explorador para alcançar o host.

  2. O SF1 e o bridge copiam o frame

  3. O SF1 cria um cur frame a LA1 (seu par) para dizer a LA1 que os 3174 querem alcançar o HOST.

  4. O SF2 recebe o pacote e faz o mesmo.

  5. Agora, LA1 e LA2 criam o explorador e o enviam ao anel.

  6. O LA1 e o LA2 recebem um explorador que crie.

  7. Agora há um dilema, porque cada lado acredita que os 3174 estão anexados localmente.

  8. Cada roteador tem os 3174, local e telecontrole.

  9. Agora enviam um frame icanreach ao SF1 e ao SF2, respectivamente, que cria uma resposta do host para os 3174.

  10. o SF1 e o SF2 põem a resposta de explorador sobre o Token Ring e cada um aprende que o MAC address do host é alcançável localmente e remotamente.

  11. Da alcançabilidade de DLSw Firewall eficazmente contra o explorador que dá laços indefinidamente. Contudo, com quadros da informação não numerada (UI), isto pode dar laços, a seguir conduz o CPU e alinha a utilização até 100%.

Se isto ocorre, verifique que o anel virtual no Roteadores é exatamente o mesmo em cada lado da nuvem, como mostrado neste diagrama:

/image/gif/paws/12249/dlsw_2.gif

O Roteadores em cada lado desta nuvem tem o exato o mesmo número de anel virtual. Isto assegura-se de que um do Roteadores envie um explorador que já passe através do anel, então o roteador o deixe cair. Quando o LA1 gera um explorador para um cur frame recebido pelo SF1, o LA2 deixa-o cair porque o explorador já passou através do anel 1. Nesta encenação, é importante que o roteador tem uma ponte diferente configurada se o pacote é dirigido para o mesmo anel, que é o exemplo do lado LA da rede.

Em uma versão de Ethernet da mesma encenação, você deve desabilitar um par. Um exemplo é indicado neste diagrama:

dlsw_3.gif

Porque um pacote nos Ethernet não tem um RIF, o roteador não pode determinar se a transmissão, criada pelo outro roteador no LAN, é do outro roteador ou de uma estação de origem. Com SNA, o pacote é originado localmente ou telecontrole. Porque os exploradores de um ambiente de token ring têm de fato ambos os endereços MAC de origem e de destino, são uma não transmissão nos Ethernet, mas um directed frame a uma estação de outra.

O que ocorre no diagrama precedente é explicado nestas etapas:

  1. Um explorador é enviado do 3174 para o host.

  2. Este explorador é aceitado pelo SF1 e pelo SF2.

  3. SF1 e SF2 geram, cada um, uma CUR para LA1 e LA2 do outro lado.

  4. Estes geram um explorador que o host responde a; porque é um explorador de rota única, é respondido com a um explorador da todo-rota.

  5. o LA1 e o LA2 criam um cur frame ao SF1 e ao SF2, que criam o pacote para os 3174.

  6. O SF1 ouve o MAC address do HOST que vem dos Ethernet e acredita agora que o HOST está ficado situado no LAN local. Mas no esconderijo do SF1, o ID do host está respondendo de um peer remoto.

  7. Isto força o roteador a ter o HOST local e remoto, assim que significa que DLSw é quebrado.

Correspondentes de backup/custo

Os peeres de backup adicionam a tolerância de defeito a DLSw caso um par for perdido. Isto estabelece-se geralmente em ambientes do núcleo de modo que quando um roteador central falha, um outro roteador possa aceitar o roteador falhando. As configurações e o diagrama nesta seção ilustram uma instalação do peer de backup.

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   cost 2 promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   cost 4 promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

/image/gif/paws/12249/dlsw_8.gif

A primeira coisa a recordar sobre pares do custo de DLSw é que ambos os pares são ativos. O roteador mantém somente um peer de backup. Pode ter dois naquele tempo se se atrase é configurado. Este é o que ocorreu no diagrama precedente:

  1. D3a recebe um explorador e começa o processo enviando um cur frame a cada peer remoto.

  2. O D3B e o D3C recebem os cur frame. Cada um gera um explorador ao host, que responde de volta ao D3B e ao D3C.

  3. o D3B e o D3C respondem de volta ao D3A com Icanreach.

  4. O D3A envia a resposta de explorador à estação final.

  5. A estação remota liga o circuito do dlsw, com identificação de intercâmbio (XID) para SNA e Set Asynchronous Balanced Mode Extended (SABME) para NetBIOS.

  6. O D3A seleciona custos mais baixos dentro da alcançabilidade.

Há um temporizador no D3A que pode ser definido para dizer ao roteador quanto tempo esperar todos os exploradores para retornar ao D3A. Isto evita problemas com custos que podem ocorrer quando o roteador usa o primeiro explorador que lhe vem para trás. Emita o comando do <seconds> do temporizador de explorer-wait-time do dlsw ajustar este temporizador.

Além, ao executar border peer, DLSw envia somente um cur frame ao par o mais barato. Comporta-se diferentemente do que faz ao executar o custo sem os border peer.

Os peeres de backup operam-se um pouco de diferentemente. Você especifica o peer de backup no par que está indo ser alternativo para o par especificado. Isto significa que o par que tem a declaração de backup é o peer de backup próprio.

Especifique a opção do atraso de modo que quando o peer principal se torna operacional outra vez, os circuitos não possam rasgar para baixo imediatamente. Isto é útil se o peer principal varia para cima e para baixo, porque você não quer usar o par defeituoso.

Isto demonstra a configuração dos peeres de backup:

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1 backup-peer 1.1.14.1 linger 5
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

O par é desligado emitindo o comando show dlsw peer:

d3a#sh dls peer
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 1.1.14.1        CONNECT        464      1286  conf      0    0   0 03:17:02
 TCP 1.1.12.1        DISCONN          0         0  conf      0    0   -        -

Correspondentes de borda

Os border peer são uma característica importante de DLSw porque resolvem o problema do controle de transmissão em uma rede. Este exemplo ilustra como os border peer estão configurados e o que ocorre quando uma sessão vem acima:

/image/gif/paws/12249/dlsw_6.gif

D3E
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3e
!
!
dlsw local-peer peer-id 1.1.11.1 group 1
   border promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
!
interface Loopback0
 ip address 1.1.11.1 255.255.255.0
!
interface Serial0
 ip address 1.1.3.1 255.255.255.0
!
interface Serial1
 ip address 1.1.2.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 ip address 10.17.1.189 255.255.255.0
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3C
Current configuration:
!
version 11.1

service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
dlsw local-peer peer-id 1.1.12.1 group 2
   border promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 no fair-queue
 clockrate 500000
!
interface Serial1
 ip address 1.1.3.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 no ip address
 shutdown
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3F
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3f
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.10.1 group 1
   promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.10.1 255.255.255.0
!
interface Serial0
 ip address 1.1.2.1 255.255.255.0
 no fair-queue
!!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1 group 2
   promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.2 255.255.255.0
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

Os primeiros parte de border peer configurando devem criar peeres promíscuo. Os peeres promíscuo aceitam conexões de todo o roteador DLSw que tenta abrir um par com este roteador. Por exemplo, no diagrama precedente, você quer o D3A abrir um par com D3F. Se não há nenhuns border peer, você precisa de estabelecer peer estáticos na rede. Isto trabalha muito bem, mas quando você tem centenas de locais e você usa peer estáticos quando um roteador precisa de encontrar remotamente uma estação, o roteador tem que enviar um cur frame a cada par. Isto pode causar muitas despesas gerais.

Por outro lado, quando você usa border peer, esse roteador remoto precisa de enviar somente um pedido ao border peer. Este pedido é propagado então através dos grupos, e o roteador remoto abre um par com o outro roteador remoto para ligar um circuito e para estabelecer uma conexão. Este processo é explicado neste diagrama:

/image/gif/paws/12249/dlsw_7.gif

  1. Quando o D3A recebe o explorador, envia uma transmissão ao D3C. O D3C é o border peer a que o D3A é anexado.

  2. Quando o D3C recebe o cur frame, envia o cur frame a todos os pares no grupo. O D3C igualmente envia um frame para teste a todas as interfaces local que forem configuradas para fazer assim, e envia um cur frame aos border peer no outro grupo.

  3. O D3E recebe o CUR do D3C em um outro grupo. Então o D3E faz o mesmos enviando o CUR a todos os pares no grupo e em todas as interfaces local.

  4. O D3F recebe o cur frame e envia uma eleição de teste à interface local. Se o D3F tem um par que aponta a um outro roteador, não pode ecoar esse cur frame a um outro roteador.

  5. Quando o D3F recebe uma resposta para a estação final, retorna o frame icanreach ao D3E.

  6. O D3E envia-o ao D3C, que para a frente ele ao D3A. O D3A envia uma resposta de teste ao dispositivo.

  7. Quando a estação final começa um circuito do dlsw, com o XID para o SNA e o SABME para NetBIOS, D3A inicia uma conexão de peer com D3F e começa acima a sessão.

Este é debugar do D3C e do D3A durante este processo:

d3a#
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 40
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 40 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 0
DLSw: sending bcast to BP peer 1.1.12.1(2065)

O frame para teste que entra o roteador é considerado. Então, o roteador gera um cur frame ao D3C. A atividade D3C indica esta saída:

DLSw: Pak from peer 1.1.13.1(2065) with op DLX_MEMBER_TO_BP
DLSw: recv_member_to_border() from peer 1.1.13.1(2065)
DLSw: passing pak to core originally from 1.1.13.1 in group 2
%DLSWC-3-RECVSSP: SSP OP = 3( CUR  ) -explorer from peer 1.1.13.1(2065)
DLSw: Pak from peer 1.1.11.1(2065) with op DLX_RELAY_RSP
DLSW: relaying pak to member 1.1.13.1 in group 2

Quando o D3C receber o pacote do D3A, ele para a frente o pacote ao núcleo. Mais tarde, você vê a resposta do peer remoto que está sendo retransmitido de volta ao D3A. Então o D3A começa acima a conexão (par por encomenda) com o peer remoto que o D3F neste debuga:

DLSw: Pak from peer 1.1.12.1(2065) with op DLX_RELAY_RSP
DLSW: creating a peer-on-demand for 1.1.10.1
DLSw: passing pak to core originally from 1.1.10.1 in group 1
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 1.1.10.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44
DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 4
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: action_a() attempting to connect peer 1.1.10.1(2065)
DLSw: action_a(): Write pipe opened for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state DISCONN, new state WAIT_RD
DLSw: passive open 1.1.10.1(11003) -> 2065
DLSw: action_c(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state WAIT_RD, new state CAP_EXG
DLSw: CapExId Msg sent to peer 1.1.10.1(2065)
DLSw: Recv CapExId Msg from peer 1.1.10.1(2065)
DLSw: Pos CapExResp sent to peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 1.1.10.1(2065)
DLSw: action_f(): for peer 1.1.10.1(2065)
DLSw: closing read pipe tcp connection for peer 1.1.10.1(2065)
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: START-FSM (1474380): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 106
DLSw: END-FSM (1474380): state:DISCONNECTED->LOCAL_RESOLVE

Depois que o roteador recebe o pacote retransmitido do border peer, abre um par por encomenda com o peer remoto D3F (1.1.10.1), e põe em andamento o circuito.

debugar

A primeira etapa em toda a rede DLSW está trazendo acima os pares. Sem os pares, não há nenhuma troca dos dados. A maioria dos detalhes do que ocorre entre pares de DLSw é explicado no RFC 1795.

Nota: Se você fala ao equipamento que não é da Cisco através de DLSw, use DLSw. Contudo, entre roteadores Cisco, DLSw+ do uso.

Esta saída é da emissão debuga pares do dlsw e trazer acima os pares acima entre dois roteadores Cisco:

DLSw: passive open 5.5.5.1(11010) -> 2065
DLSw: action_b(): opening write pipe for peer 5.5.5.1(2065)
DLSw: peer 5.5.5.1(2065), old state DISCONN, new state CAP_EXG
DLSw: CapExId Msg sent to peer 5.5.5.1(2065)
DLSw: Recv CapExId Msg from peer 5.5.5.1(2065)
DLSw: Pos CapExResp sent to peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
shSw: peer 5.5.5.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 5.5.5.1(2065)
DLSw: action_f(): for peer 5.5.5.1(2065)
DLSw: closing read pipe tcp connection for peer 5.5.5.1(2065)

Esta saída mostra o roteador que começa acima do par e que abre uma sessão de TCP com o outro roteador. Então começa às capacidades de intercâmbio. Após o intercâmbio positivo das capacidades, o par é conectado. Em contraste com o RSRB, DLSw não move o par para um estado fechado quando não há nenhuma atividade, tal como o tráfego. Permanecem sempre conectados. Se os pares são desligados, a edição debuga o par do dlsw para determinar porque não são capazes da abertura.

Ao pesquisar defeitos uma sessão que está sendo trazida acima, a edição debuga o núcleo do dlsw para observar a falha de sessão e para verificar se o circuito está vindo acima.

Este é o fluxo para um controlador de comunicações 3174 ao host através do DLSw+:

/image/gif/paws/12249/dlsw_4.gif

A saída do dlsw debugar indica o fluxo da sessão que está sendo trazida acima corretamente:

ibu-7206#debug dlsw
DLSw reachability debugging is on at event level for all protocol traffic
DLSw peer debugging is on
DLSw local circuit debugging is on
DLSw core message debugging is on
DLSw core state debugging is on
DLSw core flow control debugging is on
DLSw core xid debugging is on
ibu-7206#
DLSW Received-ctlQ : CLSI Msg : UDATA_STN.Ind   dlen: 208
CSM: Received CLSI Msg : UDATA_STN.Ind   dlen: 208 from TokenRing3/0
CSM:   smac 8800.5a49.1e38, dmac c000.0000.0080, ssap F0, dsap F0
CSM: Received frame type NETBIOS DATAGRAM from 0800.5a49.1e38, To3/0
DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
DLSw: Keepalive Request sent to peer 5.5.5.1(2065))
DLSw: Keepalive Response from peer 5.5.5.1(2065)
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 41
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 41 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 0

Observe o frame para teste vir do LAN (localmente) da estação c001.68ff.0001 ao MAC address de 4000.0000.0001. Cada um. O Ind indica que um pacote está vindo dentro do LAN. Quando o roteador envia um pacote ao LAN, você vê um .RSP.

DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 5.5.5.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44

Agora você pode ver a transmissão enviada ao peer remoto e à resposta da taxa de célula inicial (ICR) para trás. Isto significa que o roteador remoto identificou a estação como alcançável. O TEST_STN.Rsp é o roteador que envia uma resposta de teste à estação.

DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 4

Depois que a estação recebe a resposta de teste, envia o primeiro XID. Você pode observar este com o IS_STN.Ind. Agora o roteador tem que sustentar este quadro temporariamente até que cancele um par detalhes entre os dois roteadores DLSw.

DLSw: new_ckt_from_clsi(): TokenRing3/0 4001.68ff.0001:4->4000.0000.0001:4
DLSw: START-FSM (1622182940): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 108
DLSw: END-FSM (1622182940): state:DISCONNECTED->LOCAL_RESOLVE
 
DLSW Received-ctlQ : CLSI Msg : REQ_OPNSTN.Cfm CLS_OK dlen: 108
DLSw: START-FSM (1622182940): event:DLC-ReqOpnStn.Cnf state:LOCAL_RESOLVE
DLSw: core: dlsw_action_b()
CORE: Setting lf size to 30
%DLSWC-3-SENDSSP: SSP OP = 3(CUR)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:LOCAL_RESOLVE->CKT_START
 
%DLSWC-3-RECVSSP: SSP OP = 4(ICR)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCI 0 - s:0 so:0 r:0 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-ICR state:CKT_START
DLSw: core: dlsw_action_e()
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  ACK   - s:20 so:1 r:20 ro:1
%DLSWC-3-SENDSSP: SSP OP = 5(ACK)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_START->CKT_ESTABLISHED

Aqui você pode observar o fluxo interno de DLSw entre os dois pares. Estes pacotes são normais para cada partida de sessão. A primeira fase é mover-se de um estado desconectado para um estado CKT_ESTABLISHED. Ambo o Roteadores transmite um cur frame para o circuito próprio. Isto é chamado o a instalação do circuito pode ser alcançada (CURCS). Quando o par que inicia o quadro CURCS recebe um quadro ICRCS, envia um reconhecimento e move-se para um estado estabelecido do circuito. Agora, ambos os roteadores DLSw estão prontos para o processamento XID.

DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
DLSw: 1622182940 sent FCA on  XID
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

O roteador recebeu um XID após ter enviado a resposta de teste à estação. Salvar este XID por um momento, a seguir transmite-o ao par através do circuito. Isto significa que você lhes está enviando pacotes para/desde o par com o circuit id etiquetado. Esta maneira, DLSw compreende a atividade entre as duas estações. Recorde que DLSw termina o Logical Link Control, o tipo-2 (LLC2), sessão em cada lado da nuvem.

%DLSWC-3-RECVSSP: SSP OP = 7(XID)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCA on  XID   - s:20 so:0 r:20 ro:0
DLSw: START-FSM (1622182940): event:WAN-XID state:CKT_ESTABLISHED
DLSw: core: dlsw_action_g()
DISP Sent : CLSI Msg : ID.Rsp   dlen: 12
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED
 
DLSW Received-ctlQ : CLSI Msg : ID.Ind   dlen: 39
DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

Você observa primeiramente uma resposta ao primeiro XID que foi enviado antes. Em ID.Rsp, você vê que o XID esteve enviado à estação, a que a estação respondeu com um ID.Ind. Este é um outro XID que seja enviado transversalmente ao par de DLSw.

%DLSWC-3-RECVSSP: SSP OP = 8(CONQ)  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-CONQ state:CKT_ESTABLISHED

Esta parte mostra-nos que a estação no outro lado respondeu com um SABME (CONQ) ao XID. A negociação de XID terminou e o roteador está pronto para começar a sessão.

DLSw: core: dlsw_action_i()
DISP Sent : CLSI Msg : CONNECT.Req   dlen: 16

Depois, o roteador envia o SABME à estação no CONNECT.Req.

DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CONTACT_PENDING
 
DLSW Received-ctlQ : CLSI Msg : CONNECT.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Connect.Cnf state:CONTACT_PENDING
DLSw: core: dlsw_action_j()
%DLSWC-3-SENDSSP: SSP OP = 9( CONR )  to peer 5.5.5.1(2065) success
DISP Sent : CLSI Msg : FLOW.Req   dlen: 0
DLSw: END-FSM (1622182940): state:CONTACT_PENDING->CONNECTED

Então você recebe o reconhecimento não numerado (UA) da estação, que é mostrada na mensagem do CONNECT.Cfm. Isto é enviado ao peer remoto através de um CONR. O processo da taxa relativa (RR) é começado então com FLOW.Req.

%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:20 so:0 r:19 ro:0
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 34
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED
 
DLSw: 1622182940 decr s - s:19 so:0 r:19 ro:0
DLSW Received-disp : CLSI Msg : DATA.Ind   dlen: 35
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  INFO  - s:19 so:0 r:39 ro:1
%DLSWC-3-SENDSSP: SSP OP = 10(INFO)  to peer 5.5.5.1(2065) success
%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:19 so:0 r:38 ro:1
DLSw: 1622182940 recv FCA on  INFO  - s:19 so:0 r:38 ro:0
DLSw: 1622182940 recv FCI 0 - s:19 so:0 r:38 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 28
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED

O DATA.Req indica que o roteador transmitiu um Eu-quadro. Data.Ind indica que o roteador recebeu um Eu-quadro. Você pode usar esta informação para determinar o fluxo de pacote de informação através dos roteadores DLSw.

DLSW Received-ctlQ : CLSI Msg : DISCONNECT.Ind   dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Disc.Ind state:CONNECTED

Esta parte contém um DISCONNECT.Ind. . O Ind indica um pacote que vem dentro do LAN. Neste caso, a estação envia uma DISCONEXÃO, que faça com que o roteador comece rasgar para baixo o circuito.

DLSw: core: dlsw_action_n()
%DLSWC-3-SENDSSP: SSP OP = 14( HLTQ )  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CONNECTED->DISC_PENDING
 
%DLSWC-3-RECVSSP: SSP OP = 15( HLTR )  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-HLTR state:DISC_PENDING

Depois que o roteador recebe a DISCONEXÃO, envia uma PARADA ao peer remoto e espera a resposta. Tudo que é deixado é enviar para baixo um UA à estação e ao fim o circuito, que é mostrado no seguinte debuga com o DISCONNECT.Rsp:

DLSw: core: dlsw_action_q()
DISP Sent : CLSI Msg : DISCONNECT.Rsp   dlen: 4
DISP Sent : CLSI Msg : CLOSE_STN.Req   dlen: 4
DLSw: END-FSM (1622182940): state:DISC_PENDING->CLOSE_PEND
 
DLSW Received-ctlQ : CLSI Msg : CLOSE_STN.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-CloseStn.Cnf state:CLOSE_PEND
DLSw: core: dlsw_action_y()
DLSw: 1622182940 to dead queue
DLSw: END-FSM (1622182940): state:CLOSE_PEND->DISCONNECTED

A última coisa DLSw executa é pôr o circuito na fila inoperante. De lá, os ponteiros são limpados e aprontam-se para um circuito novo.

Sessões de NetBIOS

O DLSw manipula as sessões NetBIOS de maneira diferente, mas as depurações são bem semelhantes.

/image/gif/paws/12249/dlsw_5.gif

Nota: Recorde que os XID não fluem para estações de netbios e que os quadros e o nome de netbios do System Switch Processor da pergunta do nome de netbios da troca dos roteadores DLSw (SSP) reconheceram. Este é o principal diferença.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12249