Distribuição de vídeo e conteúdo : Roteadores de acesso por cabo Cisco uBR900 Series

DHCP-proxy do modem a cabo nat em cable modens Cisco

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento explica como usar o comando cable-modem dhcp-proxy nat. A função principal deste comando é configurar um conjunto de endereços do Network Address Translation (NAT) com um endereço IP de Um ou Mais Servidores Cisco ICM NT fornecido pelo servidor DHCP do fornecedor de Intrernet.

Para mais informação, refira o DHCP-proxy do modem a cabo em comandos cmts do cabo IO.

cuidado Cuidado: Esteja ciente da identificação de bug Cisco CSCdt32356 (clientes registrados somente), que é fixada nos trens de versão de software 12.2 de Cisco IOS� e mais atrasado. O NAT dinâmico que usa o comando cable interface nat do pool-nome do DHCP-proxy do modem a cabo não funciona corretamente. O endereço IP de Um ou Mais Servidores Cisco ICM NT ou as máscaras de sub-rede e os gateways padrão não são atribuídos corretamente, se de todo. Depois que o comando é incorporado, o endereço que é atribuído ao conjunto NAT não responde ao Address Resolution Protocol (ARP). O ip nat pool que é criado é do espaço do modem a cabo, um pouco do que o espaço do Customer Premises Equipment (o CPE), assim que põem um endereço IP de Um ou Mais Servidores Cisco ICM NT não-roteável no conjunto NAT. Observe que este problema ocorre nos Cisco IOS Software Release para diverso Modems a cabo, especialmente 12.1(5)T. Recomenda-se que você usa o trem de Cisco IOS Software Release 12.2 no uBR924 e usa as liberações 12.2T, 12.3, e uns trens mais atrasados para o uBR905, o uBR925, e os modens CVA. Para a informação adicional, refira a identificação de bug Cisco CSCdt32356 (clientes registrados somente).

Nota: Igualmente esteja ciente destas considerações:

  1. Porque as Plataformas do uBR904 não apoiam o Cisco IOS Software Release 12.1(1)T, não é possível configurar o comando cable-modem dhcp-proxy nesta plataforma.

  2. Para permitir a característica do DHCP-proxy no uBR924, recomenda-se geralmente que você usa o Cisco IOS Software Release 12.2(6j).

  3. Para o CVA122, o comando é documentado como o DHCP-proxy do cabo nat. Este comando é o mesmo que o comando cable-modem dhcp-proxy nat no Modems a cabo do uBR900 Series.

    De um CVA122, esta saída pode ser considerada:

    Router(config)# interface cable 0
    
    Router(config-if)# cable?
    
    cable-modem

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • Compreensão básica da tradução de endereço de rede e porque é usada

  • Protocolo do Data-over-Cable Service Interface Specifications (DOCSIS) 1.0

  • A interface de linha do comando do Cisco IOS Software

Componentes Utilizados

Esta tabela mostra os Cisco IOS Software Release que apoiam este comando para cada plataforma do cable modem Cisco:

Libere-se que introduzido o comando cable-modem dhcp-proxy Plataforma
12.1(1)T uBR924
12.1(3)XL ubr905
12.2(2)XA ubr925
12.1(5)XU1 CVA122

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

NAT dinâmico contra o NAT estático

Com NAT dinâmico, as traduções não existem na tabela de tradução NAT até que o roteador receba o tráfego que exige a tradução. As traduções dinâmica têm um período de intervalo, depois do qual são removidas da tabela de tradução. Com NAT estático, contudo, as traduções existem na tabela de tradução NAT assim que você configurar um comando static nat, e permanecem na tabela de tradução até que você suprima do comando static nat ou dos comandos.

A maneira a mais fácil de determinar que você tem o NAT dinâmico configurado em seu modem a cabo é procurando por este comando na configuração do modem a cabo:

ip nat inside source list 100 interface cable-modem0 overload

Apontando o origem do NAT a uma lista de acessos, você está construindo dinamicamente a tabela de tradução NAT. O comando cable-modem dhcp-proxy nat usa estes recursos NAT dinâmicos.

Configuração usando o comando cable-modem dhcp-proxy nat

Ao usar o comando cable-modem dhcp-proxy nat, o endereço usado para o conjunto NAT é atribuído automaticamente do servidor DHCP do operador de cabo.

Ao usar esta opção, inclua estes comandos nat configuration:

  • interface interna nat IP — Use para configurar a interface Ethernet como a relação do “interior”.

  • interface externa nat IP — Use para configurar a interface de cabo como a relação da “parte externa”.

  • sobrecarga — Especifique esta opção com o comando ip nat global configuration porque o conjunto NAT criado pelo comando cable-modem dhcp-proxy nat contém somente um endereço IP de Um ou Mais Servidores Cisco ICM NT.

Após ter configurado o roteador com o comando cable-modem dhcp-proxy nat, recarregue o roteador. Durante o processo de provisionamento DOCSIS, o roteador envia uma requisição de cliente de DHCP obter um endereço IP de Um ou Mais Servidores Cisco ICM NT para a interface de cabo. O roteador envia então uma requisição DHCP de proxy ao servidor DHCP usando o MAC address da interface Ethernet. O servidor DHCP responde com um segundo endereço IP de Um ou Mais Servidores Cisco ICM NT que o roteador atribui a uma interface de loopback dinamicamente configurada que esteja apontando a um conjunto NAT dinamicamente configurado de somente um endereço.

Veja as saídas de configuração neste documento para a informação que está adicionada automaticamente à configuração depois que o DHCP é processado.

Para configurar o NAT de modo que crie o pool dinamicamente, emita estes comandos em seu roteador. Recorde que, a fim configurar o NAT, seu roteador deve reagir do modo de roteamento.

Router# config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)# interface ethernet 0

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!--- Assign an IP address to interface Ethernet 0.

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# ip nat inside

!--- Enable NAT inside for the Ethernet interface.

Router(config-if)# exit

Router(config)#

Router(config)# interface cable 0

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# no cable compliant bridge

!--- Remove bridging so that you can configure for routing.

Router(config-if)# ip nat outside

!--- Enable NAT outside for the cable interface.

Router(config-if)# cable-modem dhcp-proxy nat TEST_POOL

!--- Define dhcp-proxy nat for the TEST_POOL pool.

Router(config-if)# exit

Router(config)#

Router(config)# ip routing

!--- Enable routing.

Router(config)# ip nat inside source list 1 pool TEST_POOL overload

!--- Configure dynamic NAT.

Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

!--- Define interesting traffic for NAT.

A configuração olha como esta:

router# show run

Building configuration...
Current configuration : 953 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
!
ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

router#

Os comandos corajosos são esses que você incorporou; os outro são os padrões. Observe que o conjunto NAT não esteve criado ainda neste momento. O modem a cabo precisa de ser recarregado, ou a interface de cabo precisa de ser restaurada emitindo o comando shut seguido pelo comando no shut.

router# reload

Proceed with reload? [confirm]
133.CABLEMODEM.CISCO: 00:06:16: %SYS-5-RELOAD: Reload requested
System Bootstrap, Version 12.0(6r)T3, RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by Cisco Systems, Inc.
UBR924 platform with 16384 Kbytes of main memory
program load complete, entry point: 0x80010000, size: 0x398070
Self decompressing the image : #################################
################################################################
################################################################
################################################################
################################################################
################################################################
########################################################## [OK]

!--- Output suppressed.

Press RETURN to get started!

Nota: Nas saídas de configuração, a informação que está adicionada automaticamente à configuração depois que o DHCP é processado é notada com comentários.

Neste documento, um uBR7114 e o uBR924 são usados como exemplos. Os Cisco IOS Software Release instalados neles são 12.1(5)EC1 e 12.1(3a)T4, respectivamente. A figura seguinte mostra a Conectividade e os endereços IP de Um ou Mais Servidores Cisco ICM NT usados.

Figura 1: Diagrama usado na configuração usando o comando cable dhcp-proxy nat

/image/gif/paws/12176/cable_dhcp_proxy1.gif

uBR924 — Configuração do pool de endereço NAT com um endereço IP de Um ou Mais Servidores Cisco ICM NT fornecido pelo servidor DHCP do provedor de serviços
router# show run

Building configuration...
Current configuration : 1273 bytes
!
! Last configuration change at 13:12:52 - Tue Feb 29 2000
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
clock timezone - -8
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
!
interface Loopback0
 ip address 111.111.111.8 255.255.255.255

!--- Lookback interface added automatically by DHCP configuration.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream saved channel 525000000 37 1
!
ip nat pool TEST_POOL 111.111.111.8 111.111.111.8 netmask 255.255.255.0

!--- NAT pool added automatically by DHCP configuration.

ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

Verificação da configuração

Esta seção descreve como usar o show command output (resultado do comando show) para verificar a configuração do modem a cabo.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Emita o comando show arp indicar as entradas na tabela ARP.

router# show arp

Protocol  Address         Age (min) Hardware Addr   Type   Interface
Internet  111.111.111.111      56   0002.b9ff.8c1c  ARPA   cable-modem0
Internet  10.4.1.1             59   0002.b9ff.8c1c  ARPA   cable-modem0

!--- IP address of the interface cable 1/0
!--- of the cable modem termination system (CMTS).

Internet  192.168.1.1           -   0030.1976.771a  ARPA   Ethernet0
Internet  192.168.1.5          34   00a0.243c.eff5  ARPA   Ethernet0

!--- IP address of the PC behind the cable modem.

Internet  10.4.1.114            -   0030.1976.771b  ARPA   cable-modem0

O PC atrás do modem a cabo tem o endereço IP 192.168.1.5 configurado estaticamente. É muito fácil, contudo, fazer ao modem a cabo um servidor DHCP que atribua dinamicamente um endereço IP de Um ou Mais Servidores Cisco ICM NT a seus anfitriões LAN; use esta configuração:

ip dhcp excluded-address 192.168.1.1 
ip dhcp pool pool name


   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1

Para testar que o NAT trabalha, emita um comando ping do PC conectado atrás do modem a cabo para tentar alcançar a interface de cabo.

Se você olha a tabela de tradução NAT, você pode ver traduções bem-sucedidas.

router# show ip nat translations

Pro  Inside global      Inside local       Outside local    Outside global
icmp 111.111.111.8:512  192.168.1.5:512    10.4.1.114:512   10.4.1.114:512

Para mais informação, refira o DHCP-proxy do modem a cabo em comandos cmts do cabo IO.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12176