Voz : H.323

VOIP sobre o Frame Relay com PVC multipontos e prioridade

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento discute o modelagem de tráfego e a prioridade para uma Voz sobre IP (VoIP) sobre a rede do Frame Relay com a topologia de hub e spoke. A configuração do hub é tal que há dois circuitos permanentes (PVC), um para cada raio remoto, e ambos os dados e Voz são enviados sobre os mesmos PVC. É importante notar que a prioridade e a fragmentação discutidas neste documento se aplicam não somente a esta encenação mas igualmente a uma encenação onde você possa ter um PVC com Voz e dados e outro com somente dados. Os PVC de dados precisam tráfego-de ser dados forma apenas como a Voz e os PVC de dados. Isto é devido ao fato de que quando uma única tubulação física está compartilhada, neste caso no hub, o retardo de serialização afeta todos os dados.

Na topologia abaixo, New York representa o roteador central do hub. Raleigh e SÃO JOSÉ representam os roteadores remotos conectados ao hub através de uma rede do Frame Relay. Há dois PVC que conectam ao roteador New York. Neste caso, New York deve nunca enviar mais de 64 kbps a Raleigh e do mesmo modo, ele devem nunca enviar mais de 192 kbps a SÃO JOSÉ porque este excede a taxa de informação comprometida configurada (CIR) nos mapclass do Frame Relay.

Na topologia mostrada neste documento, o Roteadores com configurações de VoIP é conectado diretamente a uma perturbação do Frame Relay. Em algumas topologias, contudo, o Roteadores ativado por voz pode existir em qualquer lugar na rede, à excecpção do Cisco AS5300. Para obter mais informações sobre disto, refira a nota fornecida. O Roteadores da Voz pode ser conectado com a conectividade de LAN ao outro Roteadores que é conectado a WAN. Isto é importante de notar porque se seu Roteadores da Voz não é conectado diretamente a um serviço do Frame Relay, todos os comandos configuration da conectividade de WAN são configurados naquele Roteadores que é conectado a WAN, e não no Roteadores da Voz.

Nota:  O Roteadores do Cisco AS5300 com interfaces seriais de alta velocidade não é projetado apoiar a conexão de dados a WAN. Você precisa de usar seu Cisco AS5300 como roteadores de LAN intermediários com a funcionalidade principal para processar chamadas de voz. Você precisa roteadores dedicados de atuar como conexões direta a WAN.

Pré-requisitos

Requisitos

Antes que você tente esta configuração, assegure-se de que você encontre estas condições prévias:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Três Cisco 3640 Router com o Enterprise Plus do Software Release 12.3(5) de Cisco IOS�

  • Quatro telefones analógicos conectados às portas da estação de câmbio internacional (FXO) no spokes

  • Um PBX conectado a um controlador T1 no roteador de hub

O spokes pode igualmente ser um Cisco 2600 ou uma plataforma 1750. O hub pode ser um Cisco 2600 ou uma plataforma 3600 no caso da voz digital, mas pode igualmente ser uma plataforma do Cisco 1750 se somente a voz analógica existe no hub. Todo o modelagem de tráfego e configurações se aplicam a outras Plataformas também.

Nota: Embora este documento não é restringido ao software específico, alguns dos comandos usados aqui não estão disponíveis com todas as versões de Cisco IOS Software. Por exemplo, o comando frame-relay fragment é apoiado com IP Plus mas não por uma imagem IP.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurando o modelagem de tráfego e a prioridade para um VOIP sobre o Frame Relay

Quando você executa o VOIP sobre o Frame Relay, é importante que o tráfego enviado sobre o quadro fica a nível que é inferior ou igual ao Frame Relay CIR. O roteador não envia o tráfego que excede o CIR quando configurado com Frame Relay Traffic Shaping (FRTS) como mostrado. Se você configura o roteador para ser executado em uma velocidade maior do que o CIR, você pode experimentar questões de qualidade de voz, e a Qualidade de voz não é garantida quando você executa PVC acima do CIR garantido.

Nota: É possível configurar a forma adaptável para permitir um roteador de estrangular abaixo da taxa de transmissão a um valor especificado se os pacotes do Frame Relay são recebidos com o jogo do bit da notificação de congestionamento explícita retrógrada (BECN). Você está recomendado que contudo, essas taxas de tráfego não são exceder o CIR do serviço do Frame Relay quando os pacotes de voz são transmitidos. Este é assegurar a qualidade apropriada e a entrega quando os pacotes da voz em tempo real são enviados através da rede. A configuração onde o CIR é excedido é recomendada somente para os PVC de dados que não levam o tráfego de voz.

Nota: Também, antes que você possa configurar seu roteador para usar VoIP, é o melhor se você compreende as características do Qualidade de Serviço (QoS) no Cisco IOS Software. Para aprender mais sobre características de QoS, refira o enfileiramento, o modelagem de tráfego, e a filtração e a fragmentação para a Voz.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento usa a instalação de rede mostrada no diagrama aqui:

/image/gif/paws/12162/voip_fr_mp_1.gif

Configurações

Este documento utiliza as seguintes configurações:

Roteador de hub de New York
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname newyork
!
logging buffered 50000 debugging
enable secret < password > [Choose a strong password with 
at least one capital letter, one number, and one special character.]
!
controller T1 2/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1-4 type e&m-wink-start
!
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay traffic-shaping

!--- This CLI command enables traffic shaping for both PVCs.

!
interface Serial2/0.1 point-to-point
description Connection to Raleigh PVC
ip address 172.16.120.2 255.255.255.0
  frame-relay interface-dlci 100
  class class-raleigh
!
interface Serial2/0.2 point-to-point
description Connection to San Jose PVC
ip address 172.16.130.2 255.255.255.0
frame-relay interface-dlci 200
  class class-sanjose
!
ip classless
!
map-class frame-relay class-raleigh
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80

!--- Recommended fragment size for 10ms delay when carrying voice
!--- traffic based on the configured CIR 64000.
!--- based on the configured CIR 64000

 frame-relay ip rtp priority 16384 16383 48

!--- Two calls with g729, no CRTP, at 24 kbps/each.

 !
map-class frame-relay class-sanjose
 frame-relay cir 192000
 frame-relay bc 1920
 frame-relay be 0
 frame-relay mincir 192000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 240

!--- This is the recommended fragment size for 10ms delay when carrying voice traffic
!--- based on the configured CIR 192000.

frame-relay ip rtp priority 16384 16383 48 

!--- Two calls with G729, no Compressed Real Time Protocol (cRTP), at 24kbpseach.

!
!
voice-port 2/0:1
!
dial-peer cor custom
!
dial-peer voice 100 pots

!--- Calls to the Public Switched Telephone Network (PSTN).

 destination-pattern 212.......
prefix 212
port 2/0:1
!
dial-peer voice 200 pots

!--- Calls to the corporate network-four digit extension forwarded.

destination-pattern 567....
 port 2/0:1
!
dial-peer voice 110 voip

!--- Calls to Raleigh.

destination-pattern 919392....
session target ipv4:172.16.120.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
dial-peer voice 210 voip    
!--- Calls to San Jose.

destination-pattern 408527....
session target ipv4:172.16.130.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end  

O comando ip qos dscp foi introduzido em IO version12.2(2)T substituir o comando ip precedence (dial-peer).

O comando frame-relay ip rtp priority reserva uma fila de prioridade estrita para um grupo de fluxos de pacote de informação do Real-Time Protocol (RTP) que pertença às portas do destino de uma faixa de protocolo de datagrama de usuário (UDP).

Nota: Porque o comando frame-relay ip rtp priority dá a prioridade absoluta sobre o outro tráfego, use este comando com cuidado. No caso da congestão, se o tráfego excede a largura de banda configurada, a seguir todo o tráfego excedente é deixado cair.

Cisco 3640 Raleigh
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname raleigh3640a
!

logging buffered 50000 debugging
enable secret < password > [Choose a strong password with at 
least one capital letter, one number, and one special character.]
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
dial-peer voice 1 pots
 destination-pattern 9193924100
port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 2126789001
  ip qos dscp cs5 media
 dtmf-relay h245-alphanumeric
 session target ipv4: 172.16.120.2 
!

interface Loopback0
 ip address 172.16.125.1 255.255.255.255
 no ip directed-broadcast
!

interface Serial2/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial2/0.1 point-to-point
description Connection to New York
 ip address 172.16.120.1 255.255.255.0

 frame-relay interface-dlci 100
  class fr_class_voip  
!
!
ip classless
no ip http server
!
!
map-class frame-relay fr_class_voip
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment  80


!--- The recommended fragment size for 10ms delay when carrying voice traffic.


!--- based on the configured CIR 64000.


  frame-relay ip rtp priority 16384 16383 48
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end

Verificar

Esta seção fornece a informação que você pode se usar para confirmar seus trabalhos da configuração.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show frame-relay fragment — Indica a informação sobre a fragmentação do Frame Relay que ocorre no roteador Cisco.

  • mostre a fila da tráfego-forma — Informação dos indicadores sobre os elementos enfileirados a nível do identificador da conexão de link de dados do virtual circuit (VC) (DLCI). Este comando é usado verificar a operação da prioridade de IP RTP sobre o Frame Relay. Quando o link é congestionado, os fluxos de voz estão identificados com um peso zero. Isto indica que o fluxo de voz está usando a fila de prioridade. Refira o exemplo de saída fornecido.

  • [dlci-] pvc do show frame-relay — Indica a informação tal como parâmetros de modelagem de tráfego, valores de fragmentação, e pacotes descartado. Refira o exemplo de saída fornecido aqui e igualmente refira o guia abrangente à Configuração e Troubleshooting do Frame Relay para mais informações.

newyork#show frame-relay fragment

interface   dlci   frag-type   frag-size   in-frag   out-frag   dropped-frag
 
Serial1/0.1 100    end-to-end    80          16        20           0 

Serial1/0.2 200    end-to-end    240         12        10           0 

newyork#show traffic-shape  serial 2/0.1
Interface Se2/0.1

     Access    Target   Byte   Sustain   Excess   Interval    Increment    Adapt
VC   List      Rate     Limit  bits/int  bits/int (ms)        (bytes)      Active

100            64000    80     640       0         10          80          -
  
newyork#show traffic-shape queue
Traffic queued in shaping queue on Serial2/0.1 dlci 100
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 16 kilobits/sec

Traffic queued in shaping queue on Serial2/0.2 dlci 200
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
    Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 144 kilobits/sec

newyork#show frame-relay pvc 100

PVC Statistics for interface Serial2/0 (Frame Relay DCE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0.1

input pkts 1078          output pkts 1078         in bytes 157792
out bytes 172284         dropped pkts 0           in pkts dropped 0
out pkts dropped 0                out bytes dropped 0
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
out BECN pkts 0          in DE pkts 0             out DE pkts 0
out bcast pkts 28        out bcast bytes 8498
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:27:48, last time pvc status changed 00:27:48
Queueing strategy: weighted fair
Current fair queue configuration:
	Discard     Dynamic      Reserved
	threshold   queue count  queue count
		64          16           0
Output queue size 0/max total 600/drops 0
fragment type end-to-end        fragment size 80
cir 64000     bc   640       be 0         limit 80     interval 10
mincir 64000     byte increment 80    BECN response no  IF_CONG no
frags 2707      bytes 172284    frags delayed 2707      bytes delayed 172284
shaping inactive
traffic shaping drops 0
ip rtp priority parameters 16384 32767 48000

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Procedimento de Troubleshooting

Estão aqui a informação de Troubleshooting e as instruções relevantes a esta configuração:

  1. Pesquise defeitos o Frame Relay e o QoS executados para a Voz e assegure sua operação correta.

  2. Continue ao Troubleshooting de falhas da chamada de voz como necessário.

    Nota: Para uma informação de Troubleshooting mais detalhada, refira o VOIP sobre o Frame Relay com QoS (fragmentação, modelagem de tráfego, prioridade RTP LLQ/IP).

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debugar a prioridade — Indica eventos do Priority Queueing (PQ) e mostra se uma gota ocorre nesta fila. Para obter mais informações, consulte Troubleshooting Quedas de Emissor com Priority Queuing.

  • debug frame-relay fragment — Evento ou Mensagens de Erro dos indicadores relativo à fragmentação do Frame Relay. Este comando é permitido somente a nível PVC na interface selecionada.

    newyork#debug priority 
    Priority output queueing debugging is on
    newyork#ping 172.16.120.1
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 172.16.120.1, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms 
    newyork# 
    *Mar  1 05:11:24.746: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.754: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.810: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.818: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.874: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.882: PQ: Serial2/0 output (Pk size/Q 13/0) 
    
    newyork#debug frame-relay fragment interface serial 2/0 100
    This may severely impact network performance.
    You are advised to enable no logging console debug. Continue?[confirm]
    Frame Relay fragment/packet debugging is on
    Displaying fragments/packets on interface Serial2/0 dlci 100 only
    
    *Mar  1 20:58:32.838: Serial1/0.1(o): dlci 100, tx-seq-num 3645, 
    B bit set, frag_hdr 03 B1 9C 3D
    *Mar  1 20:58:32.846: Serial1/0.1(o): dlci 100, tx-seq-num 3646, 
    E bit set, frag_hdr 03 B1 5C 3E
    *Mar  1 20:58:32.890: Serial1/0.1(i): dlci 100, rx-seq-num 17, 
    exp_seq-num 17,B bit set,
    	 frag_hdr 03 B1 80 11
    *Mar  1 20:58:32.894: Serial1/0.1(i): dlci 100, rx-seq-num 18, 
    exp_seq-num 18,E bit set,
    	 frag_hdr 03 B1 40 12

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12162