Voz : Qualidade de voz

VoIP por Frame Relay com qualidade de serviço (fragmentação, modelagem de tráfego, prioridade LLQ/IP RTP)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (2 Abril 2008) | Inglês (22 Agosto 2015) | Feedback


Índice

LLQ

Introdução

Este documento mostra uma configuração de exemplo de Voz sobre IP (VoIP) sobre uma rede Frame Relay com Qualidade de Serviço (QoS). Este documento inclui informações técnicas de fundo sobre recursos configurados, diretrizes de projeto e verificação básica e estratégias de Troubleshooting.

É importante notar que a configuração neste documento tem dois Roteadores da Voz que é conectado à rede do Frame Relay. Em muitas topologias contudo, os roteadores ativado da Voz podem existir em qualquer lugar. Geralmente, o Roteadores da Voz usa a conectividade de LAN ao outro Roteadores que são conectados a WAN. Isto é importante porque se seu Roteadores da Voz não é conectado diretamente à rede do Frame Relay, todos os comandos de configuração de WAN devem ser configurados naquele Roteadores conectado a WAN, e não no Roteadores da Voz, segundo as indicações das configurações neste documento.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 3640 Router com Software Release 12.2.6a do ½ do ¿  de Cisco IOSï (Enterprise Plus)

  • Cisco 2621 Router com Cisco IOS Software Release 12.2.6a (Enterprise Plus)

  • LLQ (enfileiramento de baixa latência) nos PVCs (circuitos virtuais permanentes do Frame Relay). Isto é introduzido no Cisco IOS Software Release 12.1.(2)T.

  • Prioridade do Real-Time Transport Protocol (RTP) IP do Frame Relay que é introduzida no Cisco IOS Software Release 12.0(7)T.

  • Fórum do Frame Relay (fragmentação FRF).12 que é introduzida no Cisco IOS Software Release 12.0(4)T.

  • Os Cisco IOS Software Release mais tarde do que 12.0.5T contêm melhorias significativas de desempenho para o Compressed RTP (cRTP).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Diretrizes de criação do QoS para VoIP sobre frame relay

Há dois requisitos básicos para uma boa qualidade de voz:

Para garantir as exigências previamente mencionadas, use estas diretrizes:

Prioridade estrita para tráfego de voz (prioridade LLQ ou IP RTP)

Há dois métodos principais para fornecer a prioridade estrita para o tráfego de voz:

  • Funcionalidade IP RTP Priority (também chamada de Fila de Prioridade/Weighted Fair Queuing (PQ/WFQ))

  • LLQ (também chamado de PQ / Class Based Weighted Fair Queuing (PQ/CBWFQ))

Prioridade de RTP de IP

O Frame Relay IP RTP Priority cria uma fila de prioridade estrita em um PVC do Frame Relay para um grupo de fluxos do pacote RTP que pertencem às portas do destino de uma faixa de protocolo de datagrama de usuário (UDP). Quando as portas reais usadas forem negociadas dinamicamente entre dispositivos finais ou gateways, todo o Produtos do Cisco voip utiliza o mesmo intervalo de porta UDP (16384 a 32767). Quando o roteador reconhece o tráfego de VoIP, ele o coloca no PQ exato. Quando o PQ está vazio, as outras filas estão processadas basearam no padrão WFQ. A prioridade de RTP de IP não se torna ativa até que haja congestionamento na interface. Esta imagem ilustra a operação da prioridade de IP RTP:

/image/gif/paws/12156/pq-wfq.gif

Nota: O IP RTP Priority reserva estourar o PQ quando há uma largura de banda disponível na fila padrão (WFQ). Contudo, policia restritamente os índices PQ quando há uma congestão na relação.

LLQ

O LLQ é um recurso que fornece uma PQ estrita ao CBWFQ. O LLQ habilita um único PQ estrito dentro do CBWFQ no nível de classe. Com o LLQ, os dados sensíveis a retardo (no PQ) são retirados da fila e enviados primeiro. Em um VoIP com implementação LLQ, o tráfego de voz é colocado no PQ estrito.

O PQ é vigiado para garantir que as filas justas não tenham necessidade de largura de banda. Ao configurar o PQ, especifique a quantidade máxima, em Kbps, de largura de banda disponível para o PQ. Quando a interface estiver congestionada, o PQ receberá o serviço até que a carga atinja o valor de Kbps configurado na declaração da prioridade. O tráfego em excesso é eliminado para evitar o problema com o recurso de grupos de prioridade em produtos Cisco anteriores em que as PQs de nível inferior ficam sem atividade.

Nota: Com LLQ para Frame Relay, as filas são configuradas por PVC. Cada PVC tem um PQ e um número atribuído de filas consideráveis.

/image/gif/paws/12156/llq.gif

Este método é mais complexo e flexível que a prioridade de RTP de IP. A escolha entre os métodos precisa de ser baseada nos testes padrão de tráfego em sua rede real e em suas necessidades.

Prioridade LLQ versus IP RTP

Esta tabela resume os principais diferença entre o LLQ e o IP RTP Priority e fornece diretrizes de quando usar cada método.

LLQ Prioridade de RTP de IP
Comparar tráfego de voz com base em:
  • Listas de acesso. Por exemplo, intervalo de portas UDP, endereços de hosts, campos ToS (Tipo de Serviço) do cabeçalho IP (por exemplo, Precedência IP, DSCP [Ponto de Código de Serviços Diferenciados]).
  • intervalo de portas IP RTP.
  • Campos ToS IP — DSCP e/ou Precedência IP.
  • Protocolos e Interfaces de Entrada.
  • Todos os critérios de correspondência válidos utilizados no CBWFQ.
Vantagens:
  • Mais flexibilidade no modo como o tráfego é correspondido e direcionado para o PQ estrito e para o CBWFQ.
  • É capaz de configurar classes adicionais para garantir a largura de banda para outro tráfego, como sinalização de VoIP e vídeo.
Desvantagens: Configuração complexa.
Comparar tráfego de voz com base em:
  • Baseado no intervalo de porta RTP/UDP: 16384-32767
Vantagens: Configuração simples. Desvantagens:
  • Tráfego (sinalização de VoIP) de protocolo RTCP atendido na fila WFQ.

    Nota: O protocolo RTP usa RTCP para controlar a entrega de pacotes RTP. Quando as portas RTP usarem números par, as portas RTCP usam números ímpares na escala de 16384-32767. A Prioridade RTP IP coloca portas RTP no PQ, enquanto as portas RTCP são servidas no WFQ padrão.

  • Tráfego voip dos saques no PQ. Contudo, todo o outro tráfego que precisar o tratamento preferencial e a garantia de largura de banda é servido no WFQ. Enquanto o WFQ pode diferenciar fluxos com pesos (com base na precedência IP), ele não pode garantir que a largura de banda para qualquer fluxo.
Diretrizes:
  • A escolha entre elas necessidades de ser baseado nos testes padrão de tráfego em sua rede real e em suas necessidades reais.
  • Se você precisa de fornecer a prioridade estrita a seu tráfego de voz, e o outro tráfego pode ser tratado como um único tipo (dados), a seguir o IP RTP Priority faz um bom trabalho para sua rede com uma configuração simples.
  • Se você planeja priorizar o tráfego de voz baseado em outros critérios que não sejam portas UDP. Por exemplo, o PHB (Per Hop Behavior) dos DiffServ (Differentiated Services) e o LLQ.

FRTS para voz

O FRTS fornece os parâmetros que são úteis controlar o congestionamento do tráfego de rede. O FRTS elimina gargalos nas redes Frame Relay com conexões de alta velocidade com a instalação central e conexões de baixa velocidade com as instalações de filial. Você pode configurar os valores de aplicação de taxa para limitar a taxa na qual os dados são enviados do Circuito Virtual (VC) na instalação central.

Estas definições são relacionadas ao FRTS:

  • Taxa de Informações Comprometidas (CIR)—Taxa (bits por segundo) garantida pelo provedor de Frame Relay para transferência de dados. Os valores de CIR são definidos pelo provedor de serviços de Frame Relay e configurados pelo usuário no roteador.

    Nota: A porta/taxa de acesso de interface pode ser mais altas do que o CIR. A taxa é calculada a média durante um período de tempo do intervalo de medição da taxa comprometida (Tc).

  • (Bc) do committed burst — Número máximo de bit que a rede do Frame Relay compromete para transferir sobre um Tc. Tc = Bc / CIR.

  • (Be) da intermitência excedente — Número máximo de bit não comprometido que o Frame Relay Switch tenta transferir além do CIR sobre o Tc.

  • Intervalo de medição da taxa comprometida (Tc) — Intervalo de tempo sobre que Bc ou (Bc+ seja) bit são transmitidos. O Tc é calculado como Tc = Bc/CIR. O valor Tc não é configurado diretamente em roteadores Cisco. É calculado depois que os valores Bc e CIR forem configurados. Tc não pode exceder 125 ms.

  • Para trás notificação de congestionamento explícito (BECN) — Um bit no cabeçalho de estrutura do Frame Relay que indica a congestão na rede. Quando um Frame Relay Switch reconhece a congestão, ajusta o bit BECN nos quadros destinados para o roteador de origem e instrui o roteador reduzir a taxa de transmissão.

A configuração do FRTS para o tráfego de voz é diferente daquela do modelagem de tráfego para dados somente. Ao configurar o FRTS para a Qualidade de voz, os acordos são feitos com os parâmetros do tráfego de dados. Para obter mais informações sobre destas limitações veja a seção da fragmentação (FRF.12) neste documento.

Fragmentação (FRF.12)

Um grande desafio na integração de dados de voz é controlar o retardo máximo de unidirecional de ponta a ponta para tráfego sensível ao tempo, como voz. Para a boa qualidade de voz, este atraso precisa de ser menos da Senhora 150. Uma parte importante deste atraso é o retardo de serialização na relação. Cisco recomenda que esta seja a Senhora 10 e não deva exceder a Senhora que 20 o retardo de serialização é o tempo toma para colocar realmente os bit em uma relação.

Serialization Delay = frame size (bits) / link bandwidth (bps)

Por exemplo, um pacote de 1500-bytes leva 214 ms para sair do roteador em um enlace de 56 Kbps. Se um pacote de dados diferentes do tempo real de 1500 bytes é enviado, os pacotes de dados do tempo real (Voz) estão enfileirados até que o grande pacote de dados esteja transmitido. Esse retardo é inaceitável no tráfego de voz. Se pacotes de dados em tempo não real são fragmentados em estruturas menores, eles são intercalados com estruturas em tempo real (voz). Dessa forma, tanto a voz quanto as estruturas de dados podem ser transportadas juntas ou em enlaces de velocidade baixa sem causar retardos excessivos ao tráfego de voz de tempo real.

/image/gif/paws/12156/lfi.gif

Para obter mais informações sobre fragmentação, consulte Frame Relay Fragmentation for Voice.

Nota: Nos casos onde você tem uma conexão semi-t1 dedicada (768 kbps), você provavelmente não precisa uns recursos de fragmentação. Contudo, você ainda precisa um mecanismo de QoS (IP RTP Priority ou LLQ, neste caso). A semi-T1 ou velocidades maiores oferecem largura de banda suficiente para permitir que pacotes de voz entrem e saiam da fila dentro da faixa de retardo de serialização recomendada (10 ms, não mais que 20 ms). Também, você provavelmente não precisa o cRTP, que ajuda a salvar a largura de banda comprimindo cabeçalhos de IP RTP, no caso de um T1 completo.

Redução de largura de banda

cRTP

Baseado no RFC 2508leavingcisco.com , a característica do cRTP comprime o cabeçalho de pacote de informação IP/UDP/RTP de 40 bytes a 2 ou 4 bytes. Isto reduz o consumo de largura de banda desnecessário. É um esquema de compressão de salto a salto. Consequentemente, o cRTP deve ser configurado no ambas as extremidades do link, a menos que a opção passiva for configurada.

Nota: cRTP não é necessário para garantir uma boa qualidade de voz. É um recurso que reduz o consumo de largura de banda. Configure cRTP depois de todas as outras condições serem atendidas e a qualidade de voz ser boa. Este procedimento ganha o tempo de Troubleshooting porque isola edições potenciais do cRTP.

Monitore a utilização CPU do roteador. Desabilite o cRTP se está acima de 75 por cento. Em umas taxas de enlace mais altas, as economias da largura de banda do cRTP puderam potencialmente ser aumentadas pela carga de CPU adicional. Cisco recomenda somente usar o cRTP com links mais baixo de 768 kbps, a menos que o roteador for executado em uma baixa taxa de utilização CPU.

Nota: Na ausência de um padrão, cRTP para Frame Relay foi desenvolvido no encapsulamento patenteado da Cisco. Consequentemente, não trabalha com encapsulamento do Internet Engineering Task Force (IETF) do Frame Relay. Recentemente, o FRF.20 foi finalizado para tornar o RTP Header Compression possível no encapsulamento da IETF. Contudo, na última atualização deste documento (maio de 2002), o FRF.20 não é suportado.

Para obter mais informações, consulte o Protocolo de Transporte de Tempo Real Comprimido.

Seleção do codificador/decodificador (codec)

Use codecs de baixa taxa de bits nos segmentos das chamadas VoIP. G.729 (8 kbps) é o codec do padrão para o VoIP dial-peer.

Nota: Embora o tom dual multifrequency (DTMF) esteja transportado geralmente exatamente quando os codecs da Voz do high-bit-rate estão usados (como G.711), os codecs do low-bit-rate (tais como G.729 e o G.723.1), estão aperfeiçoados altamente para testes padrão de voz e tendem a distorcer toms DMTF. Esta abordagem pode resultar em problemas durante o acessar a sistemas de Resposta de Voz Interativa (IVR). O comando dtmf relay resolve o problema de distorção de DTMF. Transporta os toms DMTF fora da banda ou separa-os do fluxo de voz codificada. Se você se usa os codecs do low-bit-rate (G.729, G.723) gerenciem sobre o comando dtmf relay sob o VoIP dial-peer.

Habilitar Detecção de Atividade de Voz (VAD)

Uma conversação típica pôde potencialmente conter 35 ao percentual de silêncio dos 50 pés. Os pacotes de silêncio são suprimidos quando o VAD é usado. Para o planeamento da largura de banda voip, supõe que o VAD reduz a largura de banda por 35 por cento. VAD é configurado por padrão nos correspondentes de discagem VoIP.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

LLQ

Use este procedimento para configurar o LLQ:

  1. Crie um mapa de classe para tráfego VoIP e defina critérios de correspondência.

    Estes comandos explicam como terminar esta tarefa:

    maui-voip-sj(config)#class-map ?
           WORD 		class-map name
           match-all 	Logical-AND all matching statements under this classmap
           match-any 	Logical-OR all matching statements under this classmap
    maui-voip-sj(config)#class-map match-all voice-traffic 
    
    !--- Choose a descriptive class_name. 
    
    
    maui-voip-sj(config-cmap)#match ?
      access-group         Access group
      any                  Any packets
      class-map            Class map
      cos                  IEEE 802.1Q/ISL class of service/user priority values
      destination-address  Destination address
      input-interface      Select an input interface to match
      ip                   IP specific values
      mpls                 Multi Protocol Label Switching specific values
      not                  Negate this match result
      protocol             Protocol
      qos-group            Qos-group
      source-address       Source address
    
    !--- In this example  the access-group matching 
    !--- option is used for its flexibility (it uses an access-list).
    
    
    maui-voip-sj(config-cmap)#match access-group ?
      <1-2699>  Access list index
      name      Named Access List
    maui-voip-sj(config-cmap)#match access-group 102 
    
    
    !--- Create the access-list to match the class-map access-group:
    
    
    maui-voip-sj(config)#access-list 102 permit udp any any range 16384 32767
    
    !--- The safest and easiest way is to match with UDP port range 16384-32767.
    !--- This is the port range Cisco IOS H.323 products utilize to transmit 
    !--- VoIP packets.
    
    

    Estas listas de acesso são usadas igualmente para combinar o tráfego de voz com o comando match access-group:

    access-list 102 permit udp any any precedence critical
    
    !--- This list filters traffic based on the IP packet TOS: Precedence field.  
    !--- Note: Ensure that the other non-voice traffic does not use the 
    !--- same precedence value.
    
    
    access-list 102 permit udp any any dscp ef
    
    !--- In order for this list to work, ensure that VoIP packets are tagged 
    !--- with the dscp ef code before they exit on the LLQ WAN interface. 
    !--- For more information on DSCP, refer to 
    !--- Implementing Quality of Service Policies with DSCP.
    !--- Note: If endpoints are not trusted on their packet marking, 
    !--- mark incoming traffic by applying an inbound service policy on an 
    !--- inbound interface. This procedure is out of the scope 
    !--- of this document. 
    
    
    access-list 102 permit udp host 192.10.1.1 host 192.20.1.1
    
    !--- This access-list can be used in cases where the VoIP 
    !--- devices cannot do precedence or DSCP marking and you 
    !--- cannot determine the  VoIP UDP port range.
     

    Estes são outros métodos correspondentes que podem ser usados em vez dos comandos access-group:

    • Com Cisco IOS Software Release 12.1.2.T e Mais Recente, a funcionalidade do IP RTP Priority é executada para o LLQ. Esta característica combina os conteúdos de classe prioritária que olham as portas UDP configuradas. É sujeita à limitação de servir somente portas uniformes no PQ.

      class-map voice
        match ip rtp 16384 16383
      
    • Estes dois métodos operam-se sob a suposição que os pacotes voip estão marcados nos host de origem ou combinados e marcados no roteador antes que a operação LLQ de saída esteja aplicada:

      class-map voice 
         match ip precedence 5
      

      OU

      class-map voice
         match ip dscp ef
      

      Nota: No Cisco IOS Software Release 12.2.2T e Mais Recente, os VoIP dial-peer podem marcar pacotes do portador e da sinalização da Voz antes da operação de LLQ. Isto permite uma maneira escalável marcar e combinar pacotes voip com os valores de código DSCP para o LLQ. Para obter mais informações, consulte Classificando a sinalização e a mídia VoIP com o DSCP para QoS.

      Router(config-dial-peer)#ip qos dscp ?
      
  2. Crie um mapa de classes para sinalização VoIP e defina critérios de correspondência (opcional).

    Use estes comandos terminar esta tarefa:

    class-map voice-signaling
      match access-group 103
    !
    access-list 103 permit tcp any eq 1720 any
    access-list 103 permit tcp any any eq 1720
    

    Nota: É possível estabelecer chamadas de VoIP usando H.323, o protocolo SIP, o protocolo MGCP ou o protocolo SCCP - protocolo proprietário usado pelo Cisco Call Manager. O exemplo anterior supõe que H.323 conecta rapidamente. Esta lista serve como a referência para as portas usadas pela sinalização voip e pelos canais de controle:

    • H.323/H.225 = TCP 1720

    • H.323/H.245 = TCP 11xxx (conexão padrão)

    • H.323/H.245 = TCP 1720 (Fast Connect)

    • H.323/H.225 RAS = UDP 1718 (ao porteiro)

    • SCCP = TCP 2000-2002 (encore CM)

    • ICCP = TCP 8001-8002 (CM Encore)

    • MGCP = UDP 2427, TCP 2428 (CM Encore)

    • SIP= UDP 5060, TCP 5060 (configurável)

  3. Crie um mapa de política e o associe aos mapas de classe VoIP.

    A finalidade do mapa de política é definir como os recursos do link são compartilhados ou atribuídos às classes diferentes do mapa. Use estes comandos terminar esta tarefa:

    maui-voip-sj(config)#policy-map VOICE-POLICY
    
    !--- Choose a descriptive policy_map_name.
    
    
    maui-voip-sj(config-pmap)#class voice-traffic
    maui-voip-sj(config-pmap-c)#priority ?
     <8-2000000>  Kilo Bits per second
    
    !--- Configure the voice-traffic class to the strict PQ
    !--- (priority command) and assign the bandwidth.
    
    
    maui-voip-sj(config-pmap)#class voice-signaling
    maui-voip-sj(config-pmap-c)#bandwidth 8
    
    !--- Assign 8 Kbps to the voice-signaling class.
    
    
    maui-voip-sj(config-pmap)#class class-default
    maui-voip-sj(config-pmap-c)#fair-queue 
    
    !--- The remaining data traffic is treated as WFQ.
    
    

    Nota: Embora seja possível enviar à fila vários tipos de tráfego de tempo real ao PQ, Cisco recomenda que você lhe dirige somente o tráfego de voz. O tráfego de tempo real, tal como o vídeo, introduz potencialmente a variação no atraso (o PQ é uma fila do first in first out (FIFO)). O tráfego de voz exige que o atraso não seja variável para evitar tremulação.

    Nota: A soma dos valores para a prioridade e as instruções de largura de banda precisam de ser inferior ou igual a mincir para o PVC. Se não, o comando service-policy não pode ser atribuído ao link. o mincir é metade do CIR à revelia. Para ver os Mensagens de Erro, assegure-se de que o comando logging console esteja permitido para o acesso de console e o comando terminal monitor esteja permitido para o acesso do telnet.

    Para obter mais informações sobre os comandos bandwidth e priority, consulte Comparando os comandos bandwidth e priority de uma política de serviços de QoS.

  4. Habilite LLQ, aplica o mapa de políticas à interface de saída WAN.

    Use estes comandos permitir o LLQ:

    maui-voip-sj(config)#map-class frame-relay VoIPovFR
    maui-voip-sj(config-if)#service-policy output VOICE-POLICY
    
    !--- The service-policy is applied to the PVC 
    !--- indirectly by configuring 
    !--- it under the map-class associated to the PVC.
    
    

Prioridade de RTP de IP

Se você não usa o LLQ, use estas diretrizes:

Router(config-map-class)#frame-relay ip rtp priority starting-rtp-port  
port-range  bandwidth 
  • starting-rtp-port — O número de porta começando UDP. O número de porta mais baixo para o qual os pacotes são enviados. Para VoIP, defina esse valor como 16384.

  • port-range—A faixa de portas de UDP de destino. O número, adicionado ao starting-rtp-port, rende o número de porta o mais alto UDP. Para VoIP, defina esse valor como 16383.

  • largura de banda — Largura de banda permitida máxima nos kbps para a fila de prioridade. Ajuste este número baseado no número de chamadas simultâneas, adicionando a largura de banda de cada atendimento pelo atendimento que os suportes de sistema.

Configuração de exemplo:

map-class frame-relay VoIPovFR  frame-relay cir 64000
 frame-relay BC 600
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80
 frame-relay ip rtp priority 16384 16383 45

Modelagem de tráfego para voz

Use estas diretrizes quando você configura o modelagem de tráfego para a Voz:

  • Não exceda o CIR do PVC.

  • Desabilite o formato adaptável do Frame Relay.

  • Define um valor baixo de Bc para que o Tc (intervalo de modelagem) seja de 10 ms (Tc = Bc/CIR). Configure o valor Bc para forçar o valor Tc desejado.

  • Defina o Valor Be como 0.

Para mais informação destas diretrizes, refira o Formatação de tráfego frame relay para VoIP e VoFR.

Nota: Alguns clientes usam PVCs separados para dados e voz. Se você tem dois PVC separados e os quer estourar no PVC de dados quando você permanecer a ou abaixo do CIR para a Voz PVC, a Qualidade de voz ainda sofre desde que estes PVC usam a mesma interface física. Nesses casos, o fornecedor do Frame Relay, assim como o roteador, precisam de dar a prioridade à Voz PVC. Os últimos podem ser feitos pelo PVC Interface Priority Queueing (PIPQ) disponível até à data do Cisco IOS Software Release 12.1(1)T.

Fragmentação (FRF.12)

Ative a fragmentação para os links de baixa velocidade (menos de 768 kbps). Ajuste o tamanho do fragmento de modo que os pacotes de voz não sejam fragmentados e não experimentem um retardo de serialização maior de 20 que a Senhora ajustou o tamanho de fragmentação baseado na velocidade de porta mais baixa entre o Roteadores. Por exemplo, se há uma topologia do Frame Relay do hub and spoke onde o hub tenha uma velocidade T1 e os roteadores remotos tenham 64 velocidades de porta K, o tamanho de fragmentação precisa de ser ajustado para a velocidade 64 K em ambo o Roteadores. Todos os outros PVC que compartilharem da mesma necessidade da interface física de configurar a fragmentação ao tamanho usaram-se pela Voz PVC. Use esta carta para determinar os valores do tamanho de fragmentação.

Velocidade mais baixa de enlace no caminho Tamanho de Fragmentação Recomendado (para Serialização em 10 ms)
56 Kbps 70 bytes
64 kbps 80 bytes
128 Kbps 160 bytes
256 kbps 320 bytes
512 Kbps 640 bytes
768 Kbps 1000 bytes
1536 Kbps 1600 bytes

Configuração de exemplo:

map-class frame-relay VoIPovFR 

!--- Some output is omitted.

 frame-relay fragment 80

Nota: Para 1536 kbps, nenhuma fragmentação é precisada tecnicamente. Contudo, a fragmentação é precisada de permitir o sistema duplo do enfileiramento de FIFO de assegurar a Qualidade de voz. Um tamanho do fragmento de 1600 bytes permite o FIFO duplo. Contudo, desde 1600 os bytes são mais altos do que a unidade de transmissão máxima de interface serial típica (MTU), grandes pacotes de dados não é fragmentada.

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

/image/gif/paws/12156/VoIP_FR.gif

Configurações

Este documento usa as configurações mostradas aqui:

  • maui-voip-sj (Cisco 3640)

  • maui-voip-austin (Cisco 3640)

maui-voip-sj (Cisco 3640)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname maui-voip-sj
!
logging buffered 10000 debugging
enable secret 5 $1$MYS3$TZ6bwrhWB25b2cVpEVgBo1
!
ip subnet-zero
!

!--- Definition of the voice signaling and traffic class maps.
!--- "voice-traffic" class uses access-list 102 for its matching criteria.
!--- "voice-signaling" class uses access-list 103 for its matching criteria.

class-map match-all voice-signaling
 match access-group 103
class-map match-all voice-traffic
  match access-group 102
!

!--- The policy map defines how the link resources are assigned
!--- to the different map classes. In this configuration, strict PQ
!--- is assigned to the voice-traffic class 
!--- with a maximum bandwidth of 45 Kbps.
 

policy-map VOICE-POLICY
  class voice-traffic
  priority 45
  class voice-signaling
  bandwidth 8


!--- Assigns a queue for voice-signaling traffic that ensures 8 Kbps.
!--- Note that this is optional and has nothing to do with good voice
!--- quality. Instead, it is a way to secure signaling.


  class class-default
  fair-queue


!--- The class-default class is used to classify traffic that does
!--- not fall into one of the defined classes.
!--- The fair-queue command associates the default class WFQ queueing.

!
interface Ethernet0/0
  ip address 172.22.113.3 255.255.255.0
  half-duplex
!
interface Serial0/0
 bandwidth 128
 no ip address
 encapsulation frame-relay
 no fair-queue
frame-relay traffic-shaping
 frame-relay ip rtp header-compression

!--- Turns on traffic shaping and cRTP. If traffic-shaping is not
!--- enabled, then map-class does not start and FRF.12 and LLQ  does
!--- not work.

!
interface Serial0/0.1 point-to-point
 bandwidth 128
 ip address 192.168.10.2 255.255.255.252
 frame-relay interface-dlci 300
  class VOIPovFR

!--- This command links the subinterface to a VoIPovFR map-class.
!--- See the map-class frame-relay VoIPovFR command  here:
!--- Note: The word VoIPovFR is selected by the user.
!

ip classless
ip route 172.22.112.0 255.255.255.0 192.168.10.1
!
map-class frame-relay VOIPovFR
 no frame-relay adaptive-shaping

!--- Disable Frame Relay BECNS. Note also that Be equals 0 by default.

frame-relay cir 64000
 frame-relay bc 640

!--- Tc = BC/CIR. In this case Tc is forced to its minimal
!--- configurable value of 10 ms.

frame-relay be 0
 frame-relay mincir 64000

!--- Although  adaptive shaping is disabled, make CIR equal minCIR
!--- as a double safety. By default minCIR  is half of CIR.

service-policy output VOICE-POLICY

!--- Enables LLQ on the PVC.

frame-relay fragment 80

!--- Turns on FRF.12 fragmentation and sets the fragment size equal to 80 bytes.
!--- This value is based on the port speed of the slowest path link.
!--- This command also enables dual-FIFO.

!
access-list 102 permit udp any any range 16384  32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!

!--- access-list 102 matches VoIP traffic 
!--- based on the UDP port range.
!--- Both odd and even ports are put into the PQ.
!--- access-list 103 matches VoIP signaling protocol. In this
!--- case, H.323 V2 is uesd with the fast start feature.

!
voice-port 1/0/0
!
dial-peer voice 1 pots
 destination-pattern 5000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 6000
 session target ipv4:192.168.10.1
 dtmf-relay cisco-rtp
 ip precedence 5

maui-voip-austin (Cisco 3640)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname maui-voip-austin
!
boot system flash slot1:c3640-is-mz.122-6a.bin
logging buffered 1000000 debugging
!
ip subnet-zero
!
class-map match-all voice-signaling
match access-group 103
class-map match-all voice-traffic
  match access-group 102
!
policy-map voice-policy
  class voice-signaling
   bandwidth 8
  class voice-traffic
    priority 45
  class class-default
   fair-queue
!
interface Ethernet0/0
 ip address 172.22.112.3 255.255.255.0
 no keepalive
 half-duplex
!
interface Serial0/0
 bandwidth 64
 no ip address
 encapsulation frame-relay
 no ip mroute-cache 
 no fair-queue
 frame-relay traffic-shaping
 frame-relay ip rtp header-compression
!
interface Serial0/0.1 point-to-point
 bandwidth 64
 ip address 192.168.10.1 255.255.255.252
 frame-relay interface-dlci 400
  class VOIPovFR
!
ip classless
ip route 172.22.113.0 255.255.255.0 192.168.10.2
!
map-class frame-relay VOIPovFR
no frame-relay adaptive-shaping
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 service-policy output voice-policy
 frame-relay fragment 80
access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
voice-port 1/0/0
!
dial-peer voice 1 pots
 destination-pattern 6000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 5000
 session target ipv4:192.168.10.2
 dtmf-relay cisco-rtp
 ip precedence 5

Verificar e solucionar problemas

Esta seção fornece as informações para confirmar que sua configuração funciona adequadamente.

Determinados comandos show são suportados pela ferramenta Output Interpreter (clientes registrados somente). Isso permite que você veja uma análise da saída do comando show.

Comandos de prioridade de LLQ / IP RTP

Estes comandos show and debug ajudam-no a verificar suas configurações LLQ e de IP RTP Priority.

  • mostre a relação do mapa de política o interface# de série — Este comando é útil ver a operação de LLQ e todas as gotas no PQ. Para obter informações adicionais sobre os diversos campos nesse comando, consulte Entendendo os contadores de pacote na Saída show policy-map interface.

  • show policy-map policy_map_name Exibe as informações dobre a configuração do mapa de políticas.

  • show queue interface-type interface-number — Configuração e estatísticas do enfileiramento considerável das lista para uma interface particular.

  • debugar a prioridade — Indica eventos PQ e mostra se deixar cair ocorre nesta fila. Para obter mais informações, consulte Troubleshooting Quedas de Emissor com Priority Queuing.

  • show class-map class_name — Indica a informação sobre a configuração de mapa de classe.

  • mostre a voz ativa do atendimento — Verificações para pacotes perdidos a nível DSP.

  • compressão de cabeçalhos do RTP IP do show frame-relay — Estatísticas dos indicadores RTP Header Compression.

Comandos de fragmentação

Use estes comandos debug and show verificar e pesquisar defeitos configurações de fragmentação.

  • show frame-relay fragment — Indica a informação sobre a fragmentação do Frame Relay que ocorre no roteador Cisco.

  • debug frame-relay fragment — Evento ou Mensagens de Erro dos indicadores relativo à fragmentação do Frame Relay. É habilitado apenas no nível do PVC na interface selecionada.

Comandos de Frame Relay/interface

Use estes comandos show verificar e pesquisar defeitos o Frame Relay/configurações da interface.

  • mostre a relação de fila da tráfego-forma — Informação dos indicadores sobre os elementos enfileirados a nível do identificador da conexão de link de dados VC (DLCI). Usado para verificar a operação da prioridade de IP RTP sobre o Frame Relay. Quando o link é congestionado, os fluxos de voz estão identificados com um peso zero. Isto indica que o fluxo de voz usa o PQ. Veja o exemplo de saída aqui.

  • show traffic-shape — Exibe infs be infs como os valores configurados para Tc, Bc, Be e CIR. Veja o exemplo de saída.

  • pvc DLCI-# do show frame-relay — Indica a informação tal como parâmetros de modelagem de tráfego, valores de fragmentação, e pacotes descartado. Veja o exemplo de saída. Consulte também Troubleshooting Frame Relay (Solucionando problemas de Frame Relay).

Problemas conhecidos

Um erro foi identificado em per VC LLQ, em que o PQ foi intensivamente vigiado mesmo quando não havia congestionamento na interface. Esse erro esteve fixado e os pacotes de voz agora deconformação são deixados cair somente se a congestão ocorre no VC. Isto faz ao comportamento do por VC LLQ o mesmos que outras relações que usam o LLQ. Este comportamento foi mudado com Cisco IOS Software Release 12.2(3) e Mais Recente.

Exemplo de saída do comando show e debug

Esta é saída do comando show and debug da amostra usada para a verificação e Troubleshooting.


!--- To capture sections of this output, the LLQ PQ bandwidth
!--- is lowered and large data traffic  is placed
!--- on the link to force packets drops. 
      
!--- Priority queue bandwidth  is lowered to 10 Kbps to force drops from the PQ.
!--- Note: To reset counters, use the clear counters command. 


maui-voip-sj#show policy-map inter ser 0/0.1
  Serial0/0.1: DLCI 300 -

  Service-policy output: VOICE-POLICY

Class-map: voice-traffic (match-all)
         26831 packets, 1737712 bytes
         5 minute offered rate 3000 bps, drop rate 2000 bps
         Match: access-group 102
         Weighted Fair Queueing
         Strict Priority
         Output Queue: Conversation 24
         Bandwidth 10 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 26311/1704020
         (total drops/bytes drops) 439/28964

   Class-map: voice-signaling (match-all)
         80 packets, 6239 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 62/4897
         (depth/total drops/no-buffer drops) 0/0/0
    
   Class-map: class-default (match-any)
         14633 packets, 6174492 bytes
         5 minute offered rate 10000 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 0/0/0

      

!--- These  commands are useful to verify the LLQ configuration.
 
      
maui-voip-austin#show policy-map voice-policy
  Policy Map voice-policy
   Class voice-signaling
        Weighted Fair Queueing
           Bandwidth 8 (kbps) Max Threshold 64 (packets)
   Class voice-traffic
        Weighted Fair Queueing
         Strict Priority
             Bandwidth 45 (kbps) Burst 1125 (Bytes)
   Class class-default
        Weighted Fair Queueing
           Flow based Fair Queueing Max Threshold 64 (packets)

maui-voip-austin#show class-map
 Class Map match-all voice-signaling (id 2)
         Match access-group  103
 Class Map match-any class-default (id 0)
         Match any
 Class Map match-all voice-traffic (id 3)
         Match access-group 102


!--- Frame Relay verification command output.


maui-voip-sj#show frame-relay fragment
interface         dlci  frag-type    frag-size  in-frag    out-frag   dropped-frag
Serial0/0.1       300   end-to-end      80         4          4          0

maui-voip-sj#show frame-relay pvc 300

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 300, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 7 output pkts 7 in bytes 926
         out bytes 918 dropped pkts 0 in FECN pkts 0
         in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
         in DE pkts 0 out DE pkts 0
         out bcast pkts 2 out bcast bytes 598
         pvc create time 1w2d, last time pvc status changed 1w2d
      service policy VOICE-POLICY

 Service-policy output: VOICE-POLICY

 Class-map: voice-traffic (match-all)
         0 packets, 0 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 102
         Weighted Fair Queueing
      Strict Priority
         Output Queue: Conversation 24
         Bandwidth 45 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 0/0
         (total drops/bytes drops) 0/0

 Class-map: voice-signaling (match-all)
         0 packets, 0 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 0/0
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: class-default (match-any)
         7 packets, 918 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 0/0/0


 Output queue size 0/max total 600/drops 0
 fragment type end-to-end fragment size 80
 cir 64000 bc 640 be 0 limit 80 interval 10
 mincir 64000 byte increment 80 BECN response no
 frags 13 bytes 962 frags delayed 8 bytes delayed 642
 
 shaping inactive
 traffic shaping drops 0


!--- In this Frame Relay verification command 
!--- output, the PQ bandwidth is lowered and heavy traffic 
!--- is placed on the interface to force drops.


maui-voip-sj#show frame-relay pvc 300

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 300, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 483 output pkts 445 in bytes 122731
         out bytes 136833 dropped pkts 0 in FECN pkts 0
         in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
         in DE pkts 0 out DE pkts 0
         out bcast pkts 4 out bcast bytes 1196
         pvc create time 1w2d, last time pvc status changed 1w2d
         service policy VOICE-POLICY

 Service-policy output: VOICE-POLICY

 Class-map: voice-traffic (match-all)
         352 packets, 22900 bytes
         5 minute offered rate 2000 bps, drop rate 2000 bps
         Match: access-group 102
         Weighted Fair Queueing
         Strict Priority
         Output Queue: Conversation 24
         Bandwidth 10 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 352/22900
         (total drops/bytes drops) 169/11188

 Class-map: voice-signaling (match-all)
         7 packets, 789 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 7/789
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: class-default (match-any)
         79 packets, 102996 bytes
         5 minute offered rate 4000 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 5/0/0
         Output queue size 5/max total 600/drops 169
         fragment type end-to-end fragment size 80
         cir 64000 bc 640 be 0 limit 80 interval 10
         mincir 64000 byte increment 80 BECN response no
         frags 2158 bytes 178145 frags delayed 1968 bytes delayed 166021

 shaping active
         traffic shaping drops 169


!--- Notice that the Tc interval equals 10 ms, 
!--- CIR equals 64000 BPS, and BC equals 640. 

     
maui-voip-sj#show traffic-shape
Interface  Se0/0.1
       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
300           64000     80     640       0          10        80         -



!--- This output is captured on an isolated lab enviroment where
!--- the routers are configured with IP RTP Priority instead of LLQ.
 

maui-voip-austin#show frame-relay PVC 100

PVC Statistics for interface Serial0/1 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1.1

  input pkts 336           output pkts 474          in bytes 61713
  out bytes 78960          dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0         
  PVC create time 1w0d, last time PVC status changed 1w0d
 Current fair queue configuration:   
   Discard      Dynamic       Reserved
   threshold    queue count   queue count
   64            16              2
 Output queue size 0/max total 600/drops 0 
  fragment type end-to-end        fragment size 80
  cir 64000     BC   640      be 0     limit 125    interval 10
  mincir 32000    byte increment 125   BECN response no
  frags 1091      bytes 82880     frags delayed 671      bytes delayed 56000
  shaping inactive
  traffic shaping drops 0
  ip rtp priority parameters 16384 32767 45000


!--- This command displays information of the VoIP dial-peers.
 
      
maui-voip-austin#show dial-peer voice 2
VoiceOverIpPeer2
        information type = voice,
        tag = 2, destination-pattern = `5000',
        answer-address = `', preference=0,
        group = 2, Admin state is up, Operation state is up,
        incoming called-number = `', connections/maximum = 0/unlimited,
        application associated: 
     type = voip, session-target = `ipv4:192.168.10.2',  
        technology prefix:
     ip precedence = 5, UDP checksum = disabled,
         session-protocol = cisco, req-qos = best-effort, 
         acc-qos = best-effort, 
     dtmf-relay = cisco-rtp, 
        fax-rate = voice,   payload size =  20 bytes
     codec = g729r8,    payload size =  20 bytes,
        Expect factor = 10, Icpif = 30,signaling-type = cas,
     VAD = enabled, Poor QOV Trap = disabled, 
        Connect Time = 165830, Charged Units = 0,
        Successful Calls = 30, Failed Calls = 0,
        Accepted Calls = 30, Refused Calls = 0,
        Last Disconnect Cause is "10",
        Last Disconnect Text is "normal call clearing.",
        Last Setup Time = 69134010.

Informações Relacionadas


Document ID: 12156