Switches de LAN : EtherChannel

EtherChannel entre o Switches do 3550/3560/3750 Series do catalizador e os Catalyst Switches que executam o exemplo de configuração do software do sistema do Cisco IOS

17 Outubro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (7 Outubro 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para que como estabeleça um EtherChannel entre um Catalyst 3550 e um Catalyst 6500/6000 que executam o software do sistema do � do Cisco IOS. O EtherChannel pode ser chamado de Fast EtherChannel ou Gigabit EtherChannel, dependendo da velocidade das interfaces ou portas usadas para formar o EtherChannel.

Nota: Os comandos do EtherChannel aplicados ao Catalyst 3550 Switch neste documento podem igualmente ser aplicados aos Catalyst 3750 Series Switch.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco IOS Software Release 12.1(14)EA running do Catalyst 3550 Switch

  • Cisco IOS Software Release 12.1(13)E1 running do interruptor do Catalyst 6500/6000

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Material de Suporte

Neste documento, duas interfaces Gigabit Ethernet em um Catalyst 3550 Switch -- a relação do gigabitethernet nos 3500 é uma interface de Ethernet negociada de 10/100/1000 -- foram empacotados em um Fast EtherChannel com duas interfaces rápidas de Ethernet de um software do sistema running do Cisco IOS do interruptor do Catalyst 6500/6000 para formar um EtherChannel da camada 2 (L2).

Nota: Neste documento, os termos Fast EtherChannel, Gigabit EtherChannel, canal de porta e grupo de canais se referem a EtherChannel.

A configuração de Catalyst switch neste documento aplica a todo o Cisco IOS do interruptor do Catalyst 6500/6000 ou Catalyst 4500/4000 Series o software do sistema running.

Este documento mostra arquivos de configuração para o Switches somente, assim como saída dos comandos relacionados à exibição de amostra. Para detalhes em como configurar um EtherChannel, refira estes documentos:

Notas importantes

O EtherChannel pode ser configurado manualmente com os comandos apropriados. Você pode igualmente configurar o EtherChannel automaticamente com Port Aggregation Protocol (PAgP) a fim mandar o interruptor negociar o canal com o outro lado. Para detalhes no PAgP, refira estes documentos:

As configurações nesse documento são implementadas com o uso do modo desejado. Se você planeia configurar manualmente o EtherChannel, use as etapas fornecidas a fim criar um Canal de porta. Evita problemas com o Protocolo de Abrangência de Árvore (STP) durante o processo de configuração. O STP pode fechar algumas portas, com um status de porta do [errdisable] desabilitado por erro, se um lado está configurado enquanto um canal antes que o outro lado possa ser configurado como um canal.

Execute estas etapas a fim criar um Canal de porta:

  1. Deixe as relações a ser usadas na porta que canaliza como administrativamente a parada programada.

  2. Crie o Canal de porta (grupo de canais) no interruptor do Catalyst 6500/6000.

    Assegure-se de que você ajuste o modo de canal a sobre, por exemplo, modo do canal-grupo 1 sobre.

  3. Crie os Canais de porta no Catalyst 3550, 3560 ou 3750 Switch.

    Certifique -se de ter definido o modo de canal para on.

  4. Reenable as relações que foram desabilitadas mais cedo no interruptor do Catalyst 6500/6000 com o comando no shut.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

/image/gif/paws/12033/89-a.gif

Nota: A interface Gigabit Ethernet no Catalyst 3550 é uma interface Ethernet 10/100/1000 Mbps negociada. A porta de gigabit no Catalyst 3550 pode igualmente ser conectada a uma porta dos FastEthernet (100 Mbps) em um Catalyst 6500/6000.

Nota: Os Catalyst 3750 Series Switch apoiam o EtherChannel da cruz-pilha, que permite que as relações dos Stack Switch diferentes sejam membros do mesmo grupo de EtherChannel. Para obter mais informações sobre do �EtherChannel no ambiente a�stacked do interruptor, refira o EtherChannel e comute a seção das pilhas da documentação configurando dos EtherChannéis para Catalyst 3750 Series Switch.

Configurações

Este documento utiliza as seguintes configurações:

Catalyst 3550
Building configuration...
Current configuration : 1610 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
enable password ww
!
ip subnet-zero
no ip finger
!
!
!
!
!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

interface Port-channel 1


!--- In this example, the L2 EtherChannel is configured.
!--- A Layer 3 (L3) EtherChannel can also be configured on the Catalyst 3550 switches.
!--- For more information, refer to the document Configuring EtherChannel.

switchport mode access no ip address snmp trap link-status!

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a 
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

!--- The port is a member of channel group 1.

interface GigabitEthernet0/1
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!


!--- The port is a member of channel group 1.

interface GigabitEthernet0/2
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!
interface GigabitEthernet0/3
 switchport mode access
 no ip address
 snmp trap link-status
!


!--- Output suppressed.

interface GigabitEthernet0/12
 switchport mode access
 no ip address
 snmp trap link-status


!--- Interface VLAN1 is required for management purposes.

interface Vlan1
 ip address 10.1.1.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
 transport input none
line vty 5 15
!
end

Catalyst 6500/6000
Building configuration...
  
 Current configuration : 5869 bytes
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname cat6500
 !
 boot buffersize 126968
 boot bootldr bootflash:c6msfc-boot-mz.121-4.E1
 enable password ww
 !
 redundancy
  main-cpu
   auto-sync standard
 ip subnet-zero
 !
 !
 no ip finger
 !
 !
 !
 !


!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

 interface Port-channel 1
  no ip address
  switchport
  switchport mode access
 !
 interface GigabitEthernet1/1
  no ip address
  shutdown
 !
 interface GigabitEthernet1/2
  no ip address
  shutdown
 !

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

 interface FastEthernet3/1
  no ip address


!--- In this example, the L2 EtherChannel is configured.
!--- An L3 EtherChannel can also be configured on the Catalyst 6500/6000 running
!--- Cisco IOS System Software. For more details, refer to the document
!--- Configuring EtherChannel.

!--- On a Catalyst 6500/6000, you must issue the switchport
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;
!--- no additional command is required.

 switchport

!--- This command puts the interface in VLAN1, by default.

 switchport mode access

!--- The port is a member of channel group 1.

 channel-group 1 mode desirable
 !
 interface FastEthernet3/2
  no ip address

!--- On a Catalyst 6500/6000, you must issue the switchport 
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;  
!--- no additional command is required.

  switchport

!--- This command puts the interface in VLAN1, by default.

  switchport mode access

!--- The port is a member of channel group 1.

  channel-group 1 mode desirable
 !
 interface FastEthernet3/3
  no ip address
 switchport
  switchport mode access
 !


!--- Output suppressed.

 !
 interface FastEthernet3/48
  no ip address
 switchport
  switchport mode access
 !


!--- Interface VLAN1 is required for management purposes.

 interface Vlan1
  ip address 10.1.1.2 255.255.255.0
 !
 ip classless
 no ip http server
 !
 !
 !
 line con 0
  transport input none
 line vty 0 4
 !
 end

Nota: Esse exemplo de configuração mostra uma configuração EtherChannel com links de acesso. A mesma configuração se aplica aos links de troncos do EtherChannel. Emita o comando switchport mode trunk, ou permita que o Switches negocie o modo com o modo desirable dinâmico. Para obter mais informações sobre de como configurar o entroncamento, refira a seção configurando dos troncos de VLAN do documento que configura VLAN.

Configuração da interface secundária do canal de porta

Um outro exemplo da configuração do canal de porta com relação secundária em Cisco IOS Software Release 12.2(25) running do Catalyst 3560 Switch.

Catalyst 3560
Building configuration...
  
Current configuration : 2480 bytes
!
version 12.2
!
interface Port-channel5
no switchport
no ip address
!
interface Port-channel5.690
!
interface Port-channel10
no switchport
no ip address
!
interface Port-channel10.1
!
interface Port-channel10.690
!
interface Port-channel11
no switchport
no ip address

Verificar

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

A fim verificar o Canal de porta no Catalyst 6500/6000 e os Catalyst 3500 Switch que executam o Cisco IOS software do sistema, emita estes comandos:

A fim verificar o status do STP no Catalyst 6500/6000 e os Catalyst 3500 Switch que executam o Cisco IOS software do sistema, emita este comando:

Catalyst 3550

Cat3550#show interface port-channel 1
Port-channel1 is up, line protocol is up
Hardware is EtherChannel, address is 0002.4b28.db02 (bia 0002.4b28.db02)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
 Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
 Members in this channel: Gi0/1 Gi0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:03:27, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
26 packets input, 5344 bytes, 0 no buffer
Received 17 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
59 packets output, 5050 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Cat3550#show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0002.4b28.db01
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:00:38 ago
          from Port-channel1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 0
 
 Port 65 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 128.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 34, received 0 

Cat3550# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
        U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Gi0/1(P)   Gi0/2(P)

Cat3550# ping 10.1.1.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Catalyst 6500/6000

Cat6500# show interface port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0002.7ef1.36e1 (bia 0002.7ef1.36e1)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s
  Members in this channel: Fa3/1 Fa3/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/2000, 0 drops
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     407 packets input, 34994 bytes, 0 no buffer
     Received 311 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     93 packets output, 16598 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Cat6500# show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.024f.6001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0002.4b28.db01
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:02:13 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300
 
 Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 0, received 66

Cat6500# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa3/1(P)   Fa3/2(P)

Cat6500# ping 10.1.1.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Troubleshooting

Estado errdisable

Um problema comum durante a configuração de EtherChannel é que as relações entram no modo do desativado por erro. Isto pode ser visto quando o EtherChannel está ligado ao modo em um interruptor, e o outro interruptor não está configurado imediatamente. Se saido neste estado por um minuto ou assim, o STP no interruptor onde o EtherChannel é permitido pensa que há um laço. Isto faz com que as portas de canalização sejam postas no estado errdisable. Veja este exemplo para obter mais informações sobre de como determinar se suas relações do EtherChannel estão no estado errdisable:

%SPANTREE-2-CHNL_MISCFG: Detected loop due to etherchannel misconfiguration of Gi0/9
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/9 in err-disable state
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/10 in err-disable state
Switch1#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SD)         -        Gi0/9(D)    Gi0/10(D)

Switch1#show interfaces GigabitEthernet 0/9 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/9                        err-disabled 1            auto   auto 10/100/1000BaseTX

Switch1#show interfaces GigabitEthernet 0/10 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/10                       err-disabled 1            auto   auto 10/100/1000BaseTX

O Mensagem de Erro indica que o EtherChannel encontrou um loop de Spanning Tree. A fim resolver a edição, ajuste o modo de canal a desejável em ambos os lados da conexão, e re-permita então as relações:

Switch1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#interface gi0/9
Switch1(config-if)#channel-group 10 mode desirable

Isto faz com que cada lado forme um canal somente se ambos concordam canalizar. Se não concordam canalizar, continuam a funcionar como portas normais.

Depois que o modo de canal é ajustado a desejável em ambos os lados da conexão, emita os comandos shutdown and no shutdown na relação associada re-permitir as portas por manualmente:

Switch1(config-if)#shutdown
Switch1(config-if)#no shutdown

da “o comando da não-negociação velocidade” não aparece na configuração running

O comando speed nonegotiate configurado em um Canal de porta não aparece sempre na configuração running. Isto acontece porque a não-negociação na relação de Canal de porta depende daquela de portas empacotadas. É introduzido quando o Canal de porta é ativo e baseado na configuração das portas do canal individual.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 12033