Switches de LAN : Inter-Switch Link (ISL)

Configuring an ISL Trunk Between a Catalyst 2948G-L3 and Catalyst 2900/3500XL or 2970 Series Switches

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (7 Outubro 2015) | Feedback


Índice


Introdução

Este documento discute como configurar um tronco de protocolo do Inter-Switch Link (ISL) entre um Cisco catalyst 2948G-L3 e Catalyst 2900/3500XL ou 2970 Series Switch. Quando você conecta um Catalyst 2948G-L3 a um interruptor, as tarefas de configuração são as mesmas que aquelas para conectar um roteador a um interruptor. O exemplo de configuração neste documento usa o Catalyst 2948G-L3 como um roteador e usa o Catalyst 3500XL como o interruptor da camada 2 (L2). Você pode substituir o Catalyst 2900XL ou a 2970 para o 3500XL, para fins deste documento.

Para usar o conceito dos VLAN no Catalyst 2948G-L3, você deve usar grupos de bridge. Cada grupo de ligação é considerado um VLAN separado. Estes grupos de bridge correspondem ao número de VLAN do switch conectado.

Pré-requisitos

Requisitos

Antes que você tente esta configuração, assegure-se de que você conecte um cabo crossover entre o 2900/3500XL ou a 2970 e o 2948G-L3. Tipicamente, você usa um cabo straight-through entre um roteador e um interruptor; mas com o Catalyst 2948G-L3, você usa um cabo crossover para conectar a um outro interruptor. Este é o mesmo cabo crossover que você usaria para uma conexão de switch a switch.

Os leitores deste documento devem estar cientes destes tópicos:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software:

  • Software Release 12.0(25)W5(27) do ½ do ¿  de Cisco IOSï para o interruptor da camada 3 (L3)/roteador (CAT2948G-IN-M)

  • Cisco IOS Software Release 12.0(5)WC9 (C3500XL-C3H2S-M) (fc1)

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Esta seção fornece a informação para configurar as características descritas neste documento.

Nota: Para encontrar a informação adicional sobre os comandos neste documento, use a ferramenta de consulta de comandos (clientes registrados somente).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/12019/25.gif

Se você quer todos os três PC poder se sibilar e ter um gateway padrão, a seguir você deve usar a construção de uma ponte sobre com Integrated Routing and Bridging (IRB).

O Catalyst 2948G-L3 é o dispositivo L3 nesta encenação. Porque é um dispositivo L3, não pode ter duas relações L3 na mesma sub-rede. É por isso você precisa de usar grupos de bridge nas relações e de amarrá-las junto com um Bridge Virtual Interface (BVI), BVI 2.

O endereço IP de Um ou Mais Servidores Cisco ICM NT do BVI 2 é o gateway padrão para todos os PC e dispositivos em VLAN2 ou em grupo de bridge 2.

Configurações

Este documento utiliza as seguintes configurações:

2948G-L3
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2948G-L3
!
!
ip subnet-zero
bridge irb
!
!
!
interface FastEthernet1

!--- This interface is the ISL trunk to the switch.

 no ip address
 no ip directed-broadcast
!
interface FastEthernet1.1
 encapsulation isl 1        
 no ip redirects
 no ip directed-broadcast
 bridge-group 1

!--- Use bridge-group 1 for the trunk subinterface.
!--- You can not use an IP address here because of the subnet
!--- overlap that would occur due to BVI 1, which is in the
!--- same subnet.

!
interface FastEthernet1.2
 encapsulation isl 2
 no ip redirects
 no ip directed-broadcast
 bridge-group 2             
!
interface FastEthernet2
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet3
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet4
 no ip address
 no ip directed-broadcast
 bridge-group 1

!--- This port belongs to VLAN 1.

!
interface BVI1
 ip address 10.1.1.1 255.255.0.0

!--- This is the IP address of BVI 1.

 no ip directed-broadcast
 no ip route-cache cef
!
interface BVI2

!--- This is the IP address of BVI 2.

 ip address 10.2.2.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
!
ip classless
!
bridge 1 protocol ieee

!--- Choose IEEE as the Spanning Tree Protocol.

 bridge 1 route ip

!--- Allow routing to occur for IP.

bridge 2 protocol ieee
 bridge 2 route ip
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

2900/3500XL ou 2970

!--- First, add VLAN 2 to the VLAN database for a 2900/3500XL
!--- switch:

3500XL# vlan database

3500XL(vlan)# vlan 2

VLAN 2 added:
    Name: VLAN0002

3500XL(vlan)# exit

APPLY completed.
Exiting....
3500XL#

!--- The Catalyst 2970 gives you the option to configure VLANs
!--- from the VLAN database or from global configuration mode:

2970# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

2970(config)# vlan 2

2970(config-vlan)# end

2970#

!--- The switchport configurations on the Catalyst 2900/3500XL
!--- and on the 2970 are identical, for the purposes of this
!--- document. Remember that the Catalyst 2970 has 10/100/1000
!--- ports (1000Base-T), so the interfaces in this output
!--- would instead be labeled Gigabit Ethernet 0/1, 0/2,
!--- and so forth.

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3500XL
!
interface FastEthernet0/1
 switchport mode trunk

!--- This port is an ISL trunk.

!
interface FastEthernet0/2
 switchport access vlan 2

!--- This port is in VLAN 2.

!
interface FastEthernet0/3

!--- This port is in the default VLAN 1.

!
interface FastEthernet0/4
!
!
interface VLAN1
 ip address 10.1.1.100 255.255.0.0

!--- This is the IP address of the management interface.

 no ip directed-broadcast
 no ip route-cache
!
snmp-server engineID local 000000090200000AF484CC80
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

Verificar

Esta seção fornece a informação para confirmar que sua configuração está trabalhando corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show interface fa0/1 switchport — Verifique o estado do tronco no 2900/3500XL ou na 2970 e veja que VLAN são ativos.

    3500XL# show interface fa0/1 switchport
    
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No
    3500XL#
  • mostra vlan — Verifique que as portas no 2900/3500XL ou na 2970 estão atribuídas aos VLAN corretos.

    3500XL# show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    VLAN0002                         active    Fa0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    3500XL#
  • show interface bvi 1 — Verifique que as interfaces de BVI 2948G-L3 e o protocolo de linha são ambas acima no 2948G-L3.

    2948G-L3# show interface bvi 1
    
    BVI1 is up, line protocol is up
      Hardware is BVI, address is 0001.c75c.680a (bia 0000.0000.0000)
      Internet address is 10.1.1.1/16
      MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set
      ARP type: ARPA, ARP Timeout 04:00:00
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue 0/0 (size/max)
    2948G-L3#
  • mostre a ponte 1 — Verifique que a ponte 1 está enviando. Você pode também verificar se o protocolo Spanning Tree está habilitado e sendo encaminhado com um comando show spanning-tree.

    2948G-L3# show bridge 1
    
    Total of 300 station blocks, 299 free
    Codes: P - permanent, S - self
    
    Bridge Group 1:
    
        Address       Action   Interface
    00ee.1e9f.50c0   forward   Fa1.1
    
    2948G-L3#

Troubleshooting

Esta seção fornece pontas e exemplo de saída para ajudar a pesquisar defeitos sua configuração.

  • Verifique se você pode executar ping para o outro dispositivo.

  • Verifique se os PCs podem executar o ping em outros PCs nas VLANs.

  • Assegure-se de que o gateway padrão esteja correto. Neste cenário, o gateway padrão são os respectivos BIVs no 2948G-L3.

2948G-L3# ping 10.1.1.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms

2948G-L3# show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.2.2                -   0030.40d6.4008  ARPA   BVI2
Internet  10.1.1.1                -   0030.40d6.400a  ARPA   BVI1
Internet  10.1.1.100              1   00ee.1e9f.50c0  ARPA   BVI1
2948G-L3#

Informações Relacionadas


Document ID: 12019