WAN : T1/E1 e T3/E3

Colocando Links NxE1 Juntos com uma Interface Multilink

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (19 Dezembro 2015) | Feedback


Índice


Introdução

Os exemplos de configuração neste documento mostram como você pode agrupar links NxE1 (com ou sem enquadramento G.704) por meio de uma interface Multilink. A interface multilink é introduzida no Software Release 12.0(3)T do ½ do ¿  de Cisco IOSï para o protocolo ponto-a-ponto distribuído do Multilink (PPP) no Versatile Interface Processor do Cisco 7500 Router (VIP) - interfaces T1 ou E1 baseadas (veja a seção da “informação relacionada” deste documento). A interface Multilink é suportada para interfaces T1/E1 (e outras WAN) não baseadas em VIP desde o Cisco IOS Software Release 12.0(4)T.

Pré-requisitos

Requisitos

Como o PPP Multilink aumenta a carga da unidade central de processamento, é recomendável que você:

  1. Verifique a carga média atual da unidade central de processamento antes de adicionar interfaces Multilink ou Links E1 a uma interface Multilink.

  2. Use o PPP Multilink distribuído em plataformas baseadas em VIP do Cisco 7500 sempre que possível. Refira a documentação dos novos recursos do Cisco IOS Software Release 12.0(3)T para mais detalhes nas limitações e nas condições prévias do Multilink PPP distribuído (veja a seção da “informação relacionada” deste documento).

  3. Desabilite a fragmentação do PPP Multilink quando possível.

Nota: Isso aumenta a latência no grupo Multilink.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Um roteador Cisco 7505 equipado com VIP2-50 e PA-MC-8E1 que executa o Cisco IOS Software Release 12.1(11a).

  • Um roteador Cisco 7206 equipado com PA-MC-8E1 que executa o Cisco IOS Software Release 12.1(11).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Material de Suporte

O PPP Multilink, padronizado no RFC 1990, é similar às técnicas de balanceamento de carga por enviar pacotes pelos links individuais usando o sistema de rodízio. Contudo, o PPP Multilink possui três recursos adicionais significativos.

  • Por trabalhar na camada de link, o PPP Multilink faz um grupo NxT1/E1 aparecer como um link lógico para os protocolos da camada superior do roteador. Por isso, somente um endereço de rede precisa ser configurado para o grupo NxT1/E1 inteiro.

  • O PPP Multilink mantém controle do sequenciamento de pacotes e armazena em buffer os pacotes que chegam com antecedência. O PPP Multilink preserva a ordem dos pacotes em todo o grupo NxT1/E1 com essa capacidade.

  • Você pode habilitar a fragmentação de pacotes para dividir grandes pacotes de dados em fragmentos de pacote menores que são transmitidos individualmente pelos links. Em muitas circunstâncias, a fragmentação pode aumentar a eficiência do link NxT1/E1.

O PPP Multilink também oferece gerenciabilidade de link significativa. Se um link individual falhar, o PPP Multilink poderá detectar automaticamente a falha e remover esse link do grupo. Enquanto um link do grupo funcionar, a interface lógica que representa o grupo permanecerá ativa. Com o uso de sinais de manutenção de atividade, o PPP Multilink pode detectar quando um link que falhou anteriormente volta a funcionar e reinserir esse link no grupo. Além disso, você pode adicionar mais links ao grupo ao configurá-los como um membro do grupo quando houver necessidade de mais largura de banda. Não é necessária nenhuma reconfiguração da camada de rede, como endereçamento novo. Este também é um fator importante quando se avalia o uso de serviços de roteador avançados. Por exemplo, você pode configurar uma Qualidade de Serviço específica uma única vez para o grupo como um todo, em vez de fazê-lo para cada link do grupo.

A desvantagem da funcionalidade avançada está no fato de o PPP Multilink exigir maior processamento da unidade central de processamento do que as soluções de balanceamento de carga. A reorganização do pacote, a remontagem de fragmentos e o próprio protocolo PPP Multilink aumentam a carga da unidade central de processamento.

Configurar

Esta seção apresenta informações para configurar as características que este documento descreve.

Nota: Use a Command Lookup Tool (apenas para clientes registrados) para obter informações adicionais sobre os comandos que este documento usa.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede.

http://www.cisco.com/c/dam/en/us/support/docs/wan/t1-e1-t3-e3/11044-ppp-11044.gif

Configurações

Este documento utiliza estas configurações.

Links E1 com enquadramento G.704

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
username bob password 0 mlppp 

!--- This is an optional Challenge Handshake Authentication Protocol 
!--- (CHAP) secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

! 
no ip domain-lookup 
! 
! 
controller E1 1/0/0 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.
 
! 
controller E1 1/0/1 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/2 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/3 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/4 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/5 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/6 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/7 
�channel-group 0 timeslots 1-31 


!--- You must assign all timeslots to one channel-group.

! 
interface Multilink1 
�ip address 10.10.10.1 255.255.255.0 
�no cdp enable 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This command is optional to reduce CPU load. 

�multilink-group 1 
! 
interface Serial1/0/0:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable first-in, first-out (FIFO)  
!--- queueing on the Serial interface.  

ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/1:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/2:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 
 
encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/3:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/4:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/5:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/6:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/7:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Ethernet1/1/0 
�ip address 10.10.20.1 255.255.255.0 
�no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
username diana password 0 mlppp 

!--- An optional CHAP secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
! 
! 
controller E1 3/0 
�clock source internal 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/1 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.
 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/2 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/3 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/4 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/5 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/6 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/7 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
! 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.2 255.255.255.0 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This command is optional to reduce CPU load.
 
�multilink-group 1 
! 
interface FastEthernet0/0 
�ip address 10.10.30.1 255.255.255.0 
�no ip route-cache 
�no ip mroute-cache 
�half-duplex 
�no cdp enable 
! 
interface Serial3/0:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/1:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/2:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/3:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/4:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/5:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/6:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/7:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
ip classless 
ip route 10.10.20.0. 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Links E1 sem enquadramento G.704

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

no ip domain-lookup 
! 
! 
controller E1 0/1/0 
�channel-group 0 unframed 
! 
controller E1 0/1/1 
�channel-group 0 unframed 
! 
controller E1 0/1/2 
�channel-group 0 unframed 
! 
controller E1 0/1/3 
�channel-group 0 unframed 
! 
controller E1 0/1/4 
�channel-group 0 unframed 
! 
controller E1 0/1/5 
�channel-group 0 unframed 
! 
controller E1 0/1/6 
�channel-group 0 unframed 
! 
controller E1 0/1/7 
�channel-group 0 unframed 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.1 255.255.255.0 
�no cdp enable 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This is an optional command to reduce CPU load. 

�multilink-group 1 
! 
interface Serial0/1/0:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/1:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/2:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/3:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/4:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/5:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/6:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/7:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Ethernet1/1/0 
�ip address 10.10.20.1 255.255.255.0 
�no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 

! 
controller E1 3/0 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/1 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/2 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/3 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/4 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/5 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/6 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/7 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
! 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.2 255.255.255.0 
�ppp multilink 
�no ppp multilink fragmentation 

�!--- This is an optional command to reduce CPU load. 

�multilink-group 1 
! 
interface FastEthernet0/0 
�ip address 10.10.30.1 255.255.255.0 
�no ip route-cache 
�no ip mroute-cache 
�half-duplex 
�no cdp enable 
! 
interface Serial3/0:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/1:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/2:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/3:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/4:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/5:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/6:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/7:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
ip classless 
ip route 10.10.20.0 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Verificar

Esta seção oferece informações que você pode usar para verificar se sua configuração funciona adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show ppp multilink — Exibe todos os grupos Multilink juntamente com todos os membros do grupo Multilink.

  • show interfaces multilink — Mostra o status do grupo Multilink.

  • show interfaces serial — Mostra o status de cada membro do grupo Multilink.

  • show controllers e1 — Mostra o status de cada link E1.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Procedimento de Troubleshooting

Este procedimento é relevante para ambas as configurações.

  1. Verifique o status da interface Multilink com o comando show interface multilink:

    • Se a interface Multilink estiver inativa, verifique o status de todos os membros do grupo Multilink com o comando show ppp multilink.

    • Se o protocolo de linha Multilink estiver inativo, verifique as mensagens do Network Control Protocol (NCP) e do PPP Multilink (MLP) com os comandos debug ppp negotiation e debug ppp multilink events.

  2. Se um membro do Multilink estiver inativo, verifique o status da interface serial com o comando show interface serial command:

    • Se a interface serial estiver inativa, verifique o status do link E1 correspondente com o comando show controller e1.

    • Se o protocolo de linha serial estiver inativo, verifique as mensagens de CHAP e do Link Control Protocol (LCP) com os comandos debug ppp negotiation e debug ppp authentication.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Debugação antes de usar comandos debug.

  • show ppp multilink — Exibe todos os grupos Multilink juntamente com todos os membros do grupo Multilink.

  • show interfaces multilink — Mostra o status do grupo Multilink.

  • show interfaces serial — Mostra o status de cada membro do grupo Multilink.

  • show controllers e1 — Mostra o status de cada link E1.

  • debug ppp negotiation — Mostra todas as mensagens de negociação de LCP e NCP.

  • debug ppp authentication — (Opcional) Mostra todas as mensagens de autenticação CHAP.

  • debug ppp multilink events — Mostra todos os eventos do grupo MLP.

Esta saída mostra os comandos de troubleshooting do Cisco 7505 para o primeiro exemplo de configuração.

Os oito links E1 estão ativos:

diana#show ppp multilink 

Multilink1, bundle name is bob 
� Bundle up for 00:05:35 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 3/255 load 
� 0x1226 received sequence, 0x1226 sent sequence 
� Member links: 8 active, 0 inactive (max not set, min not set) 
��� Serial1/0/0:0, since 00:05:35, no frags rcvd 
��� Serial1/0/1:0, since 00:05:35, no frags rcvd 
��� Serial1/0/2:0, since 00:05:35, no frags rcvd 
��� Serial1/0/3:0, since 00:05:35, no frags rcvd 
��� Serial1/0/4:0, since 00:05:35, no frags rcvd 
��� Serial1/0/5:0, since 00:05:35, no frags rcvd 
��� Serial1/0/6:0, since 00:05:35, no frags rcvd 
��� Serial1/0/7:0, since 00:05:35, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 3/255, rxload 3/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:06:39 
� Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 241000 bits/sec, 28 packets/sec 
� 5 minute output rate 241000 bits/sec, 28 packets/sec 
���� 6525 packets input, 9810620 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 6526 packets output, 9796112 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions � 

Nesta saída, o controlador E1 3/0 no Cisco 7206 está desabilitado, o que faz com que o controlador E1 1/0/0 e o Serial 1/0/0:0 do Cisco 7505 fiquem inativos:

diana# 
*Nov 23 12:52:54.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to down 
*Nov 23 12:52:56.171: %LINK-3-UPDOWN: 
Interface Serial1/0/0:0, changed state to down 
*Nov 23 12:52:57.171: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to down 

diana#show ppp multilink
Multilink1, bundle name is bob 
� Bundle up for 00:06:52 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 1/255 load 
� 0x269C received sequence, 0x269B sent sequence 
� Member links: 7 active, 1 inactive (max not set, min not set) 
��� Serial1/0/1:0, since 00:06:52, no frags rcvd 
��� Serial1/0/2:0, since 00:06:52, no frags rcvd 
��� Serial1/0/3:0, since 00:06:52, no frags rcvd 
��� Serial1/0/4:0, since 00:06:52, no frags rcvd 
��� Serial1/0/5:0, since 00:06:52, no frags rcvd 
��� Serial1/0/6:0, since 00:06:52, no frags rcvd 
��� Serial1/0/7:0, since 00:06:52, no frags rcvd 
��� Serial1/0/0:0 (inactive) 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 13888 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 6/255, rxload 6/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:07:47 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 367000 bits/sec, 40 packets/sec 
� 5 minute output rate 367000 bits/sec, 40 packets/sec 
���� 10899 packets input, 16389116 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 10901 packets output, 16367362 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is down, line protocol is down 
� Hardware is Multichannel E1 
� MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
���� reliability 255/255, txload 41/255, rxload 41/255 
� Encapsulation PPP, crc 16, Data non-inverted 
� Keepalive set (10 sec) 
� LCP Closed, multilink Closed 
� Closed: CDPCP 
� Last input 00:00:15, output 00:00:17, output hang never 
� Last clearing of "show interface" counters 00:07:42 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 323000 bits/sec, 35 packets/sec 
� 5 minute output rate 324000 bits/sec, 35 packets/sec 
���� 9811 packets input, 14623345 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 9809 packets output, 14680161 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 1 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 2 carrier transitions alarm present 
� Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
� Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is down. 
� Applique type is Channelized E1 - balanced 
� Transmitter is sending remote alarm. 
� Receiver is getting AIS. 
� Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
� International Bit: 1, National Bits: 11111 
� Data in current interval (465 seconds elapsed): 
���� 1 Line Code Violations, 1 Path Code Violations 
���� 0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
���� 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 19 Unavail Secs 
... 

diana#debug ppp negotiation 
�PPP protocol negotiation debugging is on 

diana#debug ppp authentication 
PPP authentication debugging is on 

diana#debug ppp multilink events 
Multilink events debugging is on 

Nesta saída, o controlador E1 3/0 do Cisco 7206 está habilitado novamente.

diana# 
*Nov 23 12:53:40.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to up 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: I CONFREQ [Closed] id 34 len 26 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: Lower layer not up, Fast Starting 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Treating connection as a dedicated line 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Phase is ESTABLISHING, Active Open 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFREQ [Closed] id 2 len 27 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFACK [REQsent] id 34 len 26 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: I CONFACK [ACKsent] id 2 len 27 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: State is Open 
*Nov 23 12:53:42.079: Se1/0/0:0 PPP: Phase is AUTHENTICATING, by both 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O CHALLENGE id 2 len 26 from "diana" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: I CHALLENGE id 4 len 25 from "bob" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O RESPONSE id 4 len 26 from "diana" 
*Nov 23 12:53:42.079: %LINK-3-UPDOWN: Interface Serial1/0/0:0, changed state to up 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I RESPONSE id 2 len 25 from "bob" 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I SUCCESS id 4 len 4 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: O SUCCESS id 2 len 4 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Request add link to bundle 
*Nov 23 12:53:42.087: Se1/0/0:0 PPP: Phase is VIRTUALIZED 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Adding link to bundle 
*Nov 23 12:53:42.087: Mu1 MLP: Added link Se1/0/0:0 to bundle bob 
*Nov 23 12:53:43.087: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to up 

diana#show ppp multilink
Multilink1, bundle name is bob 
� Bundle up for 00:07:46 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 7/255 load 
� 0x35BF received sequence, 0x35BE sent sequence 
� Member links: 8 active, 0 inactive (max not set, min not set) 
��� Serial1/0/1:0, since 00:07:46, no frags rcvd 
��� Serial1/0/2:0, since 00:07:46, no frags rcvd 
��� Serial1/0/3:0, since 00:07:46, no frags rcvd 
��� Serial1/0/4:0, since 00:07:46, no frags rcvd 
��� Serial1/0/5:0, since 00:07:46, no frags rcvd 
��� Serial1/0/6:0, since 00:07:46, no frags rcvd 
��� Serial1/0/7:0, since 00:07:46, no frags rcvd 
��� Serial1/0/0:0, since 00:00:13, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 7/255, rxload 7/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:08:32 
� Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 443000 bits/sec, 49 packets/sec 
� 5 minute output rate 443000 bits/sec, 49 packets/sec 
���� 14098 packets input, 21200412 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 14099 packets output, 21170758 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is up, line protocol is up 
� Hardware is Multichannel E1 
� MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
���� reliability 255/255, txload 32/255, rxload 32/255 
� Encapsulation PPP, crc 16, Data non-inverted 
� Keepalive set (10 sec) 
� LCP Open, multilink Open 
� Last input 00:00:02, output 00:00:02, output hang never 
� Last clearing of "show interface" counters 00:08:39 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 253000 bits/sec, 24 packets/sec 
� 5 minute output rate 254000 bits/sec, 24 packets/sec 
���� 9821 packets input, 14623552 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 9819 packets output, 14680370 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 1 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 3 carrier transitions no alarm present 
� Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
� Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is up. 
� Applique type is Channelized E1 - balanced 
� No alarms detected. 
� Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
� International Bit: 1, National Bits: 11111 
� Data in current interval (519 seconds elapsed): 
���� 1 Line Code Violations, 1 Path Code Violations 
���� 0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
���� 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 37 Unavail Secs 
... 

Informações Relacionadas


Document ID: 11044