Switches : Switches Cisco Catalyst 6500 Series

Configurando um IP Address de Gerenciamento nos Catalyst 4500/4000, 5500/5000, 6500/6000 Switches e no Switch de Configuração Fixa Catalyst

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (20 Outubro 2015) | Feedback


Interativo: Este documento oferece análise personalizada do seu dispositivo Cisco.


Índice


Introdução

Este documento descreve como configurar um endereço IP de gerenciamento no catalizador 4500/4000, 5500/5000 de, e no Switches do 6500/6000 Series que executa o OS do catalizador (CatOS) e o software de Cisco IOS�. Este documento também inclui os switch de configuração fixa Catalyst com Cisco IOS Software somente e também os 2900/3500XL, 2940, 2950, 2955, 2970, 3550 e 3750 Series Switches. Um endereço IP será necessário se você desejar controlar o switch de uma estação de gerenciamento TCP/IP remota. Switches que serão gerenciados via terminal de VT100 em sua porta de console não necessitam de endereço IP.

Pré-requisitos

Requisitos

A Cisco recomenda que você conheça as informações descritas nesta seção.

Os Catalyst 4500/4000, 5500/5000, 6500/6000 Switches que executam somente CatOS são switches da Camada 2 (L2). Os switch de configuração fixa Catalyst 2900/3500XLs, 2940, 2950, 2955 e 2970 também são switches L2. O protocolo TCP/IP em um switch L2 é apenas para fins de gerenciamento. Os dados que passam pelo switch podem ter endereços da camada 3 (L3), como IP, Internetwork Packet Exchange (IPX), Appletalk, etc. No entanto, o switch usa somente o endereço MAC dos dados para determinar a origem do tráfego e que portas devem recebê-los. Os switches L2 ignoram os endereços L3 ao encaminharem dados.

Os Catalyst 6500/6000, 4500/4000 e 3550/3750 Series Switches que executam Cisco IOS Software são roteadores switches ou switches L3 e podem utilizar qualquer interface para gerenciamento. Você pode configurar a interface de gerenciamento de qualquer uma das seguintes formas:

  • Como uma interface lógica, como uma interface de loopback

  • Como uma porta de acesso L2 em uma VLAN de gerenciamento

  • Como uma interface L3 com um endereço IP

    Nota: Esta é a mesma forma através da qual você configura a interface em qualquer roteador Cisco.

Os Catalyst Switches discutidos neste documento possuem estas interfaces de gerenciamento:

  • Os Catalyst 5500/5000 e 6500/6000 Series Switches com Supervisor Engine que executam o CatOS possuem duas interfaces de gerenciamento IP configuráveis:

    • A interface in-band (sc0)

    • A interface Serial Line Internet Protocol (SLIP) (sl0)]

  • Os Catalyst 4500/4000 Switches com Supervisor Engines que executam o CatOS possuem três interfaces de gerenciamento IP configuráveis. A interface adicional é chamada de interface de Ethernet de gerenciamento (me1).

  • Os switches de configuração fixa Catalyst L2 que executam Cisco IOS Software possuem somente uma interface de gerenciamento IP configurável que, por padrão, é a inter interface vlan 1.

  • Os switches da Camada 2 puros podem ter somente uma interface VLAN ativada. Isso é chamado de VLAN de gerenciamento (no IOS) ou a interface sc0 (no CatOS). O objetivo principal desta interface é o gerenciamento (telnet, SNMP, etc.). Se o switch um switch da camada 3, você pode configurar VLANs múltiplas e rota entre elas. Um switch L3 não pode lidar com IP múltiplos. Assim, não há nenhuma VLAN de gerenciamento específica no switch.

  • Os Catalyst 3550/3750 Series Switches que executam o Cisco IOS Software podem utilizar qualquer interface para o gerenciamento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Interfaces de Gerenciamento dos Catalyst 4500/4000, 5500/5000 e 6500/6000

A interface sc0 é uma interface de gerenciamento interno conectada à switching fabric. A interface sc0 participa de todas as funções de uma porta de switch normal, que incluem:

  • STP (Spanning Tree Protocol)

  • Cisco Discovery Protocol (CDP)

  • Associação a LAN virtual (VLAN)

As interfaces me1 e sl0 são interfaces de gerenciamento fora de banda que não são conectadas à estrutura de switching e não participam de nenhuma dessas funções.

Quando você configura o endereço IP, a máscara de sub-rede e o endereço de broadcast (e, na interface sc0, a associação a VLAN) da interface sc0 ou me1, você pode acessar o switch via Telnet ou Simple Network Management Protocol (SNMP). Quando você configura a relação SLIP (sl0), você pode abrir uma conexão Point-to-Point ao interruptor através da porta de Console de uma estação de trabalho.

Se você tem a saída de um comando show interface de seu dispositivo Cisco, você pode utilizar a Output Interpreter Tool (somente clientes registrados) para exibir problemas potenciais e suas correções.

A sc0 não possui uma porta externa para conexão direta. Esta interface existe como uma interface lógica dentro do switch e é acessível por meio de qualquer uma das portas física no switch. Esta figura fornece uma ilustração:

/image/gif/paws/10594/8a.gif

A me1 é realmente uma porta Ethernet física no Supervisor Engine Module nos Catalyst 4500/4000 Series Switches. Essa interface é usada apenas para o gerenciamento de rede e não suporta a switching de rede.

/image/gif/paws/10594/8d.gif

A sl0 usa a porta de console RS232 como sua interface física. A sl0 não pode ser utilizada como um console VT100 quando está no modo SLIP. Esta figura ilustra uma conexão SLIP para sl0:

8b.gif

Configuração da Interface sc0 em Catalyst 4500/4000, 5500/5000 e 6500/6000 Switches que executam o CatOS

Esta seção descreve como configurar um endereço IP na interface sc0 in-band.

  1. Conecte um terminal às portas de console dos switches.

    Para obter detalhes sobre como conectar às portas de console dos Catalyst Switches, consulte Conexão de um Terminal à Porta de Console em Catalyst Switches.

  2. Execute o comando show interface no prompt do switch para ver o status padrão das interfaces de gerenciamento.

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>        
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    !--- Catalyst 5500/5000 and 6500/6000 series switches 
    !--- do not display the me1 interface in the output.
    
    Switch-A> (enable)
  3. Execute o comando set interface sc0 172 16 84 17 255 255 255 0 172 16 84 255 para configurar um endereço IP para sc0.

    A mensagem retornada pelo switch informa quais parâmetros foram alterados.

    Nota: Ao executar o comando set interface sc0, você não pode inserir o endereço de broadcast sem a máscara de sub-rede do endereço IP.

    Switch-A> (enable) set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255 
    Interface sc0 IP address, netmask, and broadcast set. 
    Switch-A> (enable)

    Execute o comando show interface para ver as alterações.

    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING> 
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    Se você inserir somente um endereço IP após o comando set interface sc0 172 16 84 17, a máscara padrão e o endereço de broadcast padrão para a classe do endereço serão configurados automaticamente. Aqui está um exemplo:

    Switch-A> (enable) set interface sc0 172.16.84.17 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable) 
    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.0.0 broadcast 172.16.255.255 
    
    !--- Notice that the switch took the default mask 
    !--- and the broadcast address of class B.
    
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    Se você inserir o endereço IP e a máscara de sub-rede após o comando set interface sc0, o endereço de broadcast para a sub-rede específica será configurado automaticamente.

  4. Para mudar a VLAN na interface sc0, execute o comando set interface sc0 vlan-, o qual especifica o número da VLAN.

    Nota: Por padrão, a interface sc0 pertence a VLAN 1.

    Se desejar mudar a associação de sc0 para VLAN2, execute este comando:

    Switch-A> (enable) set interface sc0 2 
    
    
    Interface sc0 vlan set. 
    Switch-A> (enable)

    Nota: Certifique-se de ter configurado a VLAN 2 no switch antes de executar este comando. A configuração de VLANs em Catalyst Switches está além do alcance deste documento. Para obter mais informações, consulte Creating Ethernet VLANs on Catalyst Switches.

    Execute o comando show interface para ver as alterações.

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING> 
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
    vlan 2 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  5. Emita o comando show ip route.

    Nota:  Se você deseja poder gerenciar o switch através de um roteador, é necessário configurar um gateway padrão. O switch não participa do roteamento IP. Consequentemente, o switch não tem nenhum conhecimento da topologia L3 da rede.

    Ao executar o comando show ip route, observe que o gateway para a sub-rede sc0 está atribuído a seu próprio endereço.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    172.16.84.0   172.16.84.17         0xffffff00   U        395         sc0 
    default          default          0xff000000   UH       0           sl0 
    Switch-A> (enable)
  6. Execute o comando set ip route 0 0 0 0 172 16 84 1 ou o comando set ip route default 172 16 84 1 para estabelecer a rota padrão.

    O segundo endereço IP é o roteador diretamente conectado que será o caminho pelo restante da rede. Este endereço IP deve ser parte da mesma sub-rede IP do switch. É possível definir até três gateways IP padrão. Use a palavra-chave primary com o comando set ip route para tornar um gateway o gateway principal. Se você não especificar um gateway padrão principal, o primeiro gateway que é configurado será o gateway principal. Se mais de um gateway for designado como principal, o último gateway principal que for configurado será gateway padrão principal.

    • Switch-A> (enable) set ip route 0.0.0.0 172.16.84.1 
      Route added. 
      Switch-A> (enable)

    ou

    • Switch-A> (enable) set ip route default 172.16.84.1
      Route added. 
      Switch-A> (enable)

    Execute o comando show ip route para ver as alterações.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.84.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default        172.16.84.1          0x0        UG      0           sc0
    172.16.84.0      172.16.84.17     0xffffff00   U       525         sc0
    default          default          0xff000000   UH      0           sl0
    Switch-A> (enable)
  7. Se você precisar limpar as rotas da tabela de roteamento, execute o comando clear ip route all.

    Nota: Se você estiver conectado ao switch via Telnet de uma sub-rede diferente, perderá a conexão ao limpar as rotas. Você não poderá alcançar o switch outra vez até que alguém forneça novamente o endereço de gateway com um console anexo ou um PC/terminal que esteja na mesma sub-rede que o switch.

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    Você pode limpar somente uma rota ao especificar somente essa rota. Execute o comando clear ip route 0.0.0.0 172.16.84.1.

Configuração da Interface SLIP (sl0) em Catalyst 4500/4000, 5500/5000 e 6500/6000 Switches que excutam o CatOS

Você pode utilizar uma conexão SLIP sobre sl0 para monitorar remotamente ou controlar o switch com um dispositivo TCP/IP onde não haja nenhum outro caminho para o switch, exceto através da porta de console.

Um gerente de rede pode utilizar um PC remoto para discar para switches em qualquer lugar no mundo e controlá-los com o uso do SNMP ou Telnet sobre SLIP. Você também pode carregar o software do sistema via interface sl0 com o uso do TFTP. Sem o SLIP, a porta de console pode ser utilizada somente para o acesso de VT100 (tty) ou transferências de arquivo do Kermit. Consulte Conexão de um Modem à Porta de Console em Catalyst Switches para obter mais informações sobre como habilitar a conectividade dial-up para um Catalyst Switch.

Esta figura mostra um exemplo de gerenciamento de um switch por um terminal remoto com o uso de sl0. Este tipo de gerenciamento é algumas vezes chamado de gerenciamento out-of-band. Out-of-band significa que um terminal de gerenciamento acessa o dispositivo através de um caminho que não inclui a rede à qual o switch está conectado.

/image/gif/paws/10594/8c.gif

Se você configurar e ativar a interface sl0 de um terminal de console conectado diretamente, você perderá sua conexão de console. Se o terminal que você está usando oferecer suporte a SLIP, estabeleça uma sessão SLIP com o switch. Desative a conexão SLIP após terminar para permitir a conectividade de console direta. Se você ativar o SLIP e seu terminal não oferecer suporte a SLIP, você deve estabelecer uma conexão Telnet para o switch e desativar o sl0 ou desligar e religar o switch para recuperar o acesso à porta de Console.

Nota: A menos que você tenha um terminal que possa executar o SLIP e saiba usá-lo, execute estes passos somente de uma conexão Telnet para o switch.

  1. Estabeleça uma sessão de Telnet para o switch.

  2. Execute o comando set interface sl0 1 1 1 1 1 1 1 2 no prompt de comando para definir o endereço SLIP do switch e o endereço IP de destino.

    Aqui está um exemplo:

    Switch-A> (enable) set interface sl0 1.1.1.1 1.1.1.2
    Interface sl0 slip and destination address set.
    Switch-A> (enable)
  3. Execute o comando slip attach no prompt de comando para habilitar o modo SLIP.

    Aqui está um exemplo:

    Switch-A> (enable) slip attach
    Console Port now running SLIP.
    Switch-A> (enable)
  4. Execute o comando slip detach no prompt de comando para desabilitar o modo SLIP.

    Aqui está um exemplo:

    Switch-A> (enable) slip detach
    SLIP detached on Console port.
    Switch-A> (enable)

Configuração da Interface Ethernet de Gerenciamento (me1) em um Catalyst 4500/4000 com CatOS

Esta seção explica como configurar um endereço IP na me1 que esta presente nos Catalyst 4500/4000 Series Switches. Os pacotes recebidos na interface me1 nunca chegam à switching fabric, e não há nenhum acesso à interface me1, exceto através da porta Ethernet no Supervisor Engine.

Outra característica da interface me1 é que, quando o switch está no monitor de ROM (ROMMON), me1 é a única interface ativa. Você pode inicializar da rede via me1 ou atualizar o Cisco IOS Software via me1 no ROMmon. Entretanto, você deve estar diretamente na porta do console. Você pode utilizar esta interface ao recuperar o Catalyst 4500/4000 Series Switch de uma imagem de software corrompida ou ausente ou de uma falha de upgrade. Para obter detalhes, consulte a seção Recuperação dos Catalyst 4000, Catalyst 2948G, Catalyst 2980G e Catalyst 4912G de Recuperação de Catalyst Switches com CatOS de Falhas de Inicialização.

Você configura o endereço IP na interface me1 de uma maneira que seja similar à configuração na interface sc0. A única diferença é que você não pode anexar a interface me1 a nenhuma VLAN porque esta interface não chega à switching fabric como a interface sc0 faz.

Conclua estes passos para configurar um endereço IP na interface me1:

  1. Conecte um terminal à porta de console do switch.

  2. Execute o comando show interface no prompt do switch para ver o status padrão da interface me1.

    Aqui está um exemplo:

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  3. Execute o comando set interface me1 10.1.1.2 255.255.255.0 10.1.1.255 para configurar um endereço IP para me1.

    A mensagem retornada pelo switch informa quais parâmetros foram alterados.

    Nota: Você deve inserir uma máscara de rede para configurar um endereço de transmissão.

    Switch-A> (enable) set interface me1 10.1.1.2 255.255.255.0 10.1.1.255
    Interface me1 IP address, netmask, and broadcast set.
    Switch-A> (enable)

    Execute o comando show interface para ver as alterações efetuadas.

    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.255.255.0 broadcast 10.1.1.255
    Switch-A> (enable)

    Se você inserir somente um endereço IP após o comando set interface me1 10.1.1.2, a máscara padrão e o endereço de broadcast padrão para a classe do endereço serão configurados. Aqui está um exemplo:

    Switch-A> (enable) set interface me1 10.1.1.2 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable)
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.0.0.0 broadcast 10.255.255.255
    
    !--- Notice that the switch took the 
    !--- default mask and the broadcast address of class A.
    
    Switch-A> (enable)

    Nota: Normalmente, a interface me1 é configurada para estar em uma sub-rede diferente da interface sc0, o que permite que ambas permaneçam ativas. Ambas as interfaces podem ser configuradas na mesma sub-rede ou com o mesmo endereço IP, mas a interface sc0 é encerrada neste caso. A interface me1 sempre tem preferência nesta instância. Por exemplo, se você já configurou a interface sc0 com um endereço IP 172.16.84.17 255.255.255.0 e tentar configurar a interface me1 na mesma sub-rede (172.16.84.18 255.255.255.0), estas mensagens serão exibidas:

    Switch-A> (enable) set interface me1 172.16.84.18 255.255.255.0 172.16.80.255
    This command places me1 and sc0 into the same ip subnet. 
    The sc0 interface will be automatically configured down if necessary to resolve 
    the conflict.
    Do you want to continue (y/n) [n]?y
    Interface me1 IP address, netmask, and broadcast set.
    Interface sc0 administratively down due to conflict.
    Console> (enable)
    
    !--- Check the configuration.
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=62 <DOWN,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 172.16.84.18 netmask 255.255.255.0 broadcast 172.16.84.255
    Switch-A> (enable) 
  4. Se você observou no Passo 3 que o status de me1 é desativado em vez de ativado, execute este comando para ativa r interface manualmente:

    Switch-A> (enable) set interface me1 up
    Interface me1 administratively up.
    Switch-A> (enable)
  5. Emita o comando show ip route.

    Nota: Se você deseja poder gerenciar o switch através de um roteador, é necessário configurar um gateway padrão, pois o switch não participa do roteamento IP. Consequentemente, o switch não tem nenhum conhecimento da topologia L3 da rede.

    Ao executar o comando show ip route, observe que o gateway para a sub-rede me1 está atribuído a seu próprio endereço.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    10.1.1.0         10.1.1.2         0xffffff00   U       0           me1
    Switch-A> (enable)
  6. Execute o comando set ip route 0.0.0.0 10.1.1.3 ou o comando set ip route default 10.1.1.3 para estabelecer a rota padrão.

    O segundo endereço IP é o roteador diretamente conectado que será o caminho pelo restante da rede. Este endereço IP deve ser parte da mesma sub-rede IP do switch.

    • Switch-A> (enable)set ip route 0.0.0.0 10.1.1.3
      Route added. 
      Switch-A> (enable)

    ou

    • Switch-A> (enable) set ip route default 10.1.1.3
      Route added. 
      Switch-A> (enable)

    Execute o comando show ip route para ver as alterações.

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0           me1
    10.1.1.0         10.1.1.2         0xffffff00   U       1           me1
    Switch-A> (enable)
    
    

    Nota: Se sc0 e me1 estão em sub-redes diferentes, é possível configurar múltiplos gateways padrão. Contudo, o gateway que é definido primeiro se torna o gateway principal. Se este é o gateway pretendido, você deve utilizar a palavra-chave primary no fim do comando para mudar o gateway padrão principal. Por exemplo, 172.16.84.1 é o gateway principal em um caso em que ambos estes itens são verdadeiros:

    • Você possui sc0 com o endereço IP 172.16.84.17 255.255.255.0 configurada primeiro com o gateway padrão 172.16.84.1.

    • Você configura me1 com um endereço IP 10.1.1.2 255.255.255.0 e o gateway padrão 10.1.1.3.

    Você pode executar estes comandos para mudar o gateway principal para 10.1.1.3:

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.80.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          G       0           me1
    default          172.16.84.1      0x0          UG      11          sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38          sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4           me1
    
    !--- Notice that 172.16.84.1 is the primary default gateway.
    
    Switch-A> (enable) 
    
    !--- Change the primary default gateway to 10.1.1.3.
    
    Switch-A> (enable) set ip route default 10.1.1.3 primary
    Primary route changed
    Switch-A> (enable)
    
    !--- This message displays when the primary gateway is changed:
    
    %SYS-5-RTE_DEFGATEFROM:Default Gateway switching from 172.16.80.1
    %SYS-5-RTE_DEFGATETO:Default Gateway switching to 10.1.1.3
    
    !--- Verify the change.
    
    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0         me1
    default          172.16.84.1      0x0          G       11        sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38        sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4         me1
    
    !--- Notice that now the primary default gateway is 10.1.1.3.
    
    
  7. Se você precisar limpar as rotas da tabela de roteamento, execute o comando clear ip route all.

    Nota: Se você estiver conectado ao switch via Telnet de uma sub-rede diferente, perderá a conexão ao limpar as rotas. Você não poderá alcançar o switch outra vez até que alguém forneça novamente o endereço de gateway com um console anexo ou um PC/terminal que esteja na mesma sub-rede que o switch.

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    Você pode limpar somente uma rota ao especificar somente essa rota. Execute o comando clear ip route 0.0.0.0 10.1.1.3.

Configuração de uma Interface de Gerenciamento em Catalyst 4500/4000 Series Switches que executam o Cisco IOS Software

Em um Catalyst 4500/4000 Supervisor Engine III/IV com Cisco IOS Software, qualquer interface roteável pode ser utilizada para gerenciamento. Há três opções para configurar esta interface.

Nota: A porta Ethernet de gerenciamento (rotulada 10/100 de MGT) em um Supervisor Engine III (WS-X4014) ou no Supervisor Engine IV (WS-X4515) é utilizada no modo ROMMON para recuperar somente uma imagem do software do switch ausente ou corrompida. Esta porta não permanece ativa durante a operação normal do switch e não pode ser utilizada como uma interface de gerenciamento.

Opção 1 — Configurar uma interface de loopback para o gerenciamento do switch. Há algumas vantagens em uma interface de loopback. Um loopback é uma interface virtual que está sempre ativada. Os pacotes que são roteados para a interface de loopback são redistribuídos de volta para o switch L3 ou roteador e processados localmente. Os pacotes IP que são roteados para fora da interface de loopback, mas que não se destinam à interface de loopback, são descartados. Isso significa que a interface de loopback atua também como interface null0. A interface de loopback serve como a ID de roteador para o Open Shortest Path First (OSPF) e assim por diante. Este exemplo usa loopback 0:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Você também deve configurar um protocolo de roteamento para distribuir a sub-rede que está atribuída ao endereço de loopback ou criar uma rota estática.

Opção 2 — Configurar a interface como uma interface roteada L3 com um endereço IP. Por padrão, todas as interfaces em um Catalyst 4500/4000 Switch com Cisco IOS Software são L2. Consequentemente, você precisa tornar toda interface conectada ao resto da rede uma interface roteada L3. Execute o comando no switchport e configure o endereço IP desejado. O exemplo fornece uma ilustração. Todas as interfaces estão habilitadas por padrão. Assim, você não precisa executar o comando no shutdown. Este exemplo usa a Fast Ethernet 5/30:

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

Se você executar o comando show running-config interface fastethernet 5/30, a saída será:

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0
end

Opção 3 — Configurar uma interface L2 como parte de uma VLAN específica. Execute o comando switchport mode access e o comando switchport access vlan vlan-id e use uma Switched Virtual Interface (SVI) correspondente com um endereço IP.

Nota: Você deve compreender a diferença entre a VLAN de gerenciamento que é utilizada para administrar o switch e as VLANs de dados que são utilizadas para transmitir o tráfego L2. A VLAN de gerenciamento é um SVI que você cria com o uso do comando interface vlan vlan-id global. Não confunda este comando com os comandos que você se usa para criar VLANs de dados para transmitir tráfego L2. Nos Catalyst 6500/6000 Series Switches que executam o Cisco IOS Software, você pode configurar a VLAN de dados do banco de dados de VLAN ou você pode executar o comando vlan vlan-id global.

Conclua estes passos:

  1. Execute estes comandos:

    Switch(config)#interface vlan 1 
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Nota: Este exemplo usa VLAN 1 como a VLAN de gerenciamento. VLAN 1 está no banco de dados de VLANs por padrão.

  2. Execute o comando switchport mode access sob a interface física desejada se quiser confirmar que a interface é uma porta de switch de acesso.

    Por padrão, todas as interfaces são interfaces L2 e são portas de switch de acesso em VLAN 1. Se você pretende utilizar a VLAN 1 como a VLAN de gerenciamento, nenhuma configuração será necessária na interface. No entanto, se desejar confirmação na configuração que a interface certamente uma porta de switch de acesso, você deverá utilizar o comando switchport mode access.

    Este exemplo usa a Fast Ethernet 5/32:

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    Se você executar o comando show run interface fastethernet 5/32, a saída será:

    Switch#show run interface fastethernet 5/32
    Building configuration...
    
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
    switchport mode access
    no snmp trap link-status
    end
  3. Se desejar mudar a interface de gerenciamento da VLAN padrão 1 para outra VLAN, execute o comando interface vlan vlan-id para criar um SVI novo.

    Você deve então executar o comando switchport access vlan vlan-id para configurar uma interface L2 para ser uma parte da nova VLAN. Este exemplo demonstra este processo:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    Se você executar o comando show run interface fastethernet 5/32, a saída será:

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    Para que o switch acesse redes remotas, você deverá ter qualquer um de:

    • Um gateway padrão configurado para o roteador de próximo salto que está conectado diretamente ao switch

    • Um protocolo de roteamento dinâmico configurado

    Se você não está roteando IP, execute o comando ip default-gateway ip-address para configurar o endereço IP de um roteador gateway. Para configurar o roteamento dinâmico, use o comando router routing_protocol. Execute o comando show ip route para ver o status da tabela de roteamento.

Configuração de uma Interface de Gerenciamento em Catalyst 6500/6000 Switches que executam o Cisco IOS Software

Em um Catalyst 6500/6000 Series Switch que executa o Cisco IOS Software, qualquer interface roteável pode ser utilizada para o gerenciamento. Há três opções para configurar esta interface.

Opção 1 — Configurar uma interface de loopback para o gerenciamento do switch. Há algumas vantagens em uma interface de loopback. Um loopback é uma interface virtual que está sempre ativada. Os pacotes que são roteados para a interface de loopback são redistribuídos de volta para o switch L3 ou roteador e processados localmente. Os pacotes IP que são roteados para fora da interface de loopback, mas que não se destinam à interface de loopback, são descartados. Isso significa que a interface de loopback atua também como interface null0. A interface de loopback funciona como a ID de roteador para o OSPF e assim por diante. Este exemplo usa loopback 0:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Você também deve configurar um protocolo de roteamento para distribuir a sub-rede que está atribuída ao endereço de loopback ou criar uma rota estática.

Opção 2 — Configurar a interface como uma interface roteada L3 com um endereço IP. Todas as interfaces em um Catalyst 6500/6000 Switch que executa o Cisco IOS Software são L3 por padrão. Todas as interfaces estão habilitadas por padrão. Assim, você não precisa executar o comando no shutdown. Este exemplo usa a Fast Ethernet 5/30:

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

Se você executar o comando show running-config interface fastethernet 5/30, a saída será:

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0 
end

Opção 3 — Configurar uma interface L2 como parte de uma VLAN específica. Execute o comando switchport mode access e o comando switchport access vlan vlan-id e use uma SVI correspondente com um endereço IP.

Nota: Você deve compreender a diferença entre a VLAN de gerenciamento que é utilizada para administrar o switch e as VLANs de dados que são utilizadas para transmitir o tráfego L2. A VLAN de gerenciamento é um SVI que você cria com o uso do comando interface vlan vlan-id global. Não confunda este comando com os comandos que você se usa para criar VLANs de dados para transmitir tráfego L2. Nos Catalyst 6500/6000 Series Switches que executam o Cisco IOS Software, você pode configurar a VLAN de dados do banco de dados de VLAN ou você pode executar o comando vlan vlan-id global.

Conclua estes passos:

  1. Execute estes comandos:

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Nota: Este exemplo usa VLAN 1 como a VLAN de gerenciamento. VLAN 1 está no banco de dados de VLANs por padrão.

  2. Execute o comando switchport mode access sob a interface física desejada a fim de tornar a interface uma interface L2 na VLAN padrão 1.

    Nota: Por padrão, todas as interfaces são da L3.

    Este exemplo usa a Fast Ethernet 5/32:

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    Se você executar o comando show run interface fastethernet 5/32, a saída será:

    Switch#show run interface fastethernet 5/32
    Building configuration...
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
     switchport mode access
     no snmp trap link-status
    end
  3. Se desejar mudar a interface de gerenciamento da VLAN padrão 1 para outra VLAN, execute o comando interface vlan vlan-id para criar um SVI novo.

    Você deve então executar o comando switchport access vlan vlan-id para configurar uma interface L2 para ser uma parte da nova VLAN. Este exemplo demonstra este processo:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    Se você executar o comando show run interface fastethernet 5/32, a saída será:

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    Para que o switch acesse redes remotas, você deverá ter qualquer um de:

    • Um gateway padrão configurado para o roteador de próximo salto que está conectado diretamente ao switch

    • Um protocolo de roteamento dinâmico configurado

    Se você não está roteando IP, execute o comando ip default-gateway ip-address para configurar o endereço IP de um roteador gateway. Para configurar o roteamento dinâmico, use o comando router routing_protocol. Execute o comando show ip route para ver o status da tabela de roteamento.

Configuração de uma Interface de Gerenciamento para Switches de Configuração Fixa Catalyst L2

Os switches de configuração fixa Catalyst L2 executam o Cisco IOS Software, mas apenas switches L2. Estes switches podem ter somente uma interface de gerenciamento ativa de cada vez. A interface de gerenciamento padrão é a VLAN1. Você não pode remover a VLAN1 nesses switches. Contudo, você pode criar uma outra interface de VLAN para gerenciamento, conforme mostrado nos exemplos desta seção.

Nota: Você deve compreender a diferença entre a VLAN de gerenciamento que é utilizada para administrar o switch e as VLANs que são utilizadas para transmitir o tráfego L2. A VLAN de gerenciamento é um SVI que você cria com o uso do comando interface vlan vlan-id global. Não confunda este comando com os comandos que você se usa para criar VLANs de dados para transmitir tráfego L2. Nos XL Series Switches, você só pode criar VLANs de dados com o comando vlan database. No Cisco IOS Software Release 12.1(9)EA1 ou posterior para o 2950 (e em todas as versões de software para os 2940, os 2955, e a 2970), há uma opção adicional para a configuração das VLAN de dados. Esta opção adicional é o comando vlan vlan-id global.

Estes exemplos usam a Fast Ethernet 0/1 como uma porta de switch de acesso e como um membro da VLAN de gerenciamento. Nenhuma configuração é necessária para tornar uma interface um membro da VLAN 1 porque todas as interfaces são portas de switch de acesso na VLAN 1 por padrão.

Este é o primeiro exemplo:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 10.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

Switch#show run interface vlan 1 
Building configuration...
Current configuration: 
! 
interface VLAN1 
 ip address 10.1.1.1 255.0.0.0 
 no ip directed-broadcast 
 no ip route-cache 
end

Switch#show run interface fastethernet 0/1
Building configuration...
 
Current configuration:
!
interface FastEthernet0/1

!--- All interfaces are access switch ports in VLAN 1 by default.

end
 
Switch#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
VLAN1                      10.1.1.1        YES manual up                    up  
    
FastEthernet0/1            unassigned      YES unset  up                    up

Lembre-se que você não pode remover a interface de gerenciamento VLAN 1. Se desejar mudar a interface de gerenciamento da VLAN padrão 1 para outra VLAN, execute o comando interface vlan vlan-id para criar um SVI novo. Você deve então executar o comando switchport access vlan vlan-id para configurar uma interface L2 para ser uma parte da nova VLAN. Este exemplo demonstra este processo:

Nota: A interface de gerenciamento poderá estar no estado desativado após um recarregamento se a interface de gerenciamento não for um membro da VLAN 1 e se você tiver configurado qualquer um destes comandos no switch:

  • ip ftp source-interface vlan vlan-id

  • ip tftp source-interface vlan vlan-id

  • ip telnet source-interface vlan vlan-id

    Torne a interface de gerenciamento um membro da VLAN 1. Alternativamente, remova estes comandos da configuração ou atualize o software de switch para a imagem mais recente para resolver este problema.

Nota: Em XL Series Switches, você pode utilizar o comando management opcional sob o novo SVI para encerrar automaticamente a VLAN1 e transferir o endereço IP para a nova VLAN.

Switch(config)#interface vlan 2
Switch(config-if)#ip address 20.1.1.1 255.0.0.0
Switch(config-if)#no shut

!--- Configure an interface to access the new management VLAN.

Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#end

Switch#

Se você executar o comando show run interface fastethernet 0/1, a saída será:

Switch#show run interface fastethernet 0/1
Building configuration...
Current configuration : 85 bytes
!
interface FastEthernet 0/1
 switchport access vlan 2
 switchport mode access
end
Switch#

Para que o switch acesse redes remotas, você deve possuir um gateway padrão configurado para o roteador de próximo salto que está conectado diretamente ao switch. Execute o comando ip default-gateway ip-address para configurar o endereço IP de um roteador gateway.

Configuração de uma Interface de Gerenciamento para 3550 e 3750 Series Switches

Em Catalyst 3550 e 3750 Series Switches que executam o Cisco IOS Software, qualquer interface roteável pode ser utilizada para o gerenciamento. Há três opções para configurar esta interface.

Opção 1 — Configurar uma interface de loopback para o gerenciamento do switch. Há algumas vantagens em uma interface de loopback. Um loopback é uma interface virtual que está sempre ativada. Os pacotes que são roteados para a interface de loopback são redistribuídos de volta para o switch L3 ou roteador e processados localmente. Os pacotes IP que são roteados para fora da interface de loopback, mas que não se destinam à interface de loopback, são descartados. Isso significa que a interface de loopback atua também como interface null0. A interface de loopback funciona como a ID de roteador para o OSPF e assim por diante. Este exemplo usa loopback 0:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Você também deve configurar um protocolo de roteamento para distribuir a sub-rede que está atribuída ao endereço de loopback ou criar uma rota estática.

Opção 2 — Configurar a interface como uma interface roteada L3 com um endereço IP. Todas as interfaces em um Catalyst 3550 ou 3750 Switch que executa o Cisco IOS Software são L2 por padrão. Para transformar uma interface L2 em uma interface L3, execute o comando no switchport e, em seguida, configure um endereço IP. Todas as interfaces estão habilitadas por padrão. Assim, você não precisa executar o comando no shutdown. Este exemplo usa a Fast Ethernet 2/0/1 em um Catalyst 3750:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastethernet 2/0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

Se você executar o comando show running-config interface fastethernet 2/0/1, a saída será:

Switch#show running-config interface fastethernet 2/0/1
Building configuration...
Current configuration : 81 bytes
!
interface FastEthernet2/0/1
 no switchport
 ip address 11.1.1.1 255.0.0.0
end
Switch#

Opção 3 — Configurar uma interface L2 como parte de uma VLAN específica. Execute o comando switchport mode access e o comando switchport access vlan vlan-id e use uma SVI correspondente com um endereço IP.

Conclua estes passos:

  1. Execute estes comandos:

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Nota: Este exemplo usa VLAN 1 como a VLAN de gerenciamento. VLAN 1 está no banco de dados de VLANs por padrão.

  2. Execute o comando switchport mode access sob a interface física desejada se quiser confirmar que a interface é uma porta de switch de acesso.

    Por padrão, todas as interfaces são interfaces L2 e são portas de switch de acesso em VLAN 1. Se você pretende utilizar a VLAN 1 como a VLAN de gerenciamento, nenhuma configuração será necessária na interface. No entanto, se desejar confirmação na configuração que a interface certamente uma porta de switch de acesso, você deverá utilizar o comando switchport mode access.

    Este exemplo usa a Fast Ethernet 2/0/1:

    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#end
    

    Se você executar o comando show run interface fastethernet 2/0/1, a saída será:

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 59 bytes
    !
    interface FastEthernet2/0/1
     switchport mode access
    end
    Switch#
  3. Se desejar mudar a interface de gerenciamento da VLAN padrão 1 para outra VLAN, execute o comando interface vlan vlan-id para criar um SVI novo.

    Você deve então executar o comando switchport access vlan vlan-id para configurar uma interface L2 para ser uma parte da nova VLAN. Este exemplo demonstra este processo:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#end
    Switch#

    Se você executar o comando show run interface fastethernet 2/0/1, a saída será:

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 85 bytes
    !
    interface FastEthernet2/0/1
     switchport access vlan 2
     switchport mode access
    end
    Switch#

    Para que o switch acesse redes remotas, você deverá ter qualquer um de:

    • Um gateway padrão configurado para o roteador de próximo salto que está conectado diretamente ao switch

    • Um protocolo de roteamento dinâmico configurado

    Se você não está roteando IP, execute o comando ip default-gateway ip-address para configurar o endereço IP de um roteador gateway.

    Se você pretende configurar o roteamento dinâmico, tenha em mente que o roteamento IP está desabilitado por padrão. Você deve executar o comando de roteamento global ip para habilitar o roteamento IP. O Routing Information Protocol (RIP) é o único protocolo de roteamento dinâmico que é suportado quando o Standard Multilayer Software Image (SMI) é utilizado. O Enhanced Multilayer Software Image (EMI) é necessário para o suporte ao Interior Gateway Routing Protocol (IGRP), Enhanced IGRP (EIGRP), OSPF, e Border Gateway Protocol (BGP). Para configurar o roteamento dinâmico, use o comando router routing_protocol. Execute o comando show ip route para ver o status da tabela de roteamento.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10594