Asynchronous Transfer Mode (ATM) : Switching e túneis VP (Virtual Path)

LANE, CES e PVCs VBR PVCs em túneis de VP moldados

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra uma configuração de exemplo do LAN Emulation (LANE), dos serviços de emulação de circuitos (CES), e das conexões virtuais permanentes da taxa de bits variável (CBR) (PVC) em túneis dados forma do caminho virtual (VP). Na configuração mostrada neste documento, o LANE, o CES, e o tempo real do bit variável taxa-NON (VBR-NRT) PVC são transportados através de WAN. Estes exemplos usam túneis de VP moldados para assegurar a conformidade com contratos de tráfego. Ao usar túneis de VP moldados com os parâmetros de tráfego idênticos ao provedor de serviços, a rede ATM do provedor de serviços não deve deixar cair nenhuma pilhas.

O túnel de VP deve ser da categoria de serviço da taxa de bits constante (CBR) a fim ser dado forma: é o único túnel moldado que Cisco apoia atualmente. Você deve ter três túneis de VP porque o LANE usa as conexões virtuais comutadas da taxa de bits não especificada (CBR) (SVC), os usos CBR PVC CES, você tem um VBR PVC, e você está usando túneis de VP moldados. Você tem um para cada categoria de serviço: Canais virtuais CBR (VC) e UBR VC. Você poderia ter usado um túnel usando túneis do VP hierárquico.

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 11.3(0.8)TWA4 ASP do½ do¿Â do Cisco IOSï ou mais tarde para o LightStream 1010 (LS1010)

  • Alguma versão de Cisco 8540-MSR

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Hipóteses

O exemplo mostrado neste documento supõe estes fatos:

  • Os túneis moldados devem ser da categoria de serviço CBR, assim que este exemplo tem um túnel de VP CBR que possa somente conter CBR VC. É usado para CES CBR PVC (etiquetado VPI1 no diagrama da rede). Note que o número do identificador de caminho virtual (VPI) está localmente - significativo à porta de switch, assim que a você pode ter o mesmo número VPI no mesmo interruptor, mas duas portas de switch diferentes.

  • Porque os túneis de VP moldados não podem simultaneamente transportar VC de categorias de serviço múltiplo, o primeiro túnel de VP usado para CBR VC não pode ser usado para LANE UBR VC ou o VBR-NRT PVC. Você deve criar um outro túnel de VP para o LANE (que usa a categoria de serviço VC UBR). Consequentemente, o segundo túnel de VP (etiquetado VPI2 no diagrama da rede) é um túnel de VP CBR-dado forma através de que somente o UBR VC é permitido.

  • Um terceiro túnel de VP moldado transporta o VBR-NRT PVC (etiquetado VPI3 no diagrama da rede).

  • Você precisa de comprar três CBR VP do provedor de serviços.

  • Supõe-se que os três CBR VP têm uma taxa de célula de pico (PCR) do 10 Mbps e uma tolerância de variação de retardo da célula (CDVT) de 500 pilhas. Note que a soma dos PCR de todos os túneis de VP definidos na mesma interface física deve ser menor de 95 por cento da linha taxa da interface física (que supõe que somente os túneis de VP estão configurados na interface física).

  • Para o VBR PVC, a taxa de célula sustentada (SCR) do PVC deve ser menor de 95 por cento do PCR do túnel de VP CBR-dado forma. Ou seja o PVC SCR deve ser menor do que o 9.5 Mbps para o VBR-NRT. Se há múltiplo o VBR PVC que atravessa o CBR escava um túnel, a soma dos SCR de todo o VBR PVC deve ser menor de 95 por cento do PCR do túnel de VP moldado. Permanecer dos por cento 5 é reservado para protocolos imperativos de sinalização e outros.

  • O dispositivo 5500-asp-f é para o switching VP. O provedor de serviços executa tipicamente esta função.

  • Os serviços de pista são definidos em 8540-MSR; Os clientes de LAN Emulation (LEC) são definidos em 8540-MSR e em 5500-asp-e.

    Nota: Neste exemplo, os serviços de pista são colocados no switch ATM para a simplicidade. Aquela não é, contudo, a ótima localização para serviços de pista. O melhor lugar para um servidor de LAN Emulation (LES) ou a transmissão e servidor desconhecido (BARRAMENTO) está no módulo LANE de um Catalyst 5500. O lugar ideal para um LEC está em um Cisco 7500 Series Router.

  • Os dois centrais telefônica privada (PBX) no uso do diagrama um circuito CES CBR. Para detalhes em como configurar a simulação de circuito, refira configurar serviços de emulação de circuitos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Clique sobre o Switches neste diagrama para ver as configurações de amostra:

/image/gif/paws/10493/PVPshap.gif

Configurações

Este documento utiliza as seguintes configurações:

configuração de exemplo 5500-asp-e

5500-asp-e
5500-asp-e# show running-config

Building configuration...
Current configuration:
!
version 11.3
no service pad
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname 5500-asp-e
!
boot system flash slot0:LS1010-wp-mz.120-3c.W5.9.bin
!
ip host-routing
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 64000 cbr pcr 10240  cdvt 500
atm lecs-address-default 47.0091.8100.0000.0090.2144.8401.0090.2144.8405.00 1
atm address 47.0091.8100.0000.0050.537e.1401.0050.537e.1401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
!
interface CBR10/0/0
 no ip address
 ces circuit 0 circuit-name test
 ces pvc 0 interface ATM11/0/1.6 vpi 6 vci 100
!
interface ATM11/0/1
 no atm signaling enable
 no ip address
 atm pvp 5 shaped rx-cttr 64000 tx-cttr 64000
 atm pvp 6 shaped rx-cttr 64000 tx-cttr 64000
 atm pvp 7 shaped rx-cttr 64000 tx-cttr 64000
!
interface ATM11/0/1.5 point-to-point
 atm cac service-category cbr deny
 atm cac service-category ubr permit
!
interface ATM11/0/1.6 point-to-point
!
interface ATM11/0/1.7 point-to-point
 atm cac service-category cbr deny
 atm cac service-category vbr-nrt permit
 atm pvc 7 100 rx-cttr 63997 tx-cttr 63997  interface  ATM10/1/0 0 100
!
interface ATM11/0/2
 no ip address
!
interface ATM11/0/3
 no ip address
!
interface ATM11/1/0
 no ip address
!
interface ATM11/1/1
 no ip address
!
interface ATM11/1/2
 no ip address
!
interface ATM11/1/3
 no ip address
!
interface ATM13/0/0
 no ip address
 atm maxvp-number 0
!
interface ATM13/0/0.1 multipoint
 ip address 100.100.100.2 255.255.255.0
 lane client ethernet test
!
interface Ethernet13/0/0
 no ip address
!
no ip classless
logging buffered 16000 debugging
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Descrição dos recursos

Você pode usar os comandos show nesta seção verificar características de configuração no dispositivo. A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Você pode usar comandos show adicionais verificar a configuração; não todo são incluídas neste documento.

Para assegurar-se de que todo o LANE VCs vá através do túnel de VP correto (ou seja para impedir sinalizar do início através da interface principal), sinalizando é desabilitado na relação atm11/0/1 usando o comando no atm signaling enable. A mesma operação foi executada no 8540-MSR.

Para ver que VC estão passando através do túnel de VP com um VPI de 7, emita o comando show atm vc interface interface-number:

5500-asp-e# show atm vc interface atm11/0/1.7

Interface    VPI   VCI   Type    X-Interface  X-VPI X-VCI  Encap Status

ATM11/0/1.7  7     3      PVC     ATM13/0/0    0     181   SNAP   UP
ATM11/0/1.7  7     4      PVC     ATM13/0/0    0     182   SNAP   UP
ATM11/0/1.7  7     5      PVC     ATM13/0/0    0     180   QSAAL  UP
ATM11/0/1.7  7     16     PVC     ATM13/0/0    0     179   ILMI   UP
ATM11/0/1.7  7     18     PVC     ATM13/0/0    0     183   PNNI   UP
ATM11/0/1.7  7     100    PVC     ATM10/1/0    0     100          UP

5500-asp-e# show atm interface resource atm11/0/1.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX
Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

5500-asp-e# show atm interface resource atm11/0/1

Resource Management configuration:
    Service Classes:
        Service Category map: c1 cbr, c2 vbr-rt, c3 vbr-nrt, c4 abr, c5 ubr
        Scheduling: RS c1 WRR c2, WRR c3, WRR c4, WRR c5
        WRR Weight: 8 c2, 1 c3, 1 c4, 1 c5
    Pacing: disabled   0 Kbps rate configured, 0 Kbps rate installed
    Service Categories supported: cbr,vbr-rt,vbr-nrt,abr,ubr
    Link Distance: 0 kilometers
    Controlled Link sharing:
        Max aggregate guaranteed services: none RX,  none TX
        Max bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
        Min bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr, none vbr, none abr, none ubr
        Peak-cell-rate TX: none cbr, none vbr, none abr, none ubr
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX: none abr, none ubr
        Minimum-cell-rate TX: none abr, none ubr
        CDVT RX: none cbr, none vbr, none abr, none ubr
        CDVT TX: none cbr, none vbr, none abr, none ubr
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        117023 cbr RX, 117023 cbr TX, 117023 vbr RX, 117023 vbr TX,
        117023 abr RX, 117023 abr TX, 117023 ubr RX, 117023 ubr TX
    Allocated bit rates:
        30720 cbr RX, 30720 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Best effort connections: 0 pvcs,  4 svcs

configuração de exemplo 5500-asp-f

O interruptor é configurado para o switching VP.

5500-asp-f
5500-asp-f# show running-config

Building configuration...
Current configuration:
!
version 11.3
no service padservice timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 5500-asp-f
!
!
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 64000 cbr pcr 10240  cdvt 500
atm address 47.0091.8100.0000.0050.5308.2401.0050.5308.2401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
!
interface ATM11/0/0
 no ip address
!
interface ATM11/0/1
 no ip address
 atm pvp 5  interface  ATM11/0/0 10
 atm pvp 6 rx-cttr 64000 tx-cttr 64000 interface ATM11/0/0 6 rx-cttr 64000 tx-cttr 64000
 atm pvp 7 rx-cttr 63997 tx-cttr 63997 interface ATM11/0/0 7 rx-cttr 63997 tx-cttr 63997
!
interface ATM13/0/0
 no ip address
 atm maxvp-number 0
!
interface Ethernet13/0/0
 no ip address
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Exibição de recursos

Para verificar que o VP é operacional, emita o comando show atm vp:

5500-asp-f# show atm vp

Interface    VPI    Type  X-Interface     X-VPI     Status
ATM11/0/0    6       PVP     ATM11/0/1    6         UP
ATM11/0/0    7       PVP     ATM11/0/1    7         UP
ATM11/0/0    10      PVP     ATM11/0/1    5         UP
ATM11/0/1    5       PVP     ATM11/0/0    10        UP
ATM11/0/1    6       PVP     ATM11/0/0    6         UP
ATM11/0/1    7       PVP     ATM11/0/0    7         UP

Configuração de exemplo 8540-MSR

8540-MSR
8540-MSR# show running-config

Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 8540-MSR
!
logging buffered 4096 debugging
!
redundancy
 main-cpu
  sync config startup
  sync config running
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
ip subnet-zero
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 63998 cbr pcr 10000
atm connection-traffic-table-row index 63999 cbr pcr 10240  cdvt 500
atm lecs-address-default 47.0091.8100.0000.0090.2144.8401.0090.2144.8405.00 1
atm address 47.0091.8100.0000.0090.2144.8401.0090.2144.8401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
lane database PVP
  name test server-atm-address 47.009181000000009021448401.009021448403.01
!
!
interface CBR1/0/0
 no ip address
 no ip directed-broadcast
 shutdown
 ces circuit 0 circuit-name test
 ces pvc 0 interface ATM2/1/0.6 vpi 6 vci 100
!
interface ATM2/1/0
 no atm signaling enable
 no ip address
 no ip directed-broadcast
 atm pvp 6 shaped rx-cttr 63999 tx-cttr 63999
 atm pvp 7 shaped rx-cttr 63999 tx-cttr 63999
 atm pvp 10 shaped rx-cttr 63999 tx-cttr 63999
!
interface ATM2/1/0.6 point-to-point
 no ip directed-broadcast
!
interface ATM2/1/0.7 point-to-point
 no ip directed-broadcast
 atm cac service-category cbr deny
 atm cac service-category vbr-nrt permit
 atm pvc 7 100 rx-cttr 63997 tx-cttr 63997  interface  ATM1/1/0 0 100
!
interface ATM2/1/0.10 point-to-point
 no ip directed-broadcast
 atm cac service-category cbr deny
 atm cac service-category ubr permit
!
interface ATM2/1/1
 no ip address
 no ip directed-broadcast
!
interface ATM2/1/2
 no ip address
 no ip directed-broadcast
!
interface ATM2/1/3
 no ip address
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 atm maxvp-number 0
 lane config auto-config-atm-address
 lane config database PVP
!
interface ATM0.1 multipoint
 ip address 100.100.100.1 255.255.255.0
 no ip directed-broadcast
 lane server-bus ethernet test
 lane client ethernet test
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

Descrição dos recursos

Você pode usar os comandos show nesta seção verificar características de configuração no dispositivo.

8540-MSR# show atm interface resource atm2/1/0.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX
Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0

Resource Management configuration:
    Service Classes:
        Service Category map: c2 cbr, c2 vbr-rt, c3 vbr-nrt, c4 abr, c5 ubr
        Scheduling: RS c1 WRR c2, WRR c3, WRR c4, WRR c5
        WRR Weight: 8 c2, 1 c3, 1 c4, 1 c5
    Pacing: disabled   0 Kbps rate configured, 0 Kbps rate installed
    Service Categories supported: cbr,vbr-rt,vbr-nrt,abr,ubr
    Link Distance: 0 kilometers
    Controlled Link sharing:
        Max aggregate guaranteed services: none RX,  none TX
        Max bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
        Min bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr, none vbr, none abr, none ubr
        Peak-cell-rate TX: none cbr, none vbr, none abr, none ubr
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX: none abr, none ubr
        Minimum-cell-rate TX: none abr, none ubr
        CDVT RX: none cbr, none vbr, none abr, none ubr
        CDVT TX: none cbr, none vbr, none abr, none ubr
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        117023 cbr RX, 117023 cbr TX, 117023 vbr RX, 117023 vbr TX,
        117023 abr RX, 117023 abr TX, 117023 ubr RX, 117023 ubr TX
    Allocated bit rates:
        30720 cbr RX, 30720 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Best effort connections: 0 pvcs,  0 svcs

8540-MSR# show atm interface resource atm2/1/0.6

Resource Management configuration:
    Service Categories supported: cbr
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr,
        Peak-cell-rate TX: none cbr,
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none cbr,
        CDVT TX: none cbr,

Resource Management state:
    Available bit rates (in Kbps):
        9727 cbr RX, 9727 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        1741 cbr RX, 1741 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0.10

Resource Management configuration:
    Service Categories supported: ubr
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none ubr
        Peak-cell-rate TX: none ubr
        Minimum-cell-rate RX: none ubr
        Minimum-cell-rate TX: none ubr
        CDVT RX: none ubr
        CDVT TX: none ubr

Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas

Clique para ver a configuração de switch 5500-asp-e. Clique para ver a configuração de switch 5500-asp-f. Clique para ver a configuração do 8540-MSR Switch.


Document ID: 10493