Multiprotocol Label Switching (MPLS) : Multiprotocol Label Switching sobre ATM (MPLS sobre ATM)

MPLS por túneis de VP

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Um provedor de serviços dá-lhe normalmente uns ou vários túneis do caminho virtual (VP) para conectar junto seus dispositivos em vez de um enlace físico ponto a ponto. Este documento explica as etapas necessárias configurar o Multiprotocol Label Switching (MPLS) quando você usa túneis de VP.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10476/mpls_vptunnel-1.gif

Nesta instalação, o provedor de serviços equipou dois túneis de VP:

  • Um entre Ischia e Capri com VPI= 3 (identificador de caminho virtual)

  • Um entre Alcazaba e Capri com VPI= 4

Ischia e Alcazaba são dois Cisco 7200 Router que executam o Software Release 12.1(3a)E do½ do¿Â do Cisco IOSïÂ. Capri é um Multiservice Switch Router do Catalyst 8540 (MSR) essa liberação das corridas 12.0(10)W5(18c). Capri é um vizinho do protocolo de distribuição de etiquetas (TDP) de Alcazaba e de Ischia.

Nota: Você deve executar a liberação 12.0(3)T ou mais altamente a fim configurar esta característica.

As configurações usadas aqui são para um Catalyst 8500 MSR, ou LightStream 1010, e um roteador.

Configurações

Este documento utiliza as seguintes configurações:

Ischia
ip cef 
! 
interface Loopback0 
 ip address 1.1.1.1 255.255.255.0 
! 
interface ATM2/0.3 tag-switching 
 ip address 3.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 3 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 1.1.1.1 0.0.0.0 area 0 
 network 3.0.0.0 0.0.0.255 area 0 

Alcazaba
 ip cef 
! 
interface Loopback0 
 ip address 2.2.2.2 255.255.255.0 
! 
interface ATM4/0.4 tag-switching 
 ip address 4.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 4 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 2.2.2.2 0.0.0.0 area 0 
 network 4.0.0.0 0.0.0.255 area 0 

Capri
 interface ATM3/1/1 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 atm pvp 3 
 atm pvp 4 
! 
interface ATM3/1/1.3 point-to-point 
 ip address 3.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 
! 
interface ATM3/1/1.4 point-to-point 
 ip address 4.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 

Nota: Esta configuração é similar às configurações de roteador padrão que você pode encontrar aqui. A única diferença é que você tem que especificar ao roteador que você usa um túnel de VP. Você pode fazer este com o comando tag-switching atm vp-tunnel vpi, onde o vpi é o valor VPI que é associado com o túnel esse extremidades neste roteador.

Nota: Para o LightStream 1010 e o Catalyst 8500 MSR, você precisa de configurar uns ou vários caminhos virtuais permanentes (PVP) para cada túnel de VP com o comando atm pvp vpi. Veja aqui para uma configuração de exemplo. Uma subinterface é associada com o cada um destes túneis. Por exemplo, a relação atm 3/1/1.3 é associada com o PVP=3. Você deve configurar esta subinterface com tag-switching, como você faz na interface principal.

Verificar

Use estes comandos show do tag-switching testar que sua rede se opera corretamente:

  • show tag-switching tdp neighbor

  • mostre emperramentos do tag-switching ATM-TDP — Isto mostra a informação dinâmica da etiqueta ATM.

  • mostre a tabela do forwarding do tag-switching — Isto mostra o Tag Forwarding Information Base (TFIB).

  • show tag-switching interfaces atm [int number] detail — Isto mostra informação de switching de caractere detalhada para cada relação.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Esta saída é um resultado destes comandos entered nos dispositivos mostrados no diagrama da rede.

Ischia#show tag-switching tdp neighbor
Peer TDP Ident: 10.200.10.57:1; Local TDP Ident 1.1.1.1:1
        TCP connection: 3.0.0.2.11001 - 3.0.0.1.711
        State: Oper; PIEs sent/rcvd: 92/93; ; Downstream on demand
        Up time: 01:16:52
        TDP discovery sources:
          ATM2/0.3
 
Ischia#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Headend Router ATM2/0.3 (1 hop) 3/33  Active, VCD=127
 Destination: 1.1.1.0/24
    Tailend Router ATM2/0.3 3/33 Active, VCD=127
 Destination: 2.2.2.2/32
    Headend Router ATM2/0.3 (2 hops) 3/34  Active, VCD=128
 
Ischia#show tag-switching forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
26     3/33        4.0.0.0/24        0          AT2/0.3    point2point  
27     3/34        2.2.2.2/32        0          AT2/0.3    point2point   
 
Ischia#show tag-switching interfaces detail 
Interface ATM2/0.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        Tagswitching turbo vector
        MTU = 4470
        ATM tagging:
                Tag VPI = 3 (VP Tunnel)
                Tag VCI range = 33 - 65535
                Control VC = 3/32
 
Capri#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Tailend Switch ATM3/1/1.3 3/33 Active -> Terminating Active
 Destination: 1.1.1.1/32
    Transit ATM3/1/1.4 4/33 Active -> ATM3/1/1.3 3/33 Active
 Destination: 3.0.0.0/24
    Tailend Switch ATM3/1/1.4 4/34 Active -> Terminating Active
 Destination: 2.2.2.2/32
    Transit ATM3/1/1.3 3/34 Active -> ATM3/1/1.4 4/33 Active
 
Capri#show tag-switching tdp neighbor 
Peer TDP Ident: 1.1.1.1:1; Local TDP Ident 10.200.10.57:1
        TCP connection: 3.0.0.1.711 - 3.0.0.2.11001
        State: Oper; PIEs sent/rcvd: 95/94; ; Downstream on demand
        Up time: 01:18:49
        TDP discovery sources:
          ATM3/1/1.3
Peer TDP Ident: 2.2.2.2:1; Local TDP Ident 10.200.10.57:2
        TCP connection: 4.0.0.1.711 - 4.0.0.2.11002
        State: Oper; PIEs sent/rcvd: 93/95; ; Downstream on demand
        Up time: 01:18:22
        TDP discovery sources:
          ATM3/1/1.4
 
Capri#show tag-switching interfaces detail 
Interface ATM3/1/1.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 3, Control VC = 3/32
Interface ATM3/1/1.4:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 4, Control VC = 4/32

Esta saída é similar à saída padrão do tag-switching, mas uma diferença importante é que aponta à interface de túnel VP.


Informações Relacionadas


Document ID: 10476