Multiprotocol Label Switching (MPLS) : Multiprotocol Label Switching sobre ATM (MPLS sobre ATM)

MPLS sobre o ATM: Combinação VC

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo do Multiprotocol Label Switching (MPLS) sobre ATM usando a fusão do virtual circuit (VC).

Pré-requisitos

Requisitos

Antes que você tente esta configuração, assegure-se de que você tenha uma compreensão básica do ATM, do MPLS, e do Open Shortest Path First (OSPF).

Componentes Utilizados

Use um deste Roteadores a fim executar esta configuração:

  • Edge Label Switch Router (LSR) — Todo o ATM Router que executar o Software Release 12.0 ou Mais Recente do ½ do ¿  de Cisco IOSïÂ, com MPLS caracteriza. Esta configuração usa os Cisco 3600 Series Router que executam o Cisco IOS Software Release 12.1(3)T e um Cisco 7200 Router que execute o Cisco IOS Software Release 12.0(8)S.

  • ATM LSR — Algum switch ATM tal como o LightStream 1010 ou o Catalyst 85xx MSR. Cisco recomenda que você usa o WA4.8d da versão de software ou mais tarde. O LightStream 1010 exige um enfileiramento de PerFlow da placa de recurso (FC-PFQ).

Você pode encontrar uma descrição mais precisa das plataformas suportadas em projetar o MPLS para o ATM.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Refira estes links para obter mais informações sobre da configuração de MPLS e das convenções:

  • A facilidade da fusão VC é estandardizada na arquitetura Multiprotocol Label Switching do Internet Engineering Task Force (IETF) e no MPLS usando documentos do protocolo de distribuição de rótulo (LDP) e do switching VC ATM. Você pode alcançar both of these documentos da carta patente IETF MPLSleavingcisco.com .

  • Você pode encontrar instruções de configuração no MPLS sobre a documentação ATM.

  • O cálculo de dimensões do número de VC usados em uma rede MPLS é coberto na seção de dimensionalização do espaço da etiqueta VC MPLS de projetar o MPLS para o ATM.

Informações de Apoio

A facilidade da fusão VC permite que um interruptor agregue fluxos entrantes múltiplos com o mesmo endereço de destino em um único fluxo que parte. Onde quer que a fusão VC ocorre, diversos rótulos recebidos são traçados a um único rótulo de saída. As pilhas dos identificadores de canal virtual diferentes (VCI) que vão ao mesmo destino são transmitidas ao mesmo VC que parte com o uso de conexões do multiponto-à-ponto. Esta partilha das etiquetas reduz o número total de VC exigidos para o Label Switching. Sem fusão VC, cada trajeto (com o mesmo roteador de ingresso e a mesma classe equivalente de encaminhamento (FEC)) consome uma etiqueta VC em cada relação ao longo do trajeto. A fusão VC reduz a falta de espaço de rótulo compartilhando etiquetas para fluxos diferentes com o mesmo destino, isto é, o mesmo FEC.

Esta figura mostra um exemplo da fusão VC. Nesta figura, o Roteadores A e B enviam o tráfego para prefixar 171.69.0.0/16 no C do roteador. O switch ATM no meio é configurado com um único VCI 50 de partida limitado para prefixar 171.69.0.0/16. Os fluxos de dados do Roteadores A e B reunem-se no switch ATM e compartilham-se do mesmo VC que parte. As pilhas que vêm do VCI 40 e do VCI 70 estão protegidas nas filas de entrada do switch ATM até que os quadros AAL5 completos estejam recebidos. O quadro completo é enviado então ao C do roteador no VCI 50.

/image/gif/paws/10475/mpls_vcmerge1.gif

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede.

/image/gif/paws/10475/mpls_vcmerge2.gif

Configurações

Neste exemplo, os identificadores do ATM virtual path (VPI) 2,3, ou 4 são usados. Mas, não é imperativo especificar que caminhos virtuais (VP) são usados para o MPLS.

Configurar o Cisco Express Forwarding (CEF) IP no Roteadores. Se você usa um Cisco 7500 Router, você deve assegurar-se de que o comando ip cef distributed esteja permitido.

Este documento utiliza estas configurações.

Roteador 1
!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!
interface Loopback1
 ip address 100.100.1.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 100.100.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 100.100.0.0 0.0.0.255 area 10
 network 100.100.1.0 0.0.0.255 area 10
 network 223.0.0.12 0.0.0.0 area 10
!

Roteador 2
!
ip cef
!
interface Loopback0
 ip address 223.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 100.100.0.1 255.255.255.0
!
interface ATM1/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
!
interface ATM1/0.1 label-switching
 ip address 10.0.0.2 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 100.100.0.0 0.0.0.255 area 10
 network 223.0.0.11 0.0.0.0 area 0
!

Roteador 3
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip address 200.200.0.1 255.255.255.255
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.6 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 redistribute static
 network 10.0.0.0 0.0.0.255 area 0
 network 200.200.0.0 0.0.0.255 area 20
 network 223.0.0.21 0.0.0.0 area 0
!
ip route 158.0.0.0 255.0.0.0 Null0
!

Roteador 4
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
 no ip directed-broadcast
! 
interface Loopback1
 ip address 150.150.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM4/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.13 255.255.255.252
 no ip directed-broadcast
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.255.255 area 30
 network 223.0.0.3 0.0.0.0 area 0
!
ip route 150.150.150.0 255.255.255.0 Null0
!

Switch de ATM 1
!
interface Loopback0
 ip address 223.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface ATM4/1/2
 ip address 10.0.0.1 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM4/1/3
 ip address 10.0.0.21 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.1 0.0.0.0 area 0
!

Switch de ATM 2
!
interface Loopback0
 ip address 223.0.0.2 255.255.255.255
 no ip directed-broadcast
!
interface ATM0/1/0
 ip address 10.0.0.14 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!         
interface ATM0/1/2
 ip address 10.0.0.5 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM0/1/3
 ip address 10.0.0.22 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.2 0.0.0.0 area 0
!

Verificar

Esta seção fornece a informação que você pode se usar a fim confirmar que sua configuração trabalha corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre a capacidade do tag-switching ATM-TDP

  • mostre emperramentos do tag-switching ATM-TDP

  • show atm vc

Emita o comando show tag atm-tdp a fim obter a informação na fusão VC. Esta saída, gerada pelo comando show tag-switching atm-tdp capability, mostra que a fusão VC está permitida nestas relações:

ATMswitch2#show tag-switching atm-tdp capability 
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/0       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1023]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1023]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/2       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1018]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1018]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/3       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 16383]  UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 16383]  UNIDIR           -    -

Você igualmente pode verificar a fusão VC para ver se há um FEC particular – por exemplo, 100.100.1.1/32 – como visto nesta saída:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/47 Active -> ATM0/1/3 2/52 Active
    Transit ATM0/1/0 2/47 Active -> ATM0/1/3 2/52 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/2    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/3    2    52   TVC(O) ATM0/1/2          2   47           UP
                             ATM0/1/0          2   47           UP

Se a fusão VC não trabalha (ou se está desabilitada com o comando no tag-switching atm vc-merge), você recebe este comando output:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/38 Active -> ATM0/1/3 2/35 Active
    Transit ATM0/1/0 2/43 Active -> ATM0/1/3 2/43 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0   2    43    TVC(I) ATM0/1/3          2   43           UP
ATM0/1/2   2    38    TVC(I) ATM0/1/3          2   35           UP
ATM0/1/3   2    35    TVC(O) ATM0/1/2          2   38           UP
ATM0/1/3   2    43    TVC(O) ATM0/1/0          2   43           UP

Você pode ver desta saída que desabilitar a função da fusão VC conduz ao sistema usando muito mais VC.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 10475