Multiprotocol Label Switching (MPLS) : Multiprotocol Label Switching sobre ATM (MPLS sobre ATM)

MPLS VPN sobre ATM: com o OSPF no lado do cliente (com área 0)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo de um Virtual Private Network (VPN) do Multiprotocol Label Switching (MPLS) sobre o ATM quando o Open Shortest Path First (OSPF) esta presente no lado do cliente, a área 0.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

As letras abaixo representam os tipos diferentes de Roteadores e de Switches usados:

  • P: Roteador central do provedor

  • PE: Roteador de ponta do provedor

  • CE: Roteador de ponta do cliente

  • C : O roteador do cliente

Este diagrama mostra uma configuração típica usando estas convenções:

/image/gif/paws/10473/mplsvpn.gif

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Roteadores PE:

    • Software - Software Release 12.1(3)T do ½ do ¿  de Cisco IOSïÂ. As características do MPLS VPN aparecem na liberação 12.0(5)T. O OSPF como o protocolo de roteamento PE-CE aparece na liberação 12.0(7)T.

    • Hardware - Os Cisco 3660 ou 7206 Router. Para detalhes do outro hardware que você pode se usar, refira o MPLS de projeto para o guia ATM.

  • Roteadores CE: Todo o roteador capaz de trocar a informação de roteamento com seu roteador de PE pode ser usado.

  • Roteadores e Switches P: A função da integração do MPLS VPN reside somente na borda da rede MPLS, assim que todo o switch capacitado para MPLS pode ser usado. Nesta configuração de exemplo, a nuvem MPLS é composta de um roteador de 8540 switch de ATM multisserviço (MSR) e de um LightStream 1010. Se você está usando o Cisco lightstream 1010, nós recomendamos que você usa o WA4.8d da versão de software ou mais tarde. Você pode igualmente usar o outro Switches ATM como o Cisco BPX 8650 ou o MGX8850 na rede central ATM.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

A característica VPN, quando usada com MPLS, permite que diversos locais interconectem transparentemente através de uma rede de provedor de serviços. Uma rede de provedor de serviços pode suportar várias VPNs de IPs diferentes. Cada uma delas aparece para seus usuários como uma rede privada, separada de todas as outras redes. Na VPN, cada site pode enviar pacotes IP para qualquer outro site na mesma VPN.

Cada VPN está associada com um ou mais instâncias de VPN Routing ou de encaminhamento (VRFs) Um VRF consiste em uma tabela de IP Routing, em uma tabela derivada do Cisco Express Forwarding (EF) e em um grupo de relações que usam esta tabela do forwarding.

O roteador mantém um roteamento e uma tabela separados de Cisco EF para cada VRF. Isso evita que as informações sejam enviadas para fora da VPN e permite que a mesma sub-rede seja utilizada em várias VPNs sem provocar problemas de endereço IP duplicado.

O roteador que utiliza o Border Gateway Protocol (BGP) distribui a informação do VPN Routing usando as comunidades estendidas de BGP.

Para obter mais informações relacionadas à propagação de atualizações através de uma VPN, consulte as seguintes URLs:

Usando o OSPF

Tradicionalmente, uma rede OSPF elaborada consiste em uma área Backbone (área 0) e em um número de áreas conectadas a este backbone através de um roteador de borda de área (ABR).

Usando um backbone MPLS para o VPN com o OSPF no local de cliente, você pode introduzir um terceiro nível na hierarquia do modelo de OSPF. Este terceiro nível é chamado o super backbone do MPLS VPN.

Em casos simples, o super backbone do MPLS VPN é combinado com o backbone da área tradicional 0. Isto significa que não há nenhum area 0 backbone na rede cliente, desde que o super backbone do MPLS VPN joga o mesmo papel que o area 0 backbone. Isto é mostrado no diagrama abaixo:

/image/gif/paws/10473/mpls_ospf1.gif

Neste diagrama:

  • Os roteadores de PE são ABR e roteadores de limite de sistema autônomo (ASBR).

  • Os CE Router são OSPF Router simples.

  • A informação de VPN é transportada usando as comunidades extendida BGP dos PE a outros PE e injetar novamente nas áreas do OSPF como os anúncios link states da rede sumária (tipo 3) (LSA).

O super backbone do MPLS VPN igualmente permite clientes de usar backbones da área múltipla 0 em seus locais. Cada local pode ter uma área separada 0 enquanto é conectado ao super backbone do MPLS VPN. O resultado é o mesmo que um backbone da área particionada 0. Isto é mostrado no diagrama abaixo:

/image/gif/paws/10473/mpls_ospf2.gif

Neste caso:

  • Os roteadores de PE são ABR e roteadores ASBR.

  • Os CE Router são roteadores ABR.

  • O LSAs contendo informação do VPN é transportado usando as comunidades extendida BGP dos PE a outros PE. Em resumo a rede (tipo 3) LSA, informação é transportada entre PE e CE.

Esta configuração de exemplo é baseada na segunda instalação mostrada acima. Você pode encontrar uma configuração de exemplo que usa a primeira instalação no MPLS VPN sobre o ATM: com o OSPF no lado do cliente (sem área 0).

A informação OSPF é transportada com os atributos de comunidade estendidos BGP (que incluem um que identifica a rede de OSPF). Cada VPN deve ter seu próprio processo de OSPF. Para especificar isto, emita o comando seguinte:

<process OSPF do roteador ID > roteamento do vrf <VPN ou nome do exemplo do forwarding >

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/10473/mpls_ospf4.gif

Procedimento de configuração

A documentação do IOS da Cisco (redes privadas virtuais de MPLS) também descreve esse procedimento de configuração.

Parte I

Certifique-se de que o ip cef esteja habilitado. Se você está usando um Cisco 7500 Router, assegure-se de que o cef IP distribuído esteja permitido. Nos PE, uma vez que o MPLS se estabelece:

  1. <<<<<<<<<<<<<<<<<VPN routing/forwarding instance name>. Quando estiver fazendo isto:

    • Emita o comando abaixo especificar o distinguidor de rota correto usado para esse VPN. É utilizada para estender o endereço IP de forma que você possa identificar a qual VPN ele pertence.

      distinguidor de rota rd <VPN >

    • Configure as propriedades de importação e exportação para as comunidades estendidas de BGP. Estes são utilizados para filtrar o processo de importação e exportação.

      rota-alvo [exportação|importação|ambos] a comunidade extendida do <target VPN >

  2. Configurar os detalhes reenviado para as interfaces respectivas emitindo este comando:

    vrf IP que envia o nome <table >

    Lembre-se de configurar o endereço IP depois de fazer isso.

  3. Dependendo do PE-CE Routing Protocol que está sendo usado, você deverá ter agora um ou mais dos seguintes:

    • Configure os roteadores estáticos como a seguir:

      ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}]

    • Configurar o Routing Information Protocol (RIP) emitindo o comando:

      roteamento do vrf <VPN do IPv4 da endereço-família/nome do exemplo do forwarding >

      Uma vez que isto é feito, incorpore os comandos de configuração RIP normais.

      Observe que:

      • isto é aplicado somente às interfaces de encaminhamento para o VRF atual.

      • É necessário redistribuir o BGP correto no RASGO. Quando estiver fazendo isto, lembre-se de especificar a métrica utilizada.

    • Declare as informações de vizinho BGP

    • Configurar o OSPF emitindo o comando do Novo Cisco IOS:

      <process OSPF do roteador ID > roteamento do vrf <VPN/nome do exemplo do forwarding >.

    Observe que:

    • isto é aplicado somente às interfaces de encaminhamento para o VRF atual.

    • É necessário redistribuir o BGP correto no OSPF. Quando estiver fazendo isto, lembre-se de especificar a métrica utilizada.

    • Uma vez que o processo de OSPF é atribuído a um VRF, este número do processo está usado sempre para este VRF particular. Isso se aplica até se você não especificá-lo na linha de comando.

Parte II

Configure o BGP entre os roteadores PE. Há vários modos de configurar o BGP, como, por exemplo, utilizar o refletor de rota ou métodos de confederação. O método usado aqui – configuração vizinha direta – é o mais simples e o o mais menos escalável.

  1. Declare os vizinhos diferentes.

  2. Dê entrada com o nome do roteamento/exemplo do forwarding do vrf <VPN do IPv4 da endereço-família > para cada VPN atual neste roteador de PE. Realize uma ou mais das seguintes etapas, conforme necessário:

    • Redistribua as informações de roteamento estático.

    • Redistribuir as informações de RIP Routing

    • Redistribua as informações de OSPF Routing

    • Ative os vizinhos BGP com os roteadores CE.

  3. Entre no modo address-family vpnv4 e:

    • Ative os vizinhos

    • Especifique se uma comunidade estendida deve ser utilizada. Isso é obrigatório.

Configurações

Nota: Somente as partes relevantes da seguinte saída são incluídas aqui.

Alcazaba
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!         
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.10 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 150.150.0.1 255.255.255.0
 no ip mroute-cache
!
interface ATM4/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 150.150.0.0 0.0.0.255 area 0
 network 222.0.0.0 0.0.0.255 area 0
!
router bgp 1
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Kozel
!
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.30 255.255.255.255
!         
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 69.69.0.1 255.255.255.252
 no ip mroute-cache
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 tag-switching
 ip address 11.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 11.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 69.69.0.0 0.0.0.255 area 0
 network 222.0.0.0 0.0.0.255 area 0
!
router bgp 1
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.11 remote-as 1
 neighbor 223.0.0.11 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.11 activate
 neighbor 223.0.0.11 send-community extended
 exit-address-family
!

Rápida
!
interface Loopback0
 ip address 222.0.0.1 255.255.255.255
!
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/0
 ip address 7.7.8.1 255.255.255.0
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 7.7.7.7 0.0.0.0 area 1
 network 150.150.0.0 0.0.0.255 area 0
 network 222.0.0.1 0.0.0.0 area 1
!

Pivrnec
!
interface Loopback0
 ip address 222.0.0.3 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 6.6.7.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 69.69.0.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 3
 network 69.69.0.0 0.0.0.255 area 0
 network 222.0.0.3 0.0.0.0 area 3
!

Guilder
!         
interface Loopback0
 ip address 222.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 7.7.8.2 255.255.255.0
!
router ospf 2
 network 7.7.8.0 0.0.0.255 area 1
 network 222.0.0.0 0.0.0.255 area 1
!

Ischia
!
interface Loopback0
 ip address 222.0.0.22 255.255.255.255
!
interface Ethernet1/4
 ip address 6.6.7.2 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 6.6.7.0 0.0.0.255 area 3
 network 222.0.0.0 0.0.0.255 area 3
!

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o roteamento do vrf <VPN da rota IP ou o nome do exemplo do forwarding >

  • mostre o roteamento do vrf <VPN do VPNv4 BGP IP ou o nome do exemplo do forwarding > o <A.B.C.D >

  • mostre o número de ID do <process OSPF IP >

  • mostre o número de ID > a relação do <process OSPF IP

  • mostre o número de ID > o base de dados do <process OSPF IP

  • roteamento do show tag-switching forwarding-table vrf <VPN ou nome do exemplo do forwarding >

Emita os primeiros dois comandos acima mostrar o VRF para um VPN particular no roteador de PE.

Comandos específicos de OSPF

Comandos para um roteador de PE

Os comandos seguintes mostram a informação OSPF para o VRF correspondente. A maioria de partes importantes da saída abaixo são mostradas no texto em negrito.

Nota: Você não tem que especificar o VRF ao emitir estes comandos.

Alcazaba#show ip ospf 2
 Routing Process "ospf 2" with ID 222.0.0.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Connected to MPLS VPN Superbackbone
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    bgp 1, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 13. Checksum Sum 0x715C5 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Alcazaba#show ip ospf 2 database
 
            OSPF Router with ID (222.0.0.10) (Process ID 2)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       272         0x80000009 0xCA39   1
222.0.0.10      222.0.0.10      197         0x80000003 0xFCFF   2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      197         0x80000002 0xEA6E  
 
                Summary Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      197         0x80000002 0x4768  
6.6.7.0         222.0.0.10      750         0x80000001 0xD4D7  
7.7.7.7         222.0.0.1       272         0x80000002 0x72CC  
7.7.8.0         222.0.0.1       1003        0x80000003 0x635   
69.69.0.0       222.0.0.10      197         0x80000002 0x2228  
222.0.0.1       222.0.0.1       272         0x80000002 0x5A21  
222.0.0.3       222.0.0.10      197         0x80000004 0xE8FA  
222.0.0.11      222.0.0.1       1010        0x80000001 0x5C0C  
222.0.0.22      222.0.0.10      752         0x80000001 0x9435  
222.0.0.30      222.0.0.10      199         0x80000002 0x795B  

Alcazaba#show ip ospf 2 interface
Loopback1 is up, line protocol is up 
  Internet Address 222.0.0.10/32, Area 0 
  Process ID 2, Router ID 222.0.0.10, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Ethernet1/1 is up, line protocol is up 
  Internet Address 150.150.0.1/24, Area 0 
  Process ID 2, Router ID 222.0.0.10, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 6, maximum is 6
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

Comandos para um CE Router

Neste caso, o CE Router é um ABR porque é conectado igualmente a uma outra área. Se este roteador devia somente ter relações na área 0, seria um roteador comum, não um ABR ou um ASBR.

rapid#show ip ospf
 Routing Process "ospf 1" with ID 222.0.0.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 14 times
        Area ranges are
        Number of LSA 13. Checksum Sum 0x715C5 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 1
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm executed 48 times
        Area ranges are
        Number of LSA 16. Checksum Sum 0x8CCBE 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

rapid#show ip ospf database
 
       OSPF Router with ID (222.0.0.1) (Process ID 1)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       331         0x80000009 0xCA39   1
222.0.0.10      222.0.0.10      259         0x80000003 0xFCFF   2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      259         0x80000002 0xEA6E  
 
                Summary Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      259         0x80000002 0x4768  
6.6.7.0         222.0.0.10      812         0x80000001 0xD4D7  
7.7.7.7         222.0.0.1       331         0x80000002 0x72CC  
7.7.8.0         222.0.0.1       1062        0x80000003 0x635   
69.69.0.0       222.0.0.10      259         0x80000002 0x2228  
222.0.0.1       222.0.0.1       331         0x80000002 0x5A21  
222.0.0.3       222.0.0.10      260         0x80000004 0xE8FA  
222.0.0.11      222.0.0.1       1069        0x80000001 0x5C0C  
222.0.0.22      222.0.0.10      813         0x80000001 0x9435  
222.0.0.30      222.0.0.10      260         0x80000002 0x795B  
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1078        0x80000029 0x658E   3
222.0.0.10      222.0.0.10      2962        0x80000003 0xFCFF   2
222.0.0.11      222.0.0.11      1080        0x80000003 0xA97F   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
7.7.8.2         222.0.0.11      1081        0x80000001 0x93DA  
150.150.0.1     222.0.0.10      2962        0x80000002 0xEA6E  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.1       332         0x80000002 0x69C5  
6.6.6.6         222.0.0.10      2720        0x80000002 0x4768  
6.6.7.0         222.0.0.1       820         0x80000001 0xF635  
69.69.0.0       222.0.0.1       341         0x80000002 0x4485  
150.150.0.0     222.0.0.1       341         0x80000004 0x57CB  
222.0.0.3       222.0.0.1       341         0x80000002 0xF56   
222.0.0.3       222.0.0.10      2727        0x80000002 0xECF8  
222.0.0.10      222.0.0.1       341         0x80000002 0x6404  
222.0.0.22      222.0.0.1       820         0x80000001 0xB692  
222.0.0.30      222.0.0.1       341         0x80000002 0x9BB8  
 
                Summary ASB Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
222.0.0.10      222.0.0.1       341         0x80000002 0x4C1C  

Comandos para o roteador corrente alternada

Emita o comando seguinte mostrar a tabela de IP Routing:

Guilder#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
O IA    69.69.0.0 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
     222.0.0.0/32 is subnetted, 6 subnets
O IA    222.0.0.30 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
O IA    222.0.0.22 [110/41] via 7.7.8.1, 00:06:33, Ethernet0/1
O IA    222.0.0.10 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
C       222.0.0.11 is directly connected, Loopback0
O IA    222.0.0.3 [110/31] via 7.7.8.1, 00:06:33, Ethernet0/1
O       222.0.0.1 [110/11] via 7.7.8.1, 00:06:33, Ethernet0/1
     6.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O IA    6.6.6.6/32 [110/31] via 7.7.8.1, 00:06:34, Ethernet0/1
O IA    6.6.7.0/24 [110/40] via 7.7.8.1, 00:06:34, Ethernet0/1
     7.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       7.7.7.7/32 [110/11] via 7.7.8.1, 00:06:35, Ethernet0/1
C       7.7.8.0/24 is directly connected, Ethernet0/1
     10.0.0.0/22 is subnetted, 1 subnets
C       10.200.8.0 is directly connected, Ethernet0/0
     150.150.0.0/24 is subnetted, 1 subnets
O IA    150.150.0.0 [110/20] via 7.7.8.1, 00:06:35, Ethernet0/1

Rótulos de MPLS

Confirme que há duas etiquetas na pilha de rótulo no Label Switch Router da entrada (LSR) como segue:

Alcazaba#show tag-switching forwarding-table vrf vpn1 6.6.7.2 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
None   2/41        6.6.7.0/24        0          AT4/0.1    point2point  
        MAC/Encaps=4/12, MTU=4466, Tag Stack{2/41(vcd=10) 29}
        000A8847 0000A0000001D000

Agora, confirme que aparecem na saída LSR:

Kozel#show tag-switching forwarding-table vrf vpn1 6.6.7.2 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
29     Untagged    6.6.7.0/24[V]     1466       Et1/1      69.69.0.2    
        MAC/Encaps=0/0, MTU=1500, Tag Stack{}
        VPN route: vpn1
    Per-packet load-sharing

Comandos de Teste

Você pode agora emitir o comando ping testar que tudo é muito bem:

Ischia#ping 222.0.0.11
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 222.0.0.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
Ischia#trac
Ischia#traceroute 222.0.0.11
 
Type escape sequence to abort.
Tracing the route to 222.0.0.11
 
  1 6.6.7.1 0 msec 0 msec 0 msec
  2 69.69.0.1 0 msec 0 msec 0 msec
  3 150.150.0.1 4 msec 4 msec 0 msec
  4 150.150.0.2 4 msec 0 msec 0 msec
  5 7.7.8.2 4 msec *  0 msec

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 10473