Multiprotocol Label Switching (MPLS) : Multiprotocol Label Switching sobre ATM (MPLS sobre ATM)

MPLS VPN sobre ATM: com o OSPF no lado do cliente (sem área 0)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo de um Multiprotocol Label Switching (MPLS) VPN sobre o ATM quando o Open Shortest Path First (OSPF) esta presente no lado do cliente, sem a área 0.

A característica do Virtual Private Network (VPN), quando usada com MPLS, permite que diversos locais interconectem transparentemente através da rede de um provedor de serviços. Uma rede de provedor de serviços pode suportar várias VPNs de IPs diferentes. Cada uma delas aparece para seus usuários como uma rede privada, separada de todas as outras redes. Na VPN, cada site pode enviar pacotes IP para qualquer outro site na mesma VPN.

Pré-requisitos

Requisitos

Cada VPN está associada com um ou mais instâncias de VPN Routing ou de encaminhamento (VRFs) Um VRF consiste em uma tabela de IP Routing, em um Cisco Express Forwarding (CEF) derivado, na tabela e em um grupo de relações que usam esta tabela do forwarding.

O roteador mantém um roteamento separado e tabela de CEF para cada VRF. Com isto, a informação não pode ser enviada fora do VPN mas a mesma sub-rede pode ser usada em diversos VPN sem problemas de endereço IP duplicado.

O roteador que usa o Border Gateway Protocol (BGP) distribui a informação de roteamento VPN com as comunidades extendida BGP.

Para mais informação com respeito à propagação de atualização com um VPN, refira estas URL:

Versões de hardware e software

Estas letras representam os tipos diferentes de Roteadores e de Switches usados:

  • P: Roteador central do fornecedor

  • PE: Roteador de extremidade do provedor

  • CE: Roteador de ponta do cliente

  • C : Roteador de cliente

Nós desenvolvemos e testamos a configuração com estes versão de software e hardware:

  • Roteadores PE:

    • Software: Software Release 12.1(3)T do½ do¿Â do Cisco IOSïÂ. As características do MPLS VPN aparecem na liberação 12.0(5)T. O OSPF como o protocolo de roteamento PE-CE aparece na liberação 12.0(7)T.

    • Hardware: Os Cisco 3660 ou 7206 Router. Para detalhes do outro hardware que você pode se usar, refira o MPLS de projeto para o guia ATM.

  • Roteadores CE: Use todo o roteador que puder trocar a informação de roteamento com seu roteador de PE.

  • Roteadores e Switches P: A função da integração do MPLS VPN reside somente na borda da rede MPLS, assim que use todo o switch capacitado para MPLS. Na configuração de exemplo, a nuvem MPLS é composta de uns 8540 MSR e um LightStream 1010. Se você usa o LightStream 1010, nós recomendamos que você usa o WA4.8d da versão de software ou mais altamente. Você pode igualmente usar o outro Switches ATM, tal como o Cisco BPX 8650 ou o MGX8850 na rede central ATM.

Convenções

Este diagrama mostra uma configuração típica que use estas convenções:

/image/gif/paws/10472/mpls_ospf4.gif

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informação OSPF background

Tradicionalmente, uma rede OSPF elaborada consiste em uma área Backbone (área 0) e em um número de áreas conectadas a este backbone através de um roteador de borda de área (ABR).

Com um backbone MPLS para o VPN com o OSPF na site de cliente, você pode introduzir um terceiro nível na hierarquia do modelo de OSPF. Este terceiro nível é chamado o super backbone do MPLS VPN.

Em casos simples, o super backbone do MPLS VPN é combinado com o backbone da área tradicional 0. Isto significa que não há nenhum area 0 backbone na rede cliente desde que o super backbone do MPLS VPN joga o mesmo papel que o area 0 backbone. Isto é mostrado neste diagrama:

/image/gif/paws/10472/mpls_ospf1.gif

Este diagrama ilustra esta informação:

  • O Roteadores da ponta de provedor (PE) é ABR e Roteadores do roteador de limite de sistema autônomo (ASBR).

  • O Roteadores da ponta de cliente (CE) é OSPF Router simples.

  • A informação de VPN é transportada com as comunidades extendida BGP dos PE a outros PE e injetar novamente nas áreas do OSPF como os anúncios link states da rede sumária (tipo 3) (LSA).

O super backbone do MPLS VPN igualmente permite clientes de usar backbones da área múltipla 0 em seus locais. Cada local pode ter uma área separada 0 enquanto é conectado ao super backbone do MPLS VPN. O resultado é o mesmo que com um backbone da área particionada 0. Isto é mostrado neste diagrama:

/image/gif/paws/10472/mpls_ospf2.gif

Neste caso, estas coisas ocorrem:

  • Os roteadores de PE são ABR e roteadores ASBR.

  • Os CE Router são roteadores ABR.

  • Os LSA que contêm a informação de VPN são transportados com as comunidades extendida BGP dos PE a outros PE. Em resumo a rede (tipo 3) LSA, informação é transportada entre PE e CE.

Esta configuração de exemplo é baseada na primeira instalação mostrada. Você pode encontrar uma configuração de exemplo que usa a segunda instalação no MPLS VPN sobre o ATM: com o OSPF no lado do cliente (com área 0).

A informação OSPF é transportada com atributos de comunidade estendidos BGP (que incluem um que identifica a rede de OSPF). Cada VPN deve ter seu próprio processo de OSPF. A fim especificar isto, você pode usar este comando:

router ospf <process ID> vrf <VPN routing/forwarding instance name>

Procedimento de configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10472/mpls_ospf3.gif

A documentação do IOS da Cisco (redes privadas virtuais de MPLS) também descreve esse procedimento de configuração.

Peça do procedimento de configuração mim

Certifique-se de que o ip cef esteja habilitado. Se você usa um Cisco 7500 Router, você deve assegurar-se de que o cef IP distribuído esteja permitido. Nos PE, uma vez que o MPLS se estabelece, execute estas tarefas:

  1. Crie um VRF para cada VPN conectado com o comando ip vrf <VPN routing/forwarding instance name>. Quando você fizer este:

    • Especifique o distinguidor de rota correto utilizado para aquele VPN. Isto é usado para estender o endereço IP de Um ou Mais Servidores Cisco ICM NT de modo que você possa identificar o VPN a que pertence.

      rd <VPN route distinguisher>
      
    • Configure as propriedades de importação e exportação para as comunidades estendidas de BGP. Estes são usados para filtrar o processo da importação e da exportação.

      route-target [export|import|both] <target VPN extended community> 
      
      
  2. Configurar os detalhes reenviado para as relações dos respectives com este comando:

    ip vrf forwarding <table name>
    

    Recorde estabelecer o endereço IP de Um ou Mais Servidores Cisco ICM NT depois que você faz este.

  3. Dependente em cima do protocolo de roteamento PE-CE que você uso, você deve agora fazer uma ou vária destes:

    • Configurar as rotas estáticas:

      ip route vrf vrf-name prefix mask [next-hop-address]
                                        [interface {interface-number}] 
      
      
    • Configurar o RASGO com este comando:

      address-family ipv4 vrf <VPN routing/forwarding instance name>
      

      Quando você tiver concluído essa parte, digite os comandos normais da configuração de RIP.

      Nota: isto é aplicado somente às interfaces de encaminhamento para o VRF atual.

      Nota: Você precisa redistribuir o BGP correto no RIP. Quando você faz este, igualmente recorde especificar a métrica que é usada.

    • Declare as informações de vizinho BGP

    • Configurar o OSPF com o comando ios novo:

      router ospf <process ID> vrf <VPN routing/forwarding instance name>
      

      Nota: isto é aplicado somente às interfaces de encaminhamento para o VRF atual.

      Nota: Você precisa redistribuir o BGP correto no OSPF. Quando você faz este, igualmente recorde especificar a métrica que é usada.

      Nota: Uma vez que você atribui o processo de OSPF a um VRF, este número do processo está usado sempre para este VRF particular. Isso se aplica até se você não especificá-lo na linha de comando.

Parte II do procedimento de configuração

Configure o BGP entre os roteadores PE. Há diversas maneiras de configurar o BGP, tal como o uso do refletor de rota ou dos métodos de confederação. O método usado aqui – configuração vizinha direta – é o mais simples e o mais menos escalável.

  1. Declare os vizinhos diferentes.

  2. Incorpore o name> do roteamento/exemplo do forwarding do vrf <VPN do IPv4 da endereço-família para cada VPN atual neste roteador de PE. Realize umas ou várias destas etapas, como necessário:

    • Redistribua as informações de roteamento estático.

    • Redistribuir as informações de RIP Routing

    • Redistribua as informações de OSPF Routing

    • Ative vizinhos de BGP com os CE Router.

  3. Incorpore o modo VPN4 da família de endereços, e execute estas tarefas:

    • Ative os vizinhos

    • Especifique se uma comunidade estendida deve ser utilizada. Isso é obrigatório.

Configurações

Nota: Somente as partes relevantes da saída são incluídas aqui.

Alcazaba
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!         
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.10 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 150.150.0.1 255.255.255.0
 no ip mroute-cache
!
interface ATM4/0
 no ip address
 no ip mroute-cache
 atm sonet stm-1
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 150.150.0.0 0.0.0.255 area 1
 network 222.0.0.0 0.0.0.255 area 1
!
router bgp 1
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Kozel
!
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.30 255.255.255.255
!         
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 69.69.0.1 255.255.255.252
 no ip mroute-cache
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 tag-switching
 ip address 11.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 11.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 69.69.0.0 0.0.0.255 area 3
 network 222.0.0.0 0.0.0.255 area 3
!
router bgp 1
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.11 remote-as 1
 neighbor 223.0.0.11 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.11 activate
 neighbor 223.0.0.11 send-community extended
 exit-address-family
!

Rápida
!
interface Loopback0
 ip address 222.0.0.1 255.255.255.255
!
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!         
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 7.7.7.7 0.0.0.0 area 1
 network 150.150.0.0 0.0.0.255 area 1
 network 222.0.0.1 0.0.0.0 area 1
!

Pivrnec
!
interface Loopback0
 ip address 222.0.0.3 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 69.69.0.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 3
 network 69.69.0.0 0.0.0.255 area 3
 network 222.0.0.3 0.0.0.0 area 3
!

Verificar

comandos show

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • mostre o roteamento do vrf <VPN da rota IP ou o name> do exemplo do forwarding

  • mostre o roteamento do vrf <VPN do VPNv4 BGP IP ou o name> <A.B.C.D> do exemplo do forwarding

  • mostre o number> do <process ID OSPF IP

  • mostre a relação do number> do <process ID OSPF IP

  • mostre o base de dados do number> do <process ID OSPF IP

  • roteamento do show tag-switching forwarding-table vrf <VPN ou name> do exemplo do forwarding

Este comando mostra o VRF para um VPN particular no roteador de PE:

Alcazaba#show ip route vrf vpn1
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
B       69.69.0.0 [200/0] via 223.0.0.21, 00:19:39
     222.0.0.0/32 is subnetted, 4 subnets
B       222.0.0.30 [200/0] via 223.0.0.21, 00:19:39
C       222.0.0.10 is directly connected, Loopback1
B       222.0.0.3 [200/11] via 223.0.0.21, 00:20:39
O       222.0.0.1 [110/11] via 150.150.0.2, 00:20:59, Ethernet1/1
     6.0.0.0/32 is subnetted, 1 subnets
B       6.6.6.6 [200/11] via 223.0.0.21, 00:20:39
     7.0.0.0/32 is subnetted, 1 subnets
O       7.7.7.7 [110/11] via 150.150.0.2, 00:21:00, Ethernet1/1
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.0.0 is directly connected, Ethernet1/1

Você pode igualmente indicar a Informação de BGP para um VRF particular com o comando show ip bgp vpnv4 vrf. Os resultados de PE-PE do BGP interno (IBGP) são indicados por um i.

Alcazaba#show ip bgp vpnv4 vrf vpn1
BGP table version is 21, local router ID is 223.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:101 (default for vrf vpn1)
*>i6.6.6.6/32       223.0.0.21              11    100      0 ?
*> 7.7.7.7/32       150.150.0.2             11         32768 ?
*>i69.69.0.0/30     223.0.0.21               0    100      0 ?
*> 150.150.0.0/24   0.0.0.0                  0         32768 ?
*> 222.0.0.1/32     150.150.0.2             11         32768 ?
*>i222.0.0.3/32     223.0.0.21              11    100      0 ?
*> 222.0.0.10/32    0.0.0.0                  0         32768 ?
*>i222.0.0.30/32    223.0.0.21               0    100      0 ?

Você pode verificar os detalhes de uma entrada. A fim mostrar isto, o distinguidor de rota é "1:101."

Alcazaba#show ip bgp vpnv4 vrf vpn1 6.6.6.6
BGP routing table entry for 1:101:6.6.6.6/32, version 28
Paths: (1 available, best #1, table vpn1)
  Not advertised to any peer
  Local
    223.0.0.21 (metric 4) from 223.0.0.21 (223.0.0.21)
      Origin incomplete, metric 11, localpref 100, valid, internal, best
      Extended Community: RT:1:101 OSPF RT:3:2:0

Alcazaba#show ip bgp vpnv4 vrf vpn1 7.7.7.7
BGP routing table entry for 1:101:7.7.7.7/32, version 20
Paths: (1 available, best #1, table vpn1)
  Advertised to non peer-group peers:
  223.0.0.21 
  Local
    150.150.0.2 from 0.0.0.0 (223.0.0.3)
      Origin incomplete, metric 11, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:1:101 OSPF RT:1:2:0

O comando show ip route em um CE Router é os meios principais para verificar as tabelas de roteamento:

rapid#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
O IA    69.69.0.0 [110/11] via 150.150.0.1, 00:20:25, FastEthernet0/1
     222.0.0.0/32 is subnetted, 4 subnets
O IA    222.0.0.30 [110/11] via 150.150.0.1, 00:20:25, FastEthernet0/1
O       222.0.0.10 [110/11] via 150.150.0.1, 00:21:46, FastEthernet0/1
O IA    222.0.0.3 [110/21] via 150.150.0.1, 00:21:25, FastEthernet0/1
C       222.0.0.1 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
O IA    6.6.6.6 [110/21] via 150.150.0.1, 00:21:25, FastEthernet0/1
     7.0.0.0/24 is subnetted, 1 subnets
C       7.7.7.0 is directly connected, Loopback2
     10.0.0.0/22 is subnetted, 1 subnets
C       10.200.8.0 is directly connected, FastEthernet0/0
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.0.0 is directly connected, FastEthernet0/1
S    158.0.0.0/8 is directly connected, Null0

Comandos específicos de OSPF

Você pode usar todos os comandos show ip ospf. Quando você faz este, recorde indicar o processo ID. Nós marcamos a maioria de partes importantes da saída abaixo no texto italicizado.

O OSPF LSA do tipo 9, 10 e 11 (igualmente sabido como opaques lsa) é usado para projetar o tráfego.

Comandos para um roteador de PE

Alcazaba#show ip ospf 2
 Routing Process "ospf 2" with ID 222.0.0.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Connected to MPLS VPN super backbone
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    bgp 1, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area 1
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 7. Checksum Sum 0x420BE 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Alcazaba#show ip ospf 2 interface
Loopback1 is up, line protocol is up 
  Internet Address 222.0.0.10/32, Area 1 
  Process ID 2, Router ID 222.0.0.10, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Ethernet1/1 is up, line protocol is up 
  Internet Address 150.150.0.1/24, Area 1 
  Process ID 2, Router ID 222.0.0.10, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:07
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 3
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

Alcazaba#show ip ospf 2 database
 
            OSPF Router with ID (222.0.0.10) (Process ID 2)
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1364        0x80000013 0x7369   3
222.0.0.10      222.0.0.10      1363        0x80000002 0xFEFE   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      1363        0x80000001 0xEC6D  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      1328        0x80000001 0x4967  
69.69.0.0       222.0.0.10      1268        0x80000001 0x2427  
222.0.0.3       222.0.0.10      1328        0x80000001 0xEEF7  
222.0.0.30      222.0.0.10      1268        0x80000001 0x7B5A  

Comandos para um CE Router

rapid#show ip ospf interface
FastEthernet0/1 is up, line protocol is up 
  Internet Address 150.150.0.2/24, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.10  (Designated Router)
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up 
  Internet Address 222.0.0.1/32, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Loopback2 is up, line protocol is up 
  Internet Address 7.7.7.7/24, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host

rapid#show ip ospf database
 
       OSPF Router with ID (222.0.0.1) (Process ID 1)
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1350        0x80000013 0x7369   3
222.0.0.10      222.0.0.10      1350        0x80000002 0xFEFE   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      1351        0x80000001 0xEC6D  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      1316        0x80000001 0x4967  
69.69.0.0       222.0.0.10      1256        0x80000001 0x2427  
222.0.0.3       222.0.0.10      1316        0x80000001 0xEEF7  
222.0.0.30      222.0.0.10      1256        0x80000001 0x7B5A  

Alcazaba#show tag-switching forwarding-table vrf vpn1
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
24     Aggregate   222.0.0.10/32[V]  0                                  
25     Aggregate   150.150.0.0/24[V] 0                                  
27     Untagged    7.7.7.7/32[V]     1710       Et1/1      150.150.0.2  
28     Untagged    222.0.0.1/32[V]   0          Et1/1      150.150.0.2

Rótulos de MPLS

Você pode verificar a pilha de rótulo usada para uma rota particular:

Alcazaba#show tag-switching forwarding-table vrf vpn1 6.6.6.6 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
None   2/41        6.6.6.6/32        0          AT4/0.1    point2point  
        MAC/Encaps=4/12, MTU=4466, Tag Stack{2/41(vcd=10) 16}
        000A8847 0000A00000010000

Saída de Depuração

Está aqui um trecho da informação sobre debugging do intercâmbio de rota. Isto mostra como uma rota particular é importada.

Alcazaba#debug ip bgp vpnv4 import
Tag VPN import processing debugging is on
*Aug  5 05:10:09.283: vpn: Start import processing for: 1:101:222.0.0.3
*Aug  5 05:10:09.283: vpn: Import check for vpn1; flags mtch, impt
*Aug  5 05:10:09.283: vpn: Import for vpn1 permitted; import flags mtch, impt
*Aug  5 05:10:09.283: vpn: Same RD import for vpn1
*Aug  5 05:10:09.283: vpn: 1:101:222.0.0.3 (ver 29), imported as:
*Aug  5 05:10:09.283: vpn: 1:101:222.0.0.3 (ver 29)
*Aug  5 05:10:09.287: VPN: Scanning for import check is done.

Saída de teste

Você pode agora usar o sibilo para testar que tudo é muito bem:

Pivrnec#ping 7.7.7.7      
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

O comando traceroute indica esta saída:

Pivrnec#traceroute 7.7.7.7
 
Type escape sequence to abort.
Tracing the route to 7.7.7.7
 
  1 69.69.0.1 0 msec 0 msec 0 msec
  2 150.150.0.1 0 msec 0 msec 20 msec
  3 150.150.0.2 0 msec 0 msec * 

Os anfitriões MLPS não estão aqui porque não consideram o cabeçalho IP. Os anfitriões MPLS verificam somente a etiqueta ou a relação e então para a frente ele de entrada.

A operação no campo do Time to Live IP (TTL) é realizada somente na borda LSR. O contagem de saltos mostrado é menos do que o contagem de saltos real.


Informações Relacionadas


Document ID: 10472