Multiprotocol Label Switching (MPLS) : Multiprotocol Label Switching sobre ATM (MPLS sobre ATM)

MPLS CoS sobre o ATM: TBR Multi-VC (usando CAR)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O mecanismo da classe de serviço do Multiprotocol Label Switching (MPLS CoS) é uma característica que execute Serviços diferenciados sobre o ATM. Permite que a rede ATM trate os pacotes diferentes baseados no campo (experimental) EXP (igualmente chamado CoS) do cabeçalho de MPLS, que têm as mesmas propriedades e que pode ser traçado à Precedência IP.

0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|               Label                   | EXP |S|      TTL      |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Este documento explica como utilizar este mecanismo dentro de uma rede central MPLS que receba pacotes IP (sem bit de precedência ajustados) das fontes diferentes.

Pré-requisitos

Tagged Bit Rate do circuito Multi-virtual (Multi-VC TBR)

O MULTI-VC TBR usa trajetos e classes diferentes do novo-serviço para apoiar o tratamento diferente sobre o ATM. Este método consiste em até quatro circuitos virtuais de rótulo paralelos (LVC) (ou em “Tag VC” na terminologia velha) e em mapas a MPLS CoS. Esta tabela mostra o mapeamento padrão:

Tipo dos circuitos virtuais de rótulo Classe de serviço Tipo do IP de serviço
Disponível 0 0,4
Padrão 1 1,5
Superior 2 2,6
Controle 3 3,7

Cada Label Switch Router (LSR) tem um número de VC (um a quatro) que corresponde para o mesmo destino ou “multi-VC”. Estes LVC paralelos estabelecem-se pelo roteador de ponta ascendente com protocolo da distribuição de rótulo.

A fim apoiar os LVC a nível do interruptor, quatro categorias novas de CoS foram introduzidas. São chamados classes do Tagged Bit Rate (TBR) e são empenhos máximos de serviço (como com taxa de bits não especificada (CBR) tradicional). Podem ser configurados da mesma forma. Isto é, seus pesos do parente ou os limites de seus pontos iniciais podem ser mudados.

Classe de serviço fórum ATM CoS Peso relativo da classe Circuitos virtuais de rótulo
CBR 2 Não aplicável
VBR-RT 2 8
VBR-NRT 3 1
ABR 4 1
UBR 5 1
TBR_1 (WRR_1) 1 1 Disponível
TBR_2 (WRR_2) 6 2 Padrão
TBR_3 (WWR_3) 7 3 Superior
TBR_4 (WWR_4) 8 4 Controle

Nota: As categorias novas de CoS estão em corajoso.

Mecanismo

A borda LSR ajusta o campo MPLS CoS com o Committed Access Rate (CAR) na interface de entrada correta. O CAR pode ser configurado para atuar de acordo com um contrato ou toda a outra regra específica. O LSR na borda da rede ATM enfileira as pilhas que contêm o pacote na fila correta (disponível, padrão, superior, ou controle), dependentes do mapa COS. As pilhas transitam por então através da rede ATM MPLS com o mesmo LVC. O resultado é que, em todo o ATM LSR, as pilhas recebem um tratamento por CoS:

  • Pelo Weighted Fair Queuing (WFQ) de CoS é proporcional aos pesos relativos da classe.

  • Pelo Weighted Early Packet Discard de CoS (WEPD) é um método para rejeitar pacotes quando as filas se enchem acima (similar ao Weighted Random Early Detection (WRED)).

Em consequência, para o LS1010 e o 8540MSR, isto pelo comportamento CoS é emulado sobre pelo enfileiramento VC.

Espaço de VC

O MPLS CoS apoia fusões do padrão VC. A fim usar menos VC, você pode reduzir o LVC usado (quatro a dois, por exemplo). Refira MPLS CoS sobre o ATM: Mapa COS para uma configuração de exemplo.

O assunto do número de VC é tratado em projetar o MPLS para o ATM: Dimensionando o espaço da etiqueta VC MPLS.

Versões de hardware e software

Esta configuração foi desenvolvida e testada com estes a versão de software e hardware:

Borda LSR

  • Software - Software Release 12.1(3)T do½ do¿Â do Cisco IOSïÂ; os recursos multi-vc apareceram no Cisco IOS Software Release 12.0(5)T.

  • Hardware - Cisco 7200 Router com PA-A1.

Nota: Esta característica trabalha somente com Cisco 7200s e 7500s com PA-A1.

Núcleo ATM LSR

  • Software - Algum software release que apoiar o MPLS; as versões as mais atrasadas são recomendadas.

  • Hardware - O LS1010 e o 8540MSR.

Nota: Um enfileiramento de placa de recurso por fluxo (FC-PFQ) é imperativo para o LS1010.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10469/mpls_cos_atm1.gif

Procedimento de configuração

Este documento usa este procedimento de configuração:

  1. A fim estabelecer quatro o padrão LVC (com mapeamento padrão), adicionar esta instrução à configuração de subinterface ATM da borda LSR:

    tag-switching atm multi-vc
    
  2. Os LVC paralelos estabelecem-se automaticamente em Switches ATM. A fim classificar os pacotes, uso CAR (refira a Documentação CAR) ajustar o campo experimental do cabeçalho de MPLS ao valor desejado. Este exemplo ajusta o CoS de todos os pacotes de entrada em Ethernet 1/1 de relação a 1 (e ajusta o mapa ao “padrão”):

    interface Ethernet1/1
     rate-limit input 8000 1500 200 conform-action set-mpls-exp-transmit 1 exceed-action set-mpls-exp-transmit 1
    
  3. Você pode igualmente executar o controle de tráfego e ajustar o CoS a 2 (mapa ao “prêmio”) para o tráfego que se conforma e a 0 (mapa a “disponível”) para o tráfego que excede:

    interface Ethernet1/1
     rate-limit input 64000 8000 16000 conform-action set-mpls-exp-transmit 2 exceed-action set-mpls-exp-transmit 0
    

    Nota: Você pode igualmente usar o comando tag-switching atm vpi 2-4, mas não é imperativo especificar que identificadores de caminho virtual (VPI) são usados para o MPLS.

    Nota: Recorde configurar o cef IP (cef IP distribuído em um Cisco 7500) na configuração geral do Roteadores.

Configurações de exemplo

Este documento utiliza as seguintes configurações:

Rápida
 !
 interface Loopback0
  ip address 223.0.0.12 255.255.255.255
 !
 interface Loopback2
  ip address 7.7.7.7 255.255.255.0
 !
 !
 interface FastEthernet0/1
  ip address 150.150.0.2 255.255.255.0
  duplex auto
  speed auto
 !
 !
 router ospf 1
  network 7.7.7.7 0.0.0.0 area 0
  network 150.150.0.0 0.0.0.255 area 0
  network 223.0.0.0 0.0.0.255 area 0
 !      

Alcazaba
 !
 ip cef
 !
 !
 interface Loopback0
  ip address 223.0.0.3 255.255.255.255
 !
 interface Loopback1
  ip address 1.1.1.1 255.255.255.255
 !
 interface Ethernet1/1
  ip address 150.150.0.1 255.255.255.0
  rate-limit input 64000 32000 64000 conform-action set-mpls-exp-transmit 2 
  exceed-action set-mpls-exp-transmit 1
  no ip mroute-cache
 !
 !
 interface ATM4/0
  no ip address
  no ip mroute-cache
  no atm ilmi-keepalive
 !
 interface ATM4/0.1 tag-switching
  ip address 10.0.0.13 255.255.255.252
  tag-switching atm multi-vc
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 router ospf 1
  network 1.1.1.1 0.0.0.0 area 0
  network 10.0.0.0 0.0.0.255 area 0
  network 150.150.0.0 0.0.0.255 area 0
  network 223.0.0.3 0.0.0.0 area 0
 !

Capri
 !
 interface Loopback1
  ip address 223.0.0.6 255.255.255.255
  no ip directed-broadcast
 !
 !
 interface ATM3/0/2
  ip address 10.0.0.14 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 interface ATM3/1/2
  ip address 10.0.0.10 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 router ospf 2
  network 10.0.0.0 0.0.0.255 area 0
  network 223.0.0.6 0.0.0.0 area 0
 !

Goldorak
 !
 interface Loopback0
  ip address 223.0.0.2 255.255.255.255
  no ip directed-broadcast
 !
 interface ATM0/1/0
  ip address 10.0.0.9 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 !
 interface ATM0/1/3
  ip address 11.0.0.1 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 5-7
  tag-switching ip
 !
 !
 router ospf 1
  network 10.0.0.0 0.0.0.255 area 0
  network 11.0.0.0 0.0.0.255 area 0
  network 223.0.0.2 0.0.0.0 area 0
 !

Ischia
 !         
 ip cef
 !
 interface Loopback0
  ip address 223.0.0.11 255.255.255.255
 !
 interface Loopback1
  ip address 2.2.2.2 255.255.255.255
 !
 !
 interface ATM3/0.158 tag-switching
  ip address 11.0.0.2 255.255.255.252
  tag-switching atm multi-vc
  tag-switching atm vpi 5-7
  tag-switching ip
 !
 router ospf 1
  log-adjacency-changes
  network 2.2.2.2 0.0.0.0 area 0
  network 11.0.0.0 0.0.0.255 area 0
  network 223.0.0.11 0.0.0.0 area 0
 !

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

comandos show

Em um roteador LSR:

  • show tag-switching forwarding-table

  • mostre o detalhe da tabela do forwarding do tag-switching

Em um switch ATM:

  • mostre emperramentos do tag-switching ATM-TDP

  • <interface> <vci/vpi> do show atm vc interface

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Exemplo de saída de show

A fim verificar o multi-VC em uma borda LSR, o comando show tag-switching forwarding-table tradicional pode ser usado. A fim verificar especificamente o descritor de circuito virtual (VCD) ou o identificador de caminho virtual/identificador de canal virtual (VPI/VCI), o comando deve ser específico a um destino e deve terminar com o detalhe da palavra.

Alcazaba#show tag-switching forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
16     Untagged    7.7.7.0/24        0          Et1/1      150.150.0.2  
17     Untagged    10.0.0.0/16       0          Et1/1      150.150.0.2  
18     Untagged    158.0.0.0/8       0          Et1/1      150.150.0.2  
19     Untagged    223.0.0.12/32     0          Et1/1      150.150.0.2  
20     Untagged    7.7.7.7/32        570        Et1/1      150.150.0.2  
21     Multi-VC    10.0.0.8/30       0          AT4/0.1    point2point  
25     Multi-VC    2.2.2.2/32        0          AT4/0.1    point2point  
32     Multi-VC    223.0.0.2/32      0          AT4/0.1    point2point  
34     Multi-VC    223.0.0.6/32      0          AT4/0.1    point2point  
36     Multi-VC    11.0.0.0/30       0          AT4/0.1    point2point  
37     Multi-VC    223.0.0.11/32     0          AT4/0.1    point2point 

Alcazaba#show tag-switching forwarding-table 2.2.2.2 32 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
25     Multi-VC    2.2.2.2/32        0          AT4/0.1    point2point  
        available 2/61(882), standard 2/62(883), premium 2/63(884), control 2/64(885), 
        MAC/Encaps=4/8, MTU=4470, Tag Stack{Multi-VC}
        04F48847 004F4000
    Per-packet load-sharing 

Em todo o ATM LSR, você pode igualmente traçar os VC diferentes de uma relação a outra (com o comando show tag-switching atm-tdp bindings) com suas classes de serviço respectivas (o comando do <vci> do <vpi> do interface> do show atm vc interface <ATM).

Capri#show tag-switching atm-tdp bindings
 Destination: 2.2.2.2/32
    Transit ATM3/0/2 2/61 Active -> ATM3/1/2 2/69 Active, CoS=available
    Transit ATM3/0/2 2/62 Active -> ATM3/1/2 2/70 Active, CoS=standard
    Transit ATM3/0/2 2/63 Active -> ATM3/1/2 2/71 Active, CoS=premium
    Transit ATM3/0/2 2/64 Active -> ATM3/1/2 2/72 Active, CoS=control
 Destination: 10.0.0.8/30
    Tailend Switch ATM3/0/2 2/97 Active -> Terminating Active, CoS=available
    Tailend Switch ATM3/0/2 2/98 Active -> Terminating Active, CoS=standard
    Tailend Switch ATM3/0/2 2/99 Active -> Terminating Active, CoS=premium
    Tailend Switch ATM3/0/2 2/100 Active -> Terminating Active, CoS=control
[...]
Capri#show atm vc interface atm3/0/2 2 63
 
Interface: ATM3/0/2, Type: oc3suni 
VPI = 2  VCI = 63
Status: UP
Time-since-last-status-change: 02:07:24
Connection-type: TVC(O) 
Cast-type: multipoint-to-point-output
Packet-discard-option: enabled
Usage-Parameter-Control (UPC): pass
Wrr weight: 2
Number of OAM-configured connections: 0
OAM-configuration: disabled
OAM-states:  Not-applicable
Cross-connect-interface: ATM3/1/2, Type: oc3suni 
Cross-connect-VPI = 2 
Cross-connect-VCI = 147
Cross-connect-UPC: pass
Cross-connect OAM-configuration: disabled
Cross-connect OAM-state:  Not-applicable
Threshold Group: 9, Cells queued: 0
Rx cells: 0, Tx cells: 0
Tx Clp0:0,  Tx Clp1: 0
Rx Clp0:0,  Rx Clp1: 0
Rx Upc Violations:0, Rx cell drops:0
Rx pkts:0, Rx pkt drops:0
Rx connection-traffic-table-index: 63998
Rx service-category: WRR_3 (WRR Bit Rate)
Rx pcr-clp01: none
Rx scr-clp01: none
Rx mcr-clp01: none
Rx      cdvt: 0 (from default for interface)
Rx       mbs: none
Tx connection-traffic-table-index: 63998
Tx service-category: WRR_3 (WRR Bit Rate)
Tx pcr-clp01: none
Tx scr-clp01: none
Tx mcr-clp01: none
Tx      cdvt: none
Tx       mbs: none

Nas configurações de amostra, todos os pacotes que se conformam são enviados pelo LVC superior. Todos os pacotes que excedem a regra CAR são enviados pelo padrão LVC. Nestas primeiras saídas, um ping padrão é feito e repetido 158 vezes:

rapid#ping        
Protocol [ip]: 
Target IP address: 2.2.2.2
Repeat count [5]: 158
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 158, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (158/158), round-trip min/avg/max = 1/1/5 ms

Você pode verificar se todos os pacotes atravessem o LVC superior com o comando show atm vc na borda LSR como no exemplo de saída. Nesta amostra, a saída superior VCD é 884.

Alcazaba#show atm vc 884
ATM4/0.1: VCD: 884, VPI: 2, VCI: 63
UBR, PeakRate: 155000
AAL5-MUX, etype:0x8847, Flags: 0x40C84, VCmode: 0x0
OAM frequency: 0 second(s)
InARP DISABLED
InPkts: 0, OutPkts: 158, InBytes: 0, OutBytes: 17064
InPRoc: 0, OutPRoc: 0
InFast: 0, OutFast: 158, InAS: 0, OutAS: 0
Giants: 0
OAM cells received: 0
OAM cells sent: 0
Status: UP
Tag VC: local tag: 0

Você pode igualmente verificar em todo o switch ATM com o comando do <interface> <vpi/vci> da relação do tráfego atm vc da mostra. Nesta amostra, cada pacote de ping é transportado em três pilhas: 158*3 = 474 pilhas.

Capri#show atm vc traffic interface atm 3/0/2 2 63
Interface    VPI     VCI      Type      rx-cell-cnts     tx-cell-cnts
ATM3/0/2     2       63        TVC(O)             0                0
ATM3/0/2     2       63        TVC(I)           474                0

Informações Relacionadas


Document ID: 10469