Multiprotocol Label Switching (MPLS) : Multiprotocol Label Switching sobre ATM (MPLS sobre ATM)

Multiprotocol Label Switching (MPLS) sobre ATM sem VC-fusão

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento ilustra uma rede do Multiprotocol Label Switching (MPLS) com ATM. Desde que a VC-fusão não é usada, há um VC atribuído pela rota como determinado pelo prefixo na tabela de roteamento.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • O Software Release 12.0 ou Mais Recente de Cisco IOS� é para o MPLS no florim e no Damme.

  • Esta instalação usa um switch ATM que é usado como o Label Switch Router (LSR). Neste exemplo, é um Catalyst 8540MSR. Pode igualmente ser um LS1010. Cisco recomenda o WA4.8d da versão de software ou mais tarde o LS1010. Todo o software no 8540MSR é suficiente.

  • O Cisco Express Forwarding (CEF) precisa de ser permitido no Roteadores que executa o interruptor MPLS/Tag. Neste exemplo, o florim e Damme são Cisco 3600s. Se uns 7500 são usados, o cef IP distribuído deve ser permitido.

Nota: Embora não uma exigência, este documento use o VPI2, 3, ou 4 para todos etiquetam VC neste exemplo.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10467/mpls_basic2.gif

Nota: As interfaces de loopback foram ajustadas em todo o Roteadores/LSR. Não são mostrados no diagrama da rede para a simplicidade.

Configurações

Este documento utiliza as seguintes configurações:

Libra
!         
interface Loopback0
 ip address 100.100.0.1 255.255.0.0
 no ip directed-broadcast
!         
interface Ethernet0/1
 ip address 123.123.0.2 255.255.0.0
 no ip directed-broadcast
!         
router ospf 1
 network 100.100.0.0 0.0.255.255 area 1.1.1.1
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
!

Guilder
!
ip cef
!
interface Loopback0
 ip address 102.102.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 123.123.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM1/0.1 tag-switching
 ip address 129.129.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 102.102.0.0 0.0.255.255 area 0.0.0.0
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Capri (8540MSR)
!
interface Loopback0
 ip address 103.103.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM3/0/0
 ip address 128.128.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
interface ATM3/0/3
 ip address 129.129.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 103.103.0.0 0.0.255.255 area 0.0.0.0
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Damme
!
ip cef
!
interface Loopback0
 ip address 104.104.0.1 255.255.0.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 125.125.0.1 255.255.0.0
 no ip directed-broadcast
 duplex auto
 speed 10
 tag-switching ip
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 0/16 ilmi
 !        
 pvc 0/5 qsaal
 !
!
interface ATM1/0.2 tag-switching
 ip address 128.128.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 104.104.0.0 0.0.255.255 area 0.0.0.0
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
!

Lira
!
interface Loopback0
 ip address 101.101.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 125.125.0.2 255.255.0.0
 no ip directed-broadcast
!
router ospf 1
 network 101.101.0.0 0.0.255.255 area 2.2.2.2
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
!

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre a tabela do forwarding do tag-switching — Mostra o Tag Forwarding Information Base (TFIB).

  • mostre emperramentos do tag-switching ATM-TDP — Mostra o ATM dinâmico que etiqueta a informação.

  • mostre o detalhe do [int number] int atm do tag-switching — Informação de switching de caractere detalhada da interface per. das mostras.

Esta saída mostra que a tabela de roteamento está completa no florim:

Guilder#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

     102.0.0.0/16 is subnetted, 1 subnets

C       102.102.0.0 is directly connected, Loopback0

     103.0.0.0/32 is subnetted, 1 subnets

O       103.103.0.1 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

     100.0.0.0/32 is subnetted, 1 subnets

O       100.100.0.1 [110/11] via 123.123.0.2, 23:45:47, Ethernet0/1

     101.0.0.0/32 is subnetted, 1 subnets

O IA    101.101.0.1 [110/13] via 129.129.0.2, 23:13:01, ATM1/0.1

O    128.128.0.0/16 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

C    129.129.0.0/16 is directly connected, ATM1/0.1

     125.0.0.0/16 is subnetted, 1 subnets

O IA    125.125.0.0 [110/12] via 129.129.0.2, 23:13:08, ATM1/0.1

     123.0.0.0/16 is subnetted, 1 subnets

C       123.123.0.0 is directly connected, Ethernet0/1

     104.0.0.0/32 is subnetted, 1 subnets

O       104.104.0.1 [110/3] via 129.129.0.2, 23:14:32, ATM1/0.1

Verifique o prefixo ao mapeamento rótulo/vc com o comando show tag-switching forwarding-table.

Guilder#show tag-switching forwarding-table 

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    

tag    tag or VC   or Tunnel Id      switched   interface              

26     Untagged    100.100.0.1/32    570        Et0/1      123.123.0.2  

27     2/33        103.103.0.1/32    0          AT1/0.1    point2point  

28     2/34        128.128.0.0/16    0          AT1/0.1    point2point  

29     2/35        104.104.0.1/32    0          AT1/0.1    point2point  

30     2/37        125.125.0.0/16    0          AT1/0.1    point2point  

31     2/38        101.101.0.1/32    0          AT1/0.1    point2point 

Em Capri (o ATM LSR), você pode verificar o TVC para distribuir o emperramento com o comando show tag atm-tdp bindings. Um TVC é usado para cada entrada de tabela de roteamento.

Capri#show tag atm-tdp bindings 

 Destination: 103.103.0.0/16

    Tailend Switch ATM3/0/0 2/34 Active -> Terminating Active

    Tailend Switch ATM3/0/3 2/34 Active -> Terminating Active

 Destination: 129.129.0.0/16

    Tailend Switch ATM3/0/0 2/35 Active -> Terminating Active

 Destination: 101.101.0.1/32

    Transit ATM3/0/3 2/33 Active -> ATM3/0/0 2/36 Active

 Destination: 104.104.0.1/32

    Transit ATM3/0/3 2/35 Active -> ATM3/0/0 2/37 Active

 Destination: 125.125.0.0/16

    Transit ATM3/0/3 2/36 Active -> ATM3/0/0 2/38 Active

 Destination: 128.128.0.0/16

    Tailend Switch ATM3/0/3 2/37 Active -> Terminating Active

 Destination: 102.102.0.1/32

    Transit ATM3/0/0 2/53 Active -> ATM3/0/3 2/33 Active

 Destination: 100.100.0.1/32

    Transit ATM3/0/0 2/54 Active -> ATM3/0/3 2/34 Active

 Destination: 123.123.0.0/16

    Transit ATM3/0/0 2/55 Active -> ATM3/0/3 2/35 Active

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10467