Asynchronous Transfer Mode (ATM) : LAN Emulation (LANE)

Configuração de exemplo de simulação de LAN

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento ilustra como configurar serviços e clientes do LAN Emulation (LANE) em roteadores Cisco, em Catalyst Switches, e em Switches ATM.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10457/lane_config1.gif

Nessa instalação:

  • O roteador1 e o roteador2 são Cisco 4500 Router que executam o Software Release 12.1(4) do ½ do ¿  de Cisco IOSïÂ. Ambos atuam como os clientes de LAN Emulation (LEC).

  • O LightStream 1010 é Cisco IOS Software Release 12.0(10)W5(18b) running. Atua como um servidor de configuração de LAN Emulation (LECS).

  • O Switch Ethernet é um catalizador 5000 com um LANE blade em slot4. Este LANE blade atua como um LEC e como uma transmissão e servidor desconhecido LANE (LES/BUS).

  • Os serviços de pista foram configurados de acordo com as recomendações de projeto da pista.

  • Dois LAN emulados (ELAN) foram configurados: teste-ELAN e test-elan2.

  • O roteador1 tem um LEC em cada ELAN. O Switch Ethernet tem um LEC em test-elan2. O roteador2 e o LightStream 1010 têm um LEC no teste-ELAN.

  • No Switch Ethernet, o LAN virtual, VLAN2, é limitado a test-elan2.

  • O roteador1 é responsável de fazer o roteamento entre os dois ELAN.

Esta é a instalação lógica:

lane_config2.gif

Configurações

Este documento utiliza as seguintes configurações:

Nota: Somente as parcelas dos comandos configuration que são relevantes ao LANE são incluídas.

LightStream 1010

!--- Output suppressed.

atm lecs-address-default 47.0091.8100.0000.0060.705a.8f01.0060.705a.8f05.00

!

lane database test

  name test-elan server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.01
  name test-elan2 server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.02
!
interface atm2/0/0
 no ip address
 no ip directed-broadcast
 lane config auto-config-atm-address
 lane config database test
!
interface atm2/0/0.2 multipoint
 ip address 20.0.0.2 255.255.255.0
 no ip directed-broadcast
 lane client ethernet test-elan

!--- Output suppressed.

O teste da base de dados de LAN define o endereço do ponto de acesso de serviço de rede (NSAP) do LES/BUS para cada ELAN. Estes endereços na configuração do LightStream 1010 apontam ao LANE blade do Switch Ethernet:

lane-blade# show lane default

interface atm0:
LANE Client:        47.0091810000000060705A8F01.00E0B00B7030.**
LANE Server:        47.0091810000000060705A8F01.00E0B00B7031.**
LANE Bus:           47.0091810000000060705A8F01.00E0B00B7032.**
LANE Config Server: 47.0091810000000060705A8F01.00E0B00B7033.00

Nota:  ** representa o número de bytes da subinterface no formato hexadecimal.

Nota: A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Uma vez que você definiu a base de dados de LAN, aplique-a na interface principal do LECS usando o comando lane config database database-name. Esta é uma explicação dos três comandos que são configurados no LECS:

  • NSAP-endereço do lecs-endereço-padrão atm — Define que endereçam o interruptor anunciam como sendo os LECS NSAP a seus dispositivos conectados com o Interim Local Management Interface (ILMI). Neste caso, o endereço configurado é o endereço nsap atribuído à relação ATM0 do LightStream 1010. Emita o comando show lane default obter este endereço:

    LightStream 1010# show lane default
    
    interface ATM2/0/0:
    LANE Client:        47.0091810000000060705A8F01.0060705A8F02.**
    LANE Server:        47.0091810000000060705A8F01.0060705A8F03.**
    LANE Bus:           47.0091810000000060705A8F01.0060705A8F04.**
    LANE Config Server: 47.0091810000000060705A8F01.0060705A8F05.00
    

    Nota:  ** representa o número de bytes da subinterface no formato hexadecimal.

  • lane config auto-config-atm-address — Indica se o LECS responde às configurações de chamada feitas a seu endereço nsap real.

  • nome do base de dados da base de dados de configuração lane — Define que a base de dados de LAN o LECS usa.

Uma vez que você aplicou a configuração acima à interface principal, o LECS é ascendente e ativo.

Verificando o status de LECS

Emita o comando show lane config verificar o status lecs:

LightStream 1010# show lane config

LE Config Server ATM2/0/0 config table: test
Admin: up State: operational
LECS Mastership State: active master
list of global LECS addresses (49 seconds to update):
47.0091810000000060705A8F01.0060705A8F05.00
ATM Address of this LECS: 47.0091810000000060705A8F01.0060705A8F05.00 (auto)
 vcd  rxCnt  txCnt  callingParty
  46      1      1  47.0091810000000060705A8F01.00E0B00B7031.01 LES test-elan 0 active
  62      1      1  47.0091810000000060705A8F01.00E0B00B7031.02 LES test-elan2 0 active
ATM Address of this LECS: 47.007900000000000000000000.00A03E000001.00 (well known)
cumulative total number of unrecognized packets received so far: 0
cumulative total number of config requests received so far: 608
cumulative total number of config failures so far: 601
    cause of last failure: no configuration
    culprit for the last failure: 47.009181000000FFFF705A8F01.0050E2030602.01
Roteador1

!--- Output suppressed.

interface ATM0

 no ip address
 pvc 0/5 qsaal
 !
 PVC 0/16 ilmi
 !
 no ATM ilmi-keepalive
!
interface ATM0.2 multipoint
 ip address 20.0.0.1 255.255.255.0
 lane client ethernet test-elan
!
interface ATM0.3 multipoint
 ip address 21.0.0.1 255.255.255.0
 lane client ethernet test-elan2
!
router rip
 network 20.0.0.0
 network 21.0.0.0

!--- Output suppressed.

Verificando o status LEC

Emita estes comandos verificar o status LEC:

  • mostre o [interface atm number[.subinterface-number] do cliente LANE]

    router1# show lane client interface atm 0.2
    
    LE Client ATM0.2  ELAN name: test-elan  Admin: up  State: operational
    Client ID: 2                 LEC up for 18 hours 9 minutes 42 seconds
    ELAN ID: 0
    Join Attempt: 1
    Known LE Servers: 1
    HW Address: 0060.837b.b3a2   Type: ethernet             Max Frame Size: 1516
    ATM Address: 47.0091810000000060705A8F01.0060837BB3A2.02
     VCD  rxFrames  txFrames  Type       ATM Address
       0         0         0  configure  47.0091810000000060705A8F01.0060705A8F05.00
       5         1        47  direct     47.0091810000000060705A8F01.00E0B00B7031.01
       6       145         0  distribute 47.0091810000000060705A8F01.00E0B00B7031.01
       7         0      4567  send       47.0091810000000060705A8F01.00E0B00B7032.01
       8     10221         0  forward    47.0091810000000060705A8F01.00E0B00B7032.01
  • ATM ILMI status da mostra — Verifica se o cliente registrou corretamente seu endereço nsap com o ILMI.

    router1# show atm ilmi-status
    
    Interface : ATM0 Interface Type : Private UNI (User-side)
    ILMI VCC : (0, 16) ILMI Keepalive : Disabled
    ILMI State:       UpAndNormal
    Peer IP Addr:     10.200.10.47    Peer IF Name:     ATM0/0/0
    Peer MaxVPIbits:  8               Peer MaxVCIbits:  14
    Active Prefix(s) :
    47.0091.8100.0000.0060.705a.8f01
    End-System Registered Address(s) :
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.02(Confirmed)
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.03(Confirmed)

    Refira estes documentos para obter mais informações sobre do comando show atm ilmi-status:

Roteador2

!--- Output suppressed.

interface ATM1

 no ip address
 PVC 0/16 ilmi
 !
 PVC 0/5 qsaal
 !
 no ATM ilmi-keepalive
!
interface ATM1.2 multipoint
 ip address 20.0.0.3 255.255.255.0
 lane client ethernet test-elan
!
router rip
 network 20.0.0.0

!--- Output suppressed.

LANE blade do Switch Ethernet

!--- Output suppressed.

interface ATM0

 ATM preferred phy A
 atm PVC 1 0 5 qsaal
 ATM PVC 2 0 16 ilmi
 no ATM ilmi-keepalive
!
interface ATM0.1 multipoint
 lane server-bus ethernet test-elan

!--- Configuration of the Bus.

!
interface ATM0.2 multipoint
 lane server-bus ethernet test-elan2
!
interface ATM0.3 multipoint
 lane client ethernet 2 test-elan2

!--- Output suppressed.

O comando lane server-bus ethernet elan-name configura este dispositivo como o LES/BUS para o nome elan nomeado ELAN.

Nota: Pode somente haver um server-barramento pela subinterface de multiponto.

Comandos adicionais

Estes são alguns comandos úteis usar-se ao configurar o LANE. Não é necessário usar estes comandos a fim executar o LANE.

Nos LECS

interface ATM2/0/0
  no ip address
  no ip directed-broadcast
  lane config fixed-config-atm-address
  lane config auto-config-atm-address
  lane config config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane config database test
  • lane config fixed-config-atm-address — Indica que o LECS responde às configurações de chamada feitas ao endereço NSAP bem-conhecido. O endereço NSAP bem-conhecido é 47.007900000000000000000000.00A03E000001.00.

  • Config-atm-address NSAP da configuração de pista — Indica que as respostas LECS também às configurações de chamada feitas ao endereço nsap configurado 47.0091.8100.0000.0060.705a.8f01.0000.0000.0001.01.

No LES

interface ATM0.1 multipoint
  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane bus-atm-address 47.0091810000000060705A8F01.000000000003.01
  lane server-bus ethernet test-elan
  • lane config-atm-address NSAP — Força o LES/BUS para conectar ao LECS com o endereço do NSAP, em vez de usar o endereço LECS aprendido do ILMI.

  • lane server-atm-address NSAP e barramento-ATM-endereço NSAP da pista — Permita que você configure estaticamente o endereço nsap do LES e do BARRAMENTO respectivamente.

Refira endereços ATM da Duro-codificação para o LES/LEC/BUS/LECS para mais informação.

No LEC

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0
  lane fixed-config-atm-address
  lane client ethernet test-elan

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane client ethernet test-elan
  interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane client ethernet test-elan
  • fixo-configuração-ATM-endereço da pista — Força o LEC para conectar ao LECS usando o endereço NSAP bem-conhecido, em vez de usar o endereço nsap LECS aprendido do ILMI.

  • lane config-atm-address NSAP — Força o LEC para conectar ao LECS com o endereço do NSAP, em vez de usar o endereço LECS aprendido do ILMI.

  • lane server-atm-address NSAP — Força o LEC para conectar diretamente ao LES com o endereço do NSAP sem conectar ao LECS primeiramente.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 10457