Asynchronous Transfer Mode (ATM) : ATM para rede frame relay

Frame Relay para ATM Service Interworking (FRF.8 - modo de conversão)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O FR (Frame Relay ) para a função de entrelaçamento de serviço ATM permite a comunicação entre um usuário final FR e um usuário final ATM. É baseado no acordo da execuçãoleavingcisco.com do Frame Relay Forum (FRF.8), que especifica que uma estação final FR pode se comunicar com uma estação final ATM contanto que há um roteador que executa as especificações dadas no FRF.8 no software entre as duas estações final.

Este documento apresenta um exemplo de configuração de entrelaçamento de serviço FR para ATM usando FRF.8 (modo tradução) no LightStream 1010. Essa configuração funciona também no Catalyst 8510 MSR ou no 8540 MSR.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada na liberação do½ do¿Â do Cisco IOSï 12.0(3c)W5(9).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10409/frf8.gif

Os parâmetros de modelagem de tráfego FR usados nesse exemplo de configuração do Roteador 1 são:

  • Taxa de informações comprometidas (CIR) = 64 kbps

  • Intermitência comprometida (Bc) = 8000

  • Intermitência excedente (Be) = 8000

Nota: Para uma explicação detalhada em como pesquisar defeitos conexões do Formatação de tráfego frame relay, refira comandos show para o Formatação de tráfego frame relay.

Configurações

Este documento utiliza as seguintes configurações:

Nota: Estas configurações contêm a informação relevante somente para o Frame Relay ao ATM Service Interworking.

Roteador 1
controller E1 5/0 
 channel-group 30 timeslots 1-31 
! 
interface Serial5/0:30 
 ip address 12.12.12.2 255.255.255.0 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF. It should match the switch.
 
 no fair-queue 
 frame-relay traffic-shaping

!--- Enabling FR traffic shaping on this interface.
          
 frame-relay class test-iwf 
 frame-relay map ip 12.12.12.1 123 broadcast 
! 
map-class frame-relay test-iwf 
 no frame-relay adaptive-shaping

!--- Traffic shaping parameters configured.

 frame-relay cir 64000 
 frame-relay bc 8000 
 frame-relay be 8000

Switch de ATM
frame-relay connection-traffic-table-row index 123 64000 
8000 128000 8000 vbr-nrt 123 
! 
controller E1 4/0/0 
 clock source free-running 
 channel-group 30  timeslots 1-31 
! 
interface Serial4/0/0:30 
 no ip address 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF.

 no arp frame-relay 
 frame-relay intf-type dce

!--- Interface type is dce, because it is providing clocking.

 frame-relay pvc 123 rx-cttr 123 tx-cttr 123 service translation 
 interface  ATM0/0/0 0 123 

!--- This command makes the translation from          
!--- Frame Relay to ATM PVC 123.

Roteador 2
interface ATM2/0.123 point-to-point 
 ip address 12.12.12.1 255.255.255.0 
 no ip directed-broadcast 
 pvc 0/123

!--- Configured ATM PVC 0/123 with traffic shaping and          
!--- oam-pvc management enabled.
 
 vbr-nrt 163 81 49 
 broadcast 
 oam-pvc manage 
 encapsulation aal5snap

Os parâmetros de modelagem de tráfego no roteador2 podem ser obtidos da tabela do tráfego da conexão do Frame Relay no switch ATM (veja a seção).

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show frame-relay lmi

  • show frame-relay map

  • show frame-relay pvc

  • atm0/0/0 do show atm vc interface

  • Connection-traffic-table-row do show frame-relay

  • show atm connection-traffic-table

  • show frame-relay interface resource serial 4/0/0:30 all-information

A saída mostrada abaixo é um resultado de incorporar os comandos acima nos dispositivos mostrados no diagrama da rede. Esta saída mostra que a rede está operando adequadamente.

Roteador 1

Nota: Ao conectar um roteador Cisco a uma conexão de terceiros, é preferível usar Local Management Interface (LMI) da Internet Engineering Task Force (IETF). Observe que o LMI é Cisco e o Frame Relay é DTE porque está recebendo cronometrar do interruptor.

Router1# show frame-relay lmi 
 
LMI Statistics for interface Serial5/0:30 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 1222             Num Status msgs Rcvd 1222
  Num Update Status Rcvd 0              Num Status Timeouts 2

Para verificar se dlci está ativado e mapeado para o endereço IP correspondente, use o comando show frame-relay map.

Router1# show frame-relay map 

Serial5/0:30 (up): ip 12.12.12.1 dlci 123(0x7B,0x1CB0), static,
              broadcast,
              IETF, status defined, active

Para verificar o estado do pvc do Frame Relay, use o comando show frame-relay pvc. Na saída abaixo nós podemos ver que é ativa.

Router1# show frame-relay pvc 
 
PVC Statistics for interface Serial5/0:30 (Frame Relay DTE)
 
              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
 
DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0:30
 
  input pkts 786           output pkts 549          in bytes 742312    
  out bytes 684503         dropped pkts 6           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 1          out bcast bytes 608       
  pvc create time 03:25:16, last time pvc status changed 03:09:30

Switch de ATM

Nota: O termo ATM-PX/Y/Z refere-se à pseudo interface.

ATMswitch# show atm vc interface atm 0/0/0
Interface         VPI  VCI   Type   X-Interface      X-VPI X-VCI Encap  Status 
ATM0/0/0          0    5     PVC    ATM2/0/0          0    43    QSAAL  UP
ATM0/0/0          0    16    PVC    ATM2/0/0          0    35    ILMI   UP
ATM0/0/0          0    101   PVC    ATM0/1/0          0    101          UP
ATM0/0/0          0    102   PVC    ATM0/1/0          0    102          UP
ATM0/0/0          0    123   PVC    ATM-P4/0/0        30   155          UP

Para indicar o Frame Relay às conexões ATM no interruptor, use o comando show frame-relay connection-traffic-table-row, como mostrado abaixo:

ATMswitch# show frame-relay connection-traffic-table-row 
Row            cir      bc     be      pir      fr-atm Service-category    ATM Row
                                            
100           64000   32768   32768   64000            vbr-nrt              100       
123           64000   8000    8000    128000           vbr-nrt              123       


ATMswitch# show atm connection-traffic-table 
Row      Service-category    pcr        scr/mcr       mbs         cdvt
1            ubr          7113539        none                     none
2            cbr              424                                 none
3            vbr-rt           424         424          50         none
4            vbr-nrt          424         424          50         none
5            abr              424           0                     none
6            ubr              424        none                     none
10           cbr            50000                                 none
11           cbr             1000                                 none
12           cbr            11700                                 none
100          vbr-nrt           81          81-0        50         none
123          vbr-nrt          163          81-0        49         none 
<-- (*)

2147483645*  ubr                0        none                     none
2147483646*  ubr                1        none                     none
2147483647*  ubr          7113539        none                     none

(*) Ao criar a linha da tabela de tráfego de conexão de frame-relay, você associa um índice de linha de tabela ATM ao local em que os parâmetros de modelagem de tráfego ATM são automaticamente calculados com a especificação da Interface entre portadoras de banda larga (B-ICI), V2.0 (Ver fórmulas).

ATMswitch# show frame-relay interface resource serial 4/0/0:30 all-information 
Encapsulation: FRAME-RELAY
Resource Management configuration:
    Input queues (PAM to switch fabric):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Output queues (PAM to line):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Overflow servicing for VBR: enabled
  Available bit rates (in bps):
     1920000 vbr-nrt RX, 1920000 vbr-nrt TX
     1920000 abr RX,     1920000 abr TX
     1920000 ubr RX,     1920000 ubr TX
    Overbooking: disabled
Resource Management state:  Allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX
  Actual allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 10409