Asynchronous Transfer Mode (ATM) : Classe de serviço IP à ATM

Weighted Fair Queuing por VC com base em classe (CBWFQ por VC) nos Cisco 7200, 3600, e 2600 Routers

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O WFQ (Weighted fair queuing) foi implementado para links de velocidade mais baixa (como serial) para permitir um tratamento considerável a cada tipo de tráfego. Para fazer seu trabalho, o WFQ classifica o tráfego nos fluxos diferentes baseados na informação de camada 3 e 4 associada (endereços IP de Um ou Mais Servidores Cisco ICM NT, portas TCP, e assim por diante). Não é necessário definir listas de acesso para que isso funcione. Com WFQ, o tráfego da largura de banda baixa tem a prioridade eficaz sobre o tráfego da largura de banda elevada. O tráfego de largura de banda elevada compartilha a mídia de transmissão de forma proporcional para pesos atribuídos.

O WFQ tem as seguintes limitações:

  • Se o fluxo do tráfego aumentar significativamente, o WFQ não poderá ser ajustado, porque não é escalável.

  • O WFQ não está disponível em relações de alta velocidade, tais como o ATM.

Um novo recurso, o CBWFQ (Enfileiramento Considerável Ponderado Baseado em Classe), foi desenvolvido para cuidar das limitações de WFQ. Ao contrário do WFQ, o CBWFQ permite que você defina classes de tráfego. Uma vez que as classes foram definidas, os parâmetros podem então ser aplicados. Estes parâmetros incluem a largura de banda e o fila-limite.

Ao usar o CBWFQ, o peso especificado para uma classe transforma-se o peso de cada pacote que combina os critérios de classe. Esse peso é derivado da largura de banda que você atribuiu para a classe. O WFQ é aplicado então a estas classes em vez da aplicação aos fluxos eles mesmos. As classes podem incluir diversos fluxos.

É abaixo um sumário por vc da disponibilidade CBWFQ nos 7200, nos 3600, e nos 2600 Router:

  • 7200: Versões 12.0(5)T do ½ do ¿  de Cisco IOSïÂ, 12.0(5)XE, 12.1(1), 12.1(1)T, 12.1(1)E e mais tarde utilização de um PA-A3.

  • 7200 com NSE: Versão do Cisco IOS 12.1(7)E e mais tarde.

  • 7200 com NSE-1 prestam serviços de manutenção ao acelerador: Versão do Cisco IOS 12.2(4)B1.

  • 2600/3600 com apoio LLQ/CBWFQ dos módulos NM-1A-T3/E3 na versão do Cisco IOS 12.1(5)T e mais tarde.

  • 2600/3600 com módulos de rede DS3/E3: Versão do Cisco IOS 12.1(2)T.

Nota: A funcionalidade do switching do Cisco Express Forwarding (CEF) deve ser usada porque o CBWFQ monitora somente pacotes comutados por CEF.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas seguintes versões de hardware:

  • Cisco 7200, 3600, e 2600 Series Router

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10395/7200-1.gif

  • 1/130 são o valor VPI/VCI atribuído no ambas as extremidades do PVC entre os 7200 e do roteador A.

  • O gerador de tráfego é conectado para conectar os Ethernet rápida 3/0.

  • Os 7200 são a versão do Cisco IOS running 12.0(5)T.

  • O roteador A é usado como um dispositivo do dissipador para os testes.

  • A configuração é executada em uns 7200, mas é similar em um 2600/3600.

Configuração de exemplo

Está abaixo a configuração 7200 necessária executar o CBWFQ:

7200
    class-map ixia
      match input-interface FastEthernet3/0
    class-map loopbacks
      match access-group 102
    !
    policy-map mypol
      class ixia
       bandwidth 40000
       queue-limit 40
      class loopbacks
       bandwidth 10000
      class class-default
       fair-queue
    !
    interface ATM2/0.130 point-to-point
     ip address 14.0.0.2 255.0.0.0
     no ip directed-broadcast
     pvc 1/130
      service-policy output mypol
      vbr-nrt 100000 75000
      broadcast
      encapsulation aal5mux ip
    !
    access-list 102 permit ip host 10.0.0.1 host 11.0.0.1

Estão abaixo alguns comentários na configuração:

  • Os mapas da classe classificam e atribuem pesos para traficar. Parâmetros de classificação e mapas de classe são definidos no mesmo lugar. Neste caso, uma classe é aplicada a todo o tráfego de entrada nos Ethernet rápida 3/0 (o tráfego do gerador de tráfego). A outra classe é relacionada ao tráfego entre os laços de retorno (definidos nos 7200 e o roteador A).

  • Após ter definido os parâmetros de classificação, você pode usar um mapa de política para aplicar parâmetros de tráfego a estes fluxos classificados. Neste caso, o fluxo do gerador de tráfego “é atribuído” uma largura de banda do 40 Mbps e uma profundidade de fila de 40 pacotes. O tráfego entre laços de retorno é atribuído uma largura de banda do 10 Mbps.

  • A profundidade de fila é o número de pacotes que podem ser armazenados para uma classe particular antes que as gotas ocorram. O valor padrão é 64 (que é igualmente o Maximum Queue Depth).

  • Depois que os parâmetros de tráfego foram definidos para cada classe, o CBWFQ está aplicado em uma VC-base usando o comando seguinte: serviço-política [entrada|Policy-map-name da saída].

  • Tráfego que não combina um dos mapas da classe definida será atribuído um mapa da classe padrão (padrão da classe) que seja definido no mapa de política. Todo o tráfego não classificado será aplicado os parâmetros definidos sob esta classe padrão. Neste caso, o Weighted Fair Queuing normal é configurado.

  • Para esta configuração de exemplo, o CBWFQ é aplicado em um VC, mas pode ser usado em um conjunto de PVC também. Além, o CBWFQ pode ser associado com o Weighted Random Early Discard (WRED) como um mecanismo de queda (quando o fila-limite é alcançado).

Importante:

Antes de executar as tarefas de configuração nesta seção, você deve primeiramente criar as classes que serão usadas para diferenciar o tráfego no VC, a seguir define um mapa de política para inclui-las. Você pode configurar políticas de classe para tantas como classes como são definidos no roteador -- até o máximo de 64. No entanto, a quantidade total de largura de banda de VC alocada (para todas as classes incluídas em um mapa de política) não deve exceder 75 por cento da largura de banda disponível do VC.

Porque o CBWFQ fornece uma garantia de largura de banda mínima, você pode somente aplicar o CBWFQ aos VC com classes de serviço a não ser o UBR e o UBR+.

Você não pode aplicar por vc o WFQ e o CBWFQ a UBR e a UBR+ VC porque both of these classes de serviço são as classes de melhor esforço que não garantem a largura de banda mínima. Quando o CBWFQ é permitido para um VC, todas as classes configuradas como a política de serviços estão instaladas parte de no sistema de enfileiramento considerável.

Se você aplica uma política de serviços a um ATM VC e a política inclui uma característica que não seja o Parallel Express Forwarding (PXF) - permitido, os pacotes punted ao caminho de switching inferior seguinte. Execute o comando show pxf acc summ e procure um valor de incremento para os pontapés devido aos “recursos de emissor.”

router#show pxf acc sum      
            Pkts             Dropped   RP Processed             Ignored 
           Total                 242      328395045                   0 
10 second averages: PXF complex busy:       28%  PXF read pipeline full:   0% 
PXF Statistic: 
     Packets RP -> PXF: 
         switch ip:                       0 
         switch raw:              556612940 
         qos fastsend:                    0 
         qos enqueue:                     0 
     Total:                       556612940 
Packets PXF -> RP: 
         qos pkts:                        0 
         fast pkts:               228217649 
         drops: total                   242 
           "    no route               :         242 
         punts: total             328395045 
           "    not IP                 :         597 
           "    IP options             :         676 
           "    CEF no adjacency       :      186770 
           "    CEF receive            :      265306 
           "    output feature         :   327916956 

Configuração CBWFQ avançada em roteadores 7200

Nos Cisco 7200 Router que executam a versão do Cisco IOS 12.1(5)E, 12.1(5)T e mais tarde, nós podemos agrupar as classes do mapa para formar uns mapas mais complicados da classe. Adicionalmente, nós podemos associar operações lógica para classificar parâmetros do mapa (para determinar se o tráfego combina uma classe).

Deixe-nos olhar os seguintes mapas da classe para esclarecer este conceito:

Configuração CBWFQ avançada
class-map match-all ixia
  description traffic from Ixia 
  match input-interface FastEthernet1/0 
class-map match-all ftp1 
  description ftp traffic initiated by the traffic generator 
  match class-map ixia 
  match class-map ftp2 
class-map match-all ftp2 
  match access-group 103 
class-map match-any test 
  match access-group 102    
  match input-interface Ethernet0/0 
! 
access-list 103 permit tcp any any eq ftp    
! 
access-list 102 permit ip host 10.1.1.1 any

A diferença entre a verificação de repetição de todos os dados e de qualquer dado é a seguinte:

  • compatível com todos: um fluxo está associado com um mapa da classe se todas as circunstâncias associadas são verificadas.

  • compatível com qualquer significa: um fluxo está associado com um mapa de classe se ALGUMAS de circunstâncias associadas são verificadas (não necessariamente todas as circunstâncias).

Nós podemos ver aqui que um mapa da classe pode incluir testes contra outros mapas da classe configurada. Neste caso, um fluxo está associado com o ftp1 se combina todas as circunstâncias definidas sob o ixia do mapa da classe e o mapa ftp2 da classe.

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o [.z] do x/y atm da relação do mapa de política — Este comando permite que você considere as estatísticas pela fila, tal como as gotas. É útil para monitorar os resultados de uma serviço-política criada com o comando line interface(cli) da Qualidade de Serviço modular de Cisco (QoS) (MQC). Para informações mais detalhadas sobre de como interpretar a saída deste comando, refira compreendendo contadores de pacote de informação em saídas de interface do mapa de política da mostra.

            7200#show policy-map interface atm 2/0.130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0

    Nota: Veja as seguintes explicações em relação aos dois tipos de gotas:

    • Descartes: gotas totais disto fila.

    • Quedas traseiras: as gotas desta enfileiram-se somente quando uma outra fila tem um pacote recebido com um número de sequência “mais baixo” WFQ e o sistema de WFQ alcança o número limite de fila máxima de pacote.

  • mostre o [.z] vc do x/y atm da relação do mapa de política [vcd | vpi/vci] — este comando dá mais granularidade para VC específicos.

            7200#show policy-map interface atm 2/0.130 vc 1/130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0
    

Você pode igualmente usar outros comandos como o mapa de classe da mostra ou mostrar a classe do mapa de política para obter mais informação detalhada nas classes do mapa.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 10395