WAN : Point-to-Point Protocol (PPP)

Multilink PPP em roteadores back-to-back com interfaces seriais múltiplas

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Em alguns ambientes, pode ser necessário agrupar links seriais para que atuem como uma única largura de banda agregada. Este documento descreve como configurar um Cisco 2503 Access Server para agrupar duas interfaces seriais com dois métodos diferentes:

Essas configurações podem ser utilizadas para roteadores conectados por linhas concedidas ou roteadores que tenham uma Unidade serviço de canais (CSU), uma Unidade de serviço de dados (DSU) ou um Adaptador de terminais (TA) ISDN configurado para discar. (Os roteadores da Cisco não foram configurados para discar números de telefone.) Você pode incluir características adicionais a essa configuração para suprir suas necessidades.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2503 Routers

  • Software Release 12.2(7b) do ½ do ¿  de Cisco IOSïÂ

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Produtos Relacionados

Essa configuração pode ser usada com quaisquer dois roteadores que tenham duas interfaces seriais WAN cada. É possível usar WIC-1T, WIC-2T ou interfaces seriais WAN fixas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10382/pppmultilink.gif

Configurações

Esta configuração foi testada com o Cisco IOS Software Release 12.2(7b) em Cisco 2500 Series Routers. Os mesmos conceitos de configuração se aplicam a uma topologia de roteador similar ou a outras releases do software Cisco IOS.

Exemplo 1: Discador da Interface

Exemplo 2: Modelo Virtual

Exemplo 1: Discador da Interface

Roteador 1 - Cisco 2503
Current configuration:
version 12.2
 
hostname Router1
!
username Router2 password 0 abc

!--- This local username and password pair is used for PPP Challenge
!--- Handshake Authentication Protocol (CHAP) authentication.

ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

!--- The loopback address is used by interface dialer 1.

!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1

 !--- Interface Serial0 is a member of rotary-group 1.
 !--- The rotary group configuration is in interface dialer 1. 

 no fair-queue
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 pulse-time 1
!
interface Dialer1

!--- This is the configuration for rotary-group 1.
!--- The dialer interface number must exactly match the rotary group number.

 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 192.168.20.1 name Router2 broadcast
 dialer load-threshold 2 either
 dialer-group 1

 !--- Apply interesting traffic definition from dialer-list 1.

 no fair-queue
 ppp authentication chap
 ppp direction callout  

 !--- This is a hidden command; see the Notes section for more information.

 ppp multilink

 !--- Allow multilink for the dialer profile.
 !--- Without this command, multilink is NOT negotiated.

!
ip classless
ip route 192.168.20.1 255.255.255.255 Dialer1
dialer-list 1 protocol ip permit

!--- The dialer-list defines the interesting traffic.

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Roteador 2 - Cisco 2503
Current configuration:
version 12.2
hostname Router2
!
!
username Router1 password 0 abc
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 999
 dialer map ip 192.168.10.2 name Router1 broadcast
 dialer load-threshold 2 either
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 192.168.10.2 255.255.255.255 Dialer1
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
end

Observações sobre o Exemplo 1

O comando ppp direction callout é um comando oculto usando quando um roteador está confuso quanto a quem chamou quem (quando conectado no modo back-to-back ou conectado por linhas em uso e a CSU/DSU ou a ISDN TA estão configuradas para discagem). O comando ppp direction callin também pode ser usado. Use um desses comandos.

  • Para um roteador local, use o comando ppp direction callout.

  • Para um roteador remoto, use ppp direction callin.

Se você não usar esse comando, o roteador conecta por um momento e então desconecta.

A configuração acima descreve dois roteadores, o Roteador 1 e o Roteador 2, que têm duas interfaces seriais a serem agrupadas para atuar como uma única largura de banda agregada. Em ambos os roteadores, interface loopback está configurado e integrado com o discador da interface usando ip unnumbered loopback0. As interfaces seriais não são configuradas para nenhum endereço IP. As interfaces físicas Serial0 e Serial1 são configuradas com dialer rotary-group e associadas a um único discador da interface lógica.

Dialer-list define o tráfego de interesse que, por sua vez, aciona o comando dialer-group 1 no discador da interface 1 para ativar o link. O dialer map definido em ambos os discadores mapeia o discador da interface 1 ao endereço IP do roteador peer, e o nome de host definido é usado na autenticação CHAP. A rota estática definida roteia o tráfego para o destino.

O comando ppp authentication chap permite a negociação PPP. Os comando dialer load-threshold define uma carga que é acionada para ativar a segunda linha serial. Os comandos ppp multilink e dialer rotary-group foram configurados de modo que ambas as interfaces seriais possam ser agrupadas juntas como uma interface de acesso virtual para largura de banda agregada. O comando ppp direction callout determina qual lado precisa fazer um callout durante a negociação PPP e a autenticação CHAP.

Exemplo de Confirmação 1

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Router1# show ppp multilink 
Virtual-Access1, bundle name is Router2 
  Bundle up for 00:01:05 
  Dialer interface is Dialer1 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 1/255 load 
  0x0 received sequence, 0x0 sent sequence 
  Member links: 2 (max not set, min not set) 
    Serial0, since 00:01:05, no frags rcvd 
    Serial1, since 00:01:05, no frags rcvd   

 Router2# show ppp multilink  

 Virtual-Access1, bundle name is Router1
  Bundle up for 00:03:25
  Dialer interface is Dialer1
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:03:25, no frags rcvd
    Serial0, since 00:03:25, no frags rcvd

Exemplo de Troubleshooting 1

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

Comandos debug

No Roteador 1, o comando debug ppp authentication mostra o sucesso do CHAP.

May  8 17:52:19: Se1 PPP: Using configured call direction
May  8 17:52:19: Se1 PPP: Treating connection as a callout
May  8 17:52:19: Se0 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se0 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O SUCCESS id 135 len 4
May  8 17:52:19: Se1 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se1 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O SUCCESS id 135 len 4
5d05h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
May  8 17:52:19: Vi1 PPP: Using configured call direction
May  8 17:52:19: Vi1 PPP: Treating connection as a callout
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to up

No Roteador 2, o comando debug ppp authentication mostra “Waiting for peer....”

5d02h: %LINK-3-UPDOWN: Interface Serial0, changed state to up
5d02h: Se0 PPP: Treating connection as a callin
5d02h: Se0 CHAP: O CHALLENGE id 132 len 28 from "Router2"
5d02h: Se0 CHAP: I CHALLENGE id 133 len 28 from "Router1"
5d02h: Se0 CHAP: Waiting for peer to authenticate first
5d02h: Se0 CHAP: I RESPONSE id 132 len 28 from "Router1"
5d02h: Se0 CHAP: O SUCCESS id 132 len 4
5d02h: Se0 CHAP: Processing saved Challenge, id 133
5d02h: Se0 CHAP: O RESPONSE id 133 len 28 from "Router2"
5d02h: Se0 CHAP: I SUCCESS id 133 len 4
5d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

Exemplo 2: Modelo Virtual

Roteador 1 - Cisco 2503
Current configuration
!
version 12.2
!
hostname Router1
!
!
username Router2 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
 
multilink virtual-template 1

!--- Applies the virtual interface template to the multilink bundle.

 
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

 !--- The loopback address is used by virtual-template 1.

 
 
interface Virtual-Template1

!--- Interface virtual-template is a logical interface that creates
!--- virtual access interfaces dynamically and applies them to 
!--- physical serial interfaces.

 ip unnumbered Loopback0

!--- Always unnumber the virtual-template to an UP interface.
!--- Do not assign a static IP.

 ppp authentication chap
 ppp multilink 

 !--- Enables multilink PPP on the virtual-template interface.

 
interface Serial0
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
!
ip classless
!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Roteador 2 - Cisco 2503
Current configuration :
!
version 12.2
!
hostname Router2
!
!
username Router1 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
multilink virtual-template 1
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Virtual-Template1
 ip unnumbered Loopback0
 ppp authentication chap
 ppp multilink
!
interface Serial0
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
!
end

A configuração acima descreve o modelo virtual configurado no Roteador 1 e no Roteador 2. Nesse exemplo, ambos os roteadores estão configurados com modelos virtuais. Os roteadores estão conectados simultaneamente e a seção de multilink não fica ociosa. Nenhuma rota estática é necessária: uma rota de host é instalada após negociações PPP.

Use o Cisco IOS Software versão 11.3 ou posterior para usar molde virtual para multilink PPP.

O comando virtual template cria de forma dinâmica uma interface de acesso virtual e a aplica a interfaces seriais físicas com o comando multilink virtual-template. Os parâmetros (como ppp authentication chap) configurados no modelo virtual de interface são aplicados a ambas as interfaces seriais. O comando ppp multilink no modelo virtual da interface agrupa as interfaces seriais físicas para formar uma acesso virtual a fim de agregar a largura de banda.

Exemplo de Confirmação 2

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Router2# show ppp multilink
 
Virtual-Access1, bundle name is Router1

!--- Virtual Access interface used for the bundle

  Bundle up for 00:20:38
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:20:39, no frags rcvd
    Serial0, since 00:20:39, no frags rcvd

!--- Note that there are two links (Se 0 and Se1) in the bundle

Estes comandos também podem ser úteis:

  • show ip route connected — Para ver se a rota de IP do acesso virtual está instalada.

  • show interface virtual-access x — Para verificar o status de determinada interface de acesso virtual. No exemplo acima, o número da interface de acesso virtual é 1.

Exemplo de Troubleshooting 2

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

Configure os carimbos de hora/data na configuração global como segue:

service timestamps debug datetime msec
service timestamps log datetime msec

Use estes comandos para troubleshooting:

  • debug ppp negotiation — Para verificar se um cliente passa a negociação PPP. Você também pode verificar quais opções (retorno de chamada, PPP de Multienlace [MLP] e assim por diante) e quais protocolos (IP, IPX e outros) são negociados.

  • debug ppp authentication — Para verificar se um cliente passa a autenticação.

  • debug vtemplate — Para verificar quais configurações de modelo virtual são usadas.

  • debug vprofile — Para verificar quais opções de configuração são aplicadas à interface de acesso virtual.


Informações Relacionadas


Document ID: 10382